1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Root für Xperia Pro, unter ICS.

Dieses Thema im Forum "Root / Hacking / Modding für Sony Ericsson Xperia Pro" wurde erstellt von siyman, 01.06.2012.

  1. siyman, 01.06.2012 #1
    siyman

    siyman Threadstarter Android-Experte

    Beiträge:
    509
    Erhaltene Danke:
    68
    Registriert seit:
    10.03.2011
    Bei mir hats geklappt, allerdings musste ich wieder etwas zwischen den Zeilen lesen. Daher mal eine kleine Zusammenfassung:

    0) Geht auf diese Seite (Flashtool - Xperia devices flashing) und ladet euch das Flashtool herunter.

    1) Geht auf diese Seite (xda-developers - View Single Post - [ROOT][FTF][locked/unlocked]Neo/Neo V Official 4.0.4 ICS 4.1.B.0.431) und ladet euch den MT11i_4.1.A.0.562_kernel.ftf herunter.

    2) Geht auf diese Seite ([ROOT] Rooting Toolkit for Xperia 2011 ICS [FW:.562]{LOCKED & UNLOCKED BOOTLOADERS} - xda-developers) und ladet euch die ADB Treiber herunter.

    3) Geht auf diese Seite ([ROOT] Rooting Toolkit for Xperia 2011 ICS [FW:.562]{LOCKED & UNLOCKED BOOTLOADERS} - xda-developers) und ladet euch den 2011er DoomLord One-Click herunter.
    Update 17.05.13: Da der Downloadlink scheinbar nicht mehr funktioniert, gibt's bei chip.de die 4.0er von Doomlord.

    4) Geht auf diese Seite (Download: MK16i_4.0.4_Kernel_ICS.ftf | xup.in) und ladet euch den MK16i 4.0.4 Kernel.
    Edit: noch mögliches verfahren, flasht aber einen älteren Kernel, nutzt daher bitte folgende Methode:
    5) Schließt euer Pro an den SEUS (Update service - Sony Smartphones (Global UK English)) und installiert das Upgrade - ich habe full wiped.

    6) Richtet erstmal alles mittels Assistent ein, damit ihr auch wisst, dass euer Pro funktioniert. Prüft anschließend in euren Einstellungen, ob der Debug-Mode ausgeschaltet und die Installation aus unsicheren Quellen deaktiviert ist. Sollte das so sein, so schaltet beide Funktionen ein, da ansonsten nicht korrekt geflasht werden kann! (Danke an BlinkyBob für den Tipp)

    7) Schließt euer Pro an den PC an, startet das Flashtool, klickt auf das Blitz-Symbol, wählt 'Flashmode', wählt den MT11i-Kernel aus, flasht nur den Kernel und wartet ab, bis alles fertig ist. (Nach dem reboot mit dem neuen Kernel habt ihr keine grafische ausgabe mehr auf dem display. Das ist genau so gewollt und es funktioniert nach dem reflash des originalen kernels wieder alles!)
    Update 17.05.13: Insofern ihr ein Flashtool höher als Version 0.9.10 nutzt, müsst ihr aus der ftf-Datei die Kernel- und Loader-Datei in ein eigenes extrahieren. Wählt nun einfach dieses Verzeichnis beim Flashtool aus und flasht allein die beiden Dateien - damit umgeht ihr die nicht mehr vorhandene Auswahl.

    8) Schließt das Flashtool und installiert die ADB-Treiber.

    9) Entfernt den Akku vom Gerät, setzt ihn wieder ein, schließt das Pro an den PC an, schaltet es ein und wartet bis die Hardwaretasten aufleuchten.

    10) Jetzt startet ihr den DoomLoard One-Click-Rooter, bestätigt die Enter-Taste und wartet, bis die Nachricht "All Done!" erscheint.

    11) Lasst das Handy gerootet neu booten (also wieder wie oben einen Akku-Pull durchführen) und startet wieder das Flash-Tool.

    12) Nochmals auf den Blitz klicken und den MK16i Kernel (und nur den Kernel, nicht die gesamte Firmware.tft) flashen.

    13) You're rooted =)

    14) Seit dem Update auf die 587 ist nach dem Rooting das Tastaturlayout auf Englisch. BlinkyBob hat dafür eine einfache Lösung:



     
    Zuletzt bearbeitet: 17.05.2013
    Dingels, radiohöhrer, Hoot und 22 andere haben sich bedankt.
  2. SkaFan, 01.06.2012 #2
    SkaFan

    SkaFan Android-Hilfe.de Mitglied

    Beiträge:
    45
    Erhaltene Danke:
    2
    Registriert seit:
    01.06.2012
    Hat das jemand getestet?
    Habe mit Punkt 7 Probleme...

    ich kann nicht nur den Kernel auswählen, sondern nur zusammen mit dem Loader (bin im flash modus)
    flashe ich das ganze tft paket bricht der flasher ab, error...
     
  3. mg247, 02.06.2012 #3
    mg247

    mg247 Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    2
    Registriert seit:
    02.06.2012
    Tablet:
    Sony Xperia Tablet Z
    Bei mir gings.. Super!!! Vielen Dank! Aber das Keyboard ist auf qwerty und nicht auf qwertz... was muss man da ändern? Im Ordner System/usr/keyboard-config/ die Datei keyprint.xml? Wenn ja, dann wie ändern?
     
  4. Maverick2k, 02.06.2012 #4
    Maverick2k

    Maverick2k Neuer Benutzer

    Beiträge:
    14
    Erhaltene Danke:
    3
    Registriert seit:
    30.03.2012
    Bei Punkt 7 und 12 kann man rechts den Kernel auswählen.

    Bin gerade fertig geworden: Beim ersten Versuch ging das Display nicht mehr an (Punkt 5 rettet), beim zweiten und nach genauerem Lesen ("enable "USB DEBUGGING" from (Menu\Settings\Developer Options\Development) und enable "UNKNOWN SOURCES" from (Menu\Settings\Security)") keine Probleme. Frisch aufgesetzt ist die Performance wirklich top.

    BTW: In Flashtool\drivers haben die Flashtool Drivers die Versionsnummer 1.0.1, beim Link unter Punkt 2 die 1.0.0. Konnte aber keinen Unterschied feststellen.
     
  5. SkaFan, 02.06.2012 #5
    SkaFan

    SkaFan Android-Hilfe.de Mitglied

    Beiträge:
    45
    Erhaltene Danke:
    2
    Registriert seit:
    01.06.2012
    ich hatte erst mit Flashtool 0.6xx probiert... daher der Fehler, mit 0.8xx geht es.
    nach dem flashen des MK11 Kernel hat mal übrigens kein Display mehr... hätte man ruhig mal dazu schreiben können... man muss also dran denken vorher USB debug und ein- bzw auszustellen.
     
  6. siyman, 02.06.2012 #6
    siyman

    siyman Threadstarter Android-Experte

    Beiträge:
    509
    Erhaltene Danke:
    68
    Registriert seit:
    10.03.2011
    Das mit dem Display hab ich in der Eile vergessen. Liegt daran, dass der bootlocker die grafische Ausgabe von nicht-signierten kernels blockiert.

    Zwecks usb-debugging muss man nichts beachten, denn der one-click-rooter erledigt das alles von allein.
     
  7. mg247, 03.06.2012 #7
    mg247

    mg247 Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    2
    Registriert seit:
    02.06.2012
    Tablet:
    Sony Xperia Tablet Z
    Und was ist nun mit dem Hardware-Keyboard? Ist ja auf qwerty eingestellt... will aber schon qwertz...
     
  8. siyman, 03.06.2012 #8
    siyman

    siyman Threadstarter Android-Experte

    Beiträge:
    509
    Erhaltene Danke:
    68
    Registriert seit:
    10.03.2011
    Kann das nicht nachvollziehen, denn bei mir ist sowohl Software als auch Hardware qwertz. Vorher gewiped? Andernfalls kann ichs mir nicht erklären. Oder aber upgrade via pc companion?
     
  9. ybs_khanh, 03.06.2012 #9
    ybs_khanh

    ybs_khanh Neuer Benutzer

    Beiträge:
    1
    Erhaltene Danke:
    0
    Registriert seit:
    02.06.2012
    I'm can't finish the DoomLoard tool to root ? It's errror, can't find the device. What's should I do now ?
     
  10. siyman, 03.06.2012 #10
    siyman

    siyman Threadstarter Android-Experte

    Beiträge:
    509
    Erhaltene Danke:
    68
    Registriert seit:
    10.03.2011
    Wenn du deine userdaten behältst, ist das denke ich dein Problem. Mach doch vorher einfach nen nandroid-backup, mittels flashtool kommst du ja immer auf 2.3.4 zurück. Also nix zu verlieren. Und hinterher einfach mal fullwipe.

    @ybs_khanh:
    Please reask your question in the correct thread on xda-developers, because this is a german Forum.
     
  11. mg247, 03.06.2012 #11
    mg247

    mg247 Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    2
    Registriert seit:
    02.06.2012
    Tablet:
    Sony Xperia Tablet Z
    Bei mir stand qwerty-en in der Keyprint.xml... deswegen... habs nun geändert und es geht alles! Juhu!
     
  12. Brainless, 03.06.2012 #12
    Brainless

    Brainless Neuer Benutzer

    Beiträge:
    23
    Erhaltene Danke:
    1
    Registriert seit:
    03.04.2012
    der Kernel Link unter 4. ist tot. :(
     
  13. siyman, 03.06.2012 #13
    siyman

    siyman Threadstarter Android-Experte

    Beiträge:
    509
    Erhaltene Danke:
    68
    Registriert seit:
    10.03.2011
    Brainless bedankt sich.
  14. Brainless, 03.06.2012 #14
    Brainless

    Brainless Neuer Benutzer

    Beiträge:
    23
    Erhaltene Danke:
    1
    Registriert seit:
    03.04.2012
    made my day! THX! ;-)
     
  15. felix99_dc, 04.06.2012 #15
    felix99_dc

    felix99_dc Android-Hilfe.de Mitglied

    Beiträge:
    80
    Erhaltene Danke:
    7
    Registriert seit:
    04.06.2012
    Bei mir funzt es so nicht.
    Hab nach dem flashen vom MK11 Kernel Probleme.
    Wenn ich danach den MK16i Kernel flashen will kommt folgendes:

    Nach dem flashen des MK11 Kernels muss ich ja die Batterie rausnehmen, sonst kann ich ja nix ausmachen ohne Display.

    Nach der letzten Log-linehab ich auch Akku raus da nix rebootete und dann An gedrückt und es kommt nix :/:cursing:

    Was mache ich falsch???!!
     
  16. siyman, 04.06.2012 #16
    siyman

    siyman Threadstarter Android-Experte

    Beiträge:
    509
    Erhaltene Danke:
    68
    Registriert seit:
    10.03.2011
    Du hältst dich nicht an die Anleitung :) das einzige, was du flashen sollst, ist der Kernel, nicht den loader. Das haut so einfach nicht. Also beim mk16 TFT Flash NUR den Kernel markieren, nicht den Loader und schon sollte alles klappen ;)
     
    felix99_dc bedankt sich.
  17. felix99_dc, 04.06.2012 #17
    felix99_dc

    felix99_dc Android-Hilfe.de Mitglied

    Beiträge:
    80
    Erhaltene Danke:
    7
    Registriert seit:
    04.06.2012
    Wie schnell die Zeit vergeht. Habs irgendwie hinbekommen. Das Handy lebt wieder :)

    Danke für die Hilfe.
    Hab das Xperia erst seit Januar und damit mehr gelitten ^^ als mit dem Wildfire wo alles irgendwie einfacher ging *g*.
    Aber nu is ja wieder alles in Butter , root is da, Handy lebt

    Danke nochmal für die Klarstellung ! Wird bestimmt noch jemandem helfen
    der so'n noob ist was das rumflashen an Xperias angeht wie ich ;-)

    Mny tnx

    Felix
     
  18. DJravingMonkey, 06.06.2012 #18
    DJravingMonkey

    DJravingMonkey Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    22.12.2011
    Funktioniert bei mir überhaupt nicht.
    Wenn ich die MT11i flashen will passiert folgendes:
     
  19. siyman, 06.06.2012 #19
    siyman

    siyman Threadstarter Android-Experte

    Beiträge:
    509
    Erhaltene Danke:
    68
    Registriert seit:
    10.03.2011
    Hatte den gleichen Fehler auch. Bei mir lag's am Flashtool. Einfach schließen, neustarten und nochmal versuchen - sollte erledigt sein.
     
  20. DJravingMonkey, 07.06.2012 #20
    DJravingMonkey

    DJravingMonkey Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    22.12.2011
    Vielen Dank für den Tipp! Jetzt hats funktioniert und ich bin gerooted!
     

Diese Seite empfehlen