1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Roter Trackball & dunkle Softkeys

Dieses Thema im Forum "Root / Hacking / Modding für Nexus One" wurde erstellt von Alo, 04.09.2010.

  1. Alo, 04.09.2010 #1
    Alo

    Alo Threadstarter Erfahrener Benutzer

    Beiträge:
    157
    Erhaltene Danke:
    23
    Registriert seit:
    22.07.2010
    Hey, ich hab ein Problem

    Zur Vorgeschichte: http://www.android-hilfe.de/root-hacking-modding-fuer-nexus-one/43069-gebrickt-slcd.html

    kurz in worten:
    - N1 LCD
    - hboot downgrade -> dunkles Display (seit dem roter Trackball)
    - Korea Rom raufgeflasht (PASSIMG_Passion_KT_KR_2.15.1010.2_FRF91_release_signed.zip)
    - CM6 stable raufgeflasht (da ist mir aufgefallen, das auch die Softkeys dunkel sind, wurde langsam dunkel :D )
    - VF Rom raufgeflasht (PASSIMG_Passion_Vodafone_Generic_2.15.151.5_R_FRF91_release_signed.zip)
    - immer mal wieder wipe, Clear Storage, VF Rom oder CM6 raufgeflasht

    edit: vielleicht sollte ich noch dazu schreiben:

    Der Trackball leuchtet rot, kurz nachdem das Nexus X beim booten animiert wird,
    wenn die pin abfrage kommt, leuchtet es kurz weiß auf, dann wieder rot.

    Sobald das Phone in den Standby geht, ist auch der Trackball dunkel.

    Ich kann mit nem App (Colour Trackball) die Trackball Farbe im Standby einstellen.

    Wenn ich mich anrufe (das Phone wieder aus dem Standby kommt) blinkt der Trackball abwechselnd rot und weiß, eigentlich ja nur weiß für eingehender Anruf!?

    Hat aber alles nichts geändert.

    Jetzt seit ihr gefragt, mir fällt nichts mehr ein.

    Ich bin für jeden Vorschlag dankbar. ;)

    edit2:
    Ach ja und im Bootlader/Fastboot/Recovery leuchtet der Trackball nicht rot.
     
    Zuletzt bearbeitet: 04.09.2010
  2. Alo, 04.09.2010 #2
    Alo

    Alo Threadstarter Erfahrener Benutzer

    Beiträge:
    157
    Erhaltene Danke:
    23
    Registriert seit:
    22.07.2010
    Hmm, ich glaubte ich hab es hinbekommen.

    Hab jetzt PASSIMG_Passion_Google_WWE_2.16.1700.1_FRG33_release_signed.zip draufgeflasht, ist so ziemlich das neuste, und hab über die Einstellungen ein Reset gemacht. Jetzt leuchtet der Trackball nicht mehr Rot, dann leuchtete er wieder Rot, jetzt wieder nicht. WARUUUUM ?!?

    Ich seh bloß nicht ob die Softkeys leuchten. Die scheinen immer noch dunkel zu sein.
     
  3. Alo, 04.09.2010 #3
    Alo

    Alo Threadstarter Erfahrener Benutzer

    Beiträge:
    157
    Erhaltene Danke:
    23
    Registriert seit:
    22.07.2010
    Kranker Scheiß...

    War unterwegs und hab mitm Phone noch nen bisschen rumgespielt.

    Was da genau heißt: NANDROID Restore, von dem Backup was ich ganz am anfang gemacht habe, gleich nachdem ich den RA Recovery drauf hatte.

    Hab dann die CM6 wieder raufgemacht und mir ist dann aufgefallen, das der Trackball nicht mehr rot leuchtet...

    Ich freu mich voll, komm nach Hause, setz mich vor die Kiste und was muss ich feststellen, der Trackball leuchtet wieder rot. AAARGHHH

    Also mach ich die Schreibtischlampe an, halte den Lichtsensor drunter, zack geht der Trackball aus. Weg von der Lampe ins "dunkle" Zimmer zurück (hab nen Baum vorm Fenster) leuchtet der Trackball wieder rot. WTF

    Any Ideas?
     
  4. Deanna, 04.09.2010 #4
    Deanna

    Deanna Android-Guru

    Beiträge:
    2,784
    Erhaltene Danke:
    456
    Registriert seit:
    25.11.2009
    Hm... ein Nachtlicht?? :D

    Sorry, wollte mich nicht lustig machen, kann mir vorstellen wie das nervt, kann aber leider nichts sinnvolles zur Lösung beitragen ;)
     
  5. Alo, 05.09.2010 #5
    Alo

    Alo Threadstarter Erfahrener Benutzer

    Beiträge:
    157
    Erhaltene Danke:
    23
    Registriert seit:
    22.07.2010
    Sooooo... bin immer noch nicht weiter...

    Hab jetzt schon mehrfach gelesen, dass der rote Trackball ein Indikator für ein Hardwaredefekt sein soll.

    Meine Theorie lautet jetzt:

    Sobald es dunkel genug ist, dass das Phone die Beleuchtung der Softkeys einschalten will, klappt das nicht und wirft als Fehlermeldung den roten Trackball.

    Das ist ja auch nur im Betriebssystem, wo die Funktion mit eingebaut ist. Im Recovery/Bootloader tritt der Fehler ja nicht auf. Die Softkeys leuchten da aber auch nicht.

    Kann da mir mal bitte jemand Feedback geben, wenn jemand mit einem funktionierendem Handy im Recovery/Bootloader ist, ob die Softkeys leuchten oder nicht?

    Ich hoffe das ist nur ein Softwarefehler, dass ich bei meinem rumgeflashe am Anfang irgendeine Funktion/Bibliothek/Img mit raufgepackt habe, die die Softkeys nicht aktivieren kann (, weil das beim LCD anders ist, wie beim LED).
     
  6. Blindy, 05.09.2010 #6
    Blindy

    Blindy Android-Experte

    Beiträge:
    531
    Erhaltene Danke:
    47
    Registriert seit:
    15.12.2009
    Phone:
    OnePlus One
    bei mir leuchten sie nicht im recovery
     
    Alo bedankt sich.
  7. Alo, 05.09.2010 #7
    Alo

    Alo Threadstarter Erfahrener Benutzer

    Beiträge:
    157
    Erhaltene Danke:
    23
    Registriert seit:
    22.07.2010
    Super, danke. Das bestätigt ja meine Theorie, so ein bisschen. Jetzt muss ich nur noch rausfinden, ob das Problem hardwareseitig oder softwareseitig ist.
     
  8. Alo, 05.09.2010 #8
    Alo

    Alo Threadstarter Erfahrener Benutzer

    Beiträge:
    157
    Erhaltene Danke:
    23
    Registriert seit:
    22.07.2010
    So... neueste Idee ist:

    Ich hab ja am Anfang, wo ich den HBOOT gedowngradet habe, mit flash_image die mtd0.img auf die misc Partiton verschoben (wenn ich das richtig verstanden habe).

    Und zwar indem ich das gemacht habe:
    Dazu habe ich eine mtd0.img mit Hilfe der Site Desire mtd0.img creator erstellt und dieses verwendet.

    Auf der Site steht, dass das img für's Desire ist, aber auch auf dem Evo4G funktionieren soll. Ich hab das halt auf meinem N1 genutzt, weil es so in der einen Anleitung, die fürs N1 ist, steht.

    Dummerweise weiß ich, dass beim Update über den Bootloader und einer PASSIMG.zip auf der SDCard Schritt für Schritt das Phone geupdatet wird, wobei ein Punkt des Updates [MISC] ist.

    Das bringt meine Theorie ins wanken, dass beim Update die MISC Partition nicht richtig geupdatet wurde und deswegen meine Sofkeys nicht funktionieren, mit der dazugehörigen Fehlermeldung (roter Trackball).

    Hoffnung gibt mir, wenn ich mir die PASSIMG.zip angucken, ist dort keine mtd0.img Datei drin, zwar jede Menge andere .img's, aber halt nicht die mtd0.img und deswegen dieser fehlenden Teil des Updates dazu beiträgt, dass ich diesen Fehler habe.

    Das heißt jetzt für mich, ich brauche eine mtd0.img das für das N1 ist und/oder von einem N1 (am besten LCD) kommt.

    Gesucht hab ich schon, aber nichts gefunden.

    Kann mir da einer helfen?
     
  9. noax, 09.09.2010 #9
    noax

    noax Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    07.10.2009
    Der alte HBoot kommt mit dem SLCD nicht zurecht.
    Problem wird z.Z. bei xda diskutiert.
     
  10. Alo

    Alo Threadstarter Erfahrener Benutzer

    Beiträge:
    157
    Erhaltene Danke:
    23
    Registriert seit:
    22.07.2010
    Kannst du mir mal bitte den Link zu dem Thread geben? Danke
     
  11. Alo

    Alo Threadstarter Erfahrener Benutzer

    Beiträge:
    157
    Erhaltene Danke:
    23
    Registriert seit:
    22.07.2010
    Hey, an alle Leser.

    Wer sich jetzt angesprochen fühlt und ein N1 LCD hat (und denke root ist auch nötig), kann mir mal bitte ein dump seines mtd0 machen:

    cat /dev/mtd/mtd0 > /sdcard/mtd0.img

    und mir diese dann bitte zur Verfügung stellen?
     
  12. Alo

    Alo Threadstarter Erfahrener Benutzer

    Beiträge:
    157
    Erhaltene Danke:
    23
    Registriert seit:
    22.07.2010
    Hallo? Keiner mit eineme N1 LCD der das mal bitte für mich machen kann?
     
  13. CT10, 13.09.2010 #13
    CT10

    CT10 Android-Hilfe.de Mitglied

    Beiträge:
    51
    Erhaltene Danke:
    4
    Registriert seit:
    13.07.2010
    Ich kann dich gern helfen, aber ich kann kaum zutrauen, dass ich wieder in cmd mache, da ich kein guter Programmierer bin...
     
  14. Alo

    Alo Threadstarter Erfahrener Benutzer

    Beiträge:
    157
    Erhaltene Danke:
    23
    Registriert seit:
    22.07.2010
    Das hat nichts mit programmieren zu tun ;)

    Ist eigentlich ganz einfach. Es gibt zwei Varianten. Eine davon hab ich selber davon schon getestet.

    Variante 1: mit einem Terminal auf dem Phone, zum Beispiel dem "Terminal Emulator", welcher bei CyanogenMod dabei ist, oder im Market erhältlich.

    Den öffnen und dort mit root rechten die obige Zeile ausführen

    1. Terminal Emulator öffnen
    2. "su" eingeben -> enter, wenn man nicht schon root ist
    3. "cat /dev/mtd/mtd0 > /sdcard/mtd0.img" eingeben
    4. jetzt ist die datei "mtd0.img" auf der SD Karte zu finden, einfach runterkopieren und dann hier im Forum beim Antworten mit anhängen.

    fertig

    Variante 2: mit adb

    1. adb einrichten, wenn es noch nicht ist
    a) phone in den debugging modus versetzen (einstellungen->anwendunge->entwicklung->usb debugging aktivieren) und per usb kabel anschließen
    b) über den geräte manager für das nexus one manuell die treiber aus dem ordner ?/android-sdk-windows/usb-treiber/ installieren
    2. mit adb auf das phone gehen "adb shell" in ?/android-sdk-windows/tools/ mit cmd ausführen
    3. jetzt ist man quasi wie im terminal auf dem phone und kann dort den befehl "cat /dev/mtd/mtd0 > /sdcard/mtd0.img" ausführen
    4. jetzt ist die datei "mtd0.img" auf der SD Karte zu finden, einfach runterkopieren und dann hier im Forum beim Antworten mit anhängen.

    fertig 2
     
  15. RinTinTigger, 13.09.2010 #15
    RinTinTigger

    RinTinTigger Gast

    Sorry, hab deinen thread zu spät gesehen.

    Hier isn Dump ;)
    (mit WinRAR gepackt)

    mtd0.rar
     
    Alo bedankt sich.
  16. CT10, 13.09.2010 #16
    CT10

    CT10 Android-Hilfe.de Mitglied

    Beiträge:
    51
    Erhaltene Danke:
    4
    Registriert seit:
    13.07.2010
    Hier bitte!
     

    Anhänge:

    • mtd0.zip
      Dateigröße:
      1.3 KB
      Aufrufe:
      22
    Alo bedankt sich.
  17. Alo

    Alo Threadstarter Erfahrener Benutzer

    Beiträge:
    157
    Erhaltene Danke:
    23
    Registriert seit:
    22.07.2010
    Super danke. Werd ich mir gleich angucken. Hab kein hex editor für android gefunden. Das von rintin hab ich schon drauf. Aber das hat nicht geholfen :/

    edit:
    so... hab jetzt beide mal ausprobiert, haben leider nichts an meinem problem geändert...
    Muss ich wohl mal weiter forschen... dann kann ja nur die EPF30 die ich danach raufgeflasht habe, schuld sein, mir ist bloss noch nicht bewusst wie, denn danach hab ich ja die FRF91 und die FRG33 ausprobiert, die leider auch nichts geändert haben...

    jetzt hab ich keine Idee mehr, nur direkt ins system einsteigen, gucken wo die funktion liegt, die die softkeys anspricht und ob man die "korrigieren" kann. oder liegt das problem ganz wo anders ??? ich weiss es nicht...

    aber irgendwann bekomm ich das auch noch hin...
     
    Zuletzt bearbeitet: 13.09.2010
  18. Macan, 16.12.2010 #18
    Macan

    Macan Gast

    Hast du eine Lösung gefunden?
     
  19. Terbium, 16.12.2010 #19
    Terbium

    Terbium Android-Hilfe.de Mitglied

    Beiträge:
    46
    Erhaltene Danke:
    8
    Registriert seit:
    16.12.2010
    Glaube zumindest zur Zeit gibt es keine Lösung das ganze zu fixen. Einzige Möglichkeit wäre es das Gerät einzuschicken. Vielleicht kommt da noch was in Zukunft aber da bin ich mir nicht sicher.
    Bei SLCD und AMOLED Nexus sind die Pinbelegungen des Trackballs und der Softkeybeleuchtung anders. Wenn die Softkeys leuchten sollen, leuchtet der Trackball rot und umgekehrt. Auch die anderen Farben des Trackballs stimmen nicht mehr.
    Du hast dein MICROP von 0c15 auf 0b15 runtergeflashed.

    Sowohl bei XDA als auch bei Cyanogen gibt es glaube ich Leute denen das Passiert ist.
     
  20. Macan, 16.12.2010 #20
    Macan

    Macan Gast

    Und da müßte es doch rein theoretisch auch wieder auf 0c15 zu bringen sein...
     

Diese Seite empfehlen