1. Nimm jetzt an unserem AGM - Gewinnspiel teil - Informationen zum M1, A2 und A8 findest Du hier, hier und hier!
  1. CassPennant, 10.01.2012 #1
    CassPennant

    CassPennant Threadstarter Android-Hilfe.de Mitglied

    Hallo!

    Ich möchte gerne die Samsung-eigene App TV Remote auf dem Nexus installieren aber im Market erscheint die Fehlermeldung "Ihr Gerät ist nicht mit diesem Artikel kompatibel".

    Gibt es eine Möglichkeit, die App trotzdem irgendwie zu installieren? Ist ja schließlich ein Samsung-Gerät, auch wenn's offiziell von Google ist.

    Danke für eure Antworten!
     
  2. Happosai, 10.01.2012 #2
    Happosai

    Happosai Fortgeschrittenes Mitglied

    Das würde mich auch interessieren.
     
  3. Handymeister, 10.01.2012 #3
    Handymeister

    Handymeister Foren-Manager Team-Mitglied Foren-Manager

    Hallo,

    ich vermute, dass sich diese Apps nur auf den eigenen Geräten von Samsung installieren lassen und das Galaxy Nexus ist für Samsung ja nur eine Auftragsarbeit.

    Viele Grüße
    Handymeister
     
  4. boshot, 10.01.2012 #4
    boshot

    boshot Android-Guru

    Denk ich auch.

    Die App braucht sicher das Samsung/Touch-Wiz Framework und nicht das Google Framework das auf dem Nexus drauf ist.

    Und bevor jetz die Frage kommt:
    Nein das Samsung Framework kann man nicht aufspielen :)


    Oder sie ist einfach (noch) nicht ICS kompatibel.
    (Wobei ich das nur mit max. 1% glaub, das es an dem liegt)
     
  5. doesdroid, 11.01.2012 #5
    doesdroid

    doesdroid Fortgeschrittenes Mitglied

    Andererseits lief die App bei meinem verlorenen Galaxy S2 auch auf Miui, und das ist doch eigentlich Open Source... Denke nicht, dass es am Touchwiz Framework liegt, eher, dass die App angepasst werden müsste. Wäre auch sehr daran interessiert, dass es klappt!
     
  6. dadri, 11.01.2012 #6
    dadri

    dadri Android-Hilfe.de Mitglied

    Na Samsung kann ja einzelne Apps für einzelne Geräte nur freigeben (siehe z.B. die gratis Spiele und Apps für die Flaggschiffe). Genau das wird hier auch der Fall sein. Ohne programmierkentnisse oder gar legal wird man da vermutlich nicht ran kommen. Samsung möchte schließlich gerne seine eigenen Geräte verkaufen.

    Sent from my Samsung Galaxy S2 (GT-I9100) using Tapatalk.
     
  7. doesdroid, 11.01.2012 #7
    doesdroid

    doesdroid Fortgeschrittenes Mitglied

    Ja, da gehe ich auch von aus. Deswegen bleibt ein klein wenig Resthoffnung, denn das Galaxy Nexus ist ja zumindest zur Hälfte von Samsung. Wenn nicht auch nicht schlimm, habe die App glaube ich drei mal benutzt und auch nur aus Geek-Neugierde...
     
  8. exbachi, 11.01.2012 #8
    exbachi

    exbachi Android-Hilfe.de Mitglied

    Ich habe das selbse Problem.
    Da ich aber die App bis zum Galaxy Nexus auf meinem Desire genutzt habe, schließe ich generelle Sperrung von nicht Samsung Geräten aus.

    Ich denke eher, da müssen Anpassungen wegen ICS oder der Auflösung gemacht werden.
     
  9. the_alien, 11.01.2012 #9
    the_alien

    the_alien Android-Lexikon

  10. exbachi, 11.01.2012 #10
    exbachi

    exbachi Android-Hilfe.de Mitglied

    Ich schon. Ich hoffe die anderen auch :D
     
  11. doesdroid, 11.01.2012 #11
    doesdroid

    doesdroid Fortgeschrittenes Mitglied

    Jau
     
  12. the_alien, 11.01.2012 #12
    the_alien

    the_alien Android-Lexikon

    Naja, scheint nur eine fehlende Unterstützung für 4.0 zu sein, die App ist ja nicht Samsung exklusiv.
     
  13. Michael M., 11.01.2012 #13
    Michael M.

    Michael M. Android-Experte

    ChatON ist auch laut Market "nicht für das Gerät verfügbar" -.-
    Wär ich Google-Chef würd ich da erstmal ordentlich den Rauch reinlassen...
     
  14. he_stheone64, 12.01.2012 #14
    he_stheone64

    he_stheone64 Android-Ikone


    Klappt nicht wenn es Touch Wiz Abhängigkeiten gibt, versuche es mal so einfach wie möglich zu erklären.

    Das Problem liegt in den ODEX files, welche im Prinizip optimierte Versionen von classes.dex files, welche in der Regel in den apk`s bereits eingebunden sind.

    Leider haben ODEX files Abhängigkeiten von jedem BOOTCLASSPATH file, der geladen wird. Der ODEX file ist nur gültig im Zusammenhang mit der passenden BOOTCLASSPATH. Dalvik prüft diese über eine checksum, wenn der ODEX geladen wird.

    BOOTCLASSPATH ist im Prinzip eine Liste von jars und apk`s, aus der die classes geladen werden können zusätzlich zur apk. Ein normales Android System hat 5 jars im BOOTCLASSPATH - core.jar, ext.jar, framework.jar, android.policy.jar und services.jar. Diese befinden sich alle in system/framework. Damit das noch komplizierter wird, haben manche apk`s leider noch zusätzliche Abhängigkeiten ausser diesen 5 jars (z.B. maps).

    Wenn also die system/framework nicht exakt die gleiche ist, laufen leider auch keine apk`s, da die ODEX nicht korrekt laden können.

    Samsung nutzt eigene framework apk und jar files, in denen resources gepulled werden von deren apps, daher klappt dies leider nicht. Sonstige resources könnte man noch relativ leicht mergen mit der stock framework, aber an oben erwähnten Gründen scheitern solche Ports von Touch wiz oder Sense.
     
    Zuletzt bearbeitet: 14.01.2012
  15. exbachi, 13.01.2012 #15
    exbachi

    exbachi Android-Hilfe.de Mitglied

    Wir können 100% ausschliesen, das die app auf Touchwiz angewiesen ist. Immerhin läuft die App auf dem Desire (Dank HTC mit Sense) und mit jedem Custom ROM (inkl. MIUI) das ich bisher auf dem Desire getestet hatte.
     
  16. fagu, 13.01.2012 #16
    fagu

    fagu Android-Hilfe.de Mitglied

    Mit der apk läuft es auch auf dem GN aber die Auflösung passt nicht! Man kann es aber trotzdem nutzen!

    com.samsung.smartview.apk
     
    hermz und doesdroid haben sich bedankt.
  17. ErDa, 13.01.2012 #17
    ErDa

    ErDa Android-Hilfe.de Mitglied

    TouchWiz-Abhängig kanns wirklich nicht sein, aufm Droid Razr von einem Bekannten läufts auch.
     
  18. he_stheone64, 14.01.2012 #18
    he_stheone64

    he_stheone64 Android-Ikone

    Die Remote ist auch eine Market app ohne Abhängigkeiten zur TWFramework, mein Kommentar bezieht sich auf system apps MIT Abhängigkeiten (das gilt auch für Sense apps & widgets).
     
  19. hermz, 03.07.2012 #19
    hermz

    hermz Android-Experte

    hat sich hier bzgl der samsung remote-app mittlerweile was getan?

    LG
     
    Zuletzt bearbeitet: 03.07.2012
  20. Benderfry, 03.07.2012 #20
    Benderfry

    Benderfry Android-Hilfe.de Mitglied

    Würde mich auch interessieren, zumal bei mir was lustiges angezeigt wird (s. Screenshot).
     

    Anhänge: