1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

SDImage Ubuntu 12.04 mit 3.0.8 Kernel (keine Modifikation am Xelio notwendig)

Dieses Thema im Forum "Linux auf Android Forum" wurde erstellt von br3zzer, 06.06.2012.

  1. br3zzer, 06.06.2012 #1
    br3zzer

    br3zzer Threadstarter Erfahrener Benutzer

    Beiträge:
    168
    Erhaltene Danke:
    77
    Registriert seit:
    01.04.2012
    Hier nun ein Image für die SD-Karte.
    Dieses muss einfach auf eine microSD welche 2GB oder größer ist geflasht werden.
    Ich empfehle eine Class 10 Speicherkarte zu verwenden für eine angenehme Performance.
    In dieser Version funktioniert auch Audio.

    Download:
    https://docs.google.com/open?id=0BxlaxD3nz2lcQlJEeUxlcEpMZGc

    Vorgehensweiße Windows User:
    -Zip-Datei herunter laden.
    -ImageSuite.exe ausführen.
    -Image + SD-Karte auswählen und flashen.


    Linux User:
    -Zip-Datei herunter laden.
    -Image mit OpenSuse Imagewriter flashen (oder mit dd)



    Anschließend SD-Karte einlegen und euer Tablet bootet Ubuntu :).
    -Benutzer: ubuntu
    -Passwort: ubuntu

    Ist die SD-Karte nicht mehr im Tablet bootet ganz normal euer Android.
     
    bs! und AsusFreak haben sich bedankt.
  2. maxtab, 07.06.2012 #2
    maxtab

    maxtab Android-Hilfe.de Mitglied

    Beiträge:
    85
    Erhaltene Danke:
    4
    Registriert seit:
    10.05.2012
    Coole Sache wolt ich sofort testen,
    aber leider stürzt der ImageSuite.exe unter Win 7 64 Bit auch imKompatibilitätsmodus ab. Hab dir micro SD in nem SD USB Adapter mit micro SD to SD Adapter. Morgen teste ich das unter XP oder Win 7 32 Bit.
    Gibt es hierzu meinungen Tipps?
    Danke
    maxtab
     
  3. br3zzer, 07.06.2012 #3
    br3zzer

    br3zzer Threadstarter Erfahrener Benutzer

    Beiträge:
    168
    Erhaltene Danke:
    77
    Registriert seit:
    01.04.2012
    Hallo Maxtab,
    ich habe es am meinem Laptop getestet ob man das Image unter Windows flashen kann. Dieser hat ebenfalls Windows 7 und 64bit.

    Kommt eine Fehlermeldung oder stuerzt ImageSuite komplett ab?
     
  4. jna, 07.06.2012 #4
    jna

    jna Ehrenmitglied

    Beiträge:
    7,398
    Erhaltene Danke:
    1,299
    Registriert seit:
    28.01.2011
    Bei mir ist die SD-Karte (ebenso USB-Stick) im Inagetool gar nicht auswählbar :(
     
  5. br3zzer, 07.06.2012 #5
    br3zzer

    br3zzer Threadstarter Erfahrener Benutzer

    Beiträge:
    168
    Erhaltene Danke:
    77
    Registriert seit:
    01.04.2012
    Ok da es mit ImageSuite wohl Probleme gibt habe ich mich nach einem anderen Programm umgeschaut welches unter Windows geht(und auch gleich getestet):
    http://hddguru.com/software/HDD-Raw-Copy-Tool/HDDRawCopy1.02Portable.exe

    1.HDDRawCopy Starten
    2.Dann als Source unter dem Punkt File das Raw-Image auswählen.
    3.Continue
    4.Anschließend als Target eure SDKarte auswählen
    5.Continue
    6.Flashen:)

    Bitte um Rückmeldung.
     
  6. benno01, 07.06.2012 #6
    benno01

    benno01 Android-Hilfe.de Mitglied

    Beiträge:
    95
    Erhaltene Danke:
    6
    Registriert seit:
    07.06.2012
    Hallo br3zzer,

    mit dem neuen Programm funktioniert die Geschichte mit W7 64bit. Bei dem anderen Programm konnte man zwar Image auswählen und die SD-Karte wurde gefunden, aber wenn man starten wollte kam der Hinweis, ob man mit Administratorenrechten gestartet hat und bei Bestätigung ging wieder alles zum Anfang.

    Mit Linux hab ich noch keinen Schimmer. Ist aber normal gestartet. Leider ist es noch nicht deutsch und für meine Wurstfinger ist alles ziemlich klein geraten. Korrekte Treffer sind da eher Zufall. Aber das kann man sicher noch einstellen.

    Vielleicht hilft das anderen, auch mal einen Versuch zu wagen.

    Gruß und vielen Dank für die Arbeit
    Thomas

    Ich nochmal,

    bin gerade ausversehen auf Screensaver gekommen und wenn ich auf Passwort gehe, kommt keine Tastatur, hänge also fest.
     
    Zuletzt bearbeitet: 07.06.2012
  7. maxtab, 07.06.2012 #7
    maxtab

    maxtab Android-Hilfe.de Mitglied

    Beiträge:
    85
    Erhaltene Danke:
    4
    Registriert seit:
    10.05.2012
    Hallo, ich hatte auch probleme mit ImageWriter.exe, dachte es liegt an Win7 64 Bit. unter XP konnte ich ImageWriter.exe gar nicht starten. Bei Win 7 32 Bit ging's auch nicht. Hab dan in einem Umbuntu Forum die Lösung gefunden. Die SD Karte muß FAT formatirert sein. Dann lief ImageWriter.exe ohne Probleme. @ Benno 01 das mit dem Screensaver ist mir auch passiert, da konnte ich nur noch mit Reset raus. Hab den Versuch mit dem Live Umbuntu aber auch erstmal wieder abgebrochen, da die Tastatur bis auf den ersten lock-in nicht eingeblendet wird. Außerdem bin ich mit der Android 4 gar nicht so unzufrieden. Aber so ist es seit es Computer gibt. Never touch.... Gute Dinge will man doch immer wieder anfassen und dran spielen oder?
    Viel Spass maxtab
     
  8. br3zzer, 07.06.2012 #8
    br3zzer

    br3zzer Threadstarter Erfahrener Benutzer

    Beiträge:
    168
    Erhaltene Danke:
    77
    Registriert seit:
    01.04.2012
    Tastatur kannst ja nach dem einloggen öffnen wenn du sie benötigst :).

    Ich hab ne Hülle mit Tastatur deshalb nutz ich das Onscreen Keyboard selten.
     
  9. maxtab, 07.06.2012 #9
    maxtab

    maxtab Android-Hilfe.de Mitglied

    Beiträge:
    85
    Erhaltene Danke:
    4
    Registriert seit:
    10.05.2012
    Hi br3zzer,
    dann sag mir bitte wie ich die Tastatur öffne.
    Danke
     
  10. br3zzer, 08.06.2012 #10
    br3zzer

    br3zzer Threadstarter Erfahrener Benutzer

    Beiträge:
    168
    Erhaltene Danke:
    77
    Registriert seit:
    01.04.2012
    1.Menü unten links->Universal Access-> CellWriter

    Da Cellwriter eigentlich auch zur Handschrifterkennung ist siehst du nicht direkt die Tastatur.
    Du musst unten links auf Train und dann rechts auf Keys.:)

    Etwas umständlich so, deshalb am besten eine Verknüpfung anlegen:

    /usr/bin/cellwriter --keyboard-only

    Dann startet Cellwriter direkt in der Keyboard Ansicht.

    Falls ich nochmal ein Image erstelle mache ich das auch gleich so :)
     
  11. br3zzer, 08.06.2012 #11
    br3zzer

    br3zzer Threadstarter Erfahrener Benutzer

    Beiträge:
    168
    Erhaltene Danke:
    77
    Registriert seit:
    01.04.2012
    Was mir noch einfällt:
    Wlan Interface habe ich vergessen gleich für euch einzutragen in diesem Release. Daher einfach im Netzwerkmanager in den Einstellungen kurz wlan0 eintragen.
     
  12. MrProper, 08.06.2012 #12
    MrProper

    MrProper Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    11
    Registriert seit:
    15.12.2010
    Funktioniert diesmal auch HDMI?
     
  13. br3zzer, 10.06.2012 #13
    br3zzer

    br3zzer Threadstarter Erfahrener Benutzer

    Beiträge:
    168
    Erhaltene Danke:
    77
    Registriert seit:
    01.04.2012
    Nein funktioniert leider noch nicht.
     
  14. gawl, 10.06.2012 #14
    gawl

    gawl Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    10.06.2012
    Vielen Dank für dieses Ubuntu, erstmalig bekomme ich das Gefühl, mit dem Xelio tatsächlich so richtig etwas Sinnvolles anfangen zu können! :)

    (Sorry an alle Android-Fans, ist nicht böse gemeint, aber als ich zum Beispiel meine Musikfestplatte (1TB über USB) anschloss und Android mir meldete "SD-Karte beschädigt", war mein anfängliches Interesse an diesem Betriebssystem doch stark gemindert. Und wenn ich sowieso "fummeln" muss, um alles mir Wichtige zum Laufen zu bekommen, dann doch direkt mit einem Linux, da habe ich mehr Erfahrung :winki:

    Das SUSE-Imagetool ging bei mir auch nicht, mit dem anderen empfohlenen Windows-Programm klappte das "Flashen" aber problemlos auf Anhieb.

    Anschließend habe ich mir die Micro-SD-Karte (per Kartenleser am Linux-PC) über gparted angesehen, es wurden zwei Partitionen angelegt, eine kleine FAT16 und eine ca 1GB große mit ext4-Dateisystem. Letztere konnte ich (mit gparted) problemlos vergrößern, sodass ich nun ein Ubuntu-Dateisystem mit (fast) der vollen Größe der Micro-SD-Kapazität habe (knapp 32 GB in meinem Falle), davon habe ich 1GB direkt wieder an eine swap-Datei abgetreten. Nun habe ich tatsächlich ein Ubuntu-System mit "Platz satt" für Nutzerdaten und weitere Programme. :)

    Lediglich folgendes fällt mir auf:

    -- Ich habe keine Akku-/Batterieanzeige unten in der Status-Leiste. Das ist schade, zumal die beim "Dual-Boot-Ubuntu v3" schon 'mal da war. Lässt sich da noch etwas machen?

    -- Gibt es evtl. eine Möglichkeit für ein Suspend und/oder Hibernate? Ich bin verwöhnt von meinem (leider arg in die Jahre gekommenen) Sharp Zaurus, den konnte man "mal eben schnell" einschalten, um kurz etwas einzutragen oder nachzusehen und ihn dann ebenso bequem wieder schlafen legen. Den Xelio muss ich anscheinend immer so richtig voll hoch- und wieder herunterfahren...!?
     
  15. br3zzer, 11.06.2012 #15
    br3zzer

    br3zzer Threadstarter Erfahrener Benutzer

    Beiträge:
    168
    Erhaltene Danke:
    77
    Registriert seit:
    01.04.2012
    Hallo gawl,

    meine Konfiguration sieht ganz ähnlich aus :) .
    Habe eine 16GB Class 10 Speicherkarte ,davon ebenfalls 1GB Swap.

    Wegen Battery Widget und Hibernate:
    Da hast du recht das wäre noch sehr hilfreich, hat aber beides auch im DualBoot Image nicht funktioniert.

    Im moment schaue ich mir noch diverse andere Desktop Umgebungen an in der Hoffnung eine zu finden mit der ich zufrieden bin und die noch weniger Performance benötigt wie LXDE.

    Ergänzung:
    Mit hal lässt sicher der Akku auslesen.

    1. apt-get install hal

    2. hal-device | grep battery.charge_level.percentage

    Das heißt wir müssen nur ein Battery Widget für lxde suchen welches HAL-Support hat und nicht Acpi.
     
    Zuletzt bearbeitet: 11.06.2012
  16. gawl, 12.06.2012 #16
    gawl

    gawl Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    10.06.2012
    Wäre es nicht einfacher, direkt den Kernel zu befragen?
    Ich habe den Eindruck, dass der Ladestand als Prozentzahl in der (Pseudo-)Textdatei

    /sys/devices/platform/sun4i-i2c.0/i2c-0/0-0034/axp20-supplyer.28/power_supply/battery/capacity

    steht bzw. daraus auslesbar ist.
    Und für mich persönlich müsste es noch nicht einmal ein ultra-schick gestaltetes Widget sein, dies als (passend kleine) Zahlenangabe in der Statusleiste fände ich schon äußerst hilfreich und wäre sicherlich resourcen-schonender als der Umweg über hal.
     
  17. MrProper, 12.06.2012 #17
    MrProper

    MrProper Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    11
    Registriert seit:
    15.12.2010
    Könnte man nicht Ubuntu12.04 Unity installieren?
    Oder läuft das wirklich so langsam?, den die Oberfäche ist ja schon für Neetbook gemacht, wäre halt besser.
     
  18. br3zzer, 13.06.2012 #18
    br3zzer

    br3zzer Threadstarter Erfahrener Benutzer

    Beiträge:
    168
    Erhaltene Danke:
    77
    Registriert seit:
    01.04.2012
    Kannst ja einfach mal ausprobieren:

    LXTErminal öffnen: sudo apt-get install unity

    Anschließend solltest du beim Loginmanager unten links unity auswählen können.
    (Kann sein das du vorher auch deine Ubuntu Partition auf der SD-Karte vergrößern musst, damit der Platz reicht.)
    Ich würde gerne mal KDE Plasma-Active testen, dieses habe ich jedoch noch nicht zum laufen bekommen.
    Mal abwarten bis es einen funktionierenden Mali Treiber gibt :)
     
  19. MrProper, 13.06.2012 #19
    MrProper

    MrProper Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    11
    Registriert seit:
    15.12.2010
    Hab ich schon so probiert.
    Aber leider kommt nach einer langen Installation dann zu einigen Fehlermeldungen.
    So genau kenn ich mich da leider auch nicht aus, nach einem Neustart kommt ich noch bis zum Log-Bildschirm, dann Funktioniert leider nichts mehr.:blushing:
     
  20. MrProper, 14.06.2012 #20
    MrProper

    MrProper Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    11
    Registriert seit:
    15.12.2010
    Achja nachdem ich mittels gparted den Speicher vergrösserte (1GB sind wirklich zu wenig) funktionierte die installation von Unity.
    Leider kommt beim Login Manager nicht die Auswahl wo Unity dabei sein sollte.
    Hab es dann Manual gestartet, kommt aber die Fehlermeldung das Opengl fehlt, denke nun würde der der fehlende Mali-Chip Treiber helfen.

    So wie es aussieht funktioniert Unity nur mit opengl, schade eigentlich.


    Ansonsten eine interessante Sache, das Zukunftspotenzial hat.

    @br3zzer Du wolltest eventuell eine andere Desktop Umgebungen einbauen, schau mal Arch Linux an, denke das könnte noch was gutes sein.
     
    Zuletzt bearbeitet: 14.06.2012

Diese Seite empfehlen