1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Selbst gebastelte Bootanimation funktioniert nicht

Dieses Thema im Forum "Root / Hacking / Modding für Sony Ericsson Xperia X10" wurde erstellt von SE_X10, 29.01.2011.

  1. SE_X10, 29.01.2011 #1
    SE_X10

    SE_X10 Threadstarter Erfahrener Benutzer

    Beiträge:
    200
    Erhaltene Danke:
    20
    Registriert seit:
    19.12.2010
    Phone:
    Sony Ericsson Xperia X10
    Hey, ich hab mal wieder ein Problem:

    Habe mir das Theme hier runtergeladen[http://www.android-hilfe.de/root-ha...-2-2-theme-fuer-freex10-beta2-green-glow.html], die .zip-Datei entpackt, die bootanimation.zip rausgesucht, diese dann wieder entpackt, bei allen bilder die Farbe verändert[sonst überhaupt nichts verändert] und das ganze wieder zur ner neuen bootanimation.zip zusammengepackt. Ich lade es rüber auf die SD card, überschreibe damit die orginal bootanimation.zip im ordner /system/media, und reboote mein handy.

    Jetzt kommt allerdings eine zeit lang ein schwarzer bildschirm anstatt irgendeiner bootanimation.

    http://www.file-upload.net/download-3174199/bootanimation.zip.html
    Das ist der downloadlink für meine erstellte .zip-datei




    Kann mir einer sagen was ich falsch gemacht habe?

    EDIT:jetzt stimmt der downloadlink für die erstelle .zip
     
    Zuletzt bearbeitet: 30.01.2011
  2. quercus, 29.01.2011 #2
    quercus

    quercus Gast

    zuerst hast ja mal das Theme geflasht, nehm ich an?

    Ging es da noch?

    JA - dann ist beim "Basteln" der Bootanimation was schiefgelaufen

    Nein - beim Flashen ging was daneben

    zu JA - ich würd die Bootanimation mal weglassen und mich besser einlesen - oder sie ist überhaupt fehlerhaft.

    zu NEIN - nochmals Flashen

    MfG Quercus
     
    Zuletzt von einem Moderator bearbeitet: 29.01.2011
  3. SE_X10, 30.01.2011 #3
    SE_X10

    SE_X10 Threadstarter Erfahrener Benutzer

    Beiträge:
    200
    Erhaltene Danke:
    20
    Registriert seit:
    19.12.2010
    Phone:
    Sony Ericsson Xperia X10
    Weder noch :laugh:

    Ich habe das theme nicht geflasht. ich will ja theoretisch nur eine selbst gebaute bootani und hab die von dem theme nur als vorlage genommen und die bilder verändert.
     
  4. quercus, 30.01.2011 #4
    quercus

    quercus Gast

    Dann darfst mal Antwort - JA - als bindend nehmen :biggrin:
     
  5. SE_X10, 30.01.2011 #5
    SE_X10

    SE_X10 Threadstarter Erfahrener Benutzer

    Beiträge:
    200
    Erhaltene Danke:
    20
    Registriert seit:
    19.12.2010
    Phone:
    Sony Ericsson Xperia X10
    Das ich was falsch gemacht hab wusste ich auch schon vorher :thumbsup: bin gut was? :winki: jetzt will ich wissen was?!

    naja habe gerade gesehn, dass in meim ersten post der downloadlink nicht gestimmt hat - jetzt tut ers.
     
  6. quercus, 30.01.2011 #6
    quercus

    quercus Gast

    Sorry - gg - wenn man nicht dabei war, ist es schwer was zu reproduzieren nur auf den Verdacht hin.

    Ja wieso machst sowas, vor einer Woche hast noch gefragt wie man das Handy einschaltet - nächste Woche wirst schon dein eigenes Handy bauen:laugh::laugh:

    *Zwinker*
    Vermutlich ist die Bootanimation fürs Green Theme geschrieben und wird ohne dem Theme gar nicht laufen - Versuch mal das Theme zu Flashen und danach nochmals die Bootanimation-
    Ansonsten - keinen blassen Schimmer - tut leid!

    MfG Quercus
     
    Zuletzt von einem Moderator bearbeitet: 30.01.2011
  7. SE_X10, 30.01.2011 #7
    SE_X10

    SE_X10 Threadstarter Erfahrener Benutzer

    Beiträge:
    200
    Erhaltene Danke:
    20
    Registriert seit:
    19.12.2010
    Phone:
    Sony Ericsson Xperia X10
    Kommt dir das bekannt vor?
    Der letzte absatz und vor allem der letzte satz!!!



    naja trotzdem Danke für dein bemühen.
     
    Zuletzt bearbeitet: 30.01.2011
  8. quercus, 30.01.2011 #8
    quercus

    quercus Gast

    Steht eh da - abgesehen von Themes und Roms!

    Lies nochmals den letzten Beitrag von mir - letzter Absatz - wir dürften zur selben Zeit geschrieben haben.

    MfG Quercus
     
  9. SE_X10, 30.01.2011 #9
    SE_X10

    SE_X10 Threadstarter Erfahrener Benutzer

    Beiträge:
    200
    Erhaltene Danke:
    20
    Registriert seit:
    19.12.2010
    Phone:
    Sony Ericsson Xperia X10
    ne passt schon, das theme an sich find ich hässlich, nur die bootani gut, [wenn sie so aussieht wie ich sie verändert habe, aber so geht ja nicht]

    ich hab jetzt einfach gar keine bootanimation in dem besagten ordner, dann kommt so n blau schimmerndes android logo, pretty cool....

    ich hab manchmal das gefühl, dass bei der orginalen sony ercisson-bootani, das X10 überfordert ist.
     
  10. quercus, 30.01.2011 #10
    quercus

    quercus Gast

    kann leicht sein - na dann passt ja wieder :)

    MfG Quercus
     
  11. DoubleX667, 30.01.2011 #11
    DoubleX667

    DoubleX667 Android-Experte

    Beiträge:
    605
    Erhaltene Danke:
    100
    Registriert seit:
    23.01.2010
    Hast du beim bearbeiten der Bilder eventuell die Farbtiefe geändert?
    Ich glaube mich zu erinnern, dass eine Bootanimation nur eine Farbtiefe von 24bit unterstützt. Vielleicht liegt es ja daran?
     
  12. Poza, 30.01.2011 #12
    Poza

    Poza Fortgeschrittenes Mitglied

    Beiträge:
    362
    Erhaltene Danke:
    78
    Registriert seit:
    15.11.2010
    Phone:
    Samsung Galaxy S3
    ja, das habe ich schon durch.... hehe...

    Mann kann nicht nur das zip öffnen und verändern...denn auch hier ist das Problem mit dem entpacken vorhanden, also auch nur mit 7zip arbeiten...

    was auch wichtig ist ist die desc.txt damit musst du ein bisschen rumspielen...
    Versuch mal diesen cod hier:

    480 854 20
    p 1 0 ani0
    p 0 0 ani1
    kopieren und in desc.txt den alten cod überschreiben...

    p.s wenn vorher folder0 stand dann muss du auch ani0/1 in folder0/1 umbenennen und beachte das beim packen die kompressionsstärke auf speichern eingestellt ist...

    Gruss Poza
     
  13. SE_X10, 30.01.2011 #13
    SE_X10

    SE_X10 Threadstarter Erfahrener Benutzer

    Beiträge:
    200
    Erhaltene Danke:
    20
    Registriert seit:
    19.12.2010
    Phone:
    Sony Ericsson Xperia X10
    dazu hab ich was intressantes gefunden, ich poste das einfach mal hier:

    Here is what the desc.txt file does and mean.

    • 480 – stretched width of the animation
    • 427 – stretched height of the animation
    • 30p – this controlled the speed of both parts of the animation
    • 1 – this defined how many times part0 of the animation looped
    • 0 – saw no change when altering this number
    • part0 – folder containing first part of the animation
    • p – this was a bit confusing as there is no space between the words “part0″ & the “p”. I tried adding a space and changing this number -> “part0 30p”. I expected this to change the speed of the second part of the animation, but there was no change as far as I could tell.
    • 0 – this defined the number of times part1 of the animation looped (0=infinite)
    • 10 – saw no change when altering this number
    • part1 – folder containing second part of the animation
    Wo stell ich das denn ein??
     
  14. Poza, 30.01.2011 #14
    Poza

    Poza Fortgeschrittenes Mitglied

    Beiträge:
    362
    Erhaltene Danke:
    78
    Registriert seit:
    15.11.2010
    Phone:
    Samsung Galaxy S3
    In jeder bootanimation findest du eine desc.txt datei.
    Die einfach im editor öffnen und bearbeiten..

    gruss poza
     
  15. SE_X10, 30.01.2011 #15
    SE_X10

    SE_X10 Threadstarter Erfahrener Benutzer

    Beiträge:
    200
    Erhaltene Danke:
    20
    Registriert seit:
    19.12.2010
    Phone:
    Sony Ericsson Xperia X10
    ich glaub du hast meine frage nicht richtig verstanden. das mit der .txt-datei hab ich verstanden aber

    Ich meine das:
    Mit "packen" meinst du doch, am ende alle dateien und ordner in einer .zip-datei packen. [mit 7-Zip]
    jetzt sagst du, ich soll hier die kompressionsstärke auf speichern stellen. Wo kann ich das einstellen?
     
  16. Poza, 30.01.2011 #16
    Poza

    Poza Fortgeschrittenes Mitglied

    Beiträge:
    362
    Erhaltene Danke:
    78
    Registriert seit:
    15.11.2010
    Phone:
    Samsung Galaxy S3
    ah..ok. sorry.

    mit rechter maustaste auf datei clicken die du packen willst
    > 7zip > zu einem Archiv hinzufügen> [zu Archiv hinzufügen Fenster] öffnet sich...

    dann wählst du Kompressionsstärke > speichern.

    kanns nicht besser beschreiben...

    edit; habe hier noch ne animation verändert..den Schluss kriege ich irgendwie noch nicht besser hin...
    Vorschau; im Anhang (Cyborg freeX10.zip)
    bootanimation.zip :http://www.megaupload.com/?d=MS060UQS
     

    Anhänge:

    Zuletzt bearbeitet: 30.01.2011
    SE_X10 bedankt sich.
  17. SE_X10, 30.01.2011 #17
    SE_X10

    SE_X10 Threadstarter Erfahrener Benutzer

    Beiträge:
    200
    Erhaltene Danke:
    20
    Registriert seit:
    19.12.2010
    Phone:
    Sony Ericsson Xperia X10
    wuhuu es tut. Danke!!
    an der Kompressionsstärke liegts.
     
  18. Poza, 30.01.2011 #18
    Poza

    Poza Fortgeschrittenes Mitglied

    Beiträge:
    362
    Erhaltene Danke:
    78
    Registriert seit:
    15.11.2010
    Phone:
    Samsung Galaxy S3
    :)
     

Diese Seite empfehlen