1. Möchtest Du unser Team im Android OS-Bereich unterstützen? Details dazu findest du hier!
  2. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

seltsames Problem mit einem In-App Kauf

Dieses Thema im Forum "Google Play Store (Android Market)" wurde erstellt von fant0mas, 18.08.2011.

  1. fant0mas, 18.08.2011 #1
    fant0mas

    fant0mas Threadstarter Android-Lexikon

    Beiträge:
    1,206
    Erhaltene Danke:
    132
    Registriert seit:
    22.02.2010
    Hi,

    nachdem weder der App-Entwickler, noch der Google Market-Support mir wirklich weiterhelfen konnte, wollte ich mal nachhören ob hier evtl. jemand eine Idee dazu hat - im "schlimmsten" Falle wollte ich dann wenigstens das Problem mal publik machen, weil scheinbar es bis dato sonst nirgends dokumentiert ist (weder auf dt. noch auf engl.!)...

    Ausgangssituation: Motorola Milestone, root, 800MHz (irrelevant aber hierfür), TheFroyoMod 2.7.0
    Market-Version: neueste (3.0.27)

    App: "Caustic" (Developer SingleCell), wobei ich davon ausgehe dass das relativ unabhängig von der App selbst ist, sondern eher mit dem In-App Purchase Mechanismus zusammenhängt.

    Was passiert ist:
    Die App bietet per In-App Purchase einen 'Full Version Unlock' an, den ich erwerben wollte - ging auch soweit scheinbar erst mal gut, nur leider hatte ich dann, zumindest laut Fehlermeldung, ein Verbindungsproblem, diese riss ab, wodurch der Kaufvorgang dann zu lange ohne Rückmeldung blieb, was eine automatische Stornierung des Kreditkartenvorgangs zur Folge hatte.

    Soweit, so gut - im Checkout-Konto steht auch folgerichtig "Kauf automatisch abgebrochen" etc. da, es wurde kein Geld verbucht, etc. etc. pp.

    Problem:
    Wenn ich jetzt versuche, den In-App Kauf erneut anzustossen, kommt IMMER(!) die Fehlermeldung (im Market dann):
    "Sie haben bereits eine Bestellung für diesen Artikel aufgegeben."
    und bricht sofort dann ab und kehrt zur App zurück.

    Jetzt kann mir der App-Developer nicht helfen, weil laut den einzigen Aufzeichnungen die er einsehen kann, der Kauf abgebrochen wurde, also KEINE laufende Bestellung vorliegt.
    Ebenso für mich (Checkout-Konto Übersicht), und scheinbar auch für den Google Support.

    Von denen bekam ich nämlich bisher 3 bis 4 "Copy & Paste" Mails mit verschiedenen Varianten derselben Anweisungen -> ich möge das Checkout Konto sowie meine Kreditkartendaten überprüfen (welche stimmen, ich kann nämlich nach wie vor "normal" Apps kaufen), die Marketversion überprüfen (ist neueste), den Marketcache löschen (habe ich, ebenfalls Daten, sowie den kompletten Market de- und re-installiert), die fragliche App neu installieren (habe ich, vorher auch versucht mit Cache löschen).

    Effekt: null.

    Ich weiss nicht weiter, der App-Dev auch nicht, vom Google Support kamen bisher nur Antworten aus der Dose - obwohl ich wenigstens schon über den "Roboter"-Mailer hinaus bin und inzwischen mit einem "Frédérique" maile.
    Der ist allerdings auch Fan des CTRL+C / CTRL+V Schnellverfahrens...

    Das einzige(!) was ich bisher nicht probiert habe (mangels Möglichkeit), ist ob In-App Purchase generell bei anderen Apps geht - ich hab einfach keine andere wo das nötig ist.
    Finde das eh unnötig, lieber wäre mir ne separate App mit Full-Version im Market - gibt es aber in diesem Fall nicht, weil der Dev sich die vielen "15-Min Tester" (=Raubkopierer) ersparen will. Womit er ja auch Recht hat. In-App Unlocks lassen sich nämlich wohl (bisher) nicht raubkopieren, da sie an das Google Konto gebunden sind.
     
  2. DrMole, 18.08.2011 #2
    DrMole

    DrMole Android-Ikone

    Beiträge:
    4,941
    Erhaltene Danke:
    1,463
    Registriert seit:
    06.08.2010
    Hast du auch den Market Ordner(com.android.vending) unter /data/data/ gelöscht?
     
  3. fant0mas, 19.08.2011 #3
    fant0mas

    fant0mas Threadstarter Android-Lexikon

    Beiträge:
    1,206
    Erhaltene Danke:
    132
    Registriert seit:
    22.02.2010
    hm, das nicht - aber habe unter anwendungen verwalten in market-eintrag cache und daten gelöscht. sollte das nicht data/data mit beinhalten?

    kann mir auch nciht vorstellen dass es daran liegen sollte - denn die fehlermeldung kommt erst nach kommunikation mit dem Market-Server.
    Spürbar daran, dass die Fehlermeldung nicht kommt oder erst später, wenn ich kurzzeitig keine oder eine schlechte Verbindung habe.
     
  4. DrMole, 19.08.2011 #4
    DrMole

    DrMole Android-Ikone

    Beiträge:
    4,941
    Erhaltene Danke:
    1,463
    Registriert seit:
    06.08.2010
    Nein, als ich mit dem Market Probleme hatte, hat das geholfen.

    geschrieben mit dem Doc-Phone
     
  5. fant0mas, 20.08.2011 #5
    fant0mas

    fant0mas Threadstarter Android-Lexikon

    Beiträge:
    1,206
    Erhaltene Danke:
    132
    Registriert seit:
    22.02.2010
    hat leider nicht geholfen, hab s gerade probiert.
     
  6. fant0mas, 31.08.2011 #6
    fant0mas

    fant0mas Threadstarter Android-Lexikon

    Beiträge:
    1,206
    Erhaltene Danke:
    132
    Registriert seit:
    22.02.2010
    Problem besteht leider nach wie vor - und unverändert - immer noch... :-(

    Keiner irgend eine weitere Idee?

    Der Market-Support hat mir nur wieder eine weitere, Copy & Paste - Antwort geschickt - ich solle auf Werkszustand zurücksetzen.

    Was das bringen soll ist mir unverständlich, habe ja bereits Market komplett deinstalliert, alle Caches etc. gelöscht, neu installiert - mehr würde ja ein Re-Flash bzw. Factory Reset in dem Sinne auch nicht machen, von daher schliesse ich das mal aus. Kann ich mir auch gerade aus Zeitgründen (Abschlüssprüfungen) eh nicht erlauben, alles zurücksetzen + neu einrichten.

    Bin für jeden weiteren Gedanken sehr dankbar!
     
  7. fant0mas, 06.10.2011 #7
    fant0mas

    fant0mas Threadstarter Android-Lexikon

    Beiträge:
    1,206
    Erhaltene Danke:
    132
    Registriert seit:
    22.02.2010
    Problem besteht weiterhin, auch mit einem neuen ROM (= Factory Reset wie vom Support vorgeschlagen, und am alten ROM lag es also auch nicht).

    Und die App (Caustic) liegt inzwischen in einer neuen Version vor, selbes Problem.

    Der In-App Kauf geht in den Market, lädt 2 sekunden, bricht ab mit "Es liegt ein Fehler vor" und geht in die App zurück (die meldet mir nur "No connection to Market", Verbindung steht aber ununterbrochen zu 100%)...

    No ideas?
     
  8. RedBlackF, 15.10.2011 #8
    RedBlackF

    RedBlackF Fortgeschrittenes Mitglied

    Beiträge:
    285
    Erhaltene Danke:
    53
    Registriert seit:
    15.10.2011
    Phone:
    Sony Xperia Ion
    Das gleiche Problem habe ich nun seit drei Tage auch.
    Die betroffene App ist "Minecraft Pocket Edition".

    Mein Gerät: Sony Ericsson Xperia arc
    Firmware: Android 2.3.3
    Marketversion: 3.1.5

    Nachdem ich sie gekauft hatte, stieß mein Bruder mich versehentlich an, die Folge war, dass ich die Bestellung fälschlicher Weise stornierte.
    Vom Kauf und von der Stornierung habe ich eine Mail bekommen.

    Die Fehlermeldung ist dieselbe, wie bei fant0mas.
    Der Support hat bisher noch nicht geantwortet, der AppDev genauso wenig...

    Auch wenn's umständlich wäre, wie wäre es, wenn man einfach ein zweites Googlekonto anlegt?
    Ich hab vorhin gesehen, dass man mehrere Konten im Market nutzen kann, von denen man eins auswählt.

    Ich versuch' das einfach mal und melde mich dann wieder hier.
     
  9. fant0mas, 17.10.2011 #9
    fant0mas

    fant0mas Threadstarter Android-Lexikon

    Beiträge:
    1,206
    Erhaltene Danke:
    132
    Registriert seit:
    22.02.2010
    hm... wenigstens nicht mehr allein mit dem Problem, auch wenn´s nicht wirklich viel Trost spendet ^^

    Update meinerseits: Ich konnte gerade eben übrigens auch gar keinen "normalen" App-Kauf (Paid App) tätigen, hatte ich seitdem gar nicht mehr probiert... scheinbar ist der Market nicht mehr gut auf mich zu sprechen?? wtf.

    Ich such mal nach Lösung generell für das Paid-App Problem (kam ja schon öfter vor), evtl. ist damit ja mein/unser In-App Problem auch zu lösen. Poste ich dann ggf. hier.
     
  10. RedBlackF, 29.11.2011 #10
    RedBlackF

    RedBlackF Fortgeschrittenes Mitglied

    Beiträge:
    285
    Erhaltene Danke:
    53
    Registriert seit:
    15.10.2011
    Phone:
    Sony Xperia Ion
    Wenn man einfach ein zweites Google-Konto eröffnet und das im Market hinzufügt usw. geht es wieder ohne Probleme..

    Der Alte Google-Account wird jetzt halt für kostenlose Apps genutzt, der Neue für kostenpflichtige.

    Der Google-Support indes verzichtet seit neustem auf Antworten. Außer die immer gleiche maschinelle Antwort erhalte ich nicht.
    Kundensupport sollte anders aussehen...
     
  11. Spider1996, 29.11.2011 #11
    Spider1996

    Spider1996 Moderator Team-Mitglied

    Beiträge:
    1,550
    Erhaltene Danke:
    632
    Registriert seit:
    05.08.2011
    Phone:
    OnePlus One
    Tablet:
    Nexus 10
    Schonmal probiert eine App über den PC zu kaufen? Dann lässt er sie ja aufs Telefon runter aber vlt löst er ja dann wieder den Knoten so das es übers Handy wieder geht.

    Edit: Damit ihr nicht Googlen müsst: https://market.android.com/

    Hoffe ich konnte helfen ;)

    Gesendet von meinem X10i mit der Android-Hilfe.de-App
     

Diese Seite empfehlen

Besucher kamen mit folgenden Begriffen auf unsere Seite:

  1. in app kauf abgebrochen