1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

SGS2 hat Probleme mit dem Umschalten zwischen FritzBox und FritzRepeater

Dieses Thema im Forum "Samsung Galaxy S2 (I9100) Forum" wurde erstellt von networm, 17.04.2012.

  1. networm, 17.04.2012 #1
    networm

    networm Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    17.04.2012
    Habe ein Vodafone-gebrandetes Galaxy S2 auf das Icecream Sw. geupdatet. Über das KIES völlig problemlos.

    Aber auch nach dem Update kann das S2 kein WLAN-Roaming. Darüber wurde schon in mehreren Threads berichtet, wie z.B. hier:

    [Samsung Galaxy S 2] SGS2 hat Probleme mit dem Umschalten zwischen Fritz.Box und Fritz.Repeater - Android Forum - AndroidPIT

    Speziell das Problem gibt es also immer noch - liegt dies etwa an der Hardware des S2? Bei mir können das iPhone4, Blackberry, Nokia, Tablets, Notebooks ohne Probleme. Der jeweilige Access-Point mit der gleichen SSID (Fritz-Box + Fritz!WLAN-Repeater) wird an seiner Feldstärke automatisch von allen Geräten angesprochen - nur das S2 schafft dies nicht!

    Aber es braucht niemand zu sagen, andere WLANs einzurichten etc. Die Art, wie dies AVM vorsieht ist eindeutig die bessere Wahl - nur muss das auch die Hardware der Geräte leisten, die sich dort einbuchen.

    Wird sich daran beim S2 noch mal was ändern oder geht das hardwaretechnisch bei diesem Gerät nicht???



    Noch zu einigen Details der Konfiguration: SSID bei Fritzbox und Repeater eingeschaltet, weil das Android Tab (ein Acer, ebenfalls mit Icecream) mit versteckter SSID ein Problem beim WLAN hat (wobei das Verstecken der SSID ja eh keinen großen Vorteil bringt); verwendet wird nur WPA2; die IPs aller Mobilgeräte sind als fest vereinbart (in der Fritzbox) - also keine DHCP-Probleme; Funkkanal ebenfalls fest
     
    Zuletzt bearbeitet: 17.04.2012
  2. badboymoerv, 17.04.2012 #2
    badboymoerv

    badboymoerv Gast

    Hey ich weiss nicht ob es hier rein gehoert, aber weiss einer ob es die funktion vom rooter abstellen auf der 4.0er android version noch gib bei der alten 2.3er gab es diese wenn du im standby modus bist das dein rooter und dein w-lan aufen handy nach 10 minuten von alleine ausschaltet weiss da einer was? Bitte un antwort

    Gesendet vom Galaxy SII
     
  3. networm, 17.04.2012 #3
    networm

    networm Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    17.04.2012
    Ich denke schon, dass dieses Problem hier auch eher handyspezifisch ist und mit der Umsetzung des ICS auf das SGS2 zusammenhängt bzw. das SGS2 direkt hardwaremäßig damit ein Problem hat...

    Andere Nutzer berichten ja, das es vorher beim Galaxy S1 keine Probleme gab aber dann mit dem neuen Galaxy S2. Und das noch mit dem verherigen Android GB...

    Weiß denn keiner was Genaueres dazu? WLAN ist ja ein grundlegendes Problem und nicht erst seit dem Update beim SGS2 ein Übel. Dachte nur, das sich evtl. etwas durch das Update etwas daran ändert.
     
    Zuletzt bearbeitet: 17.04.2012
  4. networm, 17.04.2012 #4
    networm

    networm Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    17.04.2012
    @badboymoerv

    beim 4.0.3. kann man das WLAN im benutzerdefinierten Energiesparmodus abschalten, wenn es nicht verbunden ist. Den Router kann man damit nicht beeinflussen, es sei denn, in der Fritzbox sind Zeiten definiert und zusätzlich die Funktion: "Das Funknetz wird erst abgeschaltet, wenn kein WLAN-Netzwerkgerät mehr aktiv ist." gesetzt ist. Wenn dann ein Verbindung abbricht oder man das WLAN des letzten mobilen Gerätes abschaltet, geht auch die Fritzbox WLAN-mäßig offlline...
     
  5. timmylein, 19.04.2012 #5
    timmylein

    timmylein Android-Lexikon

    Beiträge:
    1,891
    Erhaltene Danke:
    267
    Registriert seit:
    31.08.2010
    Mein S2 mit dem neuen ICS DBT hat keinerlei Probleme mit der automatischen Verbindung zum Router und Repeater.
    Beide Geräte haben die gleiche SSID und das gleiche Passwort. Das S2 verbindet problemlos im WLAN mit dem jeweils stärkeren Signal.
    WLAN läuft bisher problemlos auf allen getesteten Routern, FritzBox plus Repeater, Speedport plus Repeater, Easybox.
    Allerdings wurde bei allen Routern die Lease Time auf 14 Tage eingestellt.


    Gesendet von meinem GT-I9100 mit der Android-Hilfe.de App
     
  6. networm, 19.04.2012 #6
    networm

    networm Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    17.04.2012
    Bei mir sind die IP-Adressen in der Fritzbox ja statisch vergeben. Insofern ist keine Leasetime notwendig, da ich den DHCP-Server ja nicht nutze. Beim Repeater kann man das nicht separat einstellen - er ist aber so konfiguriert, dass er die Einstellungen der Fritzbox übernimmt. Evtl. wäre da noch ein Problem, weshalb man AVM noch mal fragen könnte. Nur bei allen anderen mobilen Geräten gibt es ja kein Probkem - was diese Theorie eigentlich bereits widerlegt.

    Oder sieht das jemand anders. So wenig, die damit ein Problem haben? bitte berichtet doch auch von positiven Meldungen. Ich kann mir derzeit keinen Reim darauf machen...

    @timmylein: was verwendest du als Router und Repeater und wo konfigurierst du, wenn du ebenfalls AVM nutzen solltest, was?
     
  7. HansemannX, 19.04.2012 #7
    HansemannX

    HansemannX Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    18.05.2011
    Bis zur Version Android 2.3.6 (LA4) hatte ich genau das gleiche Problem. Die Umschaltung zwischen der Fritzbox 7270 und dem Repeater 300E klappte mit dem SGS2 nur sporadisch. Bisweilen hing der Repaeter sogar komplett, so dass ein Reboot des Repeaters erforderlich wurde.

    Nach dem Update auf die ICS-Version (original Samsung via Kies, ungebranded) habe ich diese Probleme bisher nicht mehr. Ich hoffe mal, dass es so bleibt.
    Insgesamt läuft das WLAN nun deutlich stabiler, da auch das Umschalten auf die verschiedenen Access-Points (Professionelles SonicWall-WLAN-System mit insgesamt 6 Access-Points) in der Firma besser klappt. Vor ICS musste ich morgens das WLAN im SGS2 mindestens 2-mal an- und abschalten, ehe die Authentifizierung an der SonicWall klappte. Seit ICS ist dieses Problem nicht mehr aufgetreten.
    Ich arbeite in allen WLANs mit DHCP.

    Fazit: Im Bereich WLAN ist ICS für mich bisher ein enormer Fortschritt, die Probleme habe ich mit einigen Apps, die jetzt nicht mehr auf der SD-Karte laufen und ständige Mini-Reboots des Handys verursachen, aber das soll an anderer Stelle diskutiert werden.
     
  8. networm, 19.04.2012 #8
    networm

    networm Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    17.04.2012
    Habe genau die gleiche Konfiguration wie @HansemannX: 7270 + Repeater 300 E... :confused::confused::confused:

    Habe jetzt noch mal etwas getestet. Fritzbox und Repeater neu gebootet, fest IP aus, also Arbeit mit DHCP - wird noch schlechter, weil das Galaxy eine ganze Weile braucht, um wieder eine WLAN-Verbindung aufzubauen, wenn diese ganz weg war. Wechsel des Accesspoints bei schwacher Feldstärke wird nicht durchgeführt. Arbeit mit fester IP also besser, weil dann bei einem Abbruch sofort wieder eine WLAN-Verbindung besteht. Fritzbox und Repeater haben natürlich die aktuellste Firmware.

    Noch mal WLAN aus dem Galaxy gelöscht und neu eingegeben - alles beim alten... ipHone und Blackberry wählen immer den stärkeren Accesspoint. Das Galaxy S2 einfach nicht! Bei dem kann man übrigens auch nicht explizit die feste IP eingeben. Das WLAN wird erkannt, man gibt das Kennwort ein (bei mir WPA2-Verschlüsselung). Danach kann man nichts mehr an der WLAN-Konfiguration ändern.

    @HansemannX: hast du das mal genau getestet mit dem Umschalten? Einbuchen nahe der Fritzbox: volle Feldstärke, dann laufen Richtung Repeater und WLAN-Feldstärke beobachten. Dies muss schächer werden und sollte dann nahe dem Repeater wieder volle Power bekommen - dann hat er umgebucht.

    Wenn das so ist - wo wären noch Möglichkeiten:

    Details der Frizbox-Konfiguration:
    1. WMM: ist bei mir aktiv - und bei dir @HansemannX?
    2. Verschlüsselung: bei mir nur WPA2
    3. SSID bei mir sichtbar, weil das Acer Tablet mit ICS sonst damit ein Problem hat
    4. Funkkanal-Einstellungen: bei mir fester Kanal mit 2,4 GHz und Kanal 10, 802.11n+g+b (geht nicht anders, weil ich noch verschieden mobile Geräte habe)
    5. "Für 300 Mbit/s optimierte Funkkanäle nutzen" ist bei mir ein Haken gesetzt
    6. Sendeleistung habe ich 100%
    7. "AVM Stick & Surf aktivieren" ist bei mir deaktiviert

    @HansemannX: Tät mich interessieren, wo wir da noch Unterschiede haben. Das ist jetzt schon die verzweifelte Suche nach der Nadel im Heuhaufen - aber es muss doch irgendeine Ursache geben, wenn schon keiner die genaue Ursache zu kennen scheint. Und auf deeren Suche bin ich gerade...
     
  9. timmylein, 19.04.2012 #9
    timmylein

    timmylein Android-Lexikon

    Beiträge:
    1,891
    Erhaltene Danke:
    267
    Registriert seit:
    31.08.2010
    Router = Speedport
    Repeater = AVM Repeater
    Die Konfiguration habe ich durch Übernahme der Routerdaten auf den Repeater durchgeführt.
    Weder das Galaxy Nexus mit 4.0.2 noch das S2 mit 4.0.3 haben irgendwelche Verbindungsprobleme.
    Wie oben schon erwähnt, habe ich allerdings im Speedport die Lease Time auf 14 Tage eingestellt.


    Gesendet von meinem GT-I9100 mit der Android-Hilfe.de App
     
  10. networm, 19.04.2012 #10
    networm

    networm Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    17.04.2012
    @timmylein:

    nur spielt die Leasetime bei Verwendung einer festen IP ja keine Rolle, weil man ja nicht mehr über den DHCP-Server arbeitet. Und ansonsten könnte man in der Fritzbox auch die Leasetime gar nicht ändern, so weit ich weiss... Bei meinem vorherigen Draytek-Router war das ebenfalls kein Problem.

    Hilft mir aber nicht bei der Lösung des Problemes mit der 7270+300 E weiter...
     
  11. franzm19, 19.04.2012 #11
    franzm19

    franzm19 Android-Experte

    Beiträge:
    851
    Erhaltene Danke:
    74
    Registriert seit:
    13.02.2011
    Tablet:
    Samsung Galaxy Tab
    Konfiguration :
    FB7390 als Router und Speedport(umgefritzt) als Repeater
    Fester Funkkanal-SSID on-WPA2(beide das gleiche Passwort)-DHCP

    S2 (SiyahKernel/Omega9-ICS Rom) bucht sich immer ins stärkste Funknetz ein.
    Probleme gab es mit einer original FB7170(neueste Firmware) als Repeater. Dauernd Verbindungsabbrüche und Reichweitenprobleme.
    Die Probleme hat nicht das S2 verursacht, da mein Acer A500 und
    auch ein S1 Plus das gleiche Verhalten zeigten. Nach Austausch Speedport gegen FB7170 waren die Probleme verschwunden. Ich hatte auch einmal einen AVM Repeater zum testen da, und der machte bei mir auch nur Probleme.

    gruß Franz
     
  12. HansemannX, 20.04.2012 #12
    HansemannX

    HansemannX Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    18.05.2011
    @networm: hatte gestern nur kurz Zeit und habe mal versucht das Umschalten zu testen:
    1) WLAN beim nach Hause kommen aktiviert (SGS2 war im Büro auf der Sonicwall eingebucht), dabei komme ich zuerst in den Empfangsbereich der Fritzbox (Treppenhaus) -> WLAN-Empfang sofort verfügbar direkt über die Fritzbox
    2) in der Wohnung erfolgt das Umschalten auf den Repeater allerdings erst kurz bevor die Verbindung mit der Fritzbox abreist, obwohl der Repeater fast in der ganzen Wohnung bereits das stärkere Signal liefert
    3) auf dem Weg zum Büro zeigt sich das gleiche Bild, das SGS2 bleibt auf dem Repeater (der Empfang ist allerdings mit 1-2 Strichen noch recht gut), obwohl die Fritzbox das stärkere Signal liefert (ich stehe mittlerweile 1 m neben der Box)
    4) nach dem Ab- und wieder Anschalten des WLAN bucht sich das SGS2 auf der Fritzbox ein und hat vollen Empfang

    Fazit: Seit der ICS habe ich im ganzen Haus eine stabile WLAN-Verbindung, auch wenn das SGS2 einen einmal gewählten Access-Punkt sehr lange hält, obwohl bereits stärkere Signale verfügbar sind. Unter GB erfolgte überhaupt kein Wechsel. Selbst nach Ab- und Anschalten des WLAN erfolgte das Einbuchen immer auf dem gleichen AP, solange noch ein minimales Signal des zuletzt gewählten vorhanden war! Ein Umbuchen klappte in der Regel nur durch Trennen und erneutes Verbinden des WLANs mit Eingabe des WPA2-Keys!

    Meine Fritzbox-Firrmware ist seit ca. 1 Jahr nicht mehr aktualisiert wroden, die genauen Daten liefere ich am WE nach!
     
  13. peroehl, 20.04.2012 #13
    peroehl

    peroehl Android-Hilfe.de Mitglied

    Beiträge:
    110
    Erhaltene Danke:
    46
    Registriert seit:
    07.01.2012
    Phone:
    Huawei P9 Plus
    Tablet:
    Sony Xperia Tablet Z2
    Das Umschalten zwischen Box und Repeater liegt nicht am S2 sondern an der Fritzbox oder Repeater. Bei mir läuft auf dem 7270 die letzte Beta Version der MyFritz Firmware. Auf dem 300E die letzte Firmware.
    Diese zwei unterhalten sich und geben die Zugriffe frei.
    Obwohl mein Laptop immer an der selben Stelle steht, ist die Versorgung einmal an der Box und einmal am Repeater. Warum, weiss ich noch nicht, sollte mir auch egal sein.:razz:
    Gruss
    Peter

    PS: Meine Funkferquenz ist fest auf 2,4 GHz verdrahtet.
     
  14. Babylonprojekt, 20.04.2012 #14
    Babylonprojekt

    Babylonprojekt Fortgeschrittenes Mitglied

    Beiträge:
    364
    Erhaltene Danke:
    84
    Registriert seit:
    21.06.2011
    Phone:
    Samsung Galaxy S4 Active
    Probiert doch mal WifiJumper.

    Hier noch ein paar Infos dazu.
     
    Zuletzt bearbeitet: 20.04.2012

Diese Seite empfehlen