1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Sound beim Ein- / Ausschalten deaktivieren

Dieses Thema im Forum "Samsung Galaxy 3 (I5800) Forum" wurde erstellt von muckla, 24.05.2011.

  1. muckla, 24.05.2011 #1
    muckla

    muckla Threadstarter Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    0
    Registriert seit:
    01.02.2011
    Hallo,

    Weiß einer von euch, ob es möglich ist, den Sound, der beim Anschalten/Ausschalten kommt, dauerhaft zu deaktivieren?

    lg muckla
     
  2. DaBigFreak, 24.05.2011 #2
    DaBigFreak

    DaBigFreak Android-Guru

    Beiträge:
    3,103
    Erhaltene Danke:
    441
    Registriert seit:
    07.11.2010
    Lösche die dazugehörigen Sound-Dateien. Dazu wirst du root benötigen und ein wenig zeit um die richtigen Daten zu suchen.
    Ziehe dir am besten mal alle Daten vom Handy auf den Computer, dann such mit Windows, wird sicherlich einfacher gehen.
    Kannst ja dann mal schreiben, wo du was gemacht hast.
     
  3. mizch, 25.05.2011 #3
    mizch

    mizch Android-Guru

    Beiträge:
    2,310
    Erhaltene Danke:
    371
    Registriert seit:
    05.11.2010
    Der Einschaltsound befindet sich in /system/etc/poweron.snd. Einfach umbenennen und er sollte weg sein. Genauso mit dem Shutdown-Sound, der ist /system/media/audio/ui/shutdown.ogg.
     
  4. DaBigFreak, 26.05.2011 #4
    DaBigFreak

    DaBigFreak Android-Guru

    Beiträge:
    3,103
    Erhaltene Danke:
    441
    Registriert seit:
    07.11.2010
    Danke für die Info!

    Und es erscheint keine Fehlermeldung, oder beim Booten/Runterfahren bleibt es hängen? Wär schön wenn das mal jemand testen könnte, der mit flashen kein Problem hat^^ Ich würd des erst machen, wenn ich meine jetzige ROM so wie ichs hab flashen könnt.
     
  5. mizch, 26.05.2011 #5
    mizch

    mizch Android-Guru

    Beiträge:
    2,310
    Erhaltene Danke:
    371
    Registriert seit:
    05.11.2010
    Eben gemacht. An beide Dateinamen ein „.nee” angehängt. Fährt lautlos herunter und bootet lautlos durch. Keine Probleme.
     
    DaBigFreak bedankt sich.
  6. DaBigFreak, 26.05.2011 #6
    DaBigFreak

    DaBigFreak Android-Guru

    Beiträge:
    3,103
    Erhaltene Danke:
    441
    Registriert seit:
    07.11.2010
    Wie siet es mit den Animationen aus? Kann man die auch weg nehmen? Schalte ich das Handy aus, normal, so wird das Display nach dem Gedudel ja dunkel, bleibt aber noch ca. 20 Sekunden beleuchtet (aber eben dunkel). Erst wenn man schwer zu erkennen sieht, Display ist aus, dann kann man wieder einschalten. Zuerst dachte ich, hö, nu kann ichs nicht mehr einschalten.
    Beim Ausschalten wird doch ein richtiges Video verwendet, beim hochfahren eine Bildfolge und eine Tondatei. Kann es nun sein, wenn man das Video löscht, dass dann das ausschalten schneller geht?
     
  7. mizch, 26.05.2011 #7
    mizch

    mizch Android-Guru

    Beiträge:
    2,310
    Erhaltene Danke:
    371
    Registriert seit:
    05.11.2010
    Ich würde sagen, dass da kein Blumentopf zu gewinnen ist. Die Ausschaltanimation ist kurz, die Einschaltanimation eine reine Bildfolge. Beide laufen parallel zum Hoch/Herunterfahren, da wird nicht gewartet auf ihre Beendigung. Die zusätzliche Prozessorlast dürfte nicht groß ins Gewicht fallen. Zudem: Wie oft schaltest Du aus oder ein? Das lohnt sich nicht, auch wenn es (vermutlich) genauso einfach abzuschalten wäre.
     
  8. DaBigFreak, 26.05.2011 #8
    DaBigFreak

    DaBigFreak Android-Guru

    Beiträge:
    3,103
    Erhaltene Danke:
    441
    Registriert seit:
    07.11.2010
    Also wenn ich mit einem Terminal reboot mache, dann kommt kurz nach dem schwarzen bildschirm gleich wieder das BootLogo, danach die Hochfahrenanimation. Hier passiert das Ausschalten quasi in unter einer Sekunde. Kannst ja mal vergleichen, Terminal reboot und normales ausschalten. Find ich macht schon einen Unterschied. Gerade wenn ich dann mal ausschalten muss, weil z.B. eine Main-app abgeschmiert ist, z.B. Telefon, oder ähnliches, dann soll der Reboot schnell gehen.
    Magsts mal testen? *liebguck*
     
  9. mizch, 26.05.2011 #9
    mizch

    mizch Android-Guru

    Beiträge:
    2,310
    Erhaltene Danke:
    371
    Registriert seit:
    05.11.2010
    Der Unterschied ist mir schon bekannt. Ich habe das bisher darauf zurückgeführt, dass reboot ja ein Low-Level-Kommando ist (ein Linux-Binary), das sich nicht darum kümmert, was die Android-Oberfläche macht, nur ein paar Signale verschickt und somit den Apps keine Gelegenheit gibt, ordentlich herunterzufahren. Ob das wirklich so ist, habe ich nie geprüft.

    Wie dem auch sei: ich finde es nicht der Mühe wert, sich um das bisschen Animation Gedanken zu machen und bin mir ziemlich sicher, dass das Weglassen der Shutdown-Animation an der Zeit bis zum Abschalten nichts Grundlegendes ändert. Ausprobieren tue ich's deshalb nicht.
     
  10. DaBigFreak, 26.05.2011 #10
    DaBigFreak

    DaBigFreak Android-Guru

    Beiträge:
    3,103
    Erhaltene Danke:
    441
    Registriert seit:
    07.11.2010
    Würds ja gern selbst testen, aber was mach ich wenn irgenwo steht, spiel das video ab, is aber nicht mehr da, und es hängt fest. Deshalb fänd ichs klasse, wenn das mal jemand testen könnte, der da ggf. schnell wieder was fixen kann.
     
  11. dodnet, 27.05.2011 #11
    dodnet

    dodnet Erfahrener Benutzer

    Beiträge:
    208
    Erhaltene Danke:
    22
    Registriert seit:
    09.03.2011
    Um die Töne beim Hoch-/Runterfahren auszuschalten, kann man auch in den Einstellungen die Systemlautstärke auf lautlos stellen. Dazu braucht man kein Root.
     
  12. DaBigFreak, 27.05.2011 #12
    DaBigFreak

    DaBigFreak Android-Guru

    Beiträge:
    3,103
    Erhaltene Danke:
    441
    Registriert seit:
    07.11.2010
    Super, dann sind die Töne doch aber immer weg...
     
  13. dodnet, 28.05.2011 #13
    dodnet

    dodnet Erfahrener Benutzer

    Beiträge:
    208
    Erhaltene Danke:
    22
    Registriert seit:
    09.03.2011
    Welche Töne denn bitte?
     
  14. hermez, 28.05.2011 #14
    hermez

    hermez Android-Experte

    Beiträge:
    549
    Erhaltene Danke:
    63
    Registriert seit:
    28.02.2011
    Ich hab einfach die Shutdownanmaiton umbenannt und weg war sie^^>> kein Ton
     
  15. ultragun, 06.11.2011 #15
    ultragun

    ultragun Junior Mitglied

    Beiträge:
    40
    Erhaltene Danke:
    0
    Registriert seit:
    06.11.2011
    Das klingt ja gut, aber bei mir ist die Datei poweron.snd schreibgeschützt. Mit welcher App kann man die umbenennbar machen? Benutze den RootExplorer.
    Vielen Dank für eine Antwort! :confused2:
     
  16. ultragun, 06.11.2011 #16
    ultragun

    ultragun Junior Mitglied

    Beiträge:
    40
    Erhaltene Danke:
    0
    Registriert seit:
    06.11.2011
    So, hab nochmal rechercheirt. Ich wusste nicht das man das System in RW Modus mounten muss beim RootExplorer. Jetzt hats geklappt.
     
  17. hermez, 06.11.2011 #17
    hermez

    hermez Android-Experte

    Beiträge:
    549
    Erhaltene Danke:
    63
    Registriert seit:
    28.02.2011
    Man kann auch einfach nur den Ton unter system > media > audio > ich glaube "ui" löschen. Ich hab ihn schon gelöscht und weiß nicht mehr wo er war^^
     

Diese Seite empfehlen