1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

[SP-40] Simvalley SP40/SP60 Tethering

Dieses Thema im Forum "Simvalley SP-40 / SP-60 Forum" wurde erstellt von hbnda, 29.08.2011.

  1. hbnda, 29.08.2011 #1
    hbnda

    hbnda Threadstarter Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    1
    Registriert seit:
    29.08.2011
    Wem ist es denn schon gelungen, USB-Tethering mit dem SP40/60 auf Windows XP zu erreichen? Trotz vielen googelns und diversen Versuchen ist es mir bis dato nicht gelungen.
    Über Hilfe wäre ich sehr dankbar. :)
     
  2. snooper, 01.09.2011 #2
    snooper

    snooper Erfahrener Benutzer

    Beiträge:
    246
    Erhaltene Danke:
    18
    Registriert seit:
    24.03.2011
    Phone:
    Moto G4 Plus
    Ich glaube, Du musst auf Deinem Windows System erst einen Extender für das Dateisystem installieren.. Google mal nach einem Progrämmchen: Ext2Fsd-0.50
     
  3. Melkor, 01.09.2011 #3
    Melkor

    Melkor Super-Moderator Team-Mitglied

    Beiträge:
    17,620
    Erhaltene Danke:
    3,911
    Registriert seit:
    24.06.2009
    Phone:
    Ulefone Power + Wiko Darknight
    Tablet:
    Archos G9 Tablet, Odys Wintab 9 plus 3G
    Wearable:
    Xiaomi MiBand
    Äh warum bitte? Er will doch nur die Datenverbindung des Gerätes für XP nutzen - sprich er braucht Modemtreiber!
    Waren keine CDs mit Treibern von seiten Pearls dabei?
    Ansonten mal auf deren Seite schauen und wenn da nix ist. Nach dem orgiginal Herstller googlen und mal dessen Treiber versuchen
     
  4. hbnda, 01.09.2011 #4
    hbnda

    hbnda Threadstarter Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    1
    Registriert seit:
    29.08.2011
    Es ist genauso wie Du es sagst (schreibst)! Beim Einschalten des USB-Tethering Modus am SP40 erkennt WIN XP neue Hardware und verlangt die entsprechenden Treiber. Die gibt es aber offensichtlich nirgendwo, auch nicht bei pearl. Den Hersteller von simvalley-phones kenne ich nicht, simvalley ist Handelsmarke von pearl.
    ___________________________________________________________________________________

    Den Hersteller habe ich jetzt herausgefunden, aber auch der bietet keine Treiber an:
    http://www.umeox.com/productshow.php?productID=98
     
    Zuletzt bearbeitet: 01.09.2011
  5. Melkor, 01.09.2011 #5
    Melkor

    Melkor Super-Moderator Team-Mitglied

    Beiträge:
    17,620
    Erhaltene Danke:
    3,911
    Registriert seit:
    24.06.2009
    Phone:
    Ulefone Power + Wiko Darknight
    Tablet:
    Archos G9 Tablet, Odys Wintab 9 plus 3G
    Wearable:
    Xiaomi MiBand
    hbnda bedankt sich.
  6. hbnda, 02.09.2011 #6
    hbnda

    hbnda Threadstarter Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    1
    Registriert seit:
    29.08.2011
    Geht einwandfrei, vielen Dank!

    Unterschied zum üblichen USB-Tethering unter WIN7 : PdaNet muss auf dem Handy gestartet werden und es muss USB-Debugging eingeschaltet sein. PdaNet muss auf dem Rechner zusammen mit den ADB-Treiber installiert und gestartet sein.
    Dann wird bei hergestellter USB-Verbindung das Tethering aufgebaut.

    Um es zu wiederholen: geht nur mit USB-Debugging, der Handy Menuepunkt USB-Tethering geht hierbei nach wie vor nicht, da der WIN XP Rechner hier wieder Hardwaretreiber sucht und nicht findet.

    Fazit: etwas umständlicher als unter WIN 7, funktioniert aber einwandfrei! Ich hoffe nur, das im USB-Debuggingmodus nichts irgendwie in der Handysoftware verändert werden kann.
     
    Zuletzt bearbeitet: 02.09.2011
  7. usw, 25.11.2011 #7
    usw

    usw Neuer Benutzer

    Beiträge:
    1
    Erhaltene Danke:
    2
    Registriert seit:
    25.11.2011
    Der Thread ist zwar schon ein paar Tage alt, aber ich würde trotzdem meine Lösung ergänzen... USB Tethering mit dem SP-40 und Win-XP funktioniert auch mit "Bordmitteln" und ohne USB-Debugging. Näheres sowie Hinweise zur Installation findet sich in der Google Mobile-Hilfe unter Android-Geräte: Tethering und mobile WLAN-Hotspots - Google Mobile-Hilfe

    Die notwendigen Treiber sind auch bei XP schon vorhanden - was fehlt, ist eine INF-Datei, die dem Gerätemanager beibringt, welche Treiber für das neu erkannte Gerät gebraucht werden. Die auf o.g. Seite zum Download angebotene TETHERXP.INF kennt allerdings das SP-40 nicht... ich habe daher mal untersucht, welche Vendor-ID und welche Geräte-ID mein SP-40 hat und habe die INF-Datei mal angepasst.

    Bei meinem Linux nach dem Einstöpseln mal in die Kernel-Messages geschaut:
    [...]
    usb 5-1: New USB device found, idVendor=0bb4, idProduct=0003
    usb 5-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    usb 5-1: Product: A502 Android Phone
    usb 5-1: Manufacturer: SIMVALLEY
    [...]

    Das muss nun auch in die INF-Datei:
    [AndroidDevices]
    [...]
    ; A502 Android Phone
    %AndroidDevice% = RNDIS, USB\VID_0BB4&PID_0003
    [...]
    [AndroidDevices.NT.5.1]
    ; A502 Android Phone
    %AndroidDevice% = RNDIS.NT.5.1, USB\VID_0BB4&PID_0003
    [...]

    Die entsprechend angepasste TETHERXP.INF findet Ihr hier: http://www.sawallisch-berlin.de/tetherxp.inf

    lg vom usw
     
    Melkor und Warkiller102 haben sich bedankt.
  8. Warkiller102, 29.11.2011 #8
    Warkiller102

    Warkiller102 Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    0
    Registriert seit:
    26.08.2011
    Grüße

    danke hat mit der INF geklappt.

    Auch wenns nen kleines Problem gab, bei dem SP-40 hier war die PID eine andere (nämlich die 0004).

    Falls jemand den Treiber daher immernoch nicht installieren kann am besten wie folgt vorgehen:

    Rechtsklick auf den Arbeitsplatz->Eigenschaften->Hardware->Geräte-Manager->A502 Android Phone Rechtsklicken->Eigenschaften->Details->Hardwarekennungen auswählen.

    Dann mit der .inf abgleichen und evtl. editieren falls da was nicht gleich ist.

    MfG
    Warkiller102
     

Diese Seite empfehlen