1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

system.img ext4 in Linux mounten

Dieses Thema im Forum "Android OS Entwicklung / Customize" wurde erstellt von Comec, 08.05.2012.

  1. Comec, 08.05.2012 #1
    Comec

    Comec Threadstarter Android-Experte

    Beiträge:
    894
    Erhaltene Danke:
    401
    Registriert seit:
    16.02.2012
    Hallo zusammen,

    ich versuche gerade mit meinen nicht vorhandenen Linux Kenntnissen die system.img.ext4 von meiner MediaPad Firmware in Mint9 zu mounten. Die habe es zwar schon mit dem Befehl
    sudo mount -t ext4 -o loop system.img.ext4 /mnt
    geschafft, aber dann habe ich keine Schreibrechte und das bringt ja leider nicht viel.

    Ich hoffe mir kann jemand helfen! :)
     
    whoozy bedankt sich.
  2. Thyrion, 08.05.2012 #2
    Thyrion

    Thyrion Ehrenmitglied

    Beiträge:
    11,846
    Erhaltene Danke:
    2,451
    Registriert seit:
    21.07.2009
    Phone:
    Nexus 5X
    Dann versuch doch mal Lese-/Schreibrechte beim Mount mit anzufordern:

    sudo mount -t ext4 -o rw,loop system.img.ext4 /mnt
     
  3. Comec, 09.05.2012 #3
    Comec

    Comec Threadstarter Android-Experte

    Beiträge:
    894
    Erhaltene Danke:
    401
    Registriert seit:
    16.02.2012
    Danke für den Tipp! Bringt aber leider nix, immernoch keine Schreibrechte... :(
     
  4. Das-Ich, 06.06.2012 #4
    Das-Ich

    Das-Ich Android-Lexikon

    Beiträge:
    1,471
    Erhaltene Danke:
    375
    Registriert seit:
    23.06.2011
    Hi

    ich weiss ja nicht ob es noch aktuell ist, aber haste auch schreiberechte als user in deinem Mountpoint? Da du ja auch eine system.img mounten möchtest, könnte es auch sein das durch die Rechte unter Android nur root darauf schreiben darf. Eventuell alles als root bearbeiten nach dem mounten.

    MfG
     
  5. whoozy, 24.07.2012 #5
    whoozy

    whoozy Erfahrener Benutzer

    Beiträge:
    172
    Erhaltene Danke:
    20
    Registriert seit:
    31.05.2012
    Phone:
    Motorola Razr HD
    Genau an der Stelle bin ich auch gerade, nur eben mit Ubuntu. Wie hast Du das Problem gelöst?

    Der ursprüngliche Beitrag von 20:48 Uhr wurde um 21:14 Uhr ergänzt:

    Mit einem mit root gestarteten Nautilus hat es jetzt geklappt. Aber gibt es vielleicht noch eine elegantere Lösung ? Die Rechte des Images und des Ordners sind für den Standard-User auf 777 als r/w eingestellt.

    Der ursprüngliche Beitrag von 21:14 Uhr wurde um 21:20 Uhr ergänzt:

    Oder auch nicht. Ein CHMOD 777 hat geholfen. Verstehe nur nicht warum Nautilus in den Eigenschaften Schreibrechte ausgewiesen hat.

    Der ursprüngliche Beitrag von 21:20 Uhr wurde um 21:21 Uhr ergänzt:

    Hat sich also erledigt :flapper:
     

Diese Seite empfehlen