1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Tastatur beim X4 zerschossen

Dieses Thema im Forum "Pearl Touchlet X3 / X4 Forum" wurde erstellt von smithi, 23.11.2011.

  1. smithi, 23.11.2011 #1
    smithi

    smithi Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    23.11.2011
    Hallo zusammen

    Ich bin seit einigen Tagen stolze (?) Besitzerin eines X4 Touchlets von Pearl. Eigentlich bin ich ganz zufrieden, dank der guten Anleitung hier konnte ich problemlos den NAND-Speicher integrieren und auch das Rooten hat funktioniert. (Superoneclick + titanium Backup)
    Gestern habe ich eine zusätzliche Tastatur (Go Keyboard) installiert, diese aber wieder entfernt. Seitdem spinnt die "normale" - es kommt immer wieder folgende Fehlermeldung:
    Sprich: ich habe keine Tastatur mehr. Selbst der factory reset brachte keinen Erfolg, genauso wenig wie das Installieren einer neuen Tastatur.

    Habt Ihr irgendwelche Tipps für mich?

    Nachtrag:

    Mein erster Gedanke war, dass ich "einfach" neu installiere, so wie ich es bei meinem PC machen würde, wenn ich denn zerschossen hätte. Nur weiss ich leider nicht, wie. Google konnte mir auch nicht gross helfen, das Touchlet selber lässt im RecoveryBootModus nur ein Update zu.
    Gibt es da eine Möglichkeit, Gingerbread neu zu installieren? Vielleicht mittels ROM Manager?

    Die zweite Option, die mir einfiel, war, dass ich ja noch ein jungfräuliches X4 als Weihnachtsgeschenk rumliegen habe (ich konnte einfach nicht dran vorbei gehen im Outletcenter von Pearl - OVP-Versandretouren für 105 € abzüglich MwSt)
    Könnte man da nicht ein komplettes Backup ziehen (also inkl. Android) und das dann mittels SD-Karte übertragen?

    So viele Fragen...

    Ach so: teilweise kommt die Fehlermeldung, im Hintergrund öffnet sich dann zwar die Tastatur, aber um das Pop-Up zu beenden MUSS ich "Schliessen erzwingen" klicken, was natürlich dazu führt, dass sie dann wieder verschwindet.
    Ich habe im Menü Sprache & Tastatur auch nur noch die Einstellungen der Android Tastatur, gefolgt von Gingerbread Tastatur (mit Kasten zum Anklicken) und darunter noch Gingerbread Tastatur Einstellungen.
    Ich meine aber, dass vorher auch eine Option bestand, die von Android mittels Häckchen zu aktivieren. Das fehlt jetzt aber... (oder täusche ich mich da jetzt?) :confused2:

    Ratlose Grüsse
     
    Zuletzt bearbeitet: 23.11.2011
  2. EPA, 23.11.2011 #2
    EPA

    EPA Android-Experte

    Beiträge:
    477
    Erhaltene Danke:
    85
    Registriert seit:
    15.04.2011
    Habe auch ein X4. So können wir das eine oder andere gut vergleichen.

    Ich würde als erstes ins Verzeichnis /system/app gehen. Dazu brauchst Du irgend einen Datei-Manager. Dann würde ich alle APK-Files in /system/app noch einmal aufrufen und installieren.

    Keine Sorge, wenn die Meldung kommt, dass es eine Systemdatei ist, dann einfach darüber installieren.

    Bitte berichte, ob das geholfen hat. Ich habe dannn noch einen weiteren Lösungsvorschlag...
     
  3. smithi, 23.11.2011 #3
    smithi

    smithi Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    23.11.2011
    Hallo
    Danke erstmal, aber... :crying:
    Ich habe es ausprobiert, leider schmiert mir der DroidExplorer bei einigen apks einfach ab. Keine Chance, alle drüber zu installieren. Bei den meisten hat es zwar funktioniert, gebracht hat es allerdings nichts.

    Eine Neuinstallation der Tastatur war ergebnislos, genauso wie der Versuch mit einem anderen Keyboard. Dann stürzt halt dieser Prozess ab und ich bin weiterhin ohne Tastatur. Kann also nicht mal das WiFi anschalten, geschweige denn mich beim Market einloggen...

    Was ist denn mit der Option, ein Backup von dem anderen X4 zu ziehen? Das erscheint mir - wenn machbar - am einfachsten...
     
  4. hävksitol, 23.11.2011 #4
    hävksitol

    hävksitol Ehrenmitglied

    Beiträge:
    12,606
    Erhaltene Danke:
    8,874
    Registriert seit:
    11.01.2011
    Tablet:
    Lenovo Ideapad A2109A
    Hallo Smithi,

    um neu zu flashen, update doch einfach! Das Update korrigiert lediglich das bekannte NAND-Probleme & ist ansonsten identisch mit der ausgelieferten FW.
    MfG
     
  5. smithi, 23.11.2011 #5
    smithi

    smithi Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    23.11.2011
    So langsam macht sich das Touchlet bei mir dann doch unbeliebt... :cursing:

    Auf die Idee mit dem Update von Pearl bin ich übrigens gar nicht gekommen, dachte, dass sei nur der Windoof-Treiber und irgendeine Art App, um den Nand zu integrieren, dass es ein komplettes Abbild sein könnte... nö...
    Aber es wäre nicht so wie immer, wenn es funktioniert hätte. Im Update-Manager wird das X4 nicht erkannt, egal, was ich mache. Sprich: dasUpdate kann ich so wie von Pearl vorgeschlagen NICHT installieren. :angry:


    Habe mir jetzt auf mein X4 CWR gezogen, das selbe werde ich morgen mal auf dem anderen machen und dann dessen Backup-Datei per DroidExplorer in den passenden Ordner auf mein Tablet verschieben.
    Ansonsten scheint tatsächlich nichts zu funktionieren. Habe jetzt alle ergoogelten Tipps durch, damit meinen ganzen Nachmittag verschwendet (und verstehe immer noch nicht, was da gestern falsch gelaufen ist, mein ES File-Explorer war nebenbei bemerkt auch einfach "im Nirvana" verschwunden.) und nun am Ende meines Lateins.

    Prinzipiell bastel ich ja gerne, aber wenn es dann zur Sisyphus-Arbeit mutiert, bekomme ich dann doch irgendwann schlechte Laune.

    Mal sehen was das morgen so ergibt, jetzt habe ich echt keine Lust mehr.

    Es grüsst und dankt

    smithi
     
  6. hävksitol, 23.11.2011 #6
    hävksitol

    hävksitol Ehrenmitglied

    Beiträge:
    12,606
    Erhaltene Danke:
    8,874
    Registriert seit:
    11.01.2011
    Tablet:
    Lenovo Ideapad A2109A
    Der Thread, den ich zitiert habe, enthält Lösungen zu allen beim Update bisher beobachteten Problemen (Win7-64bit, falsche Tasten etc.)

    Gesendet mit der Android-Hilfe.de-App
     
  7. smithi, 24.11.2011 #7
    smithi

    smithi Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    23.11.2011
    Ich hatte den kompletten Thread gelesen, da ist nichts, was ich nicht ausprobiert hätte.
    Win7 64bit Treiber ist installiert, ich habe (nachdem ich mich über die komische Tastenkombination gewundert habe und deren Drücken gar nichts brachte) die richtigen gehalten. USB Debugging ist aus, das Gerät wird von meinem Laptop einwandfrei erkannt, aber nicht von dem Software-Updater.
    Nix PopUp.

    Was weiss ich was ich da falsch mache - heute Nachmittag wenn ich Zeit habe, gibt es das Backup. :unsure:
     
  8. smithi, 24.11.2011 #8
    smithi

    smithi Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    23.11.2011
    Hurra :w00t00:

    So, ich habe nun das zweite X4 mal aus der Verpackung genommen, eben den Nand aktiviert, es gerootet und dann mittels CWR ein Backup des jungfräulichen Systems gezogen.
    Speicherkarte in meins eingesteckt, restore angewählt und siehe da: Ich habe wieder ein funktionierendes Touchlet im Auslieferungszustand (+ root)
    Das Backup werde ich jetzt hüten wie meinen Augapfel und es sicher noch auf mindestens einem zusätzlichen Gerät speichern - ich kenn mich ja.

    Aber jetzt bin ich erstmal glücklich und tanze eine Runde auf dem Tisch. Hätte nicht gedacht, dass ich das eben kurz in der Mittagspause erledigt bekomme - trotzdem hatte ich sicherheitshalber alles im Gepäck :cool2:
     
  9. hävksitol, 24.11.2011 #9
    hävksitol

    hävksitol Ehrenmitglied

    Beiträge:
    12,606
    Erhaltene Danke:
    8,874
    Registriert seit:
    11.01.2011
    Tablet:
    Lenovo Ideapad A2109A
    Auch wenn Du Dein Problem selbst auf andere Weise gelöst hast:

    Vielleicht hätte dieser Beitrag (aus einem anderen Thread) geholfen.

    MfG
     
  10. smithi, 24.11.2011 #10
    smithi

    smithi Threadstarter Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    0
    Registriert seit:
    23.11.2011
    Das war einer der ersten Beiträge, die ich durchgearbeitet habe, dort hatte ich den Tip mit dem Ausschalten des USB Debuggings ja her. Speicher verbunden/nicht verbunden, alles ausprobiert.

    Bevor ich mich hier registriert habe, um um Hilfe zu schreien, habe ich einige Zeit in diversen Android-Foren verbracht (und nebenbei mein Englisch wieder aufgemöbelt), aber ich konnte einfach keine Lösung für mein Problem finden. Habe einige Anleitungen "nachgearbeitet", ohne Erfolg, bzw. das Touchlet hat nicht so reagiert, wie es sollte. Ich gehe davon aus, dass ich mir irgendwas elementares zerschossen habe (weiss zwar nicht wie, aber...), schliesslich fehlte auch plötzlich der ES Filexplorer. Und den hab ich definitiv nicht gelöscht oder verschoben (bzw. er lief auf der Sd-Karte vorher normal und nach der "Nachtruhe" war er weg)

    Da ich ausser dem Rooten unsere Samsung Handys noch null Erfahrung auf dem Gebiet Android habe, musste ich mich erst ein wenig einlesen, bis ich herausgefunden habe, welches App/Update wofür ist.

    Aber ich muss sagen, die Geschichte mit dem CWR-Backup war wirklich im nachhinein die einfachste und schnellste Lösung. Nix mit hier und da was installieren, sondern Backup machen, MicroSD-Karte tauschen und Restore. Fertig.

    Hätte ich von Anfang an machen sollen, da hätte ich gestern den Nachmittag an der Sonne verbringen können.

    Trotzdem Danke für die Mühe!!

    Grüäsli

    smithi
     

Diese Seite empfehlen