1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Tastatur und Akku Probleme nach CyanogenMod 6.1

Dieses Thema im Forum "Root / Hacking / Modding für T-Mobile G1" wurde erstellt von motoxtremo, 04.01.2011.

  1. motoxtremo, 04.01.2011 #1
    motoxtremo

    motoxtremo Threadstarter Gast

    Moin,

    ich habe in den Tagen nach Weihnachten meine neues (gebrauchtes) G1 gerooted, ne neue SPL und CyanogenMod 6.1 geflasht. Ist sowiet auch alles in Ordnung, außer das seitdem die hintergrundbeleuchtung meiner Hardware Tastatur dauherhagt aus ist, egal wie hell es ist und das der Akku Verbrauch immens gestiegen ist. Wenn ich das Handy über Nacht lade, dann abstöpsle und den Flugzeug Modus aktiviere habe ich 8 Stunden später bis zu 15% weniger Akkuladung, bei meinem Hero war es max. 1%. Und so geht es natürlich weiter, das Handy hält kaum den Tag durch obwohl ich kaum etwas damit mache, und vor Cyanogen war die originale 1.6 drauf und es war alles im Rahmen.

    Ich hab auch schon etwas nach dem Backlight Problem gegoogelt aber leider nichts gefunden, vielleicht könnt ihr mir ja weiter helfen :)

    EDIT: Nun habe ich auch noch das Problem festgestellt das ich keine SMS mehr empfangen kann. Bei Empfang einer SMS wird in der Status Leiste nur eingeblendet "Der Speicher für Nachrichten ist voll, die NAchricht wurde zurückversendet" (in etwa). Dabeihabe ich bloß ein paar SMS auf dem Handys, auf der SD ist noch massig Platz und auch der interne Speicher hat noch über 5MB...
     
    Zuletzt von einem Moderator bearbeitet: 04.01.2011
  2. Steppo, 04.01.2011 #2
    Steppo

    Steppo Android-Lexikon

    Beiträge:
    1,894
    Erhaltene Danke:
    247
    Registriert seit:
    19.02.2010
    Dann würde ich vorschlagen die Cyanogen-Rom nochmals neu zu flashen, soweit die Tastaturbeleuchtung bei 1.6 funktioniert hat, muss sie auch bei Cyano funktionieren. Von einem derartigen Problem hab ich zumindest bisher noch nichts gelesen.

    Mit dem Akku Problem wirst du dich wohl abfinden müssen, das ist bei Custom-Roms eben so... durch die ganzen Features etc.
    Ein empfehlenswertes weiteres Froyo-Rom wäre Froyo-for-Trout. Ein offiziell modifiziertes Rom für MT3G. Sehr zu empfehlen und hat diese ganzen extra Features eben nicht.


    Gruß Steppo
     
  3. DiSa, 04.01.2011 #3
    DiSa

    DiSa Android-Experte

    Beiträge:
    483
    Erhaltene Danke:
    80
    Registriert seit:
    06.11.2009
    Was hattest Du denn für ein ROM vorher 'drauf und hast Du ein Wipe gemacht, bevor du CM 6.1 geflashed hast? Es kann gut sein, dass wenn Du kein Wipe gemacht hast, die Probleme daher rühren.

    5 MB ist nicht gerade massig viel ... unter ca. 10 MB wir das Phone in der Regel seeeehr langsam. Dadurch kann es natürlich auch Probleme geben.
    Warum nutzt zu kein CutomMTD oder a2ext oder dc2x? Die Firerat-Skripts funktionieren eigentlich sehr gut!
    Zu Deinem Battery-Drain: Die Kernels von CM 6.1 haben Probleme mit Battery-Drain, wenn sie über USB mit dem Rechner verbunden waren. Danach sollte man einmal ohne USB-verbindung neu booten, dann sollte das Problem auch behoben sein.
     
  4. Steppo, 04.01.2011 #4
    Steppo

    Steppo Android-Lexikon

    Beiträge:
    1,894
    Erhaltene Danke:
    247
    Registriert seit:
    19.02.2010
    Da war der Text wohl zulang für dich :/
    Und das mit dem Wipe erledigt sich somit auch, wenn er von Stock kommt.
     
  5. motoxtremo, 04.01.2011 #5
    motoxtremo

    motoxtremo Threadstarter Gast

    Genau, vorher hatte ich die originale 1.6 ROM drauf. Und vor dem flashen hab ich natürlich einen Full Wipe gemacht.

    Auf meinem Hero hatte ich auch mehrere Custom ROMs die z.T. den Akku Verbrauch verschlimmert hatten,aber niemals in diesem Maße,das kann doch nicht normal sein. Ich meine,das Handy liegt 8h im Flugmodus völlig unbenutzt rum und der Akku verliert 15%?

    Auf dem Hero hatte ich auch manchmal den int. Speicher knall voll,aber das ich dann keine SMS empfangen bzw. Speichern kann ist mir neu. Naja,vielleicht flashe ich einfach nochmal Cyanogen neu,

    P.s: Als ich anfing diese Nachricht mit meinem G1 zu schreiben hatte ich 11% Akku,jetzt nur noch 5%!
     
  6. Haunter1982, 05.01.2011 #6
    Haunter1982

    Haunter1982 Android-Experte

    Beiträge:
    873
    Erhaltene Danke:
    134
    Registriert seit:
    08.05.2009
    Phone:
    Sony Xperia Z5 Compact
    Tja tut mir leid dir das sagen zu müssen, aber dieses Problem hatte ich auch, liegt aber nicht am ROM, da ich das Problem jetzt auch beim Orginal 1.6 habe :) entweder verwurschtelt das Cyano oder SPl oder was auch immer irgendwas so krass das das dauerhaft ist. oder dein Akku ist einfach hin.
     
  7. meckergecko, 05.01.2011 #7
    meckergecko

    meckergecko Android-Experte

    Beiträge:
    802
    Erhaltene Danke:
    116
    Registriert seit:
    09.06.2010
    zum dem Thema mit den SMS bin ich gestern zufällig über den Artikel gestolpert. Scheint also ein generelles Problem von Android zu sein...
     
  8. Steppo, 05.01.2011 #8
    Steppo

    Steppo Android-Lexikon

    Beiträge:
    1,894
    Erhaltene Danke:
    247
    Registriert seit:
    19.02.2010
    Das mit der Akkulaufzeit kann (muss aber nicht) am Akku liegen. Zumindest hört man jetzt in letzter Zeit viel von Akkuproblemen. Dies ist mir auch passiert, mein alter Akku läuft keine 4 Stunden mehr im Standby, mein neuer allerdings 1 1/2 Tage. So wie es sein sollte. Prüfe mal deinen Akku ob er etwas aufgebläht ist, dann kannst du daraus schließen dass er hinüber ist. Das G1 gibt es mittlerweile schon fast 2 jahre und da macht der akku langsam schlapp.


    Gruß Steppo
     
  9. motoxtremo, 05.01.2011 #9
    motoxtremo

    motoxtremo Threadstarter Gast

    Also der Akku kann es eigentlich nicht sein. Vorher mit der originalen 1.6 ROM war das ja alles noch im Rahmen, eben so wie ich es vom Hero gewohtn war. Solch eine krasse Steigerung muss an den Änderungen liegen, irgendwas ist schief gelaufen. Ich werd mal anfangen das ROM neu zu flashen wenn ich etwas Zeit hab.

    wie würdet ihr weiter vorgehen? Dann auch noch SPL und Radio neu flashen? Und dann mal andere Komponenten asutesten? Das Froyo for Trout klingt gut, werde das mal flashen falls CM6.1 weiter so rumzickt. Gestenr Abend hat es auch nich andauernd FCs verursacht, im Market, im Browser, der Launcher...nachm Rebott war es wieder "ok".
     
  10. motoxtremo, 08.01.2011 #10
    motoxtremo

    motoxtremo Threadstarter Gast

    So,

    Froyo for Trout ist geflasht, Radio ebenso, MultiLanguage Kit killt aber immer das ganze so das mein andy nich mehr bottet, nicht so schlimm, mit englisch komm ich auch zurecht. Super Circle Battery wird grade gekocht und ich installier nochmal Froypo for Trout nochmal neu weil es wieder am zicken war, aber die Tastatur Beleuchtung geht wieder. Wie sich der Akku verhält wird sich zeigen!

    UPDATE:

    Also nachdem ich eine Terminal App installiert hatte ist das System eingefroren --> Akku rausgenommen --> neu gebootet --> nix passiert. Dann bin nich in die Recovery hab alles gewiped und neu geflasht, war danna uch alles i.O. zumindest scheinbar denn der Eingabe screen für die PIN war wieder eingefroren. also wieder Akku raus und rein, aber dann hat es nicht mehr gebootet.

    Also ROM ist neu, RADIO ist nue, können die Probleme vielleicht von der sPL verursacht werden? Ich werd es morgen nochmal neu machen, aber vielleicht hat bis dahon ja einer von euch einen Tipp für mich :)

    EDIT: und ist es normal das gmail, Maps und Youtube fehlen?
     
    Zuletzt von einem Moderator bearbeitet: 08.01.2011
  11. Steppo, 08.01.2011 #11
    Steppo

    Steppo Android-Lexikon

    Beiträge:
    1,894
    Erhaltene Danke:
    247
    Registriert seit:
    19.02.2010
    Haha :D Du Armer, hast auch nur Probleme. Die GApps müssten eig dabei sein. Dass bei dir alles einfriert wundert mich wirklich, irgendwas musst du doch falsch machen ;) Den SPL solltest du auch neu machen. Den ...13d !
    Dann musst wahrscheinlich einen anderen Kernel nach flashen oder auch nicht?! Hab mit dem neuen SPL bisher noch nicht viel Erfahrungen gemacht. Einfach mal ausprobieren. Bei Radio und SPL bitte Achtung, der Rest ist (fast) Risikolos ;)
     
  12. motoxtremo, 09.01.2011 #12
    motoxtremo

    motoxtremo Threadstarter Gast

    Ich habs gestern Abend nochmal geflasht, alles wie vorher, nur dieses mal ohne Probleme, Akku Verbrauch scheint wieder im Rahmen zu sein, die Tastaturbeleuchtung funzt auch wieder, ebenso gab es bisher keine Freezes. 2 (kleine) Probleme habe ich aber noch

    1. Ich brauche eine aktuelle, fuktionierende (nach Möglichkeit deutsche) gmail.apk

    2. Krieg ich das Firerat Skript nicht zum laufen, obwohl ich im Temrinal Emulator aus dem Market alles so mache wie es da steht.

    Sonst gefällt mir das ROM aber, läuft schneller und stabiler als CM, wobei da natürlich auch ein Fehler vorliegen kann, also bei der CM.
     
  13. Steppo, 09.01.2011 #13
    Steppo

    Steppo Android-Lexikon

    Beiträge:
    1,894
    Erhaltene Danke:
    247
    Registriert seit:
    19.02.2010
    Die deutsche Gmail.apk im Anhang!
    Wenn du das Skript ausführst, am besten über adb (da hast dun größeren Bildschirm und kannst dir alles genauer ankucken), dann kannst du NUR über das Skript deine Apps auf die SD-Ext verschieben! Das geschieht leider nicht automatisch mit dem installieren. Andere Roms haben aber standardmäfig schon das übliche Verfahren von Eclair mit drinnen. Z.Bsp. PirateRum Froyo.


    Gruß Steppo
     

    Anhänge:

    • Gmail.apk
      Dateigröße:
      602.2 KB
      Aufrufe:
      67
    Zuletzt bearbeitet: 09.01.2011
    motoxtremo bedankt sich.
  14. motoxtremo, 09.01.2011 #14
    motoxtremo

    motoxtremo Threadstarter Gast

    Danke für die .apk, Ich werd sie morgen installieren. Und das Firerat Script hat jetzt auch funktioniert! Scheint als wären die Probleme behoben. Danke für eure Hilfe!
     
  15. Steppo, 10.01.2011 #15
    Steppo

    Steppo Android-Lexikon

    Beiträge:
    1,894
    Erhaltene Danke:
    247
    Registriert seit:
    19.02.2010
    Inwieweit funktioniert das Skript? Werden die Apps nun automatisch auf die ext installiert oder so wie ich beschrieben habe? Sonst würde ich nämlich auch auf Froyo umsteigen, mir war das mit dem Skript aber immer zu umständlich.


    Gruß
     
  16. motoxtremo, 11.01.2011 #16
    motoxtremo

    motoxtremo Threadstarter Gast

    Das kann ich dir nicht sagen, ich hab alle Apps installiert und dann das Skript ausgeführt und seitdem keine neuien installiert.

    Mit dem Akku ist aber sehr seltsam.

    1. Nacht I'm Flugmodus 12h: 0%
    2. Nacht I.F. 6h: 18%
    3. Nacht I.F. 6h: 17%

    Und wo liegt der Unterschied? In der ersten Nacht hatte ich noch keine Apps installiert! Irgendeine App (oder mehrere) ziehen also meinen Akku leer,selbst I'm Flugmodus ohne irgendetwas am Handy zu machen?

    Gibts da ne effektive Methode das rauszufinden?
     
  17. Denowa, 11.01.2011 #17
    Denowa

    Denowa Android-Guru

    Beiträge:
    2,871
    Erhaltene Danke:
    565
    Registriert seit:
    21.08.2009
    Phone:
    OnePlus One, OnePlus Two, ZTE Axon 7
    Wearable:
    Pebble
    Akku Drain. Nach jedem abstecken des USB Kabels (Laden o. Daten) einen Neustart machen.
     
  18. motoxtremo, 11.01.2011 #18
    motoxtremo

    motoxtremo Threadstarter Gast

    Soweit ich weiß hat das nur Cyanogen, oder täusche ich mich da? Aber selbst wenn nicht kann es das nciht sein, mein Handy hat seit dem letzten PC Anschluss schon mehrere Reboots hinter sich, gestern Abend habe ich es neu gestartet, voll aufgeladen, neu gestartet, nichts mit gemacht und angesteckt gelassen bis ich aufgewacht bin, dann Flugmodus und schwupps 8h später 18% Akku weg.

    Also dieser Akku drain Bug kanns wohl kaum sein, aber danke trotzdem!
     
  19. Denowa, 12.01.2011 #19
    Denowa

    Denowa Android-Guru

    Beiträge:
    2,871
    Erhaltene Danke:
    565
    Registriert seit:
    21.08.2009
    Phone:
    OnePlus One, OnePlus Two, ZTE Axon 7
    Wearable:
    Pebble
    In 8h 18% Akku weg, hört sich erst mal nicht so dramatisch an!?!
    Beim Akku Drain wäre im FM der Akku nach 3-4h leer ...

    Gib dann mal *#*#4636#*#* ein und schau im Akkuprotokoll nach
    was solange aktiv war! Ein Klick auf die Werte gibt mehr Infos preis.
    Auch unter Einstellungen -> Telefoninfo -> Akkuverbrauch kann man
    nützliche Infos finden .....
     
  20. Manfred, 12.01.2011 #20
    Manfred

    Manfred Erfahrener Benutzer

    Beiträge:
    156
    Erhaltene Danke:
    14
    Registriert seit:
    03.02.2009
    Hallo!

    Seit dem ich CM6.1 installiert habe, ist die Akkuleistung voll im Keller! Ich habe gestern ein Wipe gemcht, dachte es wird besser, aber nicht...!

    Habe nach dem Wipe keine Apps vom Markt installiert um das mal zu testen. Nach 3:48 Stunden habe ich noch 47% Akku, wobei folgender Akkuverbrauch zu sehen ist:

    Android OS 45%
    Mobilfunk Standby 33%
    Android System 5%
    ..
    ..

    Ich habe nur 2G Netze aktiviert und Synchronisierung mit Gmail. Helligkeit auf Minimum. Habs die 3:48 Stunden fast nicht benutzt. Nur 1 SMS, 1 kurzes Telefonat und ein paar Mal im Status den Akku nachgesehen.

    Gut ich habe das Gerät jetzt 2 jahre, der akku ist vielleicht nicht der beste. Unter 1.6 ist mir das nicht so extrem vorgekommen. Komme ja jetzt bei bescheidener Nutzung gerade mal 12 Stunden durch.

    Hat jemand das auch beobachtet bzw. gibtd da "irgendwo" eine Einstellung!?
    Ich möchte mir nicht einen neuen Akku kaufen und dann das gleiche Erleben. Deshalb wie lange kommt ihr mit CM6.1 durch?


    PS:
    Habe soeben im Akkuprotokoll nachgesehen und da war
    "wird ausgeführt" bei 99%

    ich hab nachgelesen, dass dann das Handy nicht in den Sleep-Mode geht. Ist das richtig? Da ich ausser dem Rom-Manager nichts installiert habe, was könnte da schuld sein?

    danke

    lg
     
    Zuletzt bearbeitet: 12.01.2011

Diese Seite empfehlen