1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Terminal-Probleme

Dieses Thema im Forum "Root / Hacking / Modding für HANNspree HANNSpad (SN10T1)" wurde erstellt von Banause, 21.10.2011.

  1. Banause, 21.10.2011 #1
    Banause

    Banause Threadstarter Junior Mitglied

    Beiträge:
    37
    Erhaltene Danke:
    8
    Registriert seit:
    08.10.2011
    Heiho!

    Leider habe ich auch nach vielem Suchen keine wirkliche Antwort auf mein Problem gefunden.

    Mein Problem sieht wie folgt aus:

    Ich setzt FB8.1 lite ein und möchte PolarisOffice auf meinem Hansi installieren. Also habe ich mir die APK gesaugt incl. der beiden Files, welche ins Verzeichnis /system/lib/ kopiert werden müssen. Da ich mein Partition nicht vergrößert habe, gibt es nun ein Platzproblem beim Kopieren der 12-MB Datei. Die passt nicht mehr in das Lib-Verzeichnis.

    Also habe ich mich ein wenig schlaugelesen beim Thema Symlinks. Nichts anderes macht ja App2SD auch. Die eigentlichen Verzeichnisse werden verschoben, und über einen Symlink "verlinkt".

    Ich habe also die beiden zu kopierenden so-Dateien unter /sdcard/download/ gespeichert, und mit Symlinks ( liegen unter /system/lib/ ) verlinkt. Beide Links (sind korrekt benannt) verweisen auch auf die entsprechenden Dateien unter /sdcard/download/.

    Trotzdem schmiert mir Polaris-Office ab, sobald ich eine neue Datei anlegen will. Dies soll angeblich ein Fehler sein, wenn die beiden so-Dateien nicht erreichbar sind. Sie sind aber korrekt verlinkt.

    Meine nächste Idee war nun die, ob die Dateirechte richtig gesetzt sind. Und hier beginnt nun mein Terminal-Problem:

    1. Beide Dateien in /sdcard/download/ weisen keine keine Dateiberechtigungsattribute mehr auf. Also z.B. kein rw- rw- rw mehr. Es wird lediglich noch die Größe der Dateien angezeigt. Kann ich im genannten Verzeichnis überhaupt Dateirechte vergeben per chmod?

    2. Die Symlinks in /system/lib/ haben kaum Berechtigungen. Möchte ich ihnen per Terminal direkt über das Pad (su-Rechte sind zugewiesen) andere Berechtigungen zuweisen, kann ich den Befehl zwar am Pad (nicht am PC) abschicken, erhalte aber keine Fehlermeldung, dass dies nicht geklappt hat. Wenn ich mir jedoch die Dateirechte im ES-Dateiexplorer (root-Rechte sind zugewiesen) anschaue, entsprechen sie nicht denen, die ich zugewiesen habe. Das Ändern der Dateirechte im ES-Dateiexplorer endet immer mit der Fehlermeldung, dass dies nicht durchgeführt werden kann, auch wenn ich angegeben habe, dass der ES-Dateiexplorer /system als schreibbar mounten soll.

    3. Wenn ich per Terminal vom PC aus auf mein Pad zugreifen will, so bekomme ich bereits nach dem "adb remount" die Meldung, dass das Device nicht vorhanden ist. Leider finde ich nirgendwo eine Anleitung, die mich mal an die Hand nimmt und mir die genaue Vorgehensweise erklärt. Geklappt hat es allerdings schon 1x, da ich über ein push vom PC aus die Dateien nach /system/lib/ verschieben wollte und mir dort dann gesagt wurde, dass kein Platz mehr vorhanden sei. Die kleinere Datei war im Verzeichnis angekommen, die größere Datei leider nicht.

    Nun zu den Fragen:

    a)
    Übernehmen die Symlinks automatisch die Dateirechte der eigentlich verlinkten Dateien, so dass ich sie beim Symlink gar nicht ändern kann?

    b)
    Warum kann ich die Dateirechte unter /sdcard/download/ nicht einsehen, geschweige denn ändern?

    c)
    Gibt es irgendwo eine "verständliche" Anleitung für dieses Terminal? Die Java-SDK und Android-SDK habe ich installiert, und auch mein Hannsi entsprechend als Gerät im "Android Virtual Device Manager" eingetragen. ADB habe ich entsprechend in den Path aufgenommen und auch unter "tools" kopiert (die neue SDK hat adb nur noch in Platform-tools).

    d)
    Habe ich einfach den falschen Ort ( /sdcard/download/ ) als Ziel für meine Dateien ausgesucht?

    Schon jetzt vielen Dank an alle, die sich ihren Kopf für mich zerbrechen. ;-)

    Gruß

    Banause
     
  2. ganymed, 21.10.2011 #2
    ganymed

    ganymed Android-Hilfe.de Mitglied

    Beiträge:
    73
    Erhaltene Danke:
    11
    Registriert seit:
    19.04.2010
    bei mir ist das Verzeichnis "Download" mit einem großen "D" geschrieben ...
    liegt es vielleicht da dran?

    unter dem TotalCommander kann ich mir die Dateirechte anschauen / ändern, welches Programm nutzt du denn?
     
  3. heinerl, 21.10.2011 #3
    heinerl

    heinerl Android-Experte

    Beiträge:
    609
    Erhaltene Danke:
    171
    Registriert seit:
    06.08.2011
    Warum vergrößerst Du nicht "einfach" die Partition? Du könntest ein Backup mit CWM machen, danach wie im Thread zur FB 7.2 Installation genannt das Rom zur Paritionsanpassung apx-flashen, das Backup mit CWM zurücklesen und zur Sicherheit noch ein ab-Kernel mit CWM flashen. Dann müßtest Du Dein jetziges System mit einer großen Partition haben.

    Soweit ich das im Market gelesen habe, funktionieren diese ganzen app2sd Apps mit Honeycomb nicht. Vielleicht ein grundsätzliches Problem der symlinks.
     
    Zuletzt bearbeitet: 21.10.2011
  4. Banause, 21.10.2011 #4
    Banause

    Banause Threadstarter Junior Mitglied

    Beiträge:
    37
    Erhaltene Danke:
    8
    Registriert seit:
    08.10.2011
    @ganymed

    Du hast mir gerade den Schweiß auf die Stirn getrieben. ;-) Nein, ist kein großes "d" bei mir. Ist ein kleines d. Wenn es daran gelegen hätte, hätte ich meinen Namen geändert und wäre untergetaucht. ;-)

    Ich nutze den ES-Dateiexplorer. Der macht mit SU-Rechten und mit Schreibrechten auf /system alles was ich möchte. *grübel*


    @heinerl

    Das "einfach" hat mich bislang davon abgehalten. Sollte ich keine andere Lösung finden, werde ich die Partition wohl vergrößern müssen. Nur ist mir nicht so wirklich wohl dabei. Die APPs2SD funktionieren bei mir sonst vorzüglich. Daher schien mir die Symlink-Lösung so attraktiv.


    Aber schon mal Dank an euch beide. Werde heute noch ein wenig rumwerkeln, und wenn es nichts wird,.. ist Morgen die Vergrößerung der Partition dran.
     
  5. muhviehstarr, 22.10.2011 #5
    muhviehstarr

    muhviehstarr Android-Hilfe.de Mitglied

    Beiträge:
    122
    Erhaltene Danke:
    22
    Registriert seit:
    03.10.2011
    hmm weiss gerad nicht obs im terminal farbig angezeigt wird.. weil unter nem linux term sind falsche links rot


    ls -al /system/lib/

    zeigt im link den richtigen Pfad?

    hatte heute Mittag schon geguckt obs im vegantab (hab ich zur Zeit drauf) Binarys wie ldd oder ldconfig gibt.. gabs da nicht. Denke mal im HC isses dasselbe oder?

    ldd /pfad/zur/binary verrät im Linux normal welche shared libs benötigt sind und auch ob welche fehlen. Wenn man den Befehl irgendwo her bekommen würd (neuere / andere busybox?) , wär man bestimmt schlauer.

    die links hast du normal mit ln -s ... angelegt right?
     
    Zuletzt bearbeitet: 22.10.2011
  6. Banause, 22.10.2011 #6
    Banause

    Banause Threadstarter Junior Mitglied

    Beiträge:
    37
    Erhaltene Danke:
    8
    Registriert seit:
    08.10.2011
    @muhviehstarr

    Ja. Habe die Links gleich nach dem Anlegen kontrolliert. Wurden grün dargestellt.

    Ich werde jetzt die Partition vergrößern und kann dann hoffentlich vom Erfolg der Einrichtung berichten. ;-)
     
  7. Banause, 22.10.2011 #7
    Banause

    Banause Threadstarter Junior Mitglied

    Beiträge:
    37
    Erhaltene Danke:
    8
    Registriert seit:
    08.10.2011
    Sodele, Berichterstattung:

    1.
    Das von heinerle genannte ROM geladen und per NV-Flash auf das Pad gebracht.
    Schocksekunde, als mir NV erzählte, dass kein Device gefunden wurde. Das Pad wurde schwarz und zeigte keine Reaktion mehr. Also Power-Taste für ca. 10 Sekunden gedrückt, bis die LED erlosch. Dann erneut versucht in den APX-Modus zu kommen, aber es kam kein Hannspree-Logo mehr. Lediglich die Power-LED sagte mir, dass noch Leben im Pad ist. Also erneut mit NV versucht und diesmal lief die Installation durch. Pad ausgeschaltet.

    2. Ab in den Recovery-Modus und die vorher auf der SD-Karte abgelegte Update.zip installiert. Pad ausgeschaltet

    3. Pad eingeschaltet und in den CWM-Modus gegangen um mein vorher gesichertes CWM-Backup zu restoren. Restore lief problemlos durch. Pad ausgeschaltet.

    4. Pad eingeschaltet, die beiden SO-Dateien nach /system/lib/ kopiert, Polaris-Office installiert,... HEUREKA. ;-) Es läuft.

    Es scheint, als würden Symlinks tatsächlich nicht immer funktionieren. Werde das noch ein wenig testen und dann schauen, ob es lediglich Polaris-Office ist, was sich da zickig anstellt.

    Mein Dank geht an ganymed, heinerle und muhviehstar für die Hilfestellung. :)
     

Diese Seite empfehlen