1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Themes für MustyMod-Rom (Eclair 2.0)

Dieses Thema im Forum "Root / Hacking / Modding für Samsung Galaxy" wurde erstellt von Meico, 25.01.2010.

  1. Meico, 25.01.2010 #1
    Meico

    Meico Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    442
    Erhaltene Danke:
    23
    Registriert seit:
    13.08.2009
    Gibt es eigentlich schon ein Theme für die Rom von Mustymod???
     
  2. wanschi, 25.01.2010 #2
    wanschi

    wanschi Android-Lexikon

    Beiträge:
    1,122
    Erhaltene Danke:
    246
    Registriert seit:
    25.09.2009
    Deine Überschrift ist sehr verwirrend. "Rom für Eclair 2.0", die Mustymodversion ist ja das ROM.
    Momentan gibt es noch (jedenfalls meine Wissens nach) keine Themes für die Version.
    Denke das wird auch noch etwa dauern, bis die Version etwas gereifter ist.
     
    Zuletzt bearbeitet: 25.01.2010
  3. lx01, 25.01.2010 #3
    lx01

    lx01 Junior Mitglied

    Beiträge:
    34
    Erhaltene Danke:
    12
    Registriert seit:
    30.07.2009
    Phone:
    Samsung Galaxy
    *Theoretisch* sollten alle Themes für 2.0-AOSP gehen.
    *Praktisch* hab ich's am Wochende versucht und mir damit alles komplett zerschossen.:D

    Die Bootanim-Themes funktionieren aber einwandfrei...
     
  4. Meico, 26.01.2010 #4
    Meico

    Meico Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    442
    Erhaltene Danke:
    23
    Registriert seit:
    13.08.2009
    Hey mal noch ne andere Frage welche Roms kann man eigentlich genau so installieren also über odin wie Android 2.0??
     
  5. Ai4key, 26.01.2010 #5
    Ai4key

    Ai4key Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    17
    Registriert seit:
    01.08.2009
    habe versucht eine boot-animation über adb zu flashen mit
    Code:
    adb push bootanimation.zip /data/local/bootanimation.zip
    was hab ich falsch gemacht?
     
  6. lx01, 26.01.2010 #6
    lx01

    lx01 Junior Mitglied

    Beiträge:
    34
    Erhaltene Danke:
    12
    Registriert seit:
    30.07.2009
    Phone:
    Samsung Galaxy
    Es würde helfen, wenn Du sagst, was eigentlich das Problem ist;) (also etwa: funktioniert einfach nicht / Galaxy bootet nicht / Galaxy hat Deinen Hund gefressen / ...)

    Spontan würd' ich aber sagen, es muß heißen
    Code:
    adb push bootanimation.zip /system/media/bootanimation.zip
     
  7. tiran, 27.01.2010 #7
    tiran

    tiran Erfahrener Benutzer

    Beiträge:
    180
    Erhaltene Danke:
    78
    Registriert seit:
    11.07.2009
    Phone:
    Nexus One
    habs auch mal probiert. Im normalfall wird an beiden stellen nach einer bootanimation gesucht zuerst in /data und dann in /system.
    Siehe dazu:
    android.git.kernel.org Git - platform/frameworks/base.git/blob - cmds/bootanimation/BootAnimation.cpp

    Falls dein Problem ist, dass der Bildschirm schwarz bleibt hast du die zip komprimiert. Das darf man nicht, man darf die sachen nur speichern.

    Hab dann gleich mal die NexusOne Animation probiert. Musste die desc.txt an die auflösung des galaxys anpassen.

    Hier kann man das auch nochmal nachlesen.
    AllDroid - View topic - Customizing Droid boot animation

    Hab mal die NexusOne Bootanimation.zip angehängt...

    Viel Spaß damit...
     

    Anhänge:

  8. Ai4key, 27.01.2010 #8
    Ai4key

    Ai4key Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    17
    Registriert seit:
    01.08.2009
    also wenn ich
    Code:
    adb push bootanimation.zip /system/media/bootanimation.zip 
    eingebe kommt,
    Code:
    *daemon not running. starting it now*
    *daemon started successfully*
    cannot stat 'bootanimation.zip': not such file or directory
    :confused:
     
    Zuletzt bearbeitet: 27.01.2010
  9. n8schicht, 27.01.2010 #9
    n8schicht

    n8schicht Android-Experte

    Beiträge:
    549
    Erhaltene Danke:
    71
    Registriert seit:
    20.07.2009
    Phone:
    Galaxy Nexus
    @Ai4key: Du musst das auch von dem Verzeichnis aus machen, in das du die Datei "bootanimation.zip" gespeichert hast
     
  10. Ai4key, 27.01.2010 #10
    Ai4key

    Ai4key Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    17
    Registriert seit:
    01.08.2009
    hab die Datei bootanimation.zip direkt im Stammverzeichnis liegen
     
  11. tiran, 27.01.2010 #11
    tiran

    tiran Erfahrener Benutzer

    Beiträge:
    180
    Erhaltene Danke:
    78
    Registriert seit:
    11.07.2009
    Phone:
    Nexus One
    komischer fehler hab ich noch nie gesehn. Ist die System Partition rw gemountet?
    Vielleicht vorher ein "adb remount" versuchen...

    Hast du mal probiert die Datei nach /data zu schieben?

    Code:
    adb push bootanimation.zip /data/local/bootanimation.zip
    
    also da habe ich die .zip liegen und es geht ohne Probleme...
     
  12. Ai4key, 27.01.2010 #12
    Ai4key

    Ai4key Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    17
    Registriert seit:
    01.08.2009
    so hat die Änderung der Bootanimation funktioniert

    1. SDK bei Android SDK | Android Developers runterladen und entpacken
    z.B. nach C:/Android/

    2. In dem Verzeichnis C:/Android/ befindet sich der Ordner "tools"
    Hierher die Bootanimation.zip kopieren

    3. Galaxy an Rechner anschließen und am Galaxy unter Einstellungen\Anwendungen\Entwicklung das USB Debugging aktivieren

    4. dann cmd.exe starten ("Ausführen" --> cmd.exe) und bis zum Prompt C:\Android\tools wechseln
    Code:
    cd c:\android\tools
    5. dann den folgenden Befehl eingeben:
    Code:
    c:\tools\adb remount
    -->es folgt "remount succeeded"
    Code:
    adb push bootanimation.zip \system\media\bootanimation.zip
    --> Enter
    -->es folgt "xxx KB/s (xxxxxx bytes in x.xxxs)"

    6. daemon wird gestartet, Vorgang bis zum Ende abwarten

    7. nach Beendigung USB Debugging am Galaxy deaktivieren, Galaxy auswerfen

    8. Reboot Galaxy

    (von http://www.android-hilfe.de/motorola-milestone/11341-boot-animation-droid-3.html hergeleitet)
     
  13. CheCroatia, 27.01.2010 #13
    CheCroatia

    CheCroatia Android-Hilfe.de Mitglied

    Beiträge:
    110
    Erhaltene Danke:
    3
    Registriert seit:
    18.01.2010
    bei mir kommt daemon wird gestartet und dan device not found
    was tun??
     
  14. wanschi, 27.01.2010 #14
    wanschi

    wanschi Android-Lexikon

    Beiträge:
    1,122
    Erhaltene Danke:
    246
    Registriert seit:
    25.09.2009
    hat du den richtigen usb treiber für dein galaxy intalliert? oder hast du nur den treiber der mit der intallation von nps installiert wird? welches betriebssystem hast du auf dem rechner?
    usb debugging aktiviert?
     
  15. CheCroatia, 28.01.2010 #15
    CheCroatia

    CheCroatia Android-Hilfe.de Mitglied

    Beiträge:
    110
    Erhaltene Danke:
    3
    Registriert seit:
    18.01.2010
    hab Debugging aktiviert hab dan probiert die Treiber des SDK zu installiren geht aber nicht hab windows 7
     
  16. wanschi, 28.01.2010 #16
    wanschi

    wanschi Android-Lexikon

    Beiträge:
    1,122
    Erhaltene Danke:
    246
    Registriert seit:
    25.09.2009
  17. CheCroatia, 29.01.2010 #17
    CheCroatia

    CheCroatia Android-Hilfe.de Mitglied

    Beiträge:
    110
    Erhaltene Danke:
    3
    Registriert seit:
    18.01.2010
    denn hab ich runtergeladen aber wie muss ich den installieren?
     

Diese Seite empfehlen