1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Titanium Backup Wiederherstellen klappt nicht

Dieses Thema im Forum "Root / Hacking / Modding für Huawei Ideos X3" wurde erstellt von spoochie, 08.11.2011.

  1. spoochie, 08.11.2011 #1
    spoochie

    spoochie Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    61
    Erhaltene Danke:
    3
    Registriert seit:
    05.11.2010
    Hallo, wie oben erwähnt klappt bei mir die Wiederherstellung nicht. Sichern funktioniert ohne Probleme nur das Wiederherstellen der Apps nicht. Habe es mal mit Document2go versucht, die standardmäßig dabei ist. Wenn ich das Programm wieder herstellen möchte, dann bleibt Titanium Backup hängen und das wars. Habe mal die Option versucht, die angezeigt wird, wenn man auf Probleme klickt. Bringt aber keinerlei Besserung. Kann das Problem jemand reproduzieren?

    MfG spooch
     
  2. Ryuk, 08.11.2011 #2
    Ryuk

    Ryuk Android-Lexikon

    Beiträge:
    1,010
    Erhaltene Danke:
    207
    Registriert seit:
    19.09.2011
    hatte mal ein komplettes titanium backup eingespielt, lief ohne probleme...

    hast du vllt. die rom gewechselt...von stock auf cyanogen?
     
  3. android_53, 08.11.2011 #3
    android_53

    android_53 Fortgeschrittenes Mitglied

    Beiträge:
    318
    Erhaltene Danke:
    46
    Registriert seit:
    25.10.2011
    ich habe die Erfahrung gemacht, dass Titanium Backup Schwierigkeiten hat Backups wiederherzustellen, die im System-Ordner liegen, besonders, wenn man es im interaktiven Modus versucht. Versuch mal die App im Batchmodus zu restoren, das hat bei mir oft geklappt.
     
  4. spoochie, 08.11.2011 #4
    spoochie

    spoochie Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    61
    Erhaltene Danke:
    3
    Registriert seit:
    05.11.2010
    Hmm, schein irgendwie dran zu liegen, dass es sich um Systemapps handelt. Die Backupps liegen allesamt auf der SD Karte nur werden sie wahrscheinlich, weil es sich ja um Systemapps handelt auf die Systempartition wiederhergestellt und das klappt wohl nicht.

    Ist nur doof jetzt, weil ich die ganzen Apps die deinstalliert habe, die ich nicht mehr brauche und die man laut dem Thread hier gefahrlos deinstallieren kann.

    Mfg spooch
     
  5. android_53, 08.11.2011 #5
    android_53

    android_53 Fortgeschrittenes Mitglied

    Beiträge:
    318
    Erhaltene Danke:
    46
    Registriert seit:
    25.10.2011
    Es scheint so zu sein, als ob Titanium-Backup die .odex-Dateien nicht sichert, zumindest kann ich sie im Verzeichnis nicht finden. Wenn du trotzdem einzelne Apps aus dem Stock-Rom wiederherstellen willst, kannst du folgendermassen vorgehen.
    1. Dir ein funktionierendes Image herunterladen. Z.B. das hier: MEGAUPLOAD - The leading online storage and file delivery service. Falls du mit CWM-recovery schon selbst ein image erstellt hast, kannst du auch das verwenden. Das image must du natürlich erstellt haben bevor du die apps gelöscht hast.
    2. Die Datei system.img, die sich in dem rar-File befindet, entpacken.
    Wie das geht, ist hier ganz gut beschrieben: http://www.android-hilfe.de/root-ha...-x3/152438-how-img-app-dateien-entpacken.html.

    Die apps, die du wieder installieren willst, musst du dann per hand das smartphone kopieren. Am besten machst du das über das adb-Tool. Ist hier mit dabei: Multiupload.com - upload your files to multiple file hosting sites! Das hast du dir vermutlich schon runtergeladen hast, als du dein Phone gerootet hast.

    Vorgehensweise:
    1. Phone über USB-Anschluss mit dem PC verbinden. Wichtig USB-Anschluss muss im Debug-Modus sein
    2. Das Zip-File herunterladen und in einem Verzeichnis entpacken.
    3. Eine Dos-Box öffnen und in das Verzeichnis wechseln
    4. Die Datei zunächst einmal auf die SD-Karte kopieren: adb push <Verzeichnis auf dem PC>\<Anwendung>.apk /sdcard
    5. Aus der Dos-Box adb.exe starten. Du startest damit eine Art Konsolenverbindung auf dem Android.
    6. su eingeben, um rootrechte zu bekommen.
    7. Das Verzeichnis /system zum Schreiben öffnen: mount -o rw,remount /dev/null /system
    8. Die Datei von der sdcard in das verzeichnis /system/app kopieren: dd if=/sdcard/<anwendung>.apk of=/system/app/<anwendung>.apk
    9. Die original-Rechte wieder herstellen: chmod 644 /system/app/<anwendung>.apk

    Das machst du für alle apps, die du wiederherstellen willst. Anschliessend musst du das Phone einmal rebooten und die Anwendung sollte wieder funktionieren
    Achtung: Apps die im Systemverzeichnis liegen bestehen im Stockrom vom X3 immer aus 2 Dateien <anwendung>.apk und <anwendung>.odex. Du musst also die Schritte 4, 8 und 9 immer für eine .apk und eine .odex-Datei durchführen.

    Die zu den apps gehörigen Daten kannst du (falls notwendig) nach dem reboot mit Titanium-Backup wiederherstellen. Die .apk und .odex Dateien wieder von der SD-Karte löschen, sie werden nicht mehr benötigt
     
    Zuletzt bearbeitet: 08.11.2011
    [8] und spoochie haben sich bedankt.
  6. spoochie, 09.11.2011 #6
    spoochie

    spoochie Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    61
    Erhaltene Danke:
    3
    Registriert seit:
    05.11.2010
    Hallo, erstmal vielen Dank.Scheint echt daran zu liegen, dass er die .odex Datei nicht mitsichert? Ist das ein Bug und vor allen Dingen bekannt bei den Entwicklern? Sonst würde ich das mal melden. So wie du es geschrieben hast klappt es Einwandfrei? Werde es dann erst einmal über diesen Umweg machen.

    MfG spooch
     
  7. android_53, 09.11.2011 #7
    android_53

    android_53 Fortgeschrittenes Mitglied

    Beiträge:
    318
    Erhaltene Danke:
    46
    Registriert seit:
    25.10.2011
    Keine Ahnung obs ein Bug ist, kannst die jungs ja mal anschreiben
     
  8. Ryuk, 09.11.2011 #8
    Ryuk

    Ryuk Android-Lexikon

    Beiträge:
    1,010
    Erhaltene Danke:
    207
    Registriert seit:
    19.09.2011
    btw...diamond-x hatte mal alle sys-apps (apk+odex) in ner zip geuppt:

    Systemapps.zip

    alternativ kann man die apps auch per rootexplorer, es file explorer oder ghost explorer wieder in den sys-ordner schieben...root vorrausgesetzt... ;)
     

Diese Seite empfehlen