1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Touchlet X3 rooten

Dieses Thema im Forum "Pearl Touchlet X3 / X4 Forum" wurde erstellt von Mark_Mahoon, 14.09.2011.

  1. Mark_Mahoon, 14.09.2011 #1
    Mark_Mahoon

    Mark_Mahoon Threadstarter Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    1
    Registriert seit:
    03.09.2011
    Hallole

    weiss jemand wie man das X3 rooten kann?

    Ich scheine irgendwie etwas zerschossen zu haben, denn ich konnte vorher mit dem Ghostcommander Verzeichnisse auf dem internen Speicher anlegen. Nun bekomm ich allerdings die Fehlermeldung "Der rootzugriff (su) wurde verweigert", ebenso meldet Titaniumbackup einen fehlenden Rootzugriff. :confused2:
     
  2. hävksitol, 15.09.2011 #2
    hävksitol

    hävksitol Ehrenmitglied

    Beiträge:
    12,606
    Erhaltene Danke:
    8,874
    Registriert seit:
    11.01.2011
    Tablet:
    Lenovo Ideapad A2109A
    Mark_Mahoon bedankt sich.
  3. N2k1, 15.09.2011 #3
    N2k1

    N2k1 Moderator Team-Mitglied

    Beiträge:
    7,903
    Erhaltene Danke:
    1,705
    Registriert seit:
    17.02.2011
    Ich werde nachher wohl mal eine Batch-Datei nun endlich erstellen, mit der man das Gerät rooten kann und gleich den NAND einbindet.
     
  4. Mark_Mahoon, 15.09.2011 #4
    Mark_Mahoon

    Mark_Mahoon Threadstarter Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    1
    Registriert seit:
    03.09.2011
    hat Perfekt geklappt, auch wenn ich mittendrin dachte das die Software abgestürzt wäre. Wer rechnet auch damit das Schritt 5 geschlagene 947 sekunden daueren kann. :smile:

    Ansonsten danke für den Tipp. Nun werd ich dem chinesischen Pferdchen mal die Sporen geben. :thumbup:
     
  5. Jagurta, 21.09.2011 #5
    Jagurta

    Jagurta Neuer Benutzer

    Beiträge:
    23
    Erhaltene Danke:
    1
    Registriert seit:
    01.09.2011

    Also bei mir bleibt er ständig bei step 6 hängen und nichts geht mehr. Sowohl auf dem Desktop als auch auf den Laptop. (beide mit Win7 64) :confused2:
    Hat jemand eine Idee?

    Jagurta
     
  6. N2k1, 21.09.2011 #6
    N2k1

    N2k1 Moderator Team-Mitglied

    Beiträge:
    7,903
    Erhaltene Danke:
    1,705
    Registriert seit:
    17.02.2011
    Da das System auf ADB-Ebene gerootet ist, kann man dort einfach die su erstezen und die Superuser.APK installieren.
    Zudem muß man bei SuperOneClick immer dazusagen, welche Vesion man benutzt.
     
  7. Jagurta, 21.09.2011 #7
    Jagurta

    Jagurta Neuer Benutzer

    Beiträge:
    23
    Erhaltene Danke:
    1
    Registriert seit:
    01.09.2011
    Sorry, nutze SuperOneClickv2.1.1-ShortFuse. Laut den hier vorliegenden Meldungen sollte das Programm eigentlich mit Root-Befehl funkt. Ich versuch das schon seit einer Woche. Was meinst du mit ersetzen und ADB-Ebene? Droid-Explorer? Die ADB-Shell mit der ich den NAND aktiviert habe kommt mir wie ein Komandozeileninterpreter vor, mit der wir früher z.B. DOS gesagt haben was es tun soll. Die meinst du doch wohl nicht. Tut mir leid wenn ich dich nerve aber in Sachen Andoid bin ich Neuling.
    Schöne Grüße
    Jagurta

    PS: in dem oft erwähnten AndroidPITiden-Buch bin ich in diesem Zusammenhang auch nicht fündig geworden.[FONT=Verdana,Bold]

    [/FONT]
     
  8. N2k1, 21.09.2011 #8
    N2k1

    N2k1 Moderator Team-Mitglied

    Beiträge:
    7,903
    Erhaltene Danke:
    1,705
    Registriert seit:
    17.02.2011
    Doch, genau diese Kommandozeile meine ich.

    adb remount
    adb push su /system/bin
    adb shell chmod 4755 /system/bin/su
    adb install bin/Superuser.apk

    Jetzt muß ich nur noch die entsprechende su und die Superuser.apk hochladen - oder Du mußt mal in Netz suchen..
     
  9. N2k1, 21.09.2011 #9
    N2k1

    N2k1 Moderator Team-Mitglied

    Beiträge:
    7,903
    Erhaltene Danke:
    1,705
    Registriert seit:
    17.02.2011
    So.. hab mal was gebastelt...

    http://n2k1.com/n2k1/X3/x3_x4_root_und_nand.zip

    Fehlen nur noch die Treiber..

    x3_rooten.bat <-- kopiert su nach /system/bin und installier Superuser.apk
    unroot_x3.bat <-- deinstalliert Superuser.apk
    nand.bat <-- formatiert den Nand um ihn bereitzustellen.

    Da bei mir alles schon passiert ist, ist es ungetestet.
    ADB ist dabei - der Treiber fehlt (wie gesagt)
     
    slippi und Jagurta haben sich bedankt.
  10. slippi, 30.10.2011 #10
    slippi

    slippi Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    30.10.2011
    Hi bin neu hier und hat auch alles gut geklappt


    aber echt vielen dank ich hab schon wie doof überall und alles ausprobiert
    mein x3 zu rooten aber irgendwie hab ichs noch nich so drauf:unsure:
     
    Zuletzt bearbeitet: 30.10.2011
  11. N2k1, 30.10.2011 #11
    N2k1

    N2k1 Moderator Team-Mitglied

    Beiträge:
    7,903
    Erhaltene Danke:
    1,705
    Registriert seit:
    17.02.2011
    Schön, wenn es nun geklappt hat.
    Hast Du schon die neue Firmware drauf?
    Was hat sich denn geändert?
     
  12. Mark_Mahoon, 30.10.2011 #12
    Mark_Mahoon

    Mark_Mahoon Threadstarter Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    1
    Registriert seit:
    03.09.2011
    Hallole

    endlich ist der Ersatz für mein X3 da. Beim neuen war das Nand schon korrekt eingebunden, aber von flash immer noch keine spur. Ausserdem krieg ich es mit interessanterweise mit Superoneklick nicht mehr gerootet, auch bei mir bleibt es bei step 6 hängen. Seltsamerweise behauptet Superoneklick das es schon gerootet wäre beim Start, dem widerspricht aber Rootcheck auf dem Gerät.

    Mal sehen wo hier der Fehler ist.

    signed MKM
     
  13. N2k1, 30.10.2011 #13
    N2k1

    N2k1 Moderator Team-Mitglied

    Beiträge:
    7,903
    Erhaltene Danke:
    1,705
    Registriert seit:
    17.02.2011
    Hatte bei einem anderen User gelesen, daß nun 10.1 installiert sei?!
    Aber zum Root: Warum nicht den Weg über die ADB shell?
     
  14. Mark_Mahoon, 03.11.2011 #14
    Mark_Mahoon

    Mark_Mahoon Threadstarter Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    1
    Registriert seit:
    03.09.2011
    Okay Fehler gefunden. Anscheinend setzt das X3 am Ende, wenn Step6 fertig ist, keine Rückmeldung an Superoneclick ab. Bei mir hat geholfen folgendes zu tun:


    1. Externe SD-arte rausnehmen
    2. Nand auswerfen
    3. anschließend Superoneclick mit Einstellung Gingerreak durchlaufen lassen
    4. bei step 6 einige Zeit warten (bei mir wars ungefähr ne halbe stunde, bevor ich gemerkt hatte das sich nichts tut)
    5. USB Kabel abziehen und sofort wieder anstecken (Meldet bei mir dann Step 6 als sucess und machte dann die noch restlichen Schritte)
    Mein X3 war danach gerootet, und hat sämtliche zugriffe erlaubt. Allerdings frag ich mich langsam wieviele verschiedene Versionen vom X3 hier rumschwirren. Irgendwie hat anscheinend jemand beim Aufspielen vom BS und Firmware rumgewürfelt.

    signed MKM
     
  15. hävksitol, 03.11.2011 #15
    hävksitol

    hävksitol Ehrenmitglied

    Beiträge:
    12,606
    Erhaltene Danke:
    8,874
    Registriert seit:
    11.01.2011
    Tablet:
    Lenovo Ideapad A2109A

    Hier gibt es schon seit längerem einen Thread mit dem Titel "Gibt es bei X3/X4 verschiedene Losnummern & welche Firmware ist dort aufgespielt?" (der sich also genau dieser Frage widmet), aber das Feedback dort ist ziemlich mau (wie leider sehr oft üblich).

    MfG
     
  16. Mark_Mahoon, 03.11.2011 #16
    Mark_Mahoon

    Mark_Mahoon Threadstarter Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    1
    Registriert seit:
    03.09.2011
    Okay bei meinem X3 ist Folgendes:

    losnummer: 93727
    Version 2.3.3
    Kernel: 2.6.35.7-tcc
    Build: V6.0.1
     
    hävksitol bedankt sich.
  17. hävksitol, 05.11.2011 #17
    hävksitol

    hävksitol Ehrenmitglied

    Beiträge:
    12,606
    Erhaltene Danke:
    8,874
    Registriert seit:
    11.01.2011
    Tablet:
    Lenovo Ideapad A2109A

    Hallo Mark_Mahoon,

    erstmal danke für Deine Angaben. Weil diese aber teilweise stark von den hier aufgelisteten abweichen, muss ich nochmal explizit nachfragen, damit es keine Missverständnisse gibt, aus denen falsche Schlussfolgerungen bzgl. der kursierenden FW-Versionen gezogen werden, also bitte nicht böse sein:

    1) Deine Angaben hast Du alle unter Menütaste --> Einstellungen --> Geräteinfo abgelesen, nicht wahr?
    2) Die Kernel-Version lautet lediglich "2.6.35.7-tcc", oder gibt es vielleicht noch etwas wie z. B. "cbsmbg@CBServer #268" auf der gleichen oder der folgenden Zeile?
    3) Gleiche Frage für die Build-Nummer: Hast Du dort "V6.0.1" abgelesen, oder hast Du diese Angabe aus den Angaben für das FW-Update übernommen, und im Systeminfo findet sich noch mehr?

    MfG
     

Diese Seite empfehlen