1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Unlösbarer Bug in meiner App

Dieses Thema im Forum "HTC Hero / T-Mobile G2 Touch Forum" wurde erstellt von Beyin, 07.06.2010.

  1. Beyin, 07.06.2010 #1
    Beyin

    Beyin Threadstarter Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    0
    Registriert seit:
    22.11.2009
    Hallo,

    ich habe mir vor kurzem eine App entwickeln lassen (CoboCards heißt sie).
    Handelt sich um einen Karteikartentrainer.

    Die erste Karteikarte ist auf dem Hero immer noch oben verschoben, d.h. ich kann den Text nicht lesen. Bei allen anderen Smartphones (Milestone, G1 etc.) tritt dieser Bug nicht auf.

    Gibt es dafür eine Erklärung? Liegt es am Gerät/Display oder am Code? Irgeneiner eine Meinung/Idee?

    Gruß

    Beyin
     
  2. Mercury0660, 07.06.2010 #2
    Mercury0660

    Mercury0660 Fortgeschrittenes Mitglied

    Beiträge:
    389
    Erhaltene Danke:
    50
    Registriert seit:
    11.12.2009
    Tablet:
    Sony Xperia Tablet Z
    Ich glaube, ohne Einsicht in den Quellcode und ein bisschen Ahnung von der Materie kann das schlecht beantwortet werden.
     
  3. Riffer, 07.06.2010 #3
    Riffer

    Riffer Android-Lexikon

    Beiträge:
    1,261
    Erhaltene Danke:
    220
    Registriert seit:
    06.03.2010
    Phone:
    OnePlus Two
    Tablet:
    Samsung Galaxy NotePRO 12.2
    Wenn es sich um eine Auftragsprogrammierung handelt, würde ich doch als erstes mal den zuständigen Programmierer fragen?
     
  4. Beyin, 07.06.2010 #4
    Beyin

    Beyin Threadstarter Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    0
    Registriert seit:
    22.11.2009
    Hab ich ja. Aber dieses Problem hat er nicht gelöst bekommen. Ist auch kein Beinbruch, weil es nur die 1. Karte ist. Danach tritt das Problem nicht auf. Bei allen anderen Geräten taucht das Problem eben nicht auf. Dachte daher, dass es etwas Hero-spezifisches sein könnte.
     
  5. gado, 07.06.2010 #5
    gado

    gado Ehrenmitglied

    Beiträge:
    3,545
    Erhaltene Danke:
    444
    Registriert seit:
    18.09.2009
    Phone:
    Nexus 6P
    Wearable:
    Pebble Steel
    Die aufgezählten Geräte laufen mit 1.6 und höher. Ist der Bug auf dem Galaxy? Kann er mal einen 1.5 Emu testen?
     
  6. Beyin, 07.06.2010 #6
    Beyin

    Beyin Threadstarter Neuer Benutzer

    Beiträge:
    21
    Erhaltene Danke:
    0
    Registriert seit:
    22.11.2009
    Kenne leider keinen mit Galaxy. Wenn einer von Euch eins besitzt, kann ich ihm gern die .apk zumailen.
     
  7. gado, 07.06.2010 #7
    gado

    gado Ehrenmitglied

    Beiträge:
    3,545
    Erhaltene Danke:
    444
    Registriert seit:
    18.09.2009
    Phone:
    Nexus 6P
    Wearable:
    Pebble Steel
    Du könntest auch einfach ein Custom 2.1 ROM testen. Wenn der Bug da nicht auftritt, dann musst du nur noch 1-3 Wochen warten, bis 2.1 offiziell draußen ist und der Fehler hat sich von selbst erledigt. :)

    Wäre dann aber kein Hero, sondern ein Cupcake Problem.
     
  8. blackboro, 08.06.2010 #8
    blackboro

    blackboro Android-Experte

    Beiträge:
    455
    Erhaltene Danke:
    33
    Registriert seit:
    02.08.2009
    Phone:
    Huawei P9
    Tablet:
    Samsung Galaxy Note 10.1
    Wearable:
    LG G Watch R
    Würde auch sagen, mache es, wie gado geraten hat oder schicke es jemandem hier zu. Falls das ein Cupcake Problem ist, dann soll er einfach das Flag setzen, dass es erst ab 1.6 läuft, dann gibt es kein Gemecker, weil es sich dann erst ab 1.6 installieren lässt.
    Der Simulator ist übrigens immer mir Vorsicht zu genießen, auf den verschiedenen Geräten kann das Verhalten schon mal unterschiedlich sein.
     
  9. Daywalker_1904, 08.06.2010 #9
    Daywalker_1904

    Daywalker_1904 Fortgeschrittenes Mitglied

    Beiträge:
    332
    Erhaltene Danke:
    10
    Registriert seit:
    26.03.2010
    Ich würde es testen ! Hab 2.1 Costum Rom druff ! Hatte noch nie 1.5 ^^
     

Diese Seite empfehlen