1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

update.zip und der EOCD Fehler

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Milestone" wurde erstellt von Spawnilein, 06.10.2010.

  1. Spawnilein, 06.10.2010 #1
    Spawnilein

    Spawnilein Threadstarter Junior Mitglied

    Beiträge:
    36
    Erhaltene Danke:
    4
    Registriert seit:
    06.10.2010
    Hi Community,

    bevor jetzt irgendjemand anfängt das ich doch bitte die How-To's und Anleitungen und sonst was durchlesen soll, das habe ich bereits.
    Sogar mehrfach
    - Lessons Learned
    - How-To 2.1 mit RSDLite
    - How To 2.1 Root für Dummies
    usw. aber ich bekomme es einfach nicht hin das die update.zip ausgeführt wird.

    Ich fang einfach mal von vorne an.

    Modell: Milestone
    Firmware: 2.1-update1
    Build: SHOLS_U2_02.36.0

    aufgespielt über Motorola Software Update.


    Jetzt wollte ich gern ein Nandroid machen weil ich vorhabe meine Notification Bar zu modden.

    Hab mir dann eure Anleitungen durchgelesen und wollte loslegen.
    Per RDSLite habe ich die vulnerable_recovery_only_RAMDLD90_78.sbf geflasht.
    RSDLite meinte am Ende auch "PASS"
    Dann die Update.zip und adbrecovery auf die SD Card ins root-Verzeichnis.
    Nun boote ich in den Recoverymode und will die update.zip ausführen aber ich bekomme immer wieder diesen EOCD fehler.

    Könnt ihr mir sagen was ich falsch mache oder vergesse ich irgendwas ?

    Vielen Dank für die Hilfe. Ich weiß echt nicht mehr weiter.
     
  2. mecss, 06.10.2010 #2
    mecss

    mecss Ehrenmitglied

    Beiträge:
    16,308
    Erhaltene Danke:
    11,089
    Registriert seit:
    14.03.2010
    Phone:
    Samsung Galaxy Note 3
  3. Bandit, 06.10.2010 #3
    Bandit

    Bandit Android-Guru

    Beiträge:
    3,552
    Erhaltene Danke:
    702
    Registriert seit:
    05.02.2010
    Hatter nciht wie man hier lesen kann

    Per RDSLite habe ich die vulnerable_recovery_only_RAMDLD90_78.sbf geflasht.
     
  4. Spawnilein, 06.10.2010 #4
    Spawnilein

    Spawnilein Threadstarter Junior Mitglied

    Beiträge:
    36
    Erhaltene Danke:
    4
    Registriert seit:
    06.10.2010
    Ich hatte es so verstanden das die vulnerable_recovery reicht.

    Werde jetzt mal versuchen die von euch vorgeschlagene Datei zu flashen und dann schau ich weiter :)

    Vielen Dank schonmal.
     
  5. feinmann, 06.10.2010 #5
    feinmann

    feinmann Junior Mitglied

    Beiträge:
    40
    Erhaltene Danke:
    0
    Registriert seit:
    19.02.2010
    Du musst nach dem Flashen der verwundbaren Recovery die Kamerataste drücken, sobald RSD rebooten möchte. Weil beim Reboot die vorherige Recovery wiederhergestellt wird.

    Also nach dem Flashen gleich in die Recovery mittels Kamerataste!!!!

    Hatte das Problem auch mal
     
  6. Spawnilein, 07.10.2010 #6
    Spawnilein

    Spawnilein Threadstarter Junior Mitglied

    Beiträge:
    36
    Erhaltene Danke:
    4
    Registriert seit:
    06.10.2010
    So, ich hab nunmal die SHOLS_U2_01.14.0_recovery_only.sbf.zip geflasht. RSDLite meinte PASS.

    Danach bin ich direkt ins Recoverymenü und bekam mal wieder den EOCD :(

    Übrigens komm ich nicht mit der Kamerataste ins REcovery sondern mit der "x" taste.
    Macht das Softwaretechnisch irgendeinen unterschied ?

    Vielen Dank für eure Hilfe ! :)
     
  7. eybee1970, 07.10.2010 #7
    eybee1970

    eybee1970 Android-Ikone

    Beiträge:
    5,390
    Erhaltene Danke:
    4,990
    Registriert seit:
    19.01.2010
    Phone:
    HTC One M9
    Dein Problem ist, dass Du die 2.36 über OTA aufgespielt hast...da ist von MOTO ein script integriert, das das aufspielen der alten recovery verhindert...

    Du hast jetzt 2 Möglichkeiten:

    1.
    http://www.android-hilfe.de/motorol...-der-shols_u2_02-36-0-2-1-bugfix-release.html
    2.

    http://www.android-hilfe.de/622405-post18.html
     
    Zuletzt bearbeitet: 07.10.2010
    Spawnilein bedankt sich.
  8. Spawnilein, 07.10.2010 #8
    Spawnilein

    Spawnilein Threadstarter Junior Mitglied

    Beiträge:
    36
    Erhaltene Danke:
    4
    Registriert seit:
    06.10.2010
    Oh mein Gott mir fällt es gerade wie Schuppen von den Augen.

    Ich hatte den Stein eigentlich per MSU geupdatet wo es das Problem ja nicht gab aber ich hatte ihn dann mal zur Reparatur eingesendet.
    Die haben zurückgeflasht und das Update hab ich dann per OTA eingespielt.

    Daran hab ich überhaupt nicht mehr gedacht.
    Ich versuch das jetzt mal mit Variante 2 wie von dir beschrieben und hoffe das es klappt.
    Danke schonmal !


    UPDATE:

    DANKE !
    Das hat nun endlich geklappt und ich mach gerade ein nandroid dank dir !!!
     
    Zuletzt bearbeitet: 07.10.2010
  9. TimeTurn, 07.10.2010 #9
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,103
    Erhaltene Danke:
    2,891
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Da Variante 2 von mir stammt: Bitte bitte :smile:
     
    Spawnilein und eybee1970 haben sich bedankt.
  10. Spawnilein, 07.10.2010 #10
    Spawnilein

    Spawnilein Threadstarter Junior Mitglied

    Beiträge:
    36
    Erhaltene Danke:
    4
    Registriert seit:
    06.10.2010
    Dann natürlich auch an dich, VIELEN DANK ! :)
     

Diese Seite empfehlen