1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

USB Brick Problem

Dieses Thema im Forum "Root / Hacking / Modding für HTC Legend" wurde erstellt von lomycess, 25.11.2010.

  1. lomycess, 25.11.2010 #1
    lomycess

    lomycess Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    8
    Registriert seit:
    26.03.2009
    Hi,

    möchte meine Erfahrungen mit dem Rooten des HTC Legend an euch weitergeben, vielleicht kann ich damit dem Einen oder Anderen helfen.

    [FONT=&quot]USB Brick Problem[/FONT]

    [FONT=&quot]Was ist passiert:[/FONT]
    [FONT=&quot]
    Beim Rooten des HTC Legend und dem nachfolgenden Draufspielen eines Roms ("legend_CM6RC2_build66.zip"), ist ein Missgeschick passiert.[/FONT]
    [FONT=&quot]
    Leider bootet das Legend nicht mehr und wird auch nicht mehr erkannt - weder über Windows7 64bit, noch auf einem Windows XP SP3 32bit Rechner als auch nicht über Ubuntu.10.4.

    Das Legend bootet, stürzt ab, bootet nochmals und kommt in den Recovery Zustand (mit dem roten Rufzeichen).

    Jetzt mit Lautstärke up + Powertaste in das Recovery - wo nur reboot system, apply sdcard:update.zip, Wipe data/factory reset und wipe cache partition ausgesucht werden kann..

    Ganz unten steht E:cant open /cache/recovery/comand[/FONT]

    [FONT=&quot]Auf das Legend kann nicht mehr zugegriffen werden, das Gerät wird nicht erkannt, siehe auch Screenshot. (http://www.android-hilfe.de/attachm...281648114t-legend-rooten-nach_rom_install.jpg)[/FONT]

    [FONT=&quot]Du kannst mit dem Gerät nichts mehr machen, ausser ….

    [/FONT]
    [FONT=&quot]Die Lösung:[/FONT]
    [FONT=&quot]
    Bei xda wird von dem Problem des Legend geschrieben, das diese Probleme erklärt und auch löst.(dort genannt USB-Brick)
    [/FONT]
    [FONT=&quot]Folgendes sollte jetzt durchgeführt werden:[/FONT]
    [FONT=&quot]
    1. Installiere adb und fastboot aus dem Android-SDK, falls noch nicht geschehen.[/FONT]
    [FONT=&quot]Über SDK wirklich _alle_ Treiber installieren und dann findet der Rechner so manches.[/FONT]
    [FONT=&quot]
    2. Schalte das Legend in den fastboot-Modus (Ausschalten, beim Einschalten den zurück Button gedrückt halten). Der Rechner sollte das Gerät in diesem Modus erkennen ('fastboot devices' an einer shell).[/FONT]
    [FONT=&quot]
    3. Mach an einer Shell 'fastboot oem boot' und speziell nach diesen Einträgen suchen: board_legend.disable_uart3,
    board_legend.usb_h2w_sw

    Wenn die beiden Werte auf 1 stehen hast du dieses USB Brick Problem.

    Folgendes ist bei Modaco dazu zu finden:[/FONT]
    [FONT=&quot]
    http://android.modaco.com/content/ht...-b0rked-fixed/[/FONT]
    [FONT=&quot]
    Leider setzt das voraus, dass dein Telefon startet. Es sollte aber vom fastboot-Modus aus wieder soweit hinzubiegen sein, dass das Legend wieder startet. [/FONT]

    [FONT=&quot]Wichtig:[/FONT][FONT=&quot] In fastboot auch fastboot oem enableqxdm 0 durchführen, wie es bei der modaco Anleitung steht. (sonst passiert folgendes: er erkennt keine SD Card, immer wird das SD Card-Symbol in der oberen Taskleiste mit einem Fragezeichen angezeigt.)[/FONT]

    [FONT=&quot]Jetzt kann der root Prozess nochmals durchgeführt werden.[/FONT]

    [FONT=&quot]Hier noch die Ausgabe der Shell mit den verschiedenen Befehlen – zum besseren Verständnis:[/FONT]

    [FONT=&quot]C:\SDK\tools>fastboot reboot-bootloader
    rebooting into bootloader... OKAY [ 0.016s]
    finished. total time: 0.017s

    C:\SDK\tools>fastboot oem boot
    < waiting for device >
    ... INFOsetup_tag addr=0x60000100 cmdline add=0x9D
    078D14
    INFOTAG:Ramdisk OK
    INFOTAG:smi ok, size = 0
    INFOTAG:hwid 0x0
    INFOTAG:skuid 0x22F00
    INFOTAG:hero panel = 0x0
    INFOTAG:engineerid = 0x0
    INFOMCP dual-die
    INFOMCP dual-die
    INFOTAG:mono-die = 0x0
    INFODevice CID is not super CID
    INFOCID is HTC__102
    INFOsetting->cid::HTC__102
    INFOserial number: HT0000000000
    INFOcommandline from head: no_console_suspend=1 console=null
    INFOcommand line length =439
    INFOactive commandline: board_legend.disable_uart3=1 board_legen
    INFOd.usb_h2w_sw=1 board_legend.disable_sdcard=1 diag.enabled=1
    INFOboard_legend.debug_uart=0 smisize=0 userdata_sel=0 androidbo
    INFOot.emmc=false androidboot.baseband=7.05.35.26L androidboot.
    INFOcid=HTC__102 androidboot.carrier=HTC-GER androidboot.mid=PB7
    INFO610000 androidboot.keycaps=qwerty androidboot.mode=normal an
    INFOdroidboot.serialno=HT0 HT000000000000 androidboot.bootloader=0.43.
    INFO0001 no_console_suspend=1 console=null
    INFOaARM_Partion[0].name=misc
    INFOaARM_Partion[1].name=recovery
    INFOaARM_Partion[2].name=boot
    INFOaARM_Partion[3].name=system
    INFOaARM_Partion[4].name=cache
    INFOaARM_Partion[5].name=userdata
    INFOpartition number=6
    INFOValid partition num=6
    INFOmpu_nand_acpu_rw 8F2 1000
    FAILED (status read failed (Too many links))
    finished. total time: 0.878s

    C:\SDK\tools>fastboot devices
    HT0 HT000000000000 fastboot[/FONT]


    [FONT=&quot] Liebe Grüße aus Wien[/FONT]

    [FONT=&quot]Markus :smile:
    [/FONT]
     
    Mr.Schnitzel, Carve und farmerjohn haben sich bedankt.
  2. farmerjohn, 25.11.2010 #2
    farmerjohn

    farmerjohn Fortgeschrittenes Mitglied

    Beiträge:
    309
    Erhaltene Danke:
    55
    Registriert seit:
    22.04.2010
    Phone:
    Oneplus 3
    Danke, ich hoffe, ich werde das nie brauchen ;)

    Aber eine Frage, es ist bei diesem Problem nicht mehr möglich, die Update.zip vom Clockworkrecovery zu installieren und dann ein neues Rom zu flashen?
     
  3. lomycess, 25.11.2010 #3
    lomycess

    lomycess Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    8
    Registriert seit:
    26.03.2009
    Hi,
    nachdem das Problem gelöst wurde, ist es möglich.
    LG, Markus
     
  4. Carve, 26.11.2010 #4
    Carve

    Carve Android-Hilfe.de Mitglied

    Beiträge:
    72
    Erhaltene Danke:
    26
    Registriert seit:
    20.10.2010
    Welches Missgeschick ist denn passiert?
     
  5. lomycess, 26.11.2010 #5
    lomycess

    lomycess Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    8
    Registriert seit:
    26.03.2009
    Hi,

    nach dem Rooting Versuch konnte ich nicht mehr auf das Legend zugreifen, das Gerät wurde nicht erkannt, siehe auch Screenshot. (http://www.android-hilfe.de/attachme...om_install.jpg)

    siehe auch unter diesem Thread

    Nix ging mehr, konnte nicht mehr starten,
    nichts draufspielen, es war ein Briefbeschwerer um EUR 429,-. (wenigstens sieht es fein aus :laugh:)

    LG; Markus
     
  6. Carve, 26.11.2010 #6
    Carve

    Carve Android-Hilfe.de Mitglied

    Beiträge:
    72
    Erhaltene Danke:
    26
    Registriert seit:
    20.10.2010
    Na, zumindest hast du während des Flashens nicht versucht dein Akku zu tauschen.. Hat es auch schon gegeben.

    Gutes Post.
     
    lomycess bedankt sich.
  7. rtuner, 16.12.2010 #7
    rtuner

    rtuner Fortgeschrittenes Mitglied

    Beiträge:
    272
    Erhaltene Danke:
    11
    Registriert seit:
    12.04.2010
    Doch, also ich hatte auch nen USB Brick und ich habe immernoch custom roms aufspielen können via Clockwork...!
     

Diese Seite empfehlen