1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Vorsicht bei Nandroid-Backups!

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Milestone" wurde erstellt von mojo, 30.01.2010.

  1. mojo, 30.01.2010 #1
    mojo

    mojo Threadstarter Erfahrener Benutzer

    Beiträge:
    248
    Erhaltene Danke:
    61
    Registriert seit:
    17.01.2010
    Alle die fremde Nandroid-Backups auf ihre Geräte aufspielen möchte ich an dieser Stelle einmal warnen:

    Ihr wisst nicht, wer was an dem Gerät vorher geändert hat,
    oder ob diese Backups 'präpariert' sind.

    Es wäre ein leichtes, ein System so zu ändern,
    dass alle Internetverbindungen über einen eigenen Server laufen und man diese mitlesen kann.
    Davon dann ein Backup, dieses als "Original von meinem Provider" hoch laden und mitlesen was die anderen so im Internet machen.

    Andere Szenarien (Zombie-Androiden ;)) sind auch denkbar.
    Ich möchte hier im Forum niemandem etwas unterstellen.
    Aber es gibt genug Leute die unreflektiert alles auf ihr Gerät packen.
     
    sandimann bedankt sich.
  2. newton, 30.01.2010 #2
    newton

    newton Android-Hilfe.de Mitglied

    Beiträge:
    146
    Erhaltene Danke:
    55
    Registriert seit:
    14.01.2010
    Phone:
    Oneplus 2
    Genau, und Motorola zwingt einen praktisch dazu, irgendwelches "obskures Zeug" aus dem Netz auf das Gerät zu packen, denn selbst machen kann mans ja nicht, dank der Signiererei von allem Sch...
     
  3. sandimann, 30.01.2010 #3
    sandimann

    sandimann Android-Experte

    Beiträge:
    852
    Erhaltene Danke:
    505
    Registriert seit:
    30.12.2009
    Diese Warnung ist vernünftig und ernst zu nehmen. Jeder muss selber wissen, ob er der Quelle vertraut und ein Backup einspielt.
     
  4. Lowbyte, 30.01.2010 #4
    Lowbyte

    Lowbyte Android-Lexikon

    Beiträge:
    989
    Erhaltene Danke:
    480
    Registriert seit:
    20.03.2009
    Na hier unter uns sollten wir doch sicher sein:confused:
     
  5. mojo, 31.01.2010 #5
    mojo

    mojo Threadstarter Erfahrener Benutzer

    Beiträge:
    248
    Erhaltene Danke:
    61
    Registriert seit:
    17.01.2010
    Hier schon, aber in anderen Foren werden auch Nandroid Backups hochgeladen.
     
  6. sandimann, 31.01.2010 #6
    sandimann

    sandimann Android-Experte

    Beiträge:
    852
    Erhaltene Danke:
    505
    Registriert seit:
    30.12.2009
    ich würde nur backups aus poseidons post auf alldroid.org oder eben von hier nutzen ;)
     
  7. Luke, 31.01.2010 #7
    Luke

    Luke Android-Experte

    Beiträge:
    480
    Erhaltene Danke:
    125
    Registriert seit:
    08.03.2009
    Phone:
    LG G4
    Nur mal so ne Frage am Rande... Wie kommt man als Milestonesklave an ein Nandroidbackup? Ich kenne Nandroid noch aus G1-Zeiten aber dazu musste ich das CustomRecovery flashen was ja uns nicht erlabt wird von Motorola... (?)
     
  8. AtzeDePeng, 31.01.2010 #8
    AtzeDePeng

    AtzeDePeng Android-Hilfe.de Mitglied

    Beiträge:
    80
    Erhaltene Danke:
    12
    Registriert seit:
    11.12.2009
    Über ADB im Recovery...

    Siehe Alldroid
     
  9. pha3ton, 31.01.2010 #9
    pha3ton

    pha3ton Erfahrener Benutzer

    Beiträge:
    223
    Erhaltene Danke:
    31
    Registriert seit:
    16.11.2009
    Mir ist aufgefallen (hatte vorher HK 2.0.1) dass man nach aufspielen eines Recovery Images, immer noch nicht das Auto Update deaktivieren kann und Apps wie z.b. Motonav und das Phoneportal nicht mehr 100% löschen kann!
    Kann das jemand bestätigen?
     
  10. mojo, 31.01.2010 #10
    mojo

    mojo Threadstarter Erfahrener Benutzer

    Beiträge:
    248
    Erhaltene Danke:
    61
    Registriert seit:
    17.01.2010
    Reicht es zum AutoUpdate-deaktivieren nicht,
    den Haken bei Einstellungen->Telefoninfo->Automatische Systemaktualisierung wegzunehmen?

    Was genau meinst du mit "nicht mehr 100%" löschen?
    Wenn man die
    /system/app/Motonav.apk
    und die Ordner
    /data/data/com.navngo.igo.javaclient
    /sdcard/Motonav
    löscht, sollte Motonav doch komplett weg sein.
     
  11. pha3ton, 31.01.2010 #11
    pha3ton

    pha3ton Erfahrener Benutzer

    Beiträge:
    223
    Erhaltene Danke:
    31
    Registriert seit:
    16.11.2009
    Also die Option Einstellungen->Telefoninfo->Automatische Systemaktualisierung gibts nicht mehr und mit 100% löschen meine ich, dass ich die app sowie den Rest aus Data/data entfernen kann, das Programm aber unter Anwendungen immer noch angezeigt wird und ich es somit nicht komplett wegbekomme! Kann also auch keine neuere Version von Motonav/iGo) installieren, da die alte Software ja immer noch vom System erkannt wird!
     
  12. Puky70, 31.01.2010 #12
    Puky70

    Puky70 Fortgeschrittenes Mitglied

    Beiträge:
    276
    Erhaltene Danke:
    29
    Registriert seit:
    26.04.2009
    @ pha3ton,

    schreibe doch deswegen mal poseidon (AllDroid) an, evt. wird das Problem noch beim nächsten Update behoben. Kann ja gut möglich sein, dass mittels nandroid Backup nicht alles sauber restored wird.

    Cu
     
  13. pha3ton, 31.01.2010 #13
    pha3ton

    pha3ton Erfahrener Benutzer

    Beiträge:
    223
    Erhaltene Danke:
    31
    Registriert seit:
    16.11.2009
    Das glaube ich nämlich auch! Habe zwar jetzt laut System die 2.0 aber ich glaube dass es ein Mix ist zwischen 2.0 & 2.0.1. Daher auch evtl. die anderen "Fehler"

    Aber dann sollten doch alle User die das so gemacht haben, die Probs haben...
     
  14. Puky70, 31.01.2010 #14
    Puky70

    Puky70 Fortgeschrittenes Mitglied

    Beiträge:
    276
    Erhaltene Danke:
    29
    Registriert seit:
    26.04.2009
    Hi,

    ich habe mal ein PM an poseidon abgesetzt und werde auch mal von HK 2.01 wieder restoren auf O2 2.0 und werde nachsehen, ob ich die gleichen Fehler habe wie Du.

    Cu
     
    pha3ton bedankt sich.
  15. pha3ton, 31.01.2010 #15
    pha3ton

    pha3ton Erfahrener Benutzer

    Beiträge:
    223
    Erhaltene Danke:
    31
    Registriert seit:
    16.11.2009
    Ok,danke! Habe eben auch mal nachgefragt, mal schauen was sich so ergibt :)
     
  16. pontomedon, 31.01.2010 #16
    pontomedon

    pontomedon Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    10
    Registriert seit:
    16.01.2010
    Und hier bin ich schon! allerdings hat hier schon jemand meinen primären nick :D

    Was meinst du mit Recovery Image? wir können keine Recovery Images flashen. Falls du ein nandroid backup restored hast: hast du /data formattiert? 90% der Fehler passieren weil /data nicht formattiert wurde und dann /system und /data nicht zusammenpassen.

    Eine Mischung aus 2.0 und 2.0.1 ist nicht möglich, da nandroid die system partition formattiert bevor das backup eingespielt wird.

    Ich kann btw auch nicht garantieren, dass an den images die ich auf alldroid verlinke nichts gedreht worden ist. sollte sowieso nur eine notmaßnahme sein.
     
  17. pha3ton, 31.01.2010 #17
    pha3ton

    pha3ton Erfahrener Benutzer

    Beiträge:
    223
    Erhaltene Danke:
    31
    Registriert seit:
    16.11.2009
    richtig ,ich hab ein Nandroid Backup aufgespielt!
    Habe die deutschen Backups alle durch und das Problem besteht weiterhin.
    Zuvor habe ich einen Wipe durchgeführt.
     
  18. pontomedon, 31.01.2010 #18
    pontomedon

    pontomedon Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    10
    Registriert seit:
    16.01.2010
    direkt vorm flashen des backups? also im recovery? normaler factory restore von android aus hilft hier nichts, da /data beim booten wieder neu aufgebaut wird.
     
  19. Puky70, 31.01.2010 #19
    Puky70

    Puky70 Fortgeschrittenes Mitglied

    Beiträge:
    276
    Erhaltene Danke:
    29
    Registriert seit:
    26.04.2009
    Also ich kann die o.g. Behauptung bestätigen. Diese Option gibt es nach einem Restore auf FW 2.0 (O2) nicht mehr. Der Rest wird wohl gleich sein.

    Zum Wipe:

    Ich habe einen vor dem Flashen unterm Recovery durchgeführt. Was ich allerdings nicht gemacht habe, ist die Umgebungsvariablen zu setzen:

    PATH=/sbin:/system/sbin:/system/bin:/system/xbin

    Hat das irgendeinen Einfluss???

    Cu
     
    Zuletzt bearbeitet: 31.01.2010
    pha3ton bedankt sich.
  20. pha3ton, 31.01.2010 #20
    pha3ton

    pha3ton Erfahrener Benutzer

    Beiträge:
    223
    Erhaltene Danke:
    31
    Registriert seit:
    16.11.2009
    Direkt vorm flashen! Beide Wipes!!! Cache und den Factory Wipe
     

Diese Seite empfehlen