1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

VPN PPTP geht nicht, oder?

Dieses Thema im Forum "LG Optimus One (P500) Forum" wurde erstellt von databoss, 12.02.2011.

  1. databoss, 12.02.2011 #1
    databoss

    databoss Threadstarter Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    02.02.2011
    Hallo zusammen,

    hat jemand von Euch VPN via PPTP auf dem P500 zum laufen gebracht?

    Mein P500 ist original also nicht gerooted und das möchte ich eigentlich auch nicht so gerne. Android Version 2.2., Kernel 2.6.32.9, Firmware V10a.

    Meine Recherchen haben ergeben das es möglicherweise am Telefon liegen könnte. Das kann ich mir nur schwer vorstellen, scheint aber so zu sein.
    :blink:

    Im AppStore gibt eine App mit Namen VPN mit dem selben unerfreulichen Ergebnis: es geht einfach nicht!

    Am Netzwerk liegt es definitiv nicht, andere Geräre verbinden problemlos.

    Ein Anruf bei der LG Hotline hat bisher auch noch nichts gebracht.

    Freu mich über jeden Bericht, ob es nun geht oder nicht, denn das vermisse ich schmerzlich.

    Danke.

    Gruß Florian
     
  2. norbert, 12.02.2011 #2
    norbert

    norbert Ehrenmitglied

    Beiträge:
    9,394
    Erhaltene Danke:
    1,631
    Registriert seit:
    10.02.2009
    Phone:
    LG G3
    Tablet:
    Medion Lifetab P9516
    was genau möchtest du damit eigentlich erreichen?
     
  3. databoss, 13.02.2011 #3
    databoss

    databoss Threadstarter Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    02.02.2011
    Ich möchte eine VPN Verbindung zu meinem lokalen Netzwerk von unterwegs, primär um eine Verbindung zu meinem Exchange Server zu bekommen.
     
  4. norbert, 13.02.2011 #4
    norbert

    norbert Ehrenmitglied

    Beiträge:
    9,394
    Erhaltene Danke:
    1,631
    Registriert seit:
    10.02.2009
    Phone:
    LG G3
    Tablet:
    Medion Lifetab P9516
    Ich hab es jetzt mal nach Android Allgemein verschoben, weil ich nicht glaube daß es P500-spezifisch ist. Hier sehe ich die Chance daß dir einer helfen kann auf jeden Fall größer.
    Ob's in Allgemein richtig ist, bin ich mir nicht sicher, aber notfalls kann es dann noch mal verschoben werden.

    An sich sollte es gehen, aber ich hab von VPN recht wenig Ahnung :blink:
     
  5. email.filtering, 16.02.2011 #5
    email.filtering

    email.filtering Gast

    Sag mal, die von der Suchfunktion ausgespuckten Threads zum Thema VPN (+PPTP) hast Du tatsächlich schon alle durch!?
     
  6. corwin42, 18.02.2011 #6
    corwin42

    corwin42 Android-Experte

    Beiträge:
    602
    Erhaltene Danke:
    220
    Registriert seit:
    31.05.2010
    Die Probleme mit VPN PPTP sind doch sehr devicespezifisch, deshalb war der Thread im Optimus One Forum schon recht gut aufgehoben.

    Zum eigentlichen Thema: Ich schaffe es auch nicht, eine VPN-Verbindung zu unserer Firma aufzubauen und darüber dann mit dem Exchange Server zu kommunizieren. Ich muss das Problem aber nochmal genauer analysieren.

    Bei einem Kollegen mit dem HTC Desire funktioniert es. Ein anderer mit einem Samsung Galaxy S geht es auch nicht. Da scheint das Problem aber eher der Exchange sync zu sein. Die VPN-Verbindung baut er angeblich auf.

    Beim meinem P500 kann ich im LogCat zwar sehen, dass ein Tunnel aufgebaut wird, allerdings hat der pppd dann wohl ein Problem und meldet "Adress family not supported by protocol"

    Weitere Analysen habe ich noch nicht gemacht. In anderen Foren habe ich gesehen, dass auf manchen Geräten der pppd nicht korrekt übersetzt ist. Ich weiss nicht, ob das bei mir auch das Problem ist.
     
  7. fboneol, 18.02.2011 #7
    fboneol

    fboneol Fortgeschrittenes Mitglied

    Beiträge:
    265
    Erhaltene Danke:
    79
    Registriert seit:
    18.06.2010
    Ich kann bestätigen, dass PPTP mit dem HTC Desire, Galaxy S, Milestone 2 und Nexus S gut funktioniert.
    Warum sollte es dann mit dem P500 nicht funktionieren ?
    Ohne die tatsächlichen Gegebenheiten zu kennen bzw. ohne Logdateien des VPN Gateways bzw Ping-/Routingtests, wird man wohl leider keine genaue Aussage treffen können.
     
  8. norbert, 18.02.2011 #8
    norbert

    norbert Ehrenmitglied

    Beiträge:
    9,394
    Erhaltene Danke:
    1,631
    Registriert seit:
    10.02.2009
    Phone:
    LG G3
    Tablet:
    Medion Lifetab P9516
    @corwin:
    aus dem Ursprungspost war nicht zu erkennen ob es sich hier tatsächlich um ein Geräteabhängiges Problem handelt. Wenn es sich aber so entwickelt, einfach Beitrag melden und um rückverschiebung ins P500 bitten (ich kanns nicht von hier aus).

    Zum VPN kann ich jetzt wenig beitragen, vor allem unter Linux kenn ich mich damit nicht aus. Im Zweifelsfall vielleicht mal mit anderen Geräten die funktionieren vergleichen, wo die Unterschiede sein könnten - angefangen vom Provider über Einstellungen bis zu Android-Version :blink:
    Irgendwo hatten wir auch einen Thread, da wollte einer über Wlan und GSM gleichzeitig zwei unterschiedliche Netzwerke fahren aus ähnlichen Gründen, vielleicht findest dort noch die eine oder andere Information?
     
  9. corwin42, 18.02.2011 #9
    corwin42

    corwin42 Android-Experte

    Beiträge:
    602
    Erhaltene Danke:
    220
    Registriert seit:
    31.05.2010
    Ich habe nochmal ein wenig gesucht und bin auf ein paar Threads gestoßen, die das Problem genauer beschreiben.

    Im Logcat findet sich folgendes:

    Code:
    D/VpnService(26589):        VPN UP: down
    I/SProxy_mtpd(26589): Start VPN daemon: mtpd
    D/SProxy_mtpd(26589): mtpd is running after 0 msec
    D/SProxy_mtpd(26589): service not yet listen()ing; try again
    D/mtpd    (26960): Waiting for control socket
    D/mtpd    (26960): Received 20 arguments
    I/mtpd    (26960): Using protocol pptp
    I/mtpd    (26960): Connecting to xxx.xxx.xxx.xxx port 1723
    I/SProxy_mtpd(26589): got data from control socket: 20
    I/mtpd    (26960): Connection established (socket = 12)
    D/mtpd    (26960): Sending SCCRQ
    D/mtpd    (26960): Received SCCRP -> Sending OCRQ (local = 50624)
    I/mtpd    (26960): Tunnel established
    D/mtpd    (26960): Received OCRQ (remote = 0)
    I/mtpd    (26960): Session established
    I/mtpd    (26960): Creating PPPoX socket
    F/mtpd    (26960): Socket() Address family not supported by protocol
    
    Also der Tunnel wird aufgebaut, beim Socket erzeugen geht aber irgendwas schief.

    Der entsprechende Source ist hier in pptp.c, Zeile 238.

    Warum es fehlschlägt ist mir nicht so ganz klar, vermutlich ist irgendein Verschlüsselungsprotokoll nicht mit reincompiliert oder ähnliches. Evtl. ist das nur ein Konfigurationsproblem des Kernels.

    Ich habe bei den XDA-Developern mal einen Thread damit eröffnet. Mal sehen, ob da was bei rauskommt.
     
  10. databoss, 07.03.2011 #10
    databoss

    databoss Threadstarter Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    02.02.2011
    Danke für die zahlreichen Antworten und Lösungsansätze.

    Hat schon jemand mehr erfahren?

    Echt frustrierend ohne unterwegs E-Mails auf die Dauer. Ein bischen wie früher... :biggrin:
     
  11. corwin42, 07.03.2011 #11
    corwin42

    corwin42 Android-Experte

    Beiträge:
    602
    Erhaltene Danke:
    220
    Registriert seit:
    31.05.2010
    Zur Info: In einigen Ländern ist ja schon Version 2.2.1 für das Optimus One verfügbar. Mit dieser Version funktioniert PPTP angeblich.
     
  12. frank_m, 07.03.2011 #12
    frank_m

    frank_m Ehrenmitglied

    Beiträge:
    20,742
    Erhaltene Danke:
    8,197
    Registriert seit:
    21.09.2010
    Phone:
    Samsung Galaxy S5 Duos (G900FD)
    Tablet:
    Samsung Galaxy Tab S 8.4
    Hallo,

    es kommt auf die Gegenstelle an. Besonders an Cisco VPN Servern kommt es zu Problemen mit den Android Geräten. Das ist herstellerübergreifend so. An anderen Gegenstellen, z.B. einem Linux PPTP Server, kommt es dagegen praktisch nie zu Problemen. Es gibt auch direkt Bug Reports dazu im Android Ticketsystem.
     
  13. databoss, 13.03.2011 #13
    databoss

    databoss Threadstarter Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    02.02.2011
    Die Gegenstelle ist ein Windows 2008 R2.

    Wann kommt denn das Update in Deutschland?

    Ich schlage vor den Thread wieder zu LG P500 Optimus One zu verschieben, da das Problem devicespezifisch ist.
     
  14. email.filtering, 13.03.2011 #14
    email.filtering

    email.filtering Gast

    Besorg Dir das Update doch ganz einfach von LGs Servern und flash es off-line! ;)

    Aber dazu sollte die P500-Community genaueres Wissen ...
     
  15. frank_m, 13.03.2011 #15
    frank_m

    frank_m Ehrenmitglied

    Beiträge:
    20,742
    Erhaltene Danke:
    8,197
    Registriert seit:
    21.09.2010
    Phone:
    Samsung Galaxy S5 Duos (G900FD)
    Tablet:
    Samsung Galaxy Tab S 8.4
    Ich wiederhole, dass dieses Problem keinesfalls device-spezifisch ist. Das PPTP Framework kommt von Android, nicht vom Hersteller.
     
  16. email.filtering, 13.03.2011 #16
    email.filtering

    email.filtering Gast

    Komm frank_m, lassen wir's! Die wollen nicht auf uns olle "Experten" und "Gurus" hören ...
     
  17. stubler, 02.04.2011 #17
    stubler

    stubler Neuer Benutzer

    Beiträge:
    1
    Erhaltene Danke:
    0
    Registriert seit:
    05.12.2010
    Also bei mir war es so. Testweise PPTP Verbindung zu einem Rechnern mit Windows XP und der Firmware V10a ging nicht, obwohl ich mit dem Notebook sehr wohl zu dem gelichen Rechner verbinden konnte.

    Nach dem Firmware Update auf V10e habe ich es erneut versucht, ging anfangs wieder nicht. Als ich aber bei Verschlüsselung aktivieren das Häkchen weggenommen habe, ging die Verbindung auf einmal einwandfrei. Ob es nun am der deaktivierten Verschlüsselung lag oder am Firmwareupdate kann ich nicht mehr feststellen.

    Was ich leider noch nicht geschafft habe ist eine VPN IPsec Verbindung zwischen dem P500 und einem Netgear FVS318V3 Router, obwohl ich irgendwo gelesen habe, das dies funktionieren soll. Falls das jemand geschafft hat, bitte die Einstellungen bekanntgeben.

    Mfg

    Hannes
     

Diese Seite empfehlen