1. Möchtest Du unser Team im Android OS-Bereich unterstützen? Details dazu findest du hier!
  2. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

VPNC-Widget

Dieses Thema im Forum "Kommunikation" wurde erstellt von flori2222, 09.03.2011.

  1. flori2222, 09.03.2011 #1
    flori2222

    flori2222 Threadstarter Neuer Benutzer

    Beiträge:
    15
    Erhaltene Danke:
    1
    Registriert seit:
    06.01.2011
    Hallo,

    ich nutze das VPNC-Widget um mich mit dem Firmenrechner zu verbinden. Funktioniert auch ganz prima.
    Einziges Problem, wenn ich die VPN-Verbindung wieder trenne und dann Wlan deaktiviere und wieder aktiviere(oder wenn sich das Gerät neu am Wlan-Router anmeldet) bekomme ich keine IP.
    Ich muss dann neu booten.

    In der Beschreibung von VPNC-Widget steht dass beim Kernel

    CONFIG_IP_ADVANCED_ROUTER=y

    gesetzt sein muss. Ist bei mir scheinbar nicht der Fall. Wie kann ich das einstellen? Vielleicht behebt das das Problem oben.

    Danke
     
  2. Zonnex, 09.03.2011 #2
    Zonnex

    Zonnex Fortgeschrittenes Mitglied

    Beiträge:
    431
    Erhaltene Danke:
    49
    Registriert seit:
    12.09.2009
    bei solchen Problemen google einfach die Einstellung für Linux allgemein, dann findet man u.a.: Linux Kernel Driver Database: CONFIG_IP_ADVANCED_ROUTER: IP: advanced router

    Nun brauchst du im Grunde nur noch einen Terminal Emulator (kannst gerne meinen nehmen ;) ) und musst folgende Zeilen eintippe:
    su
    mount -o remount, rw /proc
    echo "1" > /proc/sys/net/ipv4/ip_forward

    MfG

    Edit: zum überprüfen ob nun eine 1 statt einer 0 in der Datei steht:
    cat /proc/sys/net/ipv4/ip_forward
     
    Zuletzt von einem Moderator bearbeitet: 09.03.2011
  3. leno, 09.03.2011 #3
    leno

    leno Android-Hilfe.de Mitglied

    Beiträge:
    133
    Erhaltene Danke:
    3
    Registriert seit:
    03.08.2010
    hab mal ne allgemeine Frage zu VPN. Möchte mich gerne mit dem WLAN in der Uni verbinden und habe dafür auf dem Laptop den Cisco Client. Bis vor kurzem gabs da noch Probleme mit Android. Ist es jetzt irgendwie möglich eine Verbindung herzustellen?

    danke
     
  4. flori2222, 09.03.2011 #4
    flori2222

    flori2222 Threadstarter Neuer Benutzer

    Beiträge:
    15
    Erhaltene Danke:
    1
    Registriert seit:
    06.01.2011
    Hallo Zonnex,

    danke für die schnelle Antwort. Funktioniert leider trotz der 1 in der Datei nicht. Außerdem sind die Einstellung nach einem reboot wieder weg. Dann steht wieder 0 in der Datei.

    Ich bekomme folgende Fehlermeldung wenn ich bei VPNC Widget auf Check Prerequisites gehe:

    Error/Warning:kernel has advanced Routing disabled - cannot track dhcp ip changes during vpnc session

    Das Logfile zeigt folgendes(Persönliche Daten = "*******"):

    <?xml version='1.0' encoding='utf-8' standalone='yes' ?>
    <map>
    <string name="XAuthUsername">*********</string>
    <int name="SuccessfulConnects" value="83" />
    <string name="IPSec ID">********</string>
    <string name="VpncSessionLog">Enter IPSec secret for **********:
    Enter password for *************:
    pre-init phase...
    connect phase...
    vpnc-script ran to completion
    vpnc[5579]: select: Interrupted system call
    vpnc[5579]: terminated by signal: 15
    disconnect phase...
    /data/data/com.gmail.mjm4456.vpncwidget/files/vpnc-script: ./vpncbox: not found
    /data/data/com.gmail.mjm4456.vpncwidget/files/vpnc-script: ./vpncbox: not found
    /data/data/com.gmail.mjm4456.vpncwidget/files/vpnc-script: ./vpncbox: not found
    /data/data/com.gmail.mjm4456.vpncwidget/files/vpnc-script: ./vpncbox: not found
    /data/data/com.gmail.mjm4456.vpncwidget/files/vpnc-script: ./vpncbox: not found
    /data/data/com.gmail.mjm4456.vpncwidget/files/vpnc-script: ./vpncbox: not found
    /data/data/com.gmail.mjm4456.vpncwidget/files/vpnc-script: ./vpncbox: not found
    /data/data/com.gmail.mjm4456.vpncwidget/files/vpnc-script: ./vpncbox: not found
    /data/data/com.gmail.mjm4456.vpncwidget/files/vpnc-script: ./vpncbox: not found
    /data/data/com.gmail.mjm4456.vpncwidget/files/vpnc-script: ./vpncbox: not found
    /data/data/com.gmail.mjm4456.vpncwidget/files/vpnc-script: ./vpncbox: not found
    /data/data/com.gmail.mjm4456.vpncwidget/files/vpnc-script: ./vpncbox: not found
    VPNC started in foreground...
    disconnect phase...
    ip: RTNETLINK answers: Operation not supported on transport endpoint
    ip: dump terminated
    ip: can't find device ''
    </string>
    <string name="IPSec secret">*********</string>
    <string name="IPSecSecret">***********</string>
    <string name="IPSec gateway">********</string>
    <string name="IPSecId">********</string>
    <string name="XAuthPassword">********</string>
    <string name="IPSecGateway">********</string>
    <string name="OptionalVpncFlags">--enable-1des --dpd-idle 0</string>
    </map>

    Kannst Du mir bitte noch mal weiterhelfen. Danke!

    Der geniale Programierer von VPN Widget heißt Matthias Meier. Leider habe ich noch keine Möglichkeit gefunden ihn zu kontaktieren.

    I9000/ Doc Rom
     
    Zuletzt bearbeitet: 09.03.2011
  5. flori2222, 10.03.2011 #5
    flori2222

    flori2222 Threadstarter Neuer Benutzer

    Beiträge:
    15
    Erhaltene Danke:
    1
    Registriert seit:
    06.01.2011
    Kann mir keiner weiterhelfen. Gibt es einen Tipp, wo ich hier Hilfe bekommen könnte. Danke!
     
  6. Zonnex, 10.03.2011 #6
    Zonnex

    Zonnex Fortgeschrittenes Mitglied

    Beiträge:
    431
    Erhaltene Danke:
    49
    Registriert seit:
    12.09.2009
    achso hoppala vergessen.. ähm..
    1.) Entwickler Kontaktieren
    - im Market gibt es de nPunkt E-Mail an den Entwickler schreiben ;)

    2.)
    - im Grunde hab ich keine Idee warum es nicht geht, jedoch warum die Einstellungen wieder weg sind
    - proc scheint nen temporärer Ordner zu sein, sprich wird bei jedem Systemstart neu erstellt...
    Solltest nochmal danach googln im Moment weiß ich auch nich weiter...

    MfG
     
  7. flori2222, 13.03.2011 #7
    flori2222

    flori2222 Threadstarter Neuer Benutzer

    Beiträge:
    15
    Erhaltene Danke:
    1
    Registriert seit:
    06.01.2011
    Im Market gibt es leider nur den Punkt Homepage des Entwicklers aufrufen, leider keine Email Adresse.

    Falls jemand Matthias Meier kennt bzw. den Kontakt herstellen kann. Bitte Info. Danke!
     
  8. Zonnex, 14.03.2011 #8
    Zonnex

    Zonnex Fortgeschrittenes Mitglied

    Beiträge:
    431
    Erhaltene Danke:
    49
    Registriert seit:
    12.09.2009
    Also über Website des Entwicklers steht bei mir E-Mail schreiben.. schick dir ne PM mit der mail
     
  9. starbright, 31.10.2011 #9
    starbright

    starbright Android-Experte

    Beiträge:
    629
    Erhaltene Danke:
    68
    Registriert seit:
    14.07.2011
    Ich hab das bei mir prima ans Laufen bekommen - in Zusammenspiel mit der Fritzbox. Leider bricht die Verbindung (über 3G im Moment) nach wenigen Minuten zusammen. Das Handy vibriert dann ganz kurz, kaum merklich, und signalisiert das.
    Ich geh davon aus, dass die 3G Verbindung steht, jedenfalls bin ich nicht in Bewegung und hab hier 3 von 5 Balken
    Zumindest ist kein direkter Zusammenhang zum Standby zu erkennen, da es mal kurz, mal nach ein paar Minuten passiert.
    Das Log hab ich aktiviert und sehe als letzte Nachrichten immer die Keep-Alive Telegramme - keine Fehlermeldung...
    Auf der Fritzbox sehe ich das im Log:
    VPN Verbindung zu xxx wurde getrennt. Ursache: 3 IKE sever
    Was kann ich tun?

    Gruß
     
    Zuletzt bearbeitet: 31.10.2011

Diese Seite empfehlen