1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

W-Lan Bug beheben - tiwlan.ini, keine Berechtigung

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Milestone 2" wurde erstellt von vladi5, 07.12.2010.

  1. vladi5, 07.12.2010 #1
    vladi5

    vladi5 Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    07.12.2010
    Hallo Leute,
    habe mich im Internet viel mit dem rooten des MS2 auseinandergesetzt und mich, wie so viele dafür entschieden :smile:

    Dennoch scheine ich für gewisse Systemeinstellung zu doof zu sein. Ich leide ebenfalls unter dem Wlan-Bug, den das MS2 so mit sich bringt und wollte diesen durch eine Änderung in der tiwlan.ini beheben, wobei mir das einfach nicht gelingen will. Ich bekomme immer die Meldung, dass ich keine Änderung an der Datei vornehmen kann.
    Woran könnte das liegen???

    Habe mit z4root gerootet und benutzte einen übersichtlichen Explorer. Mehr hab ich da auch nicht installiert. Ich habe auch das superuser-app drauf, weswegen ich da mal davon ausgehe, dass der root funktioniert hat.

    Bin dankbar für jede Antwort ^^
     
  2. sceada, 08.12.2010 #2
    sceada

    sceada Erfahrener Benutzer

    Beiträge:
    233
    Erhaltene Danke:
    76
    Registriert seit:
    17.07.2009
    Wenn die Datei im system Ordner ist (ich hab jetzt nicht nachgeschaut) musst du diesen Ordner erst beschreibbar machen bevor du etwas ändern kannst ;)
    z.B. der RootExplorer kann das (oben mit dem Button "Mount r/w" - dann ändern und wieder als "r/o" mounten).
    Standardmäßig sind solche Ordner bei Android schreibgeschützt, mit diesen Befehlen (geht auch über adb, wenn auch umständlicher m.M.n.) wechselst du zwischen "read-only" und "read-write".

    mfg, Christian
     
    vladi5 bedankt sich.
  3. vladi5, 08.12.2010 #3
    vladi5

    vladi5 Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    07.12.2010
    Danke für die schnelle Antwort!

    Hab die die Umstellung auf Mount r/w gefunden und betätigt, wobei ich immernoch nicht die Datei verändern kann.
    Ich habe höchstens die Möglichkeit, die Datei als Textdokument zu öffnen und Preferenzen zu ändern.
    Wie kann ich jetzt was darin verändern???

    Falls ich nichts machen kann, bedeutet das, dass das MS2 doch nicht gerootet ist?
    Habs auch nach der Anleitung hier im Board gemacht...selbes Ergebnis.
    Wie kann ich sehen, ob der root funktioniert hat?



    Hab jetzt Zugrif auf die Dateien...lag am Explorer. Trotz der Änderung habe ich immernoch keine Verbindung zum Internet.
     
    Zuletzt bearbeitet: 08.12.2010
  4. 3-S-E, 08.12.2010 #4
    3-S-E

    3-S-E Android-Lexikon

    Beiträge:
    1,276
    Erhaltene Danke:
    342
    Registriert seit:
    21.04.2010
    Mit dem RootExplorer einfach mal einen laaaaaangen Klick auf die Datei machen und im Kontextmenü weiter nach unten scrollen... da steht dann TextEditor! Mit dem kannste die Datei ändern!!!
     
    vladi5 bedankt sich.
  5. vladi5, 09.12.2010 #5
    vladi5

    vladi5 Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    07.12.2010
    Hab jetzt zwar kein Wlan Problem mehr, aber für alle die es trotzdem noch haben:

    Habe mich nebenbei auch an Motorola wegen dem Probelm gewendet, die mir heute folgendes geschrieben haben:
    "Das Milestone kann oft keine stabile Verbindung zu WLAN Routern aufbauen, die den 802.11n Standard benutzen, wenn die WMM Funktion aktiviert ist.
    Wird diese deaktiviert, funktioniert die Verbindung problemlos und auch der Download im Market klappt dann."

    Weiss jemand, was die WMM Funktion ist?
     
  6. Kulterer, 09.12.2010 #6
    Kulterer

    Kulterer Fortgeschrittenes Mitglied

    Beiträge:
    358
    Erhaltene Danke:
    73
    Registriert seit:
    22.11.2010
    Phone:
    LG G4
    Tablet:
    LG G Pad 8.3
    Cool! Endlich mal ein Hinweis seitens Motorola!
    Für die Fritzbox gilt:
    Allgemein gilt: http://de.wikipedia.org/wiki/WMM

    Werde ich gleich heute Abend ausprobieren.

    (ja ich weiß, googlen kann jeder, aber erspart doch ein paar Klicks, wenn es hier steht.)
     
    Zuletzt bearbeitet: 09.12.2010
  7. 3-S-E, 09.12.2010 #7
    3-S-E

    3-S-E Android-Lexikon

    Beiträge:
    1,276
    Erhaltene Danke:
    342
    Registriert seit:
    21.04.2010
    Ist das jetzt eine Option beim MS2, oder bezieht sich das nur auf den AccessPoint? Weil wenn das letztere zutrifft bringt mir das an der Uni nichts: Da kann ich ja nicht mal eben den AP umkonfigurieren...
     
  8. Kulterer, 09.12.2010 #8
    Kulterer

    Kulterer Fortgeschrittenes Mitglied

    Beiträge:
    358
    Erhaltene Danke:
    73
    Registriert seit:
    22.11.2010
    Phone:
    LG G4
    Tablet:
    LG G Pad 8.3
    Ja, denke ich. Denn an der Uni habe ich keine Abbrüche, nur wenn ich zu Hause bin.
     
  9. 3-S-E, 09.12.2010 #9
    3-S-E

    3-S-E Android-Lexikon

    Beiträge:
    1,276
    Erhaltene Danke:
    342
    Registriert seit:
    21.04.2010
    Bei mir ist genau umgekehrt! -.-

    Was ich allerdings komisch finde: Ich habe bei den WLan-Standby-Richtlinien auf "niemals" umgestellt. Das sollte doch eigentlich festlegen, dass auch bei ausgeschaltetem Display das WLan nicht aus geht. Pustekuchen... 2 Minuten nach Display-Off ist WLan weg.
     
    Zuletzt bearbeitet: 09.12.2010
  10. Kulterer, 12.12.2010 #10
    Kulterer

    Kulterer Fortgeschrittenes Mitglied

    Beiträge:
    358
    Erhaltene Danke:
    73
    Registriert seit:
    22.11.2010
    Phone:
    LG G4
    Tablet:
    LG G Pad 8.3
    Habe WMM nun seit ein paar Tagen an meinem Router abgesschaltet: :-( Keine Änderung.
     

Diese Seite empfehlen