1. MrIch89, 01.02.2012 #1
    MrIch89

    MrIch89 Threadstarter Neuer Benutzer

    Moin, ich habe mir ein Webview in meien App gebastelt. Zudem habe ich 2 Buttons denen jeweils eine URL hinterlegt ist. Also wenn ich auf einen Button klicke, dann öffnet sich die URL auch.

    Aber leider öffnet sich die URL nicht in meinem Webview sondern es wird eine neue Seite geöffnet.


    Code:
    webview = (WebView) findViewById(R.id.webView1);
            webview.getSettings().setJavaScriptEnabled(true);
    
              
            
            
            
        }
        
        public void myClick(View view)
        {
            switch (view.getId()) {
            case R.id.button1:
                
                //webview.loadUrl("http://www.audi.de");


    und so weiter.

    Danke für eure Hilfe schon jetzt einmal.
     
  2. Twissi, 01.02.2012 #2
    Twissi

    Twissi Android-Hilfe.de Mitglied

  3. MrIch89, 02.02.2012 #3
    MrIch89

    MrIch89 Threadstarter Neuer Benutzer

    Danke für den Hinweis, aber ich habe das nach der Seite sozusagen angelegt mein Webview.
     
  4. MrIch89, 02.02.2012 #4
    MrIch89

    MrIch89 Threadstarter Neuer Benutzer

    Okay ich weiß was ich falsch gemacht habe.

    Hat sich erledigt.
     
  5. androidler1, 02.02.2012 #5
    androidler1

    androidler1 Android-Experte

    Wäre vielleicht interessant zu wissen wo der Fehler war ;)
     
    strider und DieGoldeneMitte haben sich bedankt.
  6. MrIch89, 03.02.2012 #6
    MrIch89

    MrIch89 Threadstarter Neuer Benutzer

    Ich hab überlesen das ich noch einen WebViewClient erstellen muss

    Code:
    webview = (WebView) findViewById(R.id.webView1);
        webview.setWebViewClient(new WebViewClient());
    
    und danach die URL erst aufrufen.
     
    androidler1 bedankt sich.