1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Widgets verschwinden einfach so

Dieses Thema im Forum "Motorola Atrix Forum" wurde erstellt von frankwth, 17.09.2011.

  1. frankwth, 17.09.2011 #1
    frankwth

    frankwth Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    97
    Erhaltene Danke:
    16
    Registriert seit:
    26.02.2010
    Jetzt habe ich bereits zum x-ten mal die Motorola (und alle anderen) Widgets einfach so verloren. Nach einem Reboot waren die Homescreens alle leer. Das passierte diesmal mit dem CherryBlur ROM 1.4 nach 5 oder 6 Neustarts. Vorher passierte dies mit Orange FR, Homebase, Alien, sowie mit wechselnden Stock- und Custom-Kernels. Ich habe eine Adata 16 GB Class 10 Speicherkarte, die aber auch nicht Schuld sein kann weil ich die Problem auch dann hatte wenn die Karte gar nicht im Handy war.

    Vor jeder ROM-Installation wipe/formatiere ich alle Caches und alle ROMs liefen eigentlich einwandfrei und flott. Mit den Custom-ROMs kommen ja meistens alternative Launcher, die ich bei meinen Versuchen aber nicht benutze. Ich weiss auch, dass Blur-Widgets nur mit dem Orginal Motorola Home-Launcher problemlos laufen. Bei CherryBlur ROM hatte ich den mitgelieferten Custom Launcher sogar via Titanium eingefroren. Nach einigen Neustarts passierte es dennoch wieder!

    Es gibt sicherlich kaum Widgets, die ich nicht schon ausprobiert habe aber dennoch finde ich Motoblur praktisch, gut aussehend und würde sie gerne beim Handy meiner Frau benutzen. Schon alleine um nicht immer alles wieder zurechtfummeln zu müssen.

    Bei XDA und sonst wo habe ich bisher immer nur Leute mit denselben Problemen gefunden, eine wirkliche Lösung aber nicht. Es läuft immer wieder darauf hinaus, dass die Widgets nur mit dem Orginal Launcher funktionieren. Da ich dies tue weiss ich nicht mehr weiter und bin für jeden Hinweis dankbar.

    Ach ja, mein Atrix ist aus UK, unlocked, rooted, mit Custom ROMs (siehe Text) und Faux Kernel 0.19 (hatte aber auch schon andere drauf).
     
  2. JonnyBlue, 18.09.2011 #2
    JonnyBlue

    JonnyBlue Android-Hilfe.de Mitglied

    Beiträge:
    132
    Erhaltene Danke:
    24
    Registriert seit:
    06.07.2011
    Phone:
    Motorola Atrix
    Wenn du hier liest, erfährst du vielleicht etwas.
    Ich hatte dasselbe Problem. Auf Alien#4 mit Faux 0.1.9 wurden die Widgets nicht mehr geladen und ja nach Luncher stand dann dort "Probleme beim Laden des Widgets" (beim goLauncherEx) oder sieh waren einfach verschwunden (Stock-Launcher).
    Bei mir lag es daran, dass beliebige Apps in den Medienbereich ausgelagert wurden. Hatte ich alle Apps auf dem Handy, also kein App2SD, gab es keine Probleme. War nur eine App auf der SD, verschwanden die Widgets nach einem Neustart.
    Probier mal aus alle Apps (einfach alle) aufs Telefon zu verschieben, richte deine Widgets wieder ein und starte neu.

    Ich bin auf CM7 ausgewichen, da gibt es das Problem nicht.
     
  3. frankwth, 18.09.2011 #3
    frankwth

    frankwth Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    97
    Erhaltene Danke:
    16
    Registriert seit:
    26.02.2010
    Guter Hinweis, danke. Meine Probleme treten genau so wie bei Dir auf: GoLauncher = Fehlermeldung oder Stock-Launcher = alle Widgets weg.

    Ich benutze aber keine Apps2Sd und Widgets duerfen auch nicht auf SD ausgelagert werden.

    Mittlerweile hat aber ein Beitrag auf xda vielleicht etwas gebracht. Jemand hat dort WebtopMod v1 als schuldigen im Verdacht weil das ein Problem mit dem Kernel verursachen soll. Da ich genau dieses wg. einiger Schmankerl im Einsatz hatte, habe ich jetzt mal wieder die Motorola Stock-Version geflasht (CherryBlur ROM aber draufgelassen). Nach einigen Reboots, die nach dem Flashen weiterer Mods erforderlich waren sind meine Widgets immer noch da :love:

    Da CherryBlur auch auf Orange FR 2.3.4 basiert, sollte Webtop ja weiterhin funktionieren. Sobald ich meine gesamten Anwendungen wieder hingefummelt habe, und es auch dann noch keine Probleme gibt, ist das Problem wohl festgemacht.

    Leider kann ich aber nur mit einem gemoddeten Webtop auf einer Terminal Konsole die Tastenbelegung auf mein englisches Motorola BT Keyboard anpassen.

    Jedenfalls haben wir schonmal 2 potentielle Fallstricke fuer die Wigetproblematik festgemacht.

    UPDATE: Hatte schon gedacht mein Atrix waere jetzt unkaputtbar! Habe dann den Faux-Kernel OC1.3 installiert und mit Setcpu ein wenig untertakted und die Voltages etwas reduziert. Alles funktionierte prima. Danach wollte ich nur noch die BlurCamera.apk in /system/app gegen eine andere austauschen. Nach dem reboot waren wieder alle Widgets weg (mit Motorolas BlurHome.apk). Vermute also mal dass es durch Kernelprobleme ausgeloest wird. Ich kann nicht glauben, dass eine Kamera-app sowas fertig bringt. Ich gehe erstmal auf den Stock Kernel zurueck.
     
    Zuletzt bearbeitet: 18.09.2011
  4. JonnyBlue, 18.09.2011 #4
    JonnyBlue

    JonnyBlue Android-Hilfe.de Mitglied

    Beiträge:
    132
    Erhaltene Danke:
    24
    Registriert seit:
    06.07.2011
    Phone:
    Motorola Atrix
    Bei dem Kernel kann natürlich auch was dransein. Bei mir trat der Fehler auch erstmals nach der Istallation von Faux 0.1.9 auf.
     
  5. frankwth, 18.09.2011 #5
    frankwth

    frankwth Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    97
    Erhaltene Danke:
    16
    Registriert seit:
    26.02.2010
    Ja, ich habe jetzt wieder einen Stock-Kernel drauf und schon alles moegliche versucht um den Fehler zu provozieren. Bis jetzt Fehlanzeige.

    Ich werde dann Morgen mal verschiedene Webtop Varianten testen. Ein Ubuntu oder Debian mit Open Office etc. auf dem LCD-TV reizt mich schon.

    Im Nachhinein meine ich auch, dass die Probleme immer dann auftraten wenn ich den Kernel geaendert hatte. Webtop bzw. die entsprechenden Mods waren wohl unschuldig. Auch sollte an nicht immer gleich alles aufeinmal aendern um den Ueberblick nicht zu verlieren.:confused2:
     
  6. JamaicaStef, 26.09.2011 #6
    JamaicaStef

    JamaicaStef Android-Hilfe.de Mitglied

    Beiträge:
    46
    Erhaltene Danke:
    5
    Registriert seit:
    17.07.2010
    Mit der neuesten Faux-Kernel (Version 0.2.0) kann man das Atrix auch wieder ausschalten ohne das die Widgets verschwinden...
     
  7. frankwth, 26.09.2011 #7
    frankwth

    frankwth Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    97
    Erhaltene Danke:
    16
    Registriert seit:
    26.02.2010
    Ich hatte auch erwartet, dass Faux v0.20 den Fehler behebt. Gerade mal neu gebootet und alle Wigets hatten die uebliche Fehlermeldung "Prolems loading..." und konnten nur noch geloescht werden. :cursing:

    Das ist ja kein exotischer Fehler sondern ziemlich happig. Ich wundere mich schon, dass solche Fehler die updates ueberleben.

    Ich installiere jetzt mal das neue Homebase ROM (Orange-Version), wo der Kernel schon eingebaut ist. Vorher hatte ich von der Stock-Version upgedated.

    Mal sehen ob es dann klappt.
     
  8. JamaicaStef, 26.09.2011 #8
    JamaicaStef

    JamaicaStef Android-Hilfe.de Mitglied

    Beiträge:
    46
    Erhaltene Danke:
    5
    Registriert seit:
    17.07.2010
    Also bei mir gibt es anscheinend das gleiche Proble, wenn ich mit SetCPU "zu scharf" undervolte und die Frequenzen durch "Set on Boot" mitstarten. Danach kommt es zum "Problem beim Laden des Widgets". Ohne UV bzw. mit geringem UV (muss jetzt getestet werden) klappt es 1a!! Also wenn du SetCPU nutzt, liegt es womöglich daran!!
     
    Zuletzt bearbeitet: 26.09.2011
  9. frankwth, 27.09.2011 #9
    frankwth

    frankwth Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    97
    Erhaltene Danke:
    16
    Registriert seit:
    26.02.2010
    Ja, ich nutze setCPU weil mir sonst die Batterielaufzeit zu kurz ist.

    Ich setze immer verschiedene Frequenzen je nach Zustand des Handies und nur am Charger gehe ich auf 1300Mhz, ansonsten max. 1100 und sogar 456 bei abgeschaltetetn Screen.

    Ich habe auch immer sofort die Voltages runtergesetzt und werde jetzt mal testen ob es ohne das Runtersetzen keine Probleme gibt.
     

Diese Seite empfehlen