1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Wie kann ich die ID meines steins ändern?Stein hat eine Falshe ID

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Milestone" wurde erstellt von natas77, 06.04.2010.

  1. natas77, 06.04.2010 #1
    natas77

    natas77 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    132
    Erhaltene Danke:
    0
    Registriert seit:
    30.01.2010
    hallo

    nach langem hin und her forschen habe ich rausgefunden das mein stein die andere(Falche) ID hat.

    es war auch der grund warum der stein im ADB Recovery modus nicht erkannt wurde!

    also wenn jemand weiß wie ich meine device ID ändern kann währe es super wenn er mir helfen könnte!


    ich hoffe es geht!
    Gruß

    zur weiteren erläuterung: gemeint ist die usb device id (abrufbar unter linux mit lsusb).. diese scheint falsch zu sein, und nun suchen wir nach einer möglichkeit diese im stein zu ändern ;)
     
    Zuletzt von einem Moderator bearbeitet: 08.04.2010
  2. cinereous, 07.04.2010 #2
    cinereous

    cinereous Gast

    Wie bekommt ein Stein überhaupt eine falsche usb-id? _Eigentlich_ ist diese HW-spezifisch.
     
  3. aslocum, 07.04.2010 #3
    aslocum

    aslocum Fortgeschrittenes Mitglied

    Beiträge:
    268
    Erhaltene Danke:
    33
    Registriert seit:
    30.08.2009
    viel einfacher währe es die device id im treiber anzupassen ;)
     
  4. natas77, 07.04.2010 #4
    natas77

    natas77 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    132
    Erhaltene Danke:
    0
    Registriert seit:
    30.01.2010
    ja das klingt logischer! aber wie?

    es ist auch sehr komisch wie das überhaupt passieren konnte das ich eine andere ID bekomme.... aber es ist so!

    im normal modus wird der stein ganz normal erkannt aber im adb recovery modus wird der nicht erkannt weil er halt treiber für eine USB ID haben will die ich nicht habe!

    ich hab es an mehreren Rechnern mit verschiedenen Betriebssystemen versucht.
     
  5. Bavilo, 07.04.2010 #5
    Bavilo

    Bavilo Erfahrener Benutzer

    Beiträge:
    182
    Erhaltene Danke:
    43
    Registriert seit:
    07.02.2010
    Woher weisst du das du eine andere ID hast? Ich hatte auch mal ne weile ein problem das der Stein nicht in der ADBRecovery erkannt wurde, aber das war ein treiber problem was nichts mit der Device ID zu tun hatte.

    Wie lautet deine Device ID?
     
  6. natas77, 07.04.2010 #6
    natas77

    natas77 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    132
    Erhaltene Danke:
    0
    Registriert seit:
    30.01.2010
    das habe ich die letzten drei Wochen auch gedacht in dem ich mit dem Problem beschäftigt habe.

    hier das Thema dazu *KLICK*

    da das Problem an mehreren verschiedenen Rechnern mit verschiedenen Betriebssystemen immer noch bestand muss es am stein liegen!

    die ID kommt wenn ich wieder zu hause bin!sorry

    die ist : ID 22b8:41d9 Motorola PCS
     
    Zuletzt bearbeitet: 07.04.2010
  7. Riffer, 07.04.2010 #7
    Riffer

    Riffer Android-Lexikon

    Beiträge:
    1,261
    Erhaltene Danke:
    220
    Registriert seit:
    06.03.2010
    Phone:
    OnePlus Two
    Tablet:
    Samsung Galaxy NotePRO 12.2
  8. natas77, 07.04.2010 #8
    natas77

    natas77 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    132
    Erhaltene Danke:
    0
    Registriert seit:
    30.01.2010
    hi danke für deine hilfe!

    ich hab es genau so gemacht wie es da steht aber leider ohne erfolg!

    bin mir aber nicht sicher ob ich das richtig gemacht habe!
     
    Zuletzt bearbeitet: 07.04.2010
  9. cinereous, 08.04.2010 #9
    cinereous

    cinereous Gast

    Und hast du auch udev neu gestartet? Sonst werden die Regeln nicht neu eingelesen. Wobei diese Regel nicht korrekt ist. Schau noch einmal in dem verlinkten Thread. Da steht die Regel anders drin. Du musst eigentlich nur
    SYSFS{idVendor}=="04e8" verändern, udev (oder den Rechner, wenn dir der Consolenaufruf von udevadm zu komplex ist) neu starten und schon ist das erledigt.
     
  10. natas77, 08.04.2010 #10
    natas77

    natas77 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    132
    Erhaltene Danke:
    0
    Registriert seit:
    30.01.2010
    ja udev habe ich nach jeder Veränderung neu gestartet!

    wie genau müsste die Regel dann aussehen?

    etwa so? :

    aber dann würde ich ihn ja keine neuen port zuweisen!
     
  11. cinereous, 08.04.2010 #11
    cinereous

    cinereous Gast

    Du musst doch da nichts zuweisen. Auf diese Art und weise bekommt das Device mit der Vendor-ID "22b8" den Zugriff "rw" für alle zugeteilt.
     
  12. natas77, 09.04.2010 #12
    natas77

    natas77 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    132
    Erhaltene Danke:
    0
    Registriert seit:
    30.01.2010
    hi

    danke für deine hilfe!

    das habe ich verstanden.aber: :)

    wenn ich den stein ans Rechner anschließe und mit Android SDK s adb shell drauf zugreifen will dann erwartet die adb ein gerät mit der id 41db.

    daher ich meine wenn ich den gerät 22b8 rw rechte gebe wird die id dadurch nicht geändert!

    sorry wenn ich da was falsch verstehe. die udev sachen sind mir sehr neu!

     
  13. cinereous, 09.04.2010 #13
    cinereous

    cinereous Gast

    Du musst die beiden IDs getrennt voneinander betrachten. 22b8 ist die "Vendor ID", was die andere ist, weiss ich grad nicht.
     
  14. bingo5, 10.04.2010 #14
    bingo5

    bingo5 Android-Lexikon

    Beiträge:
    1,283
    Erhaltene Danke:
    222
    Registriert seit:
    09.12.2009
    Phone:
    OnePlus Two + Sony Xperia Z Ultra
    Ich weiß ich helfe dir gerade bei dem Thema nicht viel weiter...

    Aber ich hatte das gleiche Problem auch schon mal.

    Die gute Nachricht: Ich habe das Problem gelöst :)
    Die schlechte: Ich weiß nicht mehr wie...

    Ist auch schon recht lang her... habe mich auch wie doof gewundert warum mein Stein eine ganz andere ID, als im Treiber angegeben, hat.

    Aber irgendwie hatte er nach ewigen herum testen die richtige ID und die Treiber wurde nun endlich ohne Probleme installiert und adb shell ging ohne Probleme...

    Ich hatte unter Windows auch versucht die Treiberinstallation zu erzwingen und die inf des Treibers anzupassen. Hat beides zwar im 1. Moment geklappt aber adb shell wollte dann trotzdem nicht...

    Aber wie gesagt ich weiß leider nicht mehr die "Lösung"... war also auch nichts spezielles... irgendwann ging es einfach..

    PS: Hatte auch mehrere PCs getestet (Windows XP, Vista und 7 - aber kein Linux)
     
  15. natas77, 10.04.2010 #15
    natas77

    natas77 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    132
    Erhaltene Danke:
    0
    Registriert seit:
    30.01.2010
    genau so sieht es auch bei mir aus bis auf das das ich die lösung noch nicht gefunden habe!

    ich würde sooo gerne paar Sachen an mein Stein ändern. und die meisten benötigen adb shell :-(

    ich habe die tage mehrere udev regeln geschrieben und die inf Dateien in der msi bearbeitet......aber es bringt leider alles nix...der stein wird nicht erkannt.
     
  16. Riffer, 10.04.2010 #16
    Riffer

    Riffer Android-Lexikon

    Beiträge:
    1,261
    Erhaltene Danke:
    220
    Registriert seit:
    06.03.2010
    Phone:
    OnePlus Two
    Tablet:
    Samsung Galaxy NotePRO 12.2
    Den debug Modus habt ihr aber schon an, oder?
    Ich bin mir nicht sicher, ob das Einfluss auf die ID hat...
     
  17. natas77, 11.04.2010 #17
    natas77

    natas77 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    132
    Erhaltene Danke:
    0
    Registriert seit:
    30.01.2010
    ja habe ich.
    aber das im recovery modus egal.
     
  18. cinereous, 11.04.2010 #18
    cinereous

    cinereous Gast

    Imho hat der Stein in jedem Modus eine andere ID. War ebenso beim Galaxy, hat sich ständig geändert, was der Grnd war, wieso viele mit einer VirtualBox-Lösung nicht zurechtkamen, da sich die durchgereichten USB--Komponenten id-technishc verändert haben.
    Was spricht eigentlich gegen ein paar udev-Rules, die immer das selbe Ziel haben? (das chmod 666 des Devices)
     
  19. natas77, 11.04.2010 #19
    natas77

    natas77 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    132
    Erhaltene Danke:
    0
    Registriert seit:
    30.01.2010
    Da spricht natürlich nichts gegen. Ich hab es natürlich schon versucht aber die rules die ich geschrieben habe funktionierten nicht. Ich weiß jetzt nicht ob die rules nicht richtig waren aber es hat nicht funktioniert.

    Mit deiner Hilfe habe ich ja eine. Rule erstellt der das Mode 666 für das gerät erreichen sollte.
     

Diese Seite empfehlen