1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

WLAN geht nicht mehr - für Linux-Kenner

Dieses Thema im Forum "Motorola Milestone Forum" wurde erstellt von kaufmann09, 11.03.2011.

  1. kaufmann09, 11.03.2011 #1
    kaufmann09

    kaufmann09 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    135
    Erhaltene Danke:
    9
    Registriert seit:
    10.01.2010
    Seit 2 bis 3 Tagen geht bei meinem Milestone das Wlan nicht mehr.

    Connect mit AP ist Ok, ich kriege auch eine IP. Ping heise.de bricht ab mit unknown host.
    In /etc fehlt die resolv.conf.

    Ist das beim Milestone so üblich?

    Ich habe root, also habe ich die Datei angelegt und den ping widerholt. Nun kann er den Namen auflösen. Beim ping kommt jetzt aber 'ping : sendto: Operation not permitted'

    Mache ich was falsch? Was könnte das Wlan kaputt gemacht haben?
     
  2. Otandis_Isunos, 11.03.2011 #2
    Otandis_Isunos

    Otandis_Isunos Ehrenmitglied

    Beiträge:
    12,679
    Erhaltene Danke:
    4,808
    Registriert seit:
    26.10.2010
    Phone:
    Motorola Moto X 2014
    Also ich hab grad mal geschaut. Die resolv.conf gibts bei mir. Aber eine generelle WLAN Verbindung wird schon hergestellt, oder!?

    Ping funktioniert bei mir ebenfalls. Wenn du großes Pech hast, hast du dir wirklich, aus welchem Grund auch immer, irgendwas zerschossen.
     
  3. k1l, 11.03.2011 #3
    k1l

    k1l Android-Lexikon

    Beiträge:
    1,317
    Erhaltene Danke:
    404
    Registriert seit:
    20.12.2009
    Tablet:
    HP Touchpad
    was hast du denn gemacht, bevor es passierte?
    welches android nutzt du? custom-rom?
    irgendwelche änderungen am system?
     
  4. kaufmann09, 11.03.2011 #4
    kaufmann09

    kaufmann09 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    135
    Erhaltene Danke:
    9
    Registriert seit:
    10.01.2010
    Nichts groß verändert ausser den üblichen Updates. Firmware ist 2.1-update1 mit One Click Root (aber schon seit Monaten) hauptsächlich für Backup (Titanium) und Firewall (Droidwall). Aber - das ist mir aufgefallen, der Stein arbeitet fast täglich schleppender. Ich habe so um die 70 Apps drauf, die ich auch alle benutze. Mittlerweile habe ich 1 bis 2 spontane Reboots am Tag, wobei es immer so 10 bis 15 Min. dauert bis ich nach dem Reboot wieder arbeiten kann. Der Speicher ist permanent voll, die Speicherwarnung kommt praktisch täglicht. Das repariere ich dann immer mit Cachemate. Der Stein ist 15 Monate alt und wurde noch nie gewiped. Ach so, ich habe natürlich auch mit abgeschalteter Firewall getestet. Und die Wlan-Verbindung wird problemlos aufgebaut. Ich habe noch ein Archos-Tablett daneben liegen. Das läuft zeitgleich mit dem selben Wlan einwandfrei.
     
  5. PaterGerd, 12.03.2011 #5
    PaterGerd

    PaterGerd Fortgeschrittenes Mitglied

    Beiträge:
    259
    Erhaltene Danke:
    22
    Registriert seit:
    08.12.2010
    Setz doch einfach mal dein System neu auf.
    Danach läuft es aufjedenfall wieder besser als so - nämlich nicht so zugemüllt..

    Und ich könnte wetten das Dein Wlan dann auch wieder funktioniert.
     
  6. kaufmann09, 13.03.2011 #6
    kaufmann09

    kaufmann09 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    135
    Erhaltene Danke:
    9
    Registriert seit:
    10.01.2010
    Ja, danke. Neu aufsetzen werde ich wohl tun. Momentan bin ich aber auf einer anderen Spur: Ich hatte vergessen (echt, kein Scherz!) dass ich mir Theft Aware drauf getan habe. Es sieht so aus, als gäbe es gewisse Wechselwirkungen zwischen Theft Aware und Setting Profiles. Das ist aber bis jetzt mehr Ahnung als Wissen. Leider fehlt mir die Zeit um der Sache im Moment auf den Grund zu gehen. Jedenfalls waren die Wlan Probleme weg, nachdem ich den Stein mit ausgeschaltetem Theft Aware neu gebootet habe. Danach TA wie eingeschaltet, noch mal neu gebootet und Wlan läuft immer noch. Setting Profiles erwähne ich, weil ich ca. 10-20 mal am Tag die Settings umschalte, je nach Aufenthaltsort und anderen Kriterien. Und das arbeitet momentan auch nicht mehr zuverlässig - ohne das es zwischendurch dort ein Update gab.
     
  7. chrissix, 05.08.2011 #7
    chrissix

    chrissix Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    05.08.2011
    Hallo, ich hatte das selbe Problem das mein Milestone zwar WLAN aktivieren konnte, aber keinen Router mehr fand.

    Nach verzweifelter Suche in Foren habe ich das Problem so lösen können:

    Obwohl mein Stein die neueste Firmware drauf hatte startete ich über den MotoHelper eine Firmware aktualisierung über dem PC (Stein an USB Kabel - USB Verbindung Portal & und Tools, und dann bei Motohelper auf Firmware aktualisieren)

    Bevor er zum aktualisieren anfängt sagt er dann dass das Milestone auf dem aktuellsten Softwarestand sei, aber das Milestone führt trotzdem einen Systemneustart durch, danach funktionierte wieder alles.

    Ich vermute einmal das durch dieses Systemneustart über das Online MotoHelper Update kaputte Protokolle repariert wurden.

    Den Grund für das plötzliche "Nicht mehr funktionieren" des WLAN kann ich mir nicht erklären, außer das ich seit langem wieder alles Apps auf einmal aktualisiert habe... vl. wurde da was durcheinandergeworfen.


    Vielleicht nützt euch meine Lösung bei euch etwas.
     
  8. mblaster4711, 05.08.2011 #8
    mblaster4711

    mblaster4711 Android-Ikone

    Beiträge:
    4,007
    Erhaltene Danke:
    582
    Registriert seit:
    29.03.2011
    Phone:
    Moto G 3rd gen.
    Tablet:
    Lenovo A10-70
    @chrissix
    hast du es auch mal mit nur einen reboot versucht?
    Dass die PC-Software was an deinem Stein geändert hat glaube ich nicht, denn wenn die anfängt zu werkel, lädt sie ein sbf runter und installiert das komplett und das nur wenn du eine ältere version auf deinem Stein hast als die welche runtergeladen werden kann.

    @kaufmann09

    70 Apps die du täglich verwendest???????
    Egal, schmeiss ein paar Apps runter dann wird der Stein auch wieder schneller, ein drittel des interen Speichers sollte man frei halten, eben darum!

    Und für was brauchst du eine Firewall auf dem Android?
    In welchen WLANS treibst du dich rum und was hast du alles laufen das man mit einer Firewall blocken müsste??????




    Gesendet mit der Android-Hilfe.de-App
     

Diese Seite empfehlen