1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

WLAN Verbindung dauert lange nach Standby

Dieses Thema im Forum "Google Nexus S Forum" wurde erstellt von Dandie, 30.11.2011.

  1. Dandie, 30.11.2011 #1
    Dandie

    Dandie Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    136
    Erhaltene Danke:
    2
    Registriert seit:
    26.10.2011
    Hallo,

    ich bin mir zwar nicht ganz sicher ob es sich hier um ein Nexus S spezifisches Problem handelt aber es könnte durchaus etwas mit Besonderheiten der Hardware und/oder Treiber zu tun haben:

    Wenn ich zuhause WLAN aktiv habe, dann verbindet sich das Nexus relativ langsam nach dem Anschalten. Manchmal geht es schneller, manchmal dauert es länger, in jedem Fall aber einige Sekunden (ca 5-20s). Die Zeit scheint auch unabhängig von der Empfangsstärke zu sein, da das gleiche Problem in unmittelbarer Reichweite des Routers auftritt.

    Kennt jemand dieses Problem und gibt es einen Workaround?

    Ach ja, bei dem Router handelt es sich um eine Fritz Fon und bei der Verschlüsselung glaube ich um WPA2. Unsere Rechner haben dieses Problem übrigens nicht.
     
  2. MrHandsome87, 30.11.2011 #2
    MrHandsome87

    MrHandsome87 Android-Experte

    Beiträge:
    524
    Erhaltene Danke:
    29
    Registriert seit:
    22.01.2011
    Angeschaltetem Handy oder Display ?

    Denn es gibt eine Option die Festlegt was getan wird. Normale einstellung ist das Wlan im StandBy auf 3G Netz umschaltet.
     
  3. Dandie, 30.11.2011 #3
    Dandie

    Dandie Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    136
    Erhaltene Danke:
    2
    Registriert seit:
    26.10.2011
    WLAN schaltet im Standby ab, was ich wegen der längeren Laufzeit auch gerne so beibehalten würde.
     
  4. MrHandsome87, 30.11.2011 #4
    MrHandsome87

    MrHandsome87 Android-Experte

    Beiträge:
    524
    Erhaltene Danke:
    29
    Registriert seit:
    22.01.2011
    Ja dann musste damit leben, denn der Verbindet sich dann immer etwas länger.
     
  5. 0211dus, 30.11.2011 #5
    0211dus

    0211dus Android-Experte

    Beiträge:
    474
    Erhaltene Danke:
    56
    Registriert seit:
    01.11.2010
    Mach mal folgendes:

    Einstellungen --> Drahtlos und Netzwerke --> WLAN-Einstellungen

    Nun druckst du die Funktionstaste (zweite von links), dann auf "Erweitert" rechts unten.

    Nun auf WLAN Standby-Richtlinie und wählst "Nie" aus... So bleibt dein WLAN aktiv, oder wählst dort eine andere Option.
     
  6. Dandie, 30.11.2011 #6
    Dandie

    Dandie Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    136
    Erhaltene Danke:
    2
    Registriert seit:
    26.10.2011
    Äh, hast du den Thread gelesen? Ich will im Standby WLAN nicht anhaben weil mir dabei der Akku zu schnell leer geht. Und bitte auch nicht sagen dass es so sein muss, weil sich damit nicht erklären lässt dass es mal schneller und mal weniger schnell geht.

    Wie lange dauert es denn bei Euch?
     
  7. blur, 30.11.2011 #7
    blur

    blur Android-Guru

    Beiträge:
    3,911
    Erhaltene Danke:
    584
    Registriert seit:
    08.07.2010
    Phone:
    Moto X Play, Xiaomi Mi3, ZUK Z1, Nexus 7
    Hast Du die mobile Datenverbindung denn abgeschaltet?
    Ne mobile Datenverbindung nimmt mehr Akku als WLAN.

    Deshalb mache ich es genau so, wie 0211dus schrub.
     
  8. Dandie, 30.11.2011 #8
    Dandie

    Dandie Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    136
    Erhaltene Danke:
    2
    Registriert seit:
    26.10.2011
    Sorry, aber das ist Unsinn. Schau mal wie lange dein Akku im Vergleich hält. Bei der Option steht doch auch schon der Hinweis dass diese Akkulaufzeit kostet.

    Die Mobilfunkverbindung bleibt ja trotzdem bestehen und ob die Datenverbindung darüber auch besteht oder nicht macht heute kaum noch einen Unterschied. Es werden ja nicht ständig Daten darüber übertragen - zumindest nicht im Standby.
     
  9. blur, 30.11.2011 #9
    blur

    blur Android-Guru

    Beiträge:
    3,911
    Erhaltene Danke:
    584
    Registriert seit:
    08.07.2010
    Phone:
    Moto X Play, Xiaomi Mi3, ZUK Z1, Nexus 7
    den Hinweis kenne ich ;)

    Vielleicht habe ich auch den falschen Schluss gezogen:
    Aber wenn ich WLAN abschalte, steigt mein Akkuverbrauch spürbar.

    Zur Ausgangsfrage,
    bei mir ist WLAN nach dem Aufwachen sofort da.
    Auch wenn ich einstelle, dass es im Standby deaktiviert werden soll.
    Kann keine Verzögerung erkennen.
     
  10. Dandie, 01.12.2011 #10
    Dandie

    Dandie Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    136
    Erhaltene Danke:
    2
    Registriert seit:
    26.10.2011
    Danke für den Hinweis. Haben Andere auch nicht dieses Problem? Gerade gestern und heute wieder recht stark dieses Phänomen gehabt: Gestern abend hat es sich quasi sofort verbunden, heute morgen erst nach über 10 Sekunden.

    Könntet Ihr vielleicht noch was zu Eurem WLAN Zugang sagen? Also welchen Router und welche Verschlüsselung ihr verwendet? Vielleicht gibt es da ja einen Zusammenhang ...
     
  11. nawatnu, 01.12.2011 #11
    nawatnu

    nawatnu Android-Hilfe.de Mitglied

    Beiträge:
    88
    Erhaltene Danke:
    26
    Registriert seit:
    06.05.2010
    Ich hab das gleiche Problem. Hab ne FritzBox 3170 und damit tritt das quasi immer auf. Interessanterweise funktioniert die Verbindung auf Arbeit einwandfrei.

    Auf meiner FritzBox hab ich jedenfalls schon alles mögliche und unmögliche an diversen Settings probiert, nichts hat geholfen. Die neueste Firmware ist drauf, auch wenn die schon 3 Jahre alt ist.

    Da sich andere Geräte (PC, iPod, Notebook) problemlos an die FritzBox connecten, kann das eigentliche Problem aber nur das Nexus S sein.

    EDIT: Verschlüsselung war immer WPA2. WEP kommt für mich nicht in Frage.
     
  12. Dandie, 01.12.2011 #12
    Dandie

    Dandie Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    136
    Erhaltene Danke:
    2
    Registriert seit:
    26.10.2011
    Ah, danke. Wollte gerade nach der Verschlüsselung fragen. Ich verwende glaube ich auch WPA2. Vielleicht liegt es wirklich daran. Ich will das eigentlich auch nicht ändern, aus diversen Gründen. Es ist auch denkbar dass eine Variante von WPA2 besser funktioniert als eine andere, also TKIP und wie sie alle heißen. Auch möglich dass es eine Besonderheit der Fritz Box im Zusammenspiel mit einer bestimmten Verschlüsselungstechnik ist ...

    Kann vielleicht jemand ohne dieses Problem was zu seiner verwendeten Verschlüsselungsmethode schreiben?
     
  13. blur, 01.12.2011 #13
    blur

    blur Android-Guru

    Beiträge:
    3,911
    Erhaltene Danke:
    584
    Registriert seit:
    08.07.2010
    Phone:
    Moto X Play, Xiaomi Mi3, ZUK Z1, Nexus 7
    Bei mir ist es der Telekom-Router Speedport W723 und auch WPA2-Verschlüsselung.
    Vielleicht liegt es ja auch an der Systemsoftware des Phones.
    Ich habe ne Alpha-Version von Android 4.0 im Einsatz.
    Die Radioversion, quasi die Verbindungsschnittstelle, ist die von GB 2.3.6,
    die sollte somit eigentlich identisch sein.
     
  14. blur, 01.12.2011 #14
    blur

    blur Android-Guru

    Beiträge:
    3,911
    Erhaltene Danke:
    584
    Registriert seit:
    08.07.2010
    Phone:
    Moto X Play, Xiaomi Mi3, ZUK Z1, Nexus 7
    Habe nun geschaut,
    meine Aussage als Unsinn abzutun hatte mir keine Ruhe gelassen ;)

    Habe heute jeweils eine Tageshälfte die Standby-Richtlinie "immer" und "nie" eingestellt.
    WLAN immer eingeschaltet zog im Schnitt 10mA weniger Strom,
    statt ~35mA nur noch ~25mA.
    Alles schön in die Historie von BatteryMonitorWidget geschrieben.

    Also würde das
    als Grund entfallen.
     
  15. Dandie, 01.12.2011 #15
    Dandie

    Dandie Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    136
    Erhaltene Danke:
    2
    Registriert seit:
    26.10.2011
    Ok, dann entschuldige ich mich schonmal hiermit. Wobei mir eine logische Erklärung dafür immer noch fehlt.

    Ich werde mal einen Selbstversuch starten und WLAN über Nacht anlassen und morgens die Akkustände miteinander vergleichen. Ich werde dann mal berichten.
     
  16. blur, 02.12.2011 #16
    blur

    blur Android-Guru

    Beiträge:
    3,911
    Erhaltene Danke:
    584
    Registriert seit:
    08.07.2010
    Phone:
    Moto X Play, Xiaomi Mi3, ZUK Z1, Nexus 7
  17. Dandie, 06.01.2012 #17
    Dandie

    Dandie Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    136
    Erhaltene Danke:
    2
    Registriert seit:
    26.10.2011
    Kurze Rückmeldung: seit dem Update auf ICS geht der Verbindungsaufbau über WLAN nach dem Standby erheblich schneller und zuverlässiger. Scheint also ein Problem des Gingerbread ROMs zu sein.
     

Diese Seite empfehlen