Mitglieder surfen ohne Werbung: Jetzt kostenlos registrieren!

Factory Image flashen - Fehlermeldung: update package missing system.img

  • 1 Antworten
  • Neuester Beitrag
Diskutiere Factory Image flashen - Fehlermeldung: update package missing system.img im Allgemeine Anleitungen zu Google Geräten im Bereich Google Geräte Allgemein.
Status
Für weitere Antworten geschlossen.
Elting

Elting

Ehrenmitglied
Ihr wollt ein Factory Image per flash-all.bat flashen und bekommt folgende Fehlermeldung?

target reported max download size of xxx bytes

archive does not contain 'boot.sig'

archive does not contain 'recovery.sig'

failed to allocate xxx bytes

error: update package missing system.img

Press any key to exit...
Keine Panik! Das ist ein bekannter Fehler der manchmal vorkommen kann. Es ist nicht ganz klar, warum dieser Fehler kommt und warum nicht alle davon betroffen sind, aber es gibt Abhilfe!

Android-Police schreibt dazu:
The most common error we're seeing today as part of the flashing process is the dreaded "missing system.img" dialog, which aborts the update process on the target device....To get around the "missing system.img" error when trying to flash a factory image, you simply need to flash the .img files manually one by one.
Quelle: Running Into The Dreaded "missing system.img" Error Flashing Android 5.0 Factory Images? Here's How To Get Around It

Freie Übersetzung:
Wenn der missing system.img Dialog kommt, wird der Update-Prozess abgebrochen. Abhilfe schafft nur das händische Flashen der einzelnen Images.

Ihr müsst das Factory Image also nach dieser Anleitung sozusagen 'von Hand' flashen. Fragen dazu stellt ihr bitte in dem anderen Thread.
 
Elting

Elting

Ehrenmitglied
User @Thyrion hat noch eine Anmerkung und evtl. Lösung zum Problem gemeldet, die ich hier gerne anfügen möchte:

Es kann auch sein, dass einfach die verwendeten Tools aus dem SDK zu alt sind. Mir hat das tatsächlich schon geholfen, das scheint aber nicht immer das Problem zu sein.

-> How to Fix 'Error: Update Package Missing System.img' with Android 5.0 Factory Images for Nexus Devices

"We're hearing from users who are getting a "missing system.img" error when trying to flash a device. If you are seeing this issue, please use the latest fastboot.

You can get it from the SDK at Download Android Studio and SDK Tools | Android Developers or you can build it in the AOSP source tree by running 'make fastboot'."
Danke an @Thyrion !
 
Status
Für weitere Antworten geschlossen.