Mitglieder surfen ohne Werbung: Jetzt kostenlos registrieren!

[GELÖST] Wireguard-Verbindung automatisch aufbauen

  • 30 Antworten
  • Neuester Beitrag
Diskutiere [GELÖST] Wireguard-Verbindung automatisch aufbauen im Allgemeine VPN-Probleme im Bereich Allgemeine EDV-Probleme.
Raz3r

Raz3r

Moderator
Teammitglied
Ich komme auf in etwa die gleichen Werte wie Du. Ich schiebe es ein Stück weit auf die noch nicht ausgereifte Anbindung der Schnittstellen des Raspi 4.
 
O

Osnh

Neues Mitglied
Hallo,

ich habe auf einem Raspberry 4 hinter einer Fritzbox 4040 einen Wirguardserver installiert. Mit der aktuellen Wireguard App von FDroid kann ich auf den Server per VPN über mein Xioami Redmi note 4 mit Lineage 9 und Elektra-Kernel zugreifen. Das Kernelmodul wird auch in der App angezeigt. Das Roaming funktioniert und der Akkuverbrauch ist auch bei 1 Prozent pro TAg. So weit so gut. Aber die Übertragungsgeschwindigkeit geht nicht über 60 KB pro Sekunde. Egal ob ich per LTE oder ohne LTE eingeloggt bin. Per Firmen Wlan komme ich auch nicht über die Geschwindigkeit von 60 KB/Sek, ohne eingeschaltetes Wireguard VPN komme ich auf 5000 KB/sek.

Wo kann man noch "schrauben"?

Vielen Dank für die Antworten.
 
Andy

Andy

Ehrenmitglied
Mal mit einem anderen Client gegentesten um auszuschließen ob es an deinem Note 4 liegt.
 
nik

nik

Senior-Moderator
Teammitglied
@Osnh wie schnell ist denn der Upload bei dir zu Hause? Ist der Pi per Kabel mit der Fritzbox verbunden?
 
O

Osnh

Neues Mitglied
Der PI ist per Kabel an der Fritzbox dran. Ohne Wireguard habe ich an dem Phone einen Upload bis zu 5000 kb/s. Mit Wireguard bis zu 2500 kb/s. (Zuhause ist aber kein VPN nötig...) Das ganze gemessen an dem angezeigten Datendurchsatz am Phone.
Wenn ich außerhaus bin, kann ich keine Verbindungsabbrüche festetellen, auch nicht beim Umschalten zwischen Simkarte und Wlan.
Es spielt keine Rolle, außerhaus ist bei ca. 60 kb/s schluss.
 
O

Osnh

Neues Mitglied
@Andy
Gibt es dann noch andere Clients? Auf den Telefon meiner Frau ohne Wireguatdkernel kommen die Verbindungen auch nicht über 60 KB/s. Und hier mit ordentlichem Stromverbrauch. Meine Vermutung ist die Fritzbox oder der Raspberry die Bremse.
 
Andy

Andy

Ehrenmitglied
Nö, also wenns bei einem anderen Smartphone auch nicht anständig funktioniert, liegt es schon mal nicht am Note 4.
Komisch ist auch, dass du bei einem Upload von 5000 kb/s bei Wireguard dann auch nur 2500 kb/s. Normalerweise dürfte da Wireguard gar nicht so limitieren.
Aber da wir ja deine Config nicht kennen ...
 
O

Osnh

Neues Mitglied
Problem gelöst. Ich hatte in der Fritzbox keine IP Weiterleitung auf den Raspberry eingetragen...
Jetzt funktioniert das VPN mit ca 20% bis 25 % weniger Speed als ohne Wireguard. (bei Wlan in der Firma und zu Hause statt 5000 kb/s ohne Wireguard jetzt bis 4000 kb/s. Bei LTE konnte ich so keine Unterschiede feststellen, ging vorher bis 1500 kb und jetzt auch) Damit kann man gut leben, im Vergleich zu den 60 kb vorher.
Warum es überhaupt mit dieser geringen Geschwindigkeit funktioniert hat, ist mir aber nicht ganz klar.

Noch einmal vielen Dank für die Hinweise.
 
S

Schubbie

Fortgeschrittenes Mitglied
Schade, dass das Thema gekapert und dadurch unübersichtlich wird.

BTT:
Angesprochene App Viscerion kann mittels Automate gesteuert werden, welches kostenfrei und ggf. etwas übersichtlicher ist.
Selbst habe ich es noch nicht getestet, nur eben probiert, ob Automate Viscerion "findet" und dem ist so, von daher sollte es gehen.

In aProfiles (ein anderer Tasker) habe ich keine Möglichkeit gefunden.

Mit freundlichem Gruß
Andreas
 
Zuletzt bearbeitet:
Andy

Andy

Ehrenmitglied
Naja, was heißt kapern ... bis einschließlich Beitrag #7 wurde ja die Lösung gegeben, dass es mit Tasker und Viscerion funktioniert.
 
S

Schubbie

Fortgeschrittenes Mitglied
Man muss schon etwas lesen, um rauszufinden, dass es nichts neues gab. Sei es drum, gehört ja zum Thema...

Ich habe Automate nun so, dass es den VPN im Heimnetz und ohne Datenverbindung abschaltet.

Einen zweiten Flow habe ich für ein bei mir bestehendes Problem, dass unter Verwendung von WireGuard bei einem Netzwechsel, bzw. nach der nächtlichen Zwangstrennung auftritt. Dabei können dann bis zum Deaktivieren von WireGuard keine Daten übertragen werden. Ich Pinge nun regelmäßig nach Hause und ist eine Netzwerkverbindung vorhanden und ich bin nicht zu Hause, wird der VPN neu aufgebaut.

Bisher bin ich zufrieden. Den Akku muss ich beobachten.