[HOWTO] VPN mit FritzBox

  • 431 Antworten
  • Neuster Beitrag
T

tallica

Neues Mitglied
Threadstarter
Moin,

da einige sicherlich auch Fritzboxen zu Hause stehen haben, die ja leider keinen der Android VPN Standards können, hier mal ne kleine Anleitung. Ich übernehme keine Garantie und kann nur berichten, wie es bei mir geklappt hat, das Ganze war im Endeffekt ein Kinderspiel, im Vergleich zu meinen ersten Versuchen mit Freetz und PPTP...

Verwendete ROM: Litening 1.2 (edit: ebenfalls getestet: Villain 2.0, Cognition 1.11, LeoMar 2.4)
(mit anderen gerooteten ROMs sollte es auch funzen, da bei Samsung anscheinend die tun.ko immer dabei ist. root ist jedoch immer Voraussetzung)
Verwendete Fritzbox: 3270 (sollte mit allen FritzBoxen gehn, die VPN können. Keine Firmware Modifikationen à la Freetz nötig!)

sonstige Anforderungen: keine :thumbsup:

1.) DynDNS in der Fritzbox einrichten, wie das geht erklärt euch google ;)

2.) Die FritzBox wie hier beschrieben einrichten (dabei immer annehmen, dass man für iOS einrichtet):
AVM - VPN-Verbindung mit Apple iOS (z.B. iPhone) bzw. Mac OS X zur FRITZ!Box (Client-LAN-Kopplung)

3.) Im Market nach "VPNC Widget" suchen, die Beschreibung durchlesen (!) und dadurch verstehen, wie man mit dem Widget umgeht.

4.) Dann einfach installieren und das Widget auf nem Homescreen platzieren.

5.) In den Einstellungen (Doppelklick drauf, steht aber auch in der Beschreibung der App) und erstmal "Check Prerequisites" machen. Wenn das fehlschlägt, dann reichen die Anforderungen der ROM oder ähnlcihes nicht. Siehe Beschreibung der App!

6.) Unter "Set Preferences" folgendes einstellen:

IPSecGateway: hostname von DynDNS (z.B. blablubb.dyndns.org)
IPSecId: die email Adresse vom Einrichtungsassistent der FritzBox
IPSec Group Password: der Eintrag "key" aus der .cfg
XAuthUsername: der xauth username aus der .cfg
XAuthPasswort: das xauth passwort aus der .cfg
other Vpnc Options: leer lassen!

7.) Das SGS2 aus dem heimischen WLAN ausloggen, und z.B. per 3G ins Inet gehn.

8.) Per Klick auf das Widget mit dem VPN verbinden.


Ich hoffe, dass ich dem ein oder anderen durch diese Anleitung helfen konnte. In meinen Augen ist das die einfachste aller Methoden, zur FritzBox ein VPN aufzubauen, da nur root nötig ist. Bei anderen Methoden war kompliziertes Patchen mit nem Hex-Editor oder das Aufspielen einer alternativen Firmware für die FritzBox ("Freetz") nötig.

Fragen versuche ich zu beantworten, kann jedoch leider kein Support für alle FritzBox-ROM Konstellationen anbieten ;)

MfG
 
Zuletzt bearbeitet:
S

Senate

Neues Mitglied
Hallo talica,

erstmal danke für die Mühe und die Anleitung.

ich habe deine Anweisung befolgt... doch leider hat es bei mir nicht funktioniert.
(am Passwort kann es nicht liegen, ich habe mit copy und paste gearbeitet und es sogar abgetippt)
Die Frage stellt sich bei mir auch, was der Xauth username under das Xauth passwort ist?
Beides ist in der Config File nicht enthalten.

Desweiteren kann ich das VPNC Widget immer nur einmal ausführen danach wird mir immer der Status Off angezeigt. Sobald ich da drauf drücke komme ich in die App.
Ich habe es dann jedesmal neu installieren müssen um verschiedene Konfigurationen zu testen.
Mitlerweile finde ich das Widget auch nicht mehr im Market um weiter zu probieren.
Was mache ich falsch?
 
bswpt

bswpt

Erfahrenes Mitglied
Senate schrieb:
Hallo talica,

erstmal danke für die Mühe und die Anleitung.

ich habe deine Anweisung befolgt... doch leider hat es bei mir nicht funktioniert.
(am Passwort kann es nicht liegen, ich habe mit copy und paste gearbeitet und es sogar abgetippt)
Die Frage stellt sich bei mir auch, was der Xauth username under das Xauth passwort ist?
Beides ist in der Config File nicht enthalten.

Desweiteren kann ich das VPNC Widget immer nur einmal ausführen danach wird mir immer der Status Off angezeigt. Sobald ich da drauf drücke komme ich in die App.
Ich habe es dann jedesmal neu installieren müssen um verschiedene Konfigurationen zu testen.
Mitlerweile finde ich das Widget auch nicht mehr im Market um weiter zu probieren.
Was mache ich falsch?
Vermutung 1 - bitte checken: du gehst in die app rein anstatt, wie oben richtig beschrieben über den Homescreen-->Widget VPNC als Widget zu hinterlegen - app starten bringt nix

Vermutung 2 - bitte checken: in der Fritz-cfg ist sehr wohl xauth....suche mal in deiner cfg nach dieser Stelle:

use_cfgmode = no;
xauth {
valid = yes;
username = "xyz";
passwd = "xyz";
}

Dort, wo ich jetzt xyz geschrieben habe müßten die gefragten Daten stehen. Steht da nix, hast du die Fritz-cfg "noch" nicht korrekt konfiguriert.

Wenn dem so ist, dann aus dem Ausgangspost Punkt 2) inhalieren....
 
S

Senate

Neues Mitglied
Vermutung 1: Ich habe es als Widet auf dem HomeScreen gezogen und nicht die App.

Vermutung 2: In der Fritzbox_dyndnsname_org.cfg steht nichts mit xauth{}.
In der vpnuser_name_mail_com.cfg ebenfalls nicht. jedoch gibt es eine Variable mit dem namen use_xauth und der Wert ist auf "no" gestellt.
use_xauth = no;

Ich habe eine Frotzbox 7170
 
B

Berenor

Neues Mitglied
Wenn Du die Anleitung auf der AVM Seite, die oben unter Punkt 2 verlinkt ist befolgt hast, sollte der xauth username und passwort Eintrag aber von Dir eingefügt worden sein und auch der use_xauth Wert sollte dann auf yes stehen.
 
S

Senate

Neues Mitglied
@Berenor genau das war mein Fehler.
Ich hatte gedacht, dass ich das nicht nochmal durchgehen muss, da ich ja bereits einen VPN user eingerichtet hatte.

Danke allen beteiligten für die klasse Unterstützung. :thumbsup: es läuft nun :).
 
B

bugz

Experte
Also bei connectet er einfach nicht... Es kommt immer sofort die Meldung "VPNC switched off". Habe alle Einträge ergänzt... Verwende eine FB7390.

Edit:
Nochmal deinstalliert und neu eingerichtet... jetzt funktioniert es.
 
Zuletzt bearbeitet:
W

winni2001

Ambitioniertes Mitglied
Hatte zu diesem Thema mal in nem anderen Beitrag folgende Anleitung geschrieben.
Vielleicht kann ja jemand damit auch was anfangen:

winni2001 schrieb:
So - habs am laufen.
Habe es mit dem VPNC Widget hinbekommen.
Das Widget gibts kostenlos im Anfroid Market.

Nutze zur Zeit die Fritzbox 7390, aber mit der 7270 und den anderen, die VPN unterstützen, sollte es auch gehen.
Voraussetzung ist natürlich auch, dass eure Fritzbox immer seine aktuelle externe IP-Adresse an einen Dynamic DNS-Service kundtut. Dynamic DNS muss also aktiviert sein und ihr müsst euren Hostnamen kennen, unter der die Fritzbox erreichbar ist.
z.B. "hostname.dyndns.org" oder so ähnlich.

Nach der Installation der App sind zunächst folgende Schritte auf der Fritzbox und danach in dem Widget nötig:

1. Den Inhalt der unteren Config-Datei kopieren und auf Eurem PC als neue Datei abspeichern. Dateiendung würde ich .cfg empfehlen. Weiss aber nicht, ob es unbedingt eine .cfg sein muss.

2. Speichert die Datei ab und nehmt die folgenden Änderungen in der Datei vor (rot):

2.1: Ersetzt bei "name =" und bei "key_id =" die Email-Adresse durch eure eigene.

2.2: Denkt euch ein Group-Password aus und ersetzt es bei "key ="

2.3: Gebt euch einen Benutzernamen und ein persönliches Kennwort und setzt diese bei "username =" bzw. "passwd =".

2.4: Sofern ihr bei eurer Fritzbox eine abweichende IP-Konfiguration vorgenommen habt, müsst ihr ebenfalls alle vorhandenen IP-Adressen, die unten noch mit 192.168.178.201 (blau) lauten auf eure Konfiguration abändern. Wenn ihr den Standard-IP-Bereich der Grundeinstellung nutzt, braucht ihr dies nicht abzuändern. 192.168.178.201 wird die IP-Adresse sein, die ihr intern bekommt, wenn ihr euch per VPN verbunden habt. Damit ihr dann auch mit euren anderen Geräten im LAN zu Hause kommunizieren könnt, muss diese Adresse natürlich im gleichen Adressraum sein.

3. Vergesst nicht die Datei nach den Änderungen nochmal zu speichern und Wechselt mit den Browser eures PC auf die Seite der Fritzbox und meldet euch an.

4.1: Vergewissert euch, dass ihr die aktuelle Firmware auf der Fritzbox habt. Macht sonst nochmal ein Update, falls es nicht klappen sollte.

4.2: Wechselt auf dem Menü unter "Internet" Unterpunkt "Freigaben" auf den Reiter "VPN".

4.3: Mit "Datei auswählen" greift ihr nun die .cfg auf, die ihr gerade angelegt und abgeändert habt. Über "VPN-Einstellungen importieren" wir die Datei geladen und die Einstellungen gesetzt.

4.4: Nach kurzer Zeit habt ihr unten eine kleine Zeile mit eurer Email-Adresse, dem Haken für "Aktiv" und eine Status-Leuchte. Die kann später nochmal hilfreich sein, wenn Ihr sehen wollt, ob der Verbindungsversuch erfolgreich war. Um diese Anzeige zu aktualisieren, muss aber immer der entsprechende Knopf unten gedrückt werden. Wenn ihr später verbunden seid, leuchtet die Status-Leuchte grün.

5. Nehmt nun euer S2 zur Hand.

5.1: Zunächst solltet ihr Wlan abschalten, damit ihr auch sicher "von Aussen" über VPN verbindet. Natürlich könnt ihr euch später auch in einem fremden Wlan (z.B. bei Freunden oder auf der Arbeit) per VPN verbinden, aber da ihr ja jetzt höchst wahrscheinlich zu Hause seid, solltet ihr nicht mit der Fritzbox per Wlan verbunden sein, mit der ihr euch gleich über VPN verbinden wollt....^^ Macht ja sonst keinen Sinn.

5.2: Gehen wir zunächst in die App "VPNC Widget" und setzen unsere Einstellungen, die mit den Angaben, die wir in der Datei vorhin gemacht haben, natürlich übereinstimmen müssen.

5.3: IPSecGateway = "hostname.dyndns.org" - natürlich hier euren eigenen Hostnamen verwenden. Eingabe natürlich hier ohne Anführungszeichen und auch ohne http://.....

5.4: IPSecID = "Email-Adresse"

5.5: IPSec Group Password = "Group_Password"

5.6: XAuthUsername und Passort entsprechend. Bei other Vpnc Options habe ich nichts eingetragen.

6. Jetzt könnt ihr auf einem leeren Platz auf einem Homescreen das Widget platzieren und loslegen.

Hoffe, das ist hilfreich und ihr bekommt die Verbindung hin!

Für weitergehende Infos googlet einfach mal nach "Androiden erobern die Fritzbox".
Da bin ich fündig geworden, musst mir aber stets aus verschiedenen Berichten die passenden Teile zusammensuchen, bis es passte.
vpncfg {
connections {
enabled = yes;
conn_type = conntype_user;
name = "email@adresse.de";
always_renew = no;
reject_not_encrypted = no;
dont_filter_netbios = yes;
localip = 0.0.0.0;
local_virtualip = 0.0.0.0;
remoteip = 0.0.0.0;
remote_virtualip = 192.168.178.201;
remoteid {
key_id = "email@adresse.de";
}
mode = phase1_mode_aggressive;
phase1ss = "all/all/all";
keytype = connkeytype_pre_shared;
key = "Group_Password";
cert_do_server_auth = no;
use_nat_t = yes;
use_xauth = yes;
use_cfgmode = no;
xauth {
valid = yes;
username = "XAuth_Username";
passwd = "XAuth_Password";
}
phase2localid {
ipnet {
ipaddr = 0.0.0.0;
mask = 0.0.0.0;
}
}
phase2remoteid {
ipaddr = 192.168.178.201;
}
phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
accesslist =
"permit ip 0.0.0.0 0.0.0.0 192.168.178.201 255.255.255.255";
}
ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500",
"udp 0.0.0.0:4500 0.0.0.0:4500";
}


// EOF
 
rauke

rauke

Experte
Bei mir steht, dass die tun nicht geladen werden konnte. Ich vermute daher, dass die tun.ko bei S2 gar nicht mitgeliefert wurde und erst nachinstalliert werden muss.
 
B

bugz

Experte
Also bei mir hat es funktioniert... Ab und zu benötige ich zwei Anläufe, aber meistens klappt es dann.
 
T

tallica

Neues Mitglied
Threadstarter
rauke schrieb:
Bei mir steht, dass die tun nicht geladen werden konnte. Ich vermute daher, dass die tun.ko bei S2 gar nicht mitgeliefert wurde und erst nachinstalliert werden muss.
stock rom? wenn ja, probier doch mal ein custom rom , vllt geht's damit...das villain rom kann ich empfehlen
 
V

Vega82

Fortgeschrittenes Mitglied
Also ich verzweifel auch dran ...

bekomme "no response from target" ... Daten stimmen alle...hab die Anleitung beachtet, per PC funzt es.

Hat noch jemand ne Idee ??
Benutzt ne FB7170, wobei das ja unwichtig sein sollte.
 
U

unam

Neues Mitglied
Es will einfach nicht. Das ist die Fehlermeldung. Sehr komisch. Jemand eine Idee?



Edit: Nicht durch das WLAN Zeichen irritieren lassen. Bin in einem anderen Netzwerk und mit 3G hab ich es auch schon probiert :)

Gesendet mit der Android-Hilfe.de-App
 
Zuletzt bearbeitet:
V

Vega82

Fortgeschrittenes Mitglied
Nach meinen nächtlichen Google erfolgen liegt das Problem, welches ich auch hab, wohl am NATing des Clients. Es gibt da ne Option die zu setzen ist, allerdings lässt sich das schlecht in der App machen.

Hat einer nen Plan, wo die cfg abgelegt wird ??
 
R

ralli1300

Fortgeschrittenes Mitglied
Hallo zusammen,

Hat schon jemand erfolgreich das Transformer per VPN mit einer Fritzbox verbunden ?

Wenn ja, wie?
 
C

cbeckstein

Erfahrenes Mitglied
unam schrieb:
Es will einfach nicht. Das ist die Fehlermeldung. Sehr komisch. Jemand eine Idee?



Edit: Nicht durch das WLAN Zeichen irritieren lassen. Bin in einem anderen Netzwerk und mit 3G hab ich es auch schon probiert :)

Gesendet mit der Android-Hilfe.de-App
habe diesbezüglich schon den Autor kontaktiert
Problem (war wohl der erste, der das gemeldet hat) hat wohl mit der busybox zu tun, die von CF root installiert wird (siehe sh Fehlermeldung im Log) oder von anderen Anwendungen (Better Terminal, Busybox Installer etc.)
scheint aber nicht so einfach fixbar zu sein...
Autor ist zur Zeit auch sehr busy...
aber wenn das jetzt viele haben das Problem, vielleicht schiebt er da Zeit für den Fix ein...
- Clemens
 
H

husvun41

Gast
Hi all,

habe das Problem das immer folgende Meldung kommt:
quick mode response rejected: (ISAKMP_N_INVALID_MESSAGE_ID)(9)
this means the concentrator did not like what we had to offer.
Possible reasons are:
* concentrator configured to require a firewall
this locks out even Cisco clients on any platform expect windows
which is an obvious security improvment. There is no workaround (yet).
* concentrator configured to require IP compression
this is not yet supported by vpnc.
Note: the Cisco Concentrator Documentation recommends against using
compression, expect on low-bandwith (read: ISDN) links, because it
uses much CPU-resources on the concentrator

Habe noch das StockRom, sollte aber egal
VPNC Widget ist das neuste aus dem Market und zeigt auch an das alle Vorrausetzungen erfüllt sind.
Die FritzBox 7390 lüft mit 84.05.04-20071.
Hatte im cfg mal auf /comp-no/ geändert, war aber nutzlos dann ging es gar nicht mehr "no respone from host" nach S4.x

Hat einer eine Idee?
Schon mal danke im vorraus.
 
U

unam

Neues Mitglied
Probier es doch mal mit root. Wird schon Sinn haben wenn der Threadstarter das dazu schreibt

Gesendet mit der Android-Hilfe.de-App
 
U

unam

Neues Mitglied
Hat niemand eine Lösung? Es muss doch irgendwie funktionieren :(

Sent from my GT-I9100 using Tapatalk
 
W

winni2001

Ambitioniertes Mitglied
Man braucht auf alle Fälle root. Auch das VPNC Widget benötigt root.
 
Ähnliche Themen - [HOWTO] VPN mit FritzBox Antworten Datum
1
30
0
Oben Unten