Mitglieder surfen ohne Werbung: Jetzt kostenlos registrieren!

VPN mit FritzBox kein Internetzugriff

  • 91 Antworten
  • Neuester Beitrag
Diskutiere VPN mit FritzBox kein Internetzugriff im Allgemeine VPN-Probleme im Bereich Allgemeine EDV-Probleme.
Fletch

Fletch

Lexikon
tomtom79 schrieb:
du willst ein gerät hinter der fritzbox ansteuern hast du in der fritzbox ein Port Forwarding eingestellt?
Bei VPN braucht man kein portforwarding.

Gesendet von meinem Galaxy Nexus mit Tapatalk 2
 
G

glientsc

Neues Mitglied
Also, ich habe nun android-peter's Konfiguration angepasst und in die Fritz!Box 7270 erfolgreich importiert:

Code:
vpncfg {
        connections {
                enabled = yes;
                conn_type = conntype_user;
                name = "Note2";
                always_renew = no;
                reject_not_encrypted = no;
                dont_filter_netbios = yes;
                localip = 0.0.0.0;
                local_virtualip = 0.0.0.0;
                remoteip = 0.0.0.0;
                remote_virtualip = 192.168.178.203;
                remoteid {
                        key_id = "*****";
                }
                mode = phase1_mode_aggressive;
                phase1ss = "all/all/all";
                keytype = connkeytype_pre_shared;
                key = "*****";
                cert_do_server_auth = no;
                use_nat_t = yes;
                use_xauth = yes;
                use_cfgmode = no;
                xauth {
                        valid = yes;
                        username = "*****";
                        passwd = "******";
                }
                
                phase2localid {
                        ipnet {
                                ipaddr = 0.0.0.0;
                                mask = 0.0.0.0;
                        }
                }
                phase2remoteid {
                        ipaddr = 192.168.178.203;
                }
                phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
                accesslist = 
                             "permit ip 0.0.0.0 0.0.0.0 192.168.178.203 255.255.255.255";
        }
        ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500", 
                            "udp 0.0.0.0:4500 0.0.0.0:4500";
}

// EOF
Ich kann auch - wie mit meiner vorherigen Konfiguration auch schon - eine Verbindung zwischen Handy und Fritz!Box herstellen. Hier die Session Log von VPNCilla:

Code:
VpnCilla (Trial) Version 2.13.2
mobile CONNECTED
Session 'Note2' initiated at 20:04:11 02-12-2012
IPSec entered secret for [EMAIL="Note2@raptoria.dyndns.org"]Note2@raptoria.dyndns.org[/EMAIL]
 Password entered for [EMAIL="glientsc@raptoria.dyndns.org"]glientsc@raptoria.dyndns.org[/EMAIL] 
 vpnc version 0.5.3-mjm3-517M
pre-init
IKE SA selected psk+xauth-aes256-sha1
NAT status: this end behind NAT? YES -- remote end behind NAT? YES
got address 192.168.178.203
connect
using IP=[URL="http://192.168.178.203/24"]192.168.178.203/24[/URL], MTU=1412, Route(s)=[URL="http://192.168.178.0/24"]192.168.178.0/24[/URL] [URL="http://0.0.0.0/0"]0.0.0.0/0[/URL], DNS=192.168.178.1 192.168.179.1, Search=
  IPSEC SA selected aes256-sha1
VPNC started in foreground...
 UDP NAT keepalive packet received
 [2012-12-02 20:04:23]
Die Fritz!Box sagt mir auch brav: VPN-Verbindung zu Note2 wurde erfolgreich hergestellt.

Trotzdem kann ich von meinem Handy aus nicht auf das Internet zugreifen, und auch nicht intern z.B. auf die Fritz!Box.

Das ganze ist auch insofern komisch, als ich es sehr wohl geschafft habe, zwischen meinem Arbeitsplatz-Computer und der Fritz!Box eine funktionierende VPN-Verbindung aufzubauen. Dabei hatte ich keine Probleme. Auf der anderen Seite funktionierte ja auch die Verbindung zwischen Handy und dem Testnetzwerk von Android-Peter. Und ich habe auch zwischen Handy und Arbeitsplatz eine VPN aufbauen können. Nur zwischen Handy und Fritz!Box funktioniert es nicht.

Also ich bin am Ende meiner Ideen angelangt, was ich noch versuchen könnte.

Interessant ist in dem Zusammenhang vielleicht auch noch die Firmware 54.05.06 meiner Fritz!Box. Es ist dies die neueste, die in Österreich verfügbar ist.
 
android-peter

android-peter

Fortgeschrittenes Mitglied
Ja, der Tipp mit dem Portforwarding war natürlich eine Luftnummer.
Dein VPN-Endpunkt befindet sich schon innerhalb des Netzes. Was willst du da wohin forwarden?

Zu deiner Firmware für die Box kann ich nichts sagen. Wenn ich mich nicht irre, wird in OE mit Annex A gearbeitet. Wir benutzen Annex B. Hast du schon mal direkt bei AVM nach einer neueren FW geschaut?

Wie gehst du denn mit deinem Handy ins Internet bei den Tests? Doch nicht etwa mit dem gleichen WLAN, so dass beide Endpunkte und die vom WLAN erhaltene IP im gleichen Netz liegen?

Wenn du möchtest, können wir unseren Test auch noch einmal in anderer Richtung machen. Dann hast du wirklich die Bestätigung, ob es mit deiner Box klappt oder nicht.


MfG Peter
 
G

glientsc

Neues Mitglied
Ok, @android-peter, danke, hab dir eben eine PN bezüglich Rückwärtstest geschrieben.
Ja, in Ö gibt es nur Annex A, und AVM ist mit den Versionen immer ein wenig hinten nach.

Natürlich gehe ich bei den Tests mit dem Handy vom Mobilnetz ins Internet.... ;)
 
T

teufel666

Neues Mitglied
Ich schlag mich auch schon den ganzen Abend mit dem Mist rum, leider auch ohne Erfolg.

Galaxy Nexus Android 4.2.1
Frizbox 6360 mit Unitymedia und IPv4 Adresse.
VPN mit Fritz!Ferzugang eingerichtet

Client: IPhone= Verbindungsaufbau OK, Daten übertagung WAN und LAN OK
Client: Notebook= Verbindungsaufbau OK, Daten übertagung WAN und LAN OK
Client: Galaxy Nexus= Verbindungsaufbau OK, Daten übertagung WAN und LAN fehlanzeige!:angry:

Macht einfach keinen Sinn :confused:
 
G

glientsc

Neues Mitglied
Also, neues von der Fritz!Box-Front:
Es funktioniert nun plötzlich. Einziges Problem ist, ich weiß nicht warum.
Ich werde morgen abend austesten, woran es liegt...
In der Zwischenzeit ein dickes Danke and @android-peter!
 
Fletch

Fletch

Lexikon
glientsc schrieb:
Also, neues von der Fritz!Box-Front:
Es funktioniert nun plötzlich. Einziges Problem ist, ich weiß nicht warum.
Ich werde morgen abend austesten, woran es liegt...
In der Zwischenzeit ein dickes Danke and @android-peter!
dann mal Glückwunsch.
Kann ich deine .cfg haben? :)
Am besten mit abgeänderten Passwörtern / Daten und nicht alles aus ge-"*" zwecks Überprüfung auf Sonderzeichen oder ähnliches.
 
android-peter

android-peter

Fortgeschrittenes Mitglied
@Fletch:
Genau diese Konfigurationsdatei habe ich ein paar Beiträge weiter oben als Anhangdatei gepostet.

MfG Peter
 
Fletch

Fletch

Lexikon
android-peter schrieb:
@Fletch:
Genau diese Konfigurationsdatei habe ich ein paar Beiträge weiter oben als Anhangdatei gepostet.

MfG Peter
TEMPLATE VPN-config_FritzBox_Shrew_und_ipod.cfg.txt

diese?

Edit:
Funktioniert nicht..... Verbindung wird aufgebaut und nichts geht durch....
ich bitte also nochmal um eine funktionierende leicht abgeänderte Version. :)
 
Zuletzt bearbeitet:
G

glientsc

Neues Mitglied
@Fletch:
also hier mal die .cfg, mit der es bei mir klappte:

Code:
vpncfg {
        connections {
                enabled = yes;
                conn_type = conntype_user;
                name = "Android-Xxxxx";
                always_renew = no;
                reject_not_encrypted = no;
                dont_filter_netbios = yes;
                localip = 0.0.0.0;
                local_virtualip = 0.0.0.0;
                remoteip = 0.0.0.0;
                remote_virtualip = 192.168.178.204;
                remoteid {
                        key_id = "Android-Xxxxx";
                }
                mode = phase1_mode_aggressive;
                phase1ss = "all/all/all";
                keytype = connkeytype_pre_shared;
                key = "abc12Zyx";
                cert_do_server_auth = no;
                use_nat_t = yes;
                use_xauth = yes;
                use_cfgmode = no;
                xauth {
                        valid = yes;
                        username = "android-xxxxx";
                        passwd = "abc12Z";
                }
                
                phase2localid {
                        ipnet {
                                ipaddr = 0.0.0.0;
                                mask = 0.0.0.0;
                        }
                }
                phase2remoteid {
                        ipaddr = 192.168.178.204;
                }
                phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
                accesslist = 
                             "permit ip 0.0.0.0 0.0.0.0 192.168.178.204 255.255.255.255";
        }
        ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500", 
                            "udp 0.0.0.0:4500 0.0.0.0:4500";
}

// EOF
Ich habe noch nicht herausgefunden, woran es liegt, dass es, oder dass es nicht funktioniert.
Ich habe es sowohl mit VPNzilla als auch mit dem Samsung Stock-VPN zum Laufen gebracht.
 
Fletch

Fletch

Lexikon
mit dieser config schaffe ich gar keine Verbindung. Er versucht kurz die Verbindung aufzubauen und dann kommt gleich wieder "Verbindung getrennt"
 
G

glientsc

Neues Mitglied
Richtig importiert? Vpncilla?

Gesendet von meinem GT-N7100 mit Tapatalk 2
 
Fletch

Fletch

Lexikon
kann man die auch falsch importieren? :)
und kein vpncilla, stock vpn client von 4.2.1
 
G

glientsc

Neues Mitglied
Keine Probleme mit dyndns? - ich hatte welche. Probiere mal, die ip, Adresse direkt einzugeben. Probiere, die Fritzbox direkt aus dem Internet anzusprechen.
Ich glaube, die reine Android Version kann das auf keinen Fall, nur die von samsung veränderte. Probiere unbedingt Vpncilla, ist gratis zum testen.


Gesendet von meinem GT-N7100 mit Tapatalk 2
 
Fletch

Fletch

Lexikon
vpncilla möchte ich nicht testen. Ich will ja das es mit dem Stock Client gehen soll.
Mit dyndns hab ich keine Probleme. Meine VPN Verbindung zu meiner qnap funktioniert ja.

Der ursprüngliche Beitrag von 12:11 Uhr wurde um 12:24 Uhr ergänzt:

so, lag wohl an einem Passwort dass er nicht verbinden wollte. Jetzt geht die Verbindung.
Aber leider auch nur das. Sprich es gehen wieder keine Daten durch. Ich komme nirgends hin. Nichtmal auf die Fritzbox.
Egal ob vpncilla oder stock vpn client.
 
G

glientsc

Neues Mitglied
vpncilla möchte ich nicht testen. Ich will ja das es mit dem Stock Client gehen soll.


wie gesagt, ich bin mir ziemlich sicher, dass es bei dir mit dem stock client nicht funktionieren wird. du kannst es auch mit vpnc widget probieren, obwohl vpncilla die erste Wahl ist.


Mit dyndns hab ich keine Probleme. Meine VPN Verbindung zu meiner qnap funktioniert ja.

was ist qnap? auf jeden Fall ist qnap ungleich fritzbox.

Der ursprüngliche Beitrag von 12:11 Uhr wurde um 12:24 Uhr ergänzt:

so, lag wohl an einem Passwort dass er nicht verbinden wollte. Jetzt geht die Verbindung.
Aber leider auch nur das. Sprich es gehen wieder keine Daten durch. Ich komme nirgends hin. Nichtmal auf die Fritzbox.
Egal ob vpncilla oder stock vpn client.[/quote]


Ja, das hatte ich ganz am Anfang auch. Ich kann es aber leider nicht mehr reproduzieren, und weiß auch nicht, woran es gelegen haben könnte.
 
Fletch

Fletch

Lexikon
Qnap ist meine Nas. Da ist auch ein VPN Server welcher funktioniert. Aber leider nur pptp.
 
G

glientsc

Neues Mitglied
Und gibt es was neues von der vpn-Front? Irgendwie hat es bei mir ja auch funktioniert...

Gesendet von meinem GT-N7100 mit Tapatalk 2
 
Fletch

Fletch

Lexikon
nö, keine Lust mehr :)
 
android-peter

android-peter

Fortgeschrittenes Mitglied
Guten Morgen,

ich bin zwar hier nicht "für die Lust" verantwortlich, aber:

Ich habe gestern mit dem Stock-VPN-Client eines SGS2 (unter den Augen seines am VPN völlig uninteressierten Nutzers) und stupidem Einhacken der Daten meines TEST-Zuganges mit dem ersten Start einen problemlosen Zugang zu meinem Testnetz und von dort auch das Routing ins Internet bekommen. (whatismyip.com zeigte die IP meines DSL-Zuganges @home, ich konnte mit der Geschwindigkeit meines Uplinks surfen.)
Das klappte ohne "Bastelei" und genau so schnell, wie vorher mit diversen SGS3 und iPods.

Der einzige Unterschied zu meinen sonst verwendeten Dauer-VPNs ist, dass ich im TEST-Zugang lediglich einen 12Byte-PSK bzw. PW verwende, und produktiv nutze ich "ordentliche" PSK/PW mit 64Byte aus Groß- und Kleinbuchstaben, Zahlen sowie den ASCII-Sonderzeichen + - ! § $ % & = ? . , und #. Die anderen wie / \ @ usw. habe ich ausgespart, da mit diesen Zeichen manchmal Probleme bekannt wurden. Ich habe mir nicht die Mühe gemacht, den möglichen Wertevorrat auf Biegen und Brechen auszutesten. Dafür haben meine kryptologischen Schlüssel, so wie ich es aus der "Firma" gewohnt bin, eine kurze Gültigkeit.

MfG Peter
 
Ähnliche Themen - VPN mit FritzBox kein Internetzugriff Antworten Datum
4
3
1