Mitglieder surfen ohne Werbung: Jetzt kostenlos registrieren!

VPN mit FritzBox kein Internetzugriff

  • 91 Antworten
  • Neuester Beitrag
Diskutiere VPN mit FritzBox kein Internetzugriff im Allgemeine VPN-Probleme im Bereich Allgemeine EDV-Probleme.
rauke

rauke

Experte
glientsc schrieb:
Ich glaube, die reine Android Version kann das auf keinen Fall, nur die von samsung veränderte. Probiere unbedingt Vpncilla, ist gratis zum testen. 2
Doch doch, der Android VPN Client kann das auch. Ich nutze das schon recht lange auf unterschiedlichen Geräten. Klappt ohne Probleme.

Gesendet von meinem HTC One X mit Tapatalk 2
 
G

glientsc

Neues Mitglied
Das mit dem letzten PW könnte durchaus der Grund gewesen sein. Mit dem Programm configure fritzbox vpn connection wird nämlich ein ziemlich langes pw erstellt.

Gesendet von meinem GT-N7100 mit Tapatalk 2
 
android-peter

android-peter

Fortgeschrittenes Mitglied
Wozu benutzt ihr das AVM-Konfigurationsprogramm, wenn ich euch doch eine fertige und werweißwieoft getestete Konfiguration liefere?

Heute Abend testet mein Sohn mit seinem Xperia active. Mal sehen, ob es damit auch funktioniert.


MfG Peter
 
G

glientsc

Neues Mitglied
android-peter schrieb:
Wozu benutzt ihr das AVM-Konfigurationsprogramm, wenn ich euch doch eine fertige und werweißwieoft getestete Konfiguration liefere?

Heute Abend testet mein Sohn mit seinem Xperia active. Mal sehen, ob es damit auch funktioniert.


MfG Peter
Missverständnis: ich benutzte es *vordem* ich auf dieses Forum stieß, und mit dem Programm funktionierte es eben nicht. Da einer der wenigen Unterschiede zu @android-peter's Konfiguration die Länge des PW ist, vermutete ich, dass dies der Grund für das Nicht-funktionieren sein könnte...
 
android-peter

android-peter

Fortgeschrittenes Mitglied
OK ....

Mit den von mir beschriebenen PSK und PW (siehe weiter oben) funktioniert es auf jeden Fall mit den getesteten Geräten von Samsung und dem iDingens.
Zu anderen Geräten kann ich mangels "Masse" nichts sagen.

BTW: Ich benutze zum Generieren der PSK und PW immer einen PW-Generator. Unter Linux > pwgen -s -C 12 >> ~/passwort.txt und für die auf Arbeit zu nutzende WinDOSe auch ein entsprechendes Programm. Gerade bei diesem kann man den zu nutzenden Zeichenvorrat exakt festlegen, so dass die "unerwünschten" Zeichen nicht benutzt werden.
 
Fletch

Fletch

Lexikon
android-peter schrieb:
Wozu benutzt ihr das AVM-Konfigurationsprogramm, wenn ich euch doch eine fertige und werweißwieoft getestete Konfiguration liefere?

Heute Abend testet mein Sohn mit seinem Xperia active. Mal sehen, ob es damit auch funktioniert.


MfG Peter
ich will dich ja nicht ärgern oder so. Aber es geht nunmal bei mir nicht.
Kannst mir ja mal deine config schicken. Mach einfach Zahlendreher in den Passwörtern. Vielleicht gehts ja nur mit bestimmten Passwortlängen oder so?!
 
rauke

rauke

Experte
Beschränkt euch doch einfach auf a-zA-Z0-9 und das ganze dann entsprechend lang. Sollte kein Problem sein hinsichtlich der Sicherheit.

Gesendet von meinem HTC One X mit Tapatalk 2
 
T

teufel666

Neues Mitglied
Ich hatte das selbe Problem, VPN Verbindung ja Datentransfer nein, egal ob passwort kurz oder lang. Nach tagelangen Versuchen mit verschiedenen Configs hatte ich einfach genug, Firmeware komplett neu aufgespielt und siehe da es geht. :thumbsup:
Ist natürlich nicht die feine Art :D aber ich wollte sowieso einiges bereinigen, sonst hätte ich es nicht gemacht.

Wünsche allen anderen noch viel Spaß bei der fehler suche.
 
android-peter

android-peter

Fortgeschrittenes Mitglied
Schuss ins Blaue:
Das Routing ist ja in der Konfiguration fest eingetragen. Alles, was nicht eigenes Netz ist, wird ins Internet geroutet.
Das müsste auch bei euch gehen.
Vlt. bekommt ihr nur keine Namensauflösung? Mal eine Webseite per IP aufgerufen? Oder in den erweiterten Einstellungen mal einen Nameserver (8.8.8.8) direkt vorgegeben?

MfG Peter

Gesendet von meinem GT-I9300 mit Tapatalk 2
 
Fletch

Fletch

Lexikon
Ich komm ja nichtmal auf die fritzbox über ip.
 
M

marcelmayer

Neues Mitglied
Meines Wissens nach muss man das Telefon aber trotzdem rooten, sonst kann keine App oder der Stock-Client einen statischen Routeneintrag anlegen.
 
android-peter

android-peter

Fortgeschrittenes Mitglied
Hallo,
diese Antwort ist sehr pauschal ...
Sicherlich kann es Geräte geben, bei denen die VPN-App mit root - Rechten laufen muss (*) , aber bei den von mir bzw. an meinem Testzugang getesteten Geräten (SGS3, SGS2, Xperia aktive und einige, wo mir deren Besitzer gar nicht mitgeteilt haben, was sie nutzen ), ging es definitiv ohne root. Auch mein eigenes SGS3 ist nicht gerootet.
(*) Oder erst noch die fehlende virtuelle Tunnelschnittstelle hinzugefügt werden muss, was ja nur mit root-Rechten geht.

MfG Peter

Gesendet von meinem GT-I9300 mit Tapatalk 2
 
Beogradjanin

Beogradjanin

Erfahrenes Mitglied
Irgendwas ist daran komisch.

Mit der Stock-Firmware (4.2.1) und dem Stock-Kernel konnte ich problemlos zu meiner Fritzbox 7570 per VPN connecten und auch darüber ins Internet gehen. Netzwerk etc. lief problemlos.

Jetzt, mit root+AOKP Firmware+franco Kernel läuft es nicht mehr. VPN Verbindung steht. Die Fritzbox zeigt auch an, dass ich connectet bin, aber das war's auch. Sonst funktioniert nichts.
 
rauke

rauke

Experte
Dann gibt es wohl einen Fehler im AOKP oder im tun-Modul von franco. Bei mir geht es mit CM10.1 und faux.
 
Beogradjanin

Beogradjanin

Erfahrenes Mitglied
Mit dem neuesten Kernel R30 (ist wohl vorhin erschienen) klappt es nun. Juhu! :D
 
Schiemanskie

Schiemanskie

Neues Mitglied
glientsc schrieb:
Also, ich habe nun android-peter's Konfiguration angepasst und in die Fritz!Box 7270 erfolgreich importiert:

Code:
vpncfg {
        connections {
                enabled = yes;
                conn_type = conntype_user;
                name = "Note2";
                always_renew = no;
                reject_not_encrypted = no;
                dont_filter_netbios = yes;
                localip = 0.0.0.0;
                local_virtualip = 0.0.0.0;
                remoteip = 0.0.0.0;
                remote_virtualip = 192.168.178.203;
                remoteid {
                        key_id = "*****";
                }
                mode = phase1_mode_aggressive;
                phase1ss = "all/all/all";
                keytype = connkeytype_pre_shared;
                key = "*****";
                cert_do_server_auth = no;
                use_nat_t = yes;
                use_xauth = yes;
                use_cfgmode = no;
                xauth {
                        valid = yes;
                        username = "*****";
                        passwd = "******";
                }
                
                phase2localid {
                        ipnet {
                                ipaddr = 0.0.0.0;
                                mask = 0.0.0.0;
                        }
                }
                phase2remoteid {
                        ipaddr = 192.168.178.203;
                }
                phase2ss = "esp-all-all/ah-none/comp-all/no-pfs";
                accesslist = 
                             "permit ip 0.0.0.0 0.0.0.0 192.168.178.203 255.255.255.255";
        }
        ike_forward_rules = "udp 0.0.0.0:500 0.0.0.0:500", 
                            "udp 0.0.0.0:4500 0.0.0.0:4500";
}
.

Code:
   use_cfgmode = no;
In meiner config war es hier = yes;
Diese Zeile hat bei mir die VPN Verbindung gebracht :) Danke!
 
Beogradjanin

Beogradjanin

Erfahrenes Mitglied
Also, bei mir klappt es ganz einfach:

1. VPN-Zugangsconfig für die Fritzbox erstellen mittels"FRITZ!Fernzugang einrichten".

2. Config in die Fritzbox laden.

3. Im Handy eine VPN-Verbindung hinzufügen:
a) Jetzt erwähne ich nur die zusätzlich wichtigen Punkte...
Typ: "IPSec Xauth PSK"
"Erweiterte Optionen einblenden" Haken setzen
DNS-Server: 192.168.178.1 (IP der Fritzbox)

Der Rest wie Adresse (zur Fritzbox), Benutzername und Passwort versteht sich von selbst.

Bei mir hakte der Internetzugang, weil ich bei DNS-Server die IP der Fritzbox nicht eingefügt hatte. Jetzt geht es problemlos.
 
S

SLinoer

Neues Mitglied
Beogradjanin schrieb:
Also, bei mir klappt es ganz einfach:

1. VPN-Zugangsconfig für die Fritzbox erstellen mittels"FRITZ!Fernzugang einrichten".

2. Config in die Fritzbox laden.

3. Im Handy eine VPN-Verbindung hinzufügen:
a) Jetzt erwähne ich nur die zusätzlich wichtigen Punkte...
Typ: "IPSec Xauth PSK"
"Erweiterte Optionen einblenden" Haken setzen
DNS-Server: 192.168.178.1 (IP der Fritzbox)

Der Rest wie Adresse (zur Fritzbox), Benutzername und Passwort versteht sich von selbst.

Bei mir hakte der Internetzugang, weil ich bei DNS-Server die IP der Fritzbox nicht eingefügt hatte. Jetzt geht es problemlos.


PENG, nachdem ich den ganzen Thread hier gelesen habe und alles zig 1898327498015 mal probiert habe, hat mir dieser Beitrag die Lösung gebracht :D
Ich habe die Konfig die hier angeboten wurde getestet, Passwörter geändert, war kurz davor die Fritte neu aufzusetzen...und dann war es einfach nur der DNS Server in den Erweiterten Optionen der gefehlt hat, jetzt funktioniert es problemlos :)

Vielen dank für den TIPP :D

Grüße

Slinoer
 
lavemetoo

lavemetoo

Erfahrenes Mitglied
:thumbsup: auch bei mir hat der Tipp mit dem manuellen Hinzufügen des DNS-Servers (Fritzbox-IP) geholfen.

Mit VPNchilla wird auch die Trennung nach 1h (1 Lifetime expired) wieder automatisch aufgebaut.
Jetzt muss ich es nur noch schaffen, dass meine FritzFonApp auch in einem fremdem Netz funktioniert. Über Mobilfunk geht es schon, aber in einem fremden WLAN beim Kumpel passiert noch nichts.
 
Fletch

Fletch

Lexikon
Hat dein Kumpel das selbe IP Subnetz wie du? 192.168.178.*? Wenn ja, teste mal eine anderes Netz bei dir.
 
Ähnliche Themen - VPN mit FritzBox kein Internetzugriff Antworten Datum
4
3
1