Anleitung zum flashen eines Roms auf das HANNSpad für Anfänger

  • 137 Antworten
  • Neuester Beitrag
Diskutiere Anleitung zum flashen eines Roms auf das HANNSpad für Anfänger im Anleitungen für HANNspree HANNSpad (SN10T1) im Bereich Root / Hacking / Modding für HANNspree HANNSpad (SN10T1).
Soulfly999

Soulfly999

Lexikon
oggi86 schrieb:
hallo,
hat von euch zufällig jemand eine backup datei für mich, ich habe meinen hansy abgeschossen und komme nur über atx rein, weiß leider aber ned genau wie des alles funktioniert, und ne backup habe ich auch ned,
danke schonmal
Gibt alleine hier im Forum bestimmt 2-5 Backups die Du dir ziehen kannst. Mal Suchfunktion benutzen.

Welche Hannspad Version hast du 1653?
 
M

mdrescher

Neues Mitglied
Hallo,

Ich habe ein Problem mit einem HANNSpad wie folgt:

- HANNSpad Modell 1653
- CWM 2.5.1.1 bekit 0.8


Dsa originale ROM ist gesichert auf dem HANNSpad, und ich kann es jederzeit wieder zurueckspielen.

Wenn ich nun aber ein Custom ROM aufspiele (gemaess der Anleitung in diesem Thread), habe ich grafische Probleme:

Auf der rechten Seite des Bildschirms ist eine Art blauer Pixelschnee zu sehen, der eine Arts Schatten der eigentlichen Benutzeroberflaeche darstellt - aehnlich eines schlecht eingestellten analogen Fernsehbildes (falls das jemand noch kennt).

Manchmal ist dieser "Pixelschnee" staerker, manchmal schwaecher, aber die Apps funktionieren normal. Wenn ich wieder via CWM das original ROM zurueckspiele, sind diese Probleme verschwunden.

Dieser Effekt ist uebrigens voellig unabhaengig von eventuell installierten speziellen Kernels.

Folgende custom ROMS habe ich ausprobiert, von hier heruntergeladen:
- Flashback 10.0 easy
- Flashback 10.3 (oder ist es 10.1?)

FB10.0 easy hat uebrigens gegen Ende Oktober letzten Jahres problemlos geklappt, auf einem anderen baugleichen HANNSpad.

Was koennte das Problem sein?

Gruss,
Michel

P.S.: Danke an all die mutigen "Frickler" und Bastler, die diese Spirenzchen moeglich machen. :)
 
M

mdrescher

Neues Mitglied
Hallo,

Nein, das pad ist ein Erstkauf - damals habe ich zwei auf einmal gekauft.

Dieselbe Anleitung befolgt (eventuell andere versionen von CWM und NVBackup-Skripten) fuer baugleiche pads, aber unterschiedliches Ergebnis, deshalb mein Post. :)

Ich habe schon mit dem Gedanken gespielt, ICS mal testweise aufzuspielen, aber die known errors haben mich doch eher davon abgehalten - das FB10.1/10.3 ist ja offensichtlich recht stabil, und das moechte ich ja doch nicht missen :)

Gibt es eine Moeglichkeit, das pad komplett zu resetten (nicht factory reset), d.h. den Speicher komplett zu leeren, und dann komplett neu aufzusetzen? Ich habe nicht vor, das pad jemals wieder zu verkaufen oder so - zur Not kann ich mir ja aus dem Forum ein stock-ROM aufspielen, falls ich es zu HANNSpree schicken muss...
 
red-orb

red-orb

Lexikon
Das einzige was nicht geht ist das mikro für alles andere gibts Lösungen.
Es kann ja sein, dass das eine Pad einen Produktionsfehler hat.
Teste einfach das Ics und du wirst kein anderes Rom mehr haben wollen:D
Komplett löschen lässt sich das Pad nicht wirklich du hast allerdings die Möglichkeit im CWM alles zu formatieren und anschließend gleich das Rom deiner Wahl flashen.
Du darfst nur nicht neu starten wenn du alles formatiert hast sonst bootet das Pad nicht mehr

gesendet vom Hanns powered by ICS
 
M

mdrescher

Neues Mitglied
Hmmm, Produktionsfehler kommt mir unwahrscheinlich vor, da das originale ROM von HANNspree keinerlei Grafikfehler hat...

Egal, ich werde mir mal das ICS anschauen gemaess der Anleitung, die Du mir gegeben hast. Welche weiteren Modifikationen brauche ich noch, damit alles (ausser das Mikro) funktioniert?
 
red-orb

red-orb

Lexikon
Eigentlich nichts wenn du nicht unbedingt Hdmi brauchst.
Also nur das aktuelle Rom vom Team DRH und den Kernel am besten den oc1b1 von marcero

gesendet vom Hanns powered by ICS
 
M

mdrescher

Neues Mitglied
So, habe gerade ICS ausprobiert - dieselben Grafikfehler. :cursing:

Wieder zurueck auf das original ROM restored, und gebooted.

Ergebnis: Perfekter Sitz, dank Drei-Wetter-Taft (fuer die, die das noch kennen *g*) Fuer alle anderen: Keine Grafikfehler mehr.

Naechster Schritt: Mal dasselbe ROM und - insbesondere - denselben Kernel flashen, die sauber auf dem anderen pad laufen... Ich vermute, dass es am Kernel liegt...
 
red-orb

red-orb

Lexikon
versuch mal einen von antibyts früheren Kerneln da gabs einen bei dem die Grafikfehler nicht afgetreten sind.
Ich glaube den 7er oder so
 
M

mdrescher

Neues Mitglied
Was mich stutzig mach ist die Tatsache, dass alles bestens aussieht, egal welcher Kernel, egal welches ROM oder CWM - bist das System fertig gebooted hat.

Gerade in den Hybrid-Kernel gebooted, und die Grafikfehler werden schlimmer...

Weiter nach dem richtigen Kernel suchen...
 
M

mdrescher

Neues Mitglied
Ich habe alle verfuegbaren Kernels von antibyts (sofern gefunden) ausprobiert - alle mit Grafikfehlern. :-(

Ich bin ratlos. Koennte es was bringen, mal ein custom ROM mit Original (naja, fast Original)-Kernel zusammen laufen zu lassen? Und wo bekaeme ich so einen Kernel her?

Diese Grafikprobleme lassen mich nicht in Ruhe. Sie scheinen meist dann aufzutreten, wenn Farbverlaeufe oder (halb-)transparente Bildschirmbereiche oder Animationen dargestellt werden sollen...
 
red-orb

red-orb

Lexikon
also der einzige Kernel der so halb orginal ist ist der hybridkernel der funktioniert allerdings nur mit 2.3.x und 3.x.
es gab ganz am anfang eine Version vom Hybrid die war fast orginal ich muss heute abend mal schaun ob ich den noch irgendwo habe

Versuch mal diesen Kernel in Verbindung mit ICS
 
Zuletzt bearbeitet:
M

mdrescher

Neues Mitglied
Hi,

red-orb schrieb:
Versuch mal diesen Kernel in Verbindung mit ICS
*schlapplach* Dieser Kernel beseitigt zwar nicht die Grafikfehler - aber dafuer steht das Tablet ueber Kopf im Landscape Modus :biggrin:

Danke fuer Deine Hilfe, ich werde wohl ICS und antibyte's Kernel nehmen - das scheint die wenigsten Grafikfehler zu haben.
 
red-orb

red-orb

Lexikon
Cool wenn der Kernel deine Grafikfehler behebt dann versuch mal dieses Rom das ist der Kernel schon mit drin
 
Hiasl

Hiasl

Fortgeschrittenes Mitglied
Hat vielleicht einer der Hannsi-Gurus eine Idee warum ich seit der letzten Reparatur (Motherboard wurde getauscht) kein 3er Rom mehr zum Laufen bekomme?
Ich hab jetzt 3 verschiedene 3.0er Roms versucht und kann jedes davon nach dem Flaschen nur genau 1x starten. Danach bleibt mein Tab immer beim Hannspree-Logo hängen.
Habs auch schon mit versch. cwm's versucht. Immer das selbe.

Die 4er Roms laufen ohne Probleme. Nur bin ich da mit der Akkulaufzeit nicht zufrieden. Komm mit einer Akkuladung nicht über den Tag.
 
M

mdrescher

Neues Mitglied
red-orb schrieb:
Cool wenn der Kernel deine Grafikfehler behebt dann versuch mal dieses Rom das ist der Kernel schon mit drin
Nee, hat er nicht. Ich habe aber das empfohlene ROM ausprobiert, was aber auch nichts gebracht hat.
 
red-orb

red-orb

Lexikon
red-orb schrieb:
Cool wenn der Kernel deine Grafikfehler behebt dann versuch mal dieses Rom das ist der Kernel schon mit drin
@Hiasl
Versuch mal dieses Rom.
stell mit NoFrills den governor auf smartass und I/O auf cfq dann sind die Akkuzeiten gigantisch
Gesendet vom ACE
 
Hiasl

Hiasl

Fortgeschrittenes Mitglied
danke für deine Info.
Hab das Rom mal installiert und bin soweit auch sehr zufrieden.
Was ich nicht verstanden habe wie ich den governor auf smartass stelle?
ich hab NoFrills installiert aber da ist nichts von einem Govenor zu finden.

Ich hab bei diesem Rom nachträglich den Kernel von fards installiert da sonst kein hdmi funktionierte. Gibt es hier negatvie Erfahrungen bei dem TeamWolf-rom in verbindung mit fards kernel?