[How-To] Downgrade/Root Desire Z

  • 556 Antworten
  • Neuester Beitrag
Diskutiere [How-To] Downgrade/Root Desire Z im Anleitungen für HTC Desire Z im Bereich Root / Hacking / Modding für HTC Desire Z.
greekfossil

greekfossil

Neues Mitglied
Was ist mit den Vodafone Geräten ? Durch ein down geht doch das branding weg oder ? Gebe es ein weg für den Fall der fälle zurück ? Wenn ja wie ? Würde gerne rooten aber will bei garantiefall kein Ärger haben.. thx schon mal im vorraus für eure antworten.
 
Conan179

Conan179

Moderator
Teammitglied
Also mein Vodafone muste ich nicht downgraden und ich hatte kein Branding drauf ;)

Gruss Conan
 
greekfossil

greekfossil

Neues Mitglied
Das Problem bei mir ist das ich es in die Hände bekommen habe als 2.2.1
 
Zuletzt bearbeitet:
Conan179

Conan179

Moderator
Teammitglied
welche build nummer hast du drauf?
 
greekfossil

greekfossil

Neues Mitglied
1.72.161.1
 
Conan179

Conan179

Moderator
Teammitglied
Dann must du downgraden nach der anleitung auf seite 1
 
greekfossil

greekfossil

Neues Mitglied
Das ist schon klar ... aber was wäre mit dem branding ?
 
Conan179

Conan179

Moderator
Teammitglied
Wen du die anleitung fertig hast hast du das recovery menü drauf, damit machts du ein backup des gesamten handys, da ist dann alles drin. Das wiederum kannst du dann ohne probleme wieder herstellen.

Gruss Conan
 
greekfossil

greekfossil

Neues Mitglied
Wäre ja nicht das erste mal das ich so etwas mache ... nur laut der Anleitung wird das System auf 2.2 zurückgestellt was zur folge hätte das das jetzige System von mir sowohl gewipet wird als auch mit einem anderen System versetzt wird was nicht von Vodafone wäre... durch die Anleitung wird nicht nur das Recovery geändert damit es mir keine sorgen machen würde.. wäre ja super wenns so einfach wäre.
 
F

FreshP

Neues Mitglied
Hallo Leute,

ich habe jetzt schon einige Male versucht, was hier auf der ersten Seite beschrieben wird, unter Windows (also cmd) und Mac ( im Terminal). Leider bin ich ein ziemlicher Anfänger mit ADB und scheitere schon am ersten Schritt.

Wenn ich unter Windows eingebe cd /Programme/Android/android-sdk-windows/platform-tools/ADB (das ist definitiv der richtige Pfad), dann sagt er mir: Das System kann den angegebenen Pfad nicht finden.. Wenn ich nur /Programme/Android/android-sdk-windows/platform-tools/ADB eingebe (also ohne cd), dann zeigt er mir einen längeren Text mit ADB-Befehlen. Wenn ich darauf dann adb devices eingebe, sagt er mir: "Der Befehl "adb" ist entweder falsch geschrieben oder konnte nicht gefunden werden.

Unter Mac gebe ich
cd /Applications/androidsdk/platformtools/ADB ein, dann sagt er mir -bash: cd: /Applications/android-sdk/platform-tools/ADB: Not a directory
Peter-Ritsemas-iMac:~ heleenvermij$
. (Peter-Ritsemas-iMac ist der Name des iMacs, heleenvermij der Account) Auch unter Mac ist es so, wenn ich nur den Pfad eingebe, bekomme ich diesen Text.

Was kann ich tun, um adb richtig zum laufen zu bringen?
Beziehungsweise, mache ich irgendetwas grundsätzlich falsch?

Bitte helft mir. Ich kenne Root von meinem HTC Hero und möchte es unbedingt auch auf meinem Desire Z.

Gruß,
Peter
 
Conan179

Conan179

Moderator
Teammitglied
Welches windows? hast du evtl. cd C:odrname...?

Gruss conan
 
F

FreshP

Neues Mitglied
Hm, ich verstehe nicht ganz worauf du hinaus willst, aber danke für die Antwort.

Ich habe XP. Wenn du das meinst.

Gruß,
Peter
 
dazw

dazw

Dauergast
FreshP schrieb:
Hallo Leute,

ich habe jetzt schon einige Male versucht, was hier auf der ersten Seite beschrieben wird, unter Windows (also cmd) und Mac ( im Terminal). Leider bin ich ein ziemlicher Anfänger mit ADB und scheitere schon am ersten Schritt.

Wenn ich unter Windows eingebe cd /Programme/Android/android-sdk-windows/platform-tools/ADB (das ist definitiv der richtige Pfad), dann sagt er mir: Das System kann den angegebenen Pfad nicht finden.. Wenn ich nur /Programme/Android/android-sdk-windows/platform-tools/ADB eingebe (also ohne cd), dann zeigt er mir einen längeren Text mit ADB-Befehlen. Wenn ich darauf dann adb devices eingebe, sagt er mir: "Der Befehl "adb" ist entweder falsch geschrieben oder konnte nicht gefunden werden.

Unter Mac gebe ich
cd /Applications/androidsdk/platformtools/ADB ein, dann sagt er mir -bash: cd: /Applications/android-sdk/platform-tools/ADB: Not a directory
Peter-Ritsemas-iMac:~ heleenvermij$
. (Peter-Ritsemas-iMac ist der Name des iMacs, heleenvermij der Account) Auch unter Mac ist es so, wenn ich nur den Pfad eingebe, bekomme ich diesen Text.

Was kann ich tun, um adb richtig zum laufen zu bringen?
Beziehungsweise, mache ich irgendetwas grundsätzlich falsch?

Bitte helft mir. Ich kenne Root von meinem HTC Hero und möchte es unbedingt auch auf meinem Desire Z.

Gruß,
Peter
"cd /Programme" bringt Dich unter Windows nicht weiter, weil / nicht, wie unter Linux, auf das ROOT zeigt. Du musst das Laufwerk mit angeben oder Dich in C:\ befinden.

Also "cd c:\Programme.......\" sollte Dir helfen.

Ergänzung: Ich sehe jetzt erst, dass Du ADB mit im CD Befehl eingibst. Das ist Humbug, denn ADB ist eine .EXE und kein Verzeichnis.

Deshalb startet Windows ja auch beim Befehl ohne "cd" die adb.exe und zeigt Dir einen Bildschirm voller Informationen an.

Lass mal das ADB beim CD weg und es sollte klappen.

Probiere also bitte folgendes aus:

cd /Programme/Android/android-sdk-windows/platform-tools
und dann
adb
 
Zuletzt bearbeitet:
F

FreshP

Neues Mitglied
Hey, danke für die Antwort!

Ich befinde mich wohl in " C:\Dokumente und Einstellungen\User\Desktop " (das steht am Anfang jeder Zeile), da ich das cmd auf den Desktop gezogen habe. Ist das okay?
Ich habe jetzt cd /Programme/Android/android-sdk-windows/platform-tools eingegeben, jetzt wird mir folgendes gesagt: Das System kann den angegebenen Pfad nicht finden.

Mittlerweile frage ich mich, ob ich grundsätzlich richtig bin. Ich habe hier unter XP ein rechteckiges, schwarzes Fenster mit weißen Buchstaben. Das Icon des Programms ist C:\ . Bin ich da richtig?
 
dazw

dazw

Dauergast
FreshP schrieb:
Hey, danke für die Antwort!

Ich befinde mich wohl in " C:\Dokumente und Einstellungen\User\Desktop " (das steht am Anfang jeder Zeile), da ich das cmd auf den Desktop gezogen habe. Ist das okay?
Ich habe jetzt cd /Programme/Android/android-sdk-windows/platform-tools eingegeben, jetzt wird mir folgendes gesagt: Das System kann den angegebenen Pfad nicht finden.

Mittlerweile frage ich mich, ob ich grundsätzlich richtig bin. Ich habe hier unter XP ein rechteckiges, schwarzes Fenster mit weißen Buchstaben. Das Icon des Programms ist C:\ . Bin ich da richtig?
Ja, das ist richtig.
Ich habe meinen Beitrag ein paar Mal editiert. Hast Du alle Änderungen mitbekommen?

Tippe bitte folgendes nacheinander ein:

cd \ [ENTER DRÜCKEN]
cd Programme\Android\android-sdk-windows\platform-tools [ENTER DRÜCKEN]
adb [ENTER DRÜCKEN]
 
Conan179

Conan179

Moderator
Teammitglied
versuch mal folgendes einzu tippen
cd C:\Programme\Android\android-sdk-windows\platform-tools

Gruss Conan
 
F

FreshP

Neues Mitglied
Danke dazw, das hat geklappt. Ich habe dann gleich mal "adb devices" eingegeben,

"adb server is out of date. killing...
* daemon started succesfully *
List of devices attached

Also da war dann kein Device. Ich denke, das liegt daran, dass ich die Treiber nicht installiert habe, wo bekomme ich die her?
Achso, USB-Debugging ist angeschaltet.

Gruß,
Peter
 
dazw

dazw

Dauergast
FreshP schrieb:
Danke dazw, das hat geklappt. Ich habe dann gleich mal "adb devices" eingegeben,

"adb server is out of date. killing...
* daemon started succesfully *
List of devices attached

Also da war dann kein Device. Ich denke, das liegt daran, dass ich die Treiber nicht installiert habe, wo bekomme ich die her?
Achso, USB-Debugging ist angeschaltet.

Gruß,
Peter
Im Android-SDK sollten USB-Treiber dabei sein.
Entweder die oder HTC-Sync installieren.

In jedem Fall sollte im Gerätemanager ein "Unknown Device" auftauchen, wenn Du das Gerät anschließt. Wenn das nicht passiert liegt das Problem noch woanders.
 
F

FreshP

Neues Mitglied
dazw schrieb:
Im Android-SDK sollten USB-Treiber dabei sein.
Entweder die oder HTC-Sync installieren.

In jedem Fall sollte im Gerätemanager ein "Unknown Device" auftauchen, wenn Du das Gerät anschließt. Wenn das nicht passiert liegt das Problem noch woanders.
Hey, ich musste die USB-Internet-Anbindung ausschalten. ;)
Ja, jetzt steht bei adb devices: "HT0BERT0092 device". Ist das okay, also kann ich jetzt anfangen?
 
dazw

dazw

Dauergast
FreshP schrieb:
Hey, ich musste die USB-Internet-Anbindung ausschalten. ;)
Ja, jetzt steht bei adb devices: "HT0BERT0092 device". Ist das okay, also kann ich jetzt anfangen?
Jupp, kannst anfangen!