FlyTouch2 - Bootloader abgeschossen, was nun?

  • 20 Antworten
  • Neuester Beitrag
Diskutiere FlyTouch2 - Bootloader abgeschossen, was nun? im APad GF10 Flytouch 2 Forum im Bereich APad Forum.
H

husvun99

Gast
Beim Ausprobieren habe ich eine nicht passende u-boot-nand.bin geflasht.

Das Pad startet jetzt nur noch mit einer kurzen Vribration.

Bildschirm bleibt schwarz und wird gar nicht erst angesprochen.

Gibt es eine Alternative zum Auslöten des Flashspeichers und externer Programmierung?

Wenn ja, welche?

Wäre das hier (J110) ein Lösungsansatz?

http://forum.xda-developers.com/showpost.php?p=11238818&postcount=36
 
Zuletzt bearbeitet von einem Moderator:
nightchild79

nightchild79

Erfahrenes Mitglied
also wenn ich vol + und - und power gleichzeitig drücker bekomm ich ne pc verbindung über flash programm (burntool und neue) aber sobald ich auf start klicke bricht die verbindung ab. gibts noch andere progs evtl. von anderen geräten?

ist ja immerhin ein stück weiter.
 
nightchild79

nightchild79

Erfahrenes Mitglied
so noch ein kleiner teilerfolg

wenn ich mit dem bekannten buntools (neu oder alt) die sachen von der 28er FW flashe (u-image und ubootnand) dann bekomm ich wieder ein bild beim flashen, am ende steht wie gehabt "pls pull out OTG and reset" mach ich das ist es trotzdem noch schwarz. hab jetzt fast alle varianten durch, sogar vom zt-180.

duno ! wo bist du ;( brauch unterstützung beim testen, vielleicht fällt dir noch nen trick ein.

@veryjo

ne hab noch net weiter nach geschaut und die sachen vom zt-180 hab ich schon durch auch das burntoll 0.7.2
 
nightchild79

nightchild79

Erfahrenes Mitglied
wenn mal jemand in kürze mal flasht über burntool(am besten mit uimage aus 28xx), kann er mir dann mal den log von unten kopieren?

hab mal nen kleines vid gemacht (low qualy)
http://www.youtube.com/watch?v=da5fRWqk6aI


so ist meiner:
FileLoad! szPathName: C:\Users\Nightchild\Desktop\GOME_Flytouch2_infomix_ix220_android\android\USBburntool\burn.ini
[Nboot_DestAddr: 0x40007fc0 strNboot_DestAddr: 0x40007fc0]
Opened successfully.
Opened successfully.
[SUCCESS: ReadFile otgtype:(1) hRead:(0x1a8)]
[SUCCESS: CreateFile]
[Memory Allocation! txBuf = 0x32ed838 ]
[UsbTxFile start! run_addr=0xffffffff]
[UsbTxFile end]
Find Device From Name
Opened successfully.
Opened successfully.
[SUCCESS: ReadFile otgtype:(0) hRead:(0x1b0)]
[SUCCESS: CreateFile]
[Memory Allocation! txBuf = 0x32ed838 ]
[UsbTxFile start! run_addr=0x40200000]
[UsbTxFile end]
[SUCCESS: CreateFile]
[Memory Allocation! txBuf = 0x33d0020 ]
[UsbTxFile start! run_addr=0x40200000]
[UsbTxFile end]
[SUCCESS: CreateFile]
[Memory Allocation! txBuf = 0x33d0020 ]
[UsbTxFile start! run_addr=0x40200000]
[UsbTxFile end]
[SUCCESS: CreateFile]
[Memory Allocation! txBuf = 0x32f0838 ]
[UsbTxFile start! run_addr=0x40200000]
[UsbTxFile end]
ReadFile 0x1b0
UpdatePipeState: 0x600003c 6


ich glaube irgendwas passt bei den speicheraddressen nicht
 
Zuletzt bearbeitet von einem Moderator:
nightchild79

nightchild79

Erfahrenes Mitglied
ich hab keine idee mehr hab jetzt alle an uboot und tools durch die ich gefunden habe, alles ohne erfolg.

ich bekomm auf den pad nur ein bild (siehe vid) wenn ich die uboot.img von der "MID-2.1-update1_v1.9-2852-20110110" flashe. egal ob ich system oder andere sachen mitflashe passiert nach dem reset wieder nix (schwarz) irgendwie glaube ich das er die uboot.img (nicht .bin!, da tut sich auch nix) nicht richtig speichert oder in die falsche speicher adresse schreibt. kein plan mehr, ich geb auf. :angry:
 
nightchild79

nightchild79

Erfahrenes Mitglied
Ich gebe auf, komm einfach nicht weiter. Egal in welchen Forum man schreibt es kommen keine antworten und andere wolln ne order nummer haben, die ich natürlich nicht habe. egal

im anhang hab ich mal nen paar Burntools geladen, für den fall das die mal jemand brauch. Ist schon echt witzig wie unterschiedlich die tools sind. vorallem an den LOG´s das eine sagt mehr als das andere. am besten fand ich die 0.6. da kamen wenigstens mal fehlercodes bei rüber.
 
Zuletzt bearbeitet:
nightchild79

nightchild79

Erfahrenes Mitglied
@veryjo

hast Du schon irgendwas Rausgefunden, zu welchen Pad die falsche FW gehört?

Ich kanns ja doch nicht einfach in der ecke liegen sehn.
 
R

RStorm

Fortgeschrittenes Mitglied
@nightchild79

schau mal hier, da verkauft jemand einzelteile von seinem pad vielleicht kannst du das eprom bekommen in sofern es noch geht (oder andere teile) wäre ne möglichkeit.
 
H

husvun99

Gast
nightchild79 schrieb:
Ich gebe auf, komm einfach nicht weiter.

Nix, weiter hier im Text ... muss doch ne Lösung geben ;)

Joint Test Action Group - Wikipedia, the free encyclopedia

The connector pins are

1. TDI (Test Data In)
2. TDO (Test Data Out)
3. TCK (Test Clock)
4. TMS (Test Mode Select)
5. TRST (Test Reset) optional.
So, und das wären dann bei uns (bei J110):

TDI (Test Data In) = RXDO
TDO (Test Data Out) = TXDO
TCK (Test Clock) = ?
TMS (Test Mode Select) = ?
TRST (Test Reset) optional = ?

3.3V
GND

?
 

Anhänge

Zuletzt bearbeitet von einem Moderator:
nightchild79

nightchild79

Erfahrenes Mitglied
als erstes brauchst ein usb2serial adpapter mit ttl und 3.3v, kosten so um die 10-25 euro
alternatic kannst du auch ein nokia datenkabel nehmen (DKU-5) ich hatte nur das dku-2 damit gehts nicht.
dann kam ja das angebot mit dem anderen mboard, aber das weiste ja.

dann brauchst nur rx, tx, gnd und 3.3v anzuschließen aber denk dran, rx am kabel geht auf tx am board und tx am kabel geht auf rx am board.

da du linux nutzt musste mal bei wiki oder googel schauen mit welchen programm du ne verbindung bekommst, glaube über telnet und putty geht das auch.

[bbcode=half-offtopic-on]
halb offtopic
aso mein anderer bruder schaut sich meine boards nochmal an, er hat heut festgestellt das auf dem überladenden (12v) 3 sicherungen durch sind und ein wiederstand. ich hätte ihn gleich fragen sollen ;( naja mal schaun wann er sich meldet.
[/bbcode=half-offtopic-off]
 
H

husvun99

Gast
nightchild79 schrieb:
als erstes brauchst ein usb2serial adpapter mit ttl und 3.3v, kosten so um die 10-25 euro
Ich "denke" mal ein JTAG (parallel) für 10 Euro tut es auch.
Zu den 3.3V, hab gelesen, dass einige USB2RS232 5V liefern ?
Das wäre dann wohl nich so gut ... oder kann man das regeln?

PS: Füher hießen diese JTAG glaub ich BDM (background debug mode interface) oder BDI (background debugging interface)
 
nightchild79

nightchild79

Erfahrenes Mitglied
ist richtig das die 5v normal ausspucken deswegen ja "TTL" da hasste dann 3,3volt

als erstes brauchst ein usb2serial adpapter mit ttl und 3.3v, kosten so um die 10-25 euro
alternatic kannst du auch ein nokia datenkabel nehmen (DKU-5) ich hatte nur das dku-2 damit gehts nicht.
 
H

husvun99

Gast
nightchild79 schrieb:
ist richtig das die 5v normal ausspucken deswegen ja "TTL" da hasste dann 3,3volt
Ich steh gerade auf'm Schlauch, helf mir mal bitte.

Ich hab hier u.A. nen Vivanco USB2RS232 (pl2303-basierend*) da steht nichts in der Bedienungsanleitung, dass der 3.3V oder 5V hat.

*die Info hab ich über Linux und nicht vom Verkäufer oder Hersteller bekommen!

Wie soll "Otto-Normalverbraucher" jetzt herausfinden welcher USB2RS232 was unterstützt?

Bei den JTAGS gibt es zumindest eine Produktbeschreibung, ein Datenblatt und Hinweis auf Software

z.B. hier:
JTAG Programmer für ARM Mikrocontrollern
http://www.anvilex.de/Extern/Datasheets/DS_P009_06.pdf
 
nightchild79

nightchild79

Erfahrenes Mitglied
Wie soll "Otto-Normalverbraucher" jetzt herausfinden welcher USB2RS232 was unterstützt?
na wenn nix bei steht wegen 3.3volt dann macht er normal 5v.


ne der hat so wie ich das gelesen hab kein ttl
du brauchst soetwas
USB 2 to TTL UART 6PIN Module Serial Converter CP2102 bei eBay.de: Network Cables Connectors (endet 24.03.11 09:24:28 MEZ)

oder halt nen nokia datenkabel

USB Datenkabel für Nokia 6610 7210 6100 6800 DKU-5 NEU bei eBay.de: Für Nokia (endet 21.03.11 11:17:32 MEZ)

da knipst du den nokia anschluss ab und machst die kabel ans board. pinbelegung für das nokia kabel hab ich irgendwo, muss ich erst suchen.
 
H

husvun99

Gast
nightchild79 schrieb:
na wenn nix bei steht wegen 3.3volt dann macht er normal 5v.

ne der hat so wie ich das gelesen hab kein ttl
Also hier steht, dass der pl2303 3.3V macht:

Siemens PL2303 USB-TTL Converter

Ich denke mal Vivanco ist nur ein Großhändel und kein Hersteller.

Deren Internetseiten und Produktbeschreibungen (Details) sind eher mau ...
 
H

husvun99

Gast
Hat hier "zufällig" jemand 'n sheet zu dem KH29SV400CBTC?

Mist, das Ding sitzt auf nem WW101-Main und ich hab keine Ahnung ob man den gegen nen 29LV400 austauschen kann ....

Also Flash (bin) für den 29LV800 hätte ich wohl noch ... ;)
 

Anhänge

H

husvun99

Gast
nightchild79 schrieb:
...
sag mal kann es sein das du den falschen ausgelötet hast?
https://www.android-hilfe.de/forum/...uers-flytouch2.84243-page-3.html#post-1200323


Du hast keinen KH29SV400CBTC, du hast die 29LV800er.

Bei XDA hatten 2 Leute geschrieben sie haben nen 29LV400er drauf.

Meine Hoffnung liegt darin, dass ich den KH29SV400CBTC gegen einen 29LV800er austauschen kann.

Das ausgelesene OS vom "800" passt wohl nicht in nen "400"er ... oder?

Den KH29SV400 kann ich z.Zt. ohne sheet nicht auslesen oder vergleichen.
Ich hab den auch in keiner Prommer-Liste gefunden ...

Kann sein, dass er zum 29LV400 kompatibel ist.

Jemand der ein WWE101-Main hat müsste halt mal scheiben was bei ihm/ihr drauf sitzt ...
 
Zuletzt bearbeitet von einem Moderator: