[Alpha] Unofficcial CM 11 (Android 4.4 - KitKat) für Huawei Ascend P1/P1XL

  • 218 Antworten
  • Neuester Beitrag
Diskutiere [Alpha] Unofficcial CM 11 (Android 4.4 - KitKat) für Huawei Ascend P1/P1XL im Custom-ROMs für Huawei Ascend P1 im Bereich Root / Custom-ROMs / Modding für Huawei Ascend P1.
P1Fan

P1Fan

Fortgeschrittenes Mitglied
Heute Morgen habe ich per Zufall auf Huawei News gelesen, das es bereits eine erste inoffizielle CM 11 Version gibt. Allerdings mit einigen Problemen.

Was funktioniert:
Ril
GPS
Wifi
Sd card
Camera
Root
Audio
Bluetooth

Was funktioniert nicht:
Es scheint alles zu funktionieren.

Screenshots:


Download Link:
cm-11-20140622-UNOFFICIAL-viva.zip - 195.26 MB

GAPPS 4.4 Links:
1) Gapps for both machines
2) Dev-Host - gapps-kk-20131031.zip - The Ultimate Free File Hosting / File Sharing Service
3) Gapps_4.4.2_20140301_TestUser
4) Gapps_4.4.2_20140306_TestUser
5) UPDATE: gapps-KK-20140315_TestUser

weitere Downloads:


Du brauchst Root?
[2013.11.13] SuperSU v1.69 - xda-developers

Installationsanleitung:

- FULL AND COMPLETE WIPE IS A MUST (IMHO)
- Boot into recovery of choice
- Take a backup
- Wipe Cache
- Wipe Dalvik
- Wipe Data/Factory Reset
- Wipe /System (or, in CWM, "format /system" under Mounts and Storage menu)
- Flash ROM
- Flash gapps (see below)
- Reboot, and wait 10 minutes before touching it at ALL
- Reboot and enjoy

Credits:

- Cyanogen Mod Team
- loller79 for the gralloc fix.

Originallinks:
[ROM][CM-11][4.4][Unofficial] Huawei Ascend P1 Beta - xda-developers
Android 4.4 KitKat Custom ROM for Ascend P1 | HuaweiNewsHuaweiNews
 
Zuletzt bearbeitet:
jayfkay

jayfkay

Stammgast
Hab ich schon mal getestet.. Läuft garnicht so schlecht, abgesehen von den glitches. Aber von der arbeitsgeschwindigkeit echt nicht verkehrt.

Gesendet von meinem U9200 mit der Android-Hilfe.de App
 
Loki0201

Loki0201

Neues Mitglied
werde es heute mal testen! installation wie gehabt über TWRP flashen und das lief bisher reibungslos ab :D
 
M

MaxRink

Erfahrenes Mitglied
Die Graphikglitches kommen vom TI-Grafiktreiber.
 
P1Fan

P1Fan

Fortgeschrittenes Mitglied
Hat es nun schon jemand getestet?
 
jayfkay

jayfkay

Stammgast
Mensch Kerl, ließ halt mal :D
Läuft so weit sehr ordentlich für so ein frühes build.

Gesendet von meinem U9200 mit der Android-Hilfe.de App
 
Loki0201

Loki0201

Neues Mitglied
also ich habe es am selben tag der installation wieder runtergehauen, weil ich probleme mit den googleapps hatte, konnte mein gmail konto nicht anmelden usw. .

Aber ansonnsten lief es, bis auf die Grafikglitches.
Bin jetzt wieder bei der B706! welche übrigens super läuft ;)
 
W

woltri

Fortgeschrittenes Mitglied
Neue Version..

Laut XDA-Forum sind die Grafik-Glitches gefixed und es soll "sehr viel stabiler" sein.

What's new:
Webview graphic glitches FIXED
Much more stable
Mounting sd card and internal fixed.
Apk's installation from sdcard is working now.
A lot from CM11.

(Was ist neu:
Webview Grafikfehler FIXED
Viel stabiler
Mounten von SD-Karte und interner Karte fixed.
APK-Installation von SD-Karte funktioniert jetzt.
Eine Menge von CM11.)

Ich lads grad schonmal runter und werde es spätestens am Wochenende mal installieren und soweit meine Kompetenz das zulässt testen.

Aber ich werde zu Themen wie Bluetooth nichts sagen können, da ich keine gegengeräte besitze die es benötigen würden.

hier der neue DL-Link
cm-11-20131125-stap75-viva.zip - 174.50 MB

und Gapps
gapps-kk-20131112_TestUser.zip - 97.79 MB
 
W

woltri

Fortgeschrittenes Mitglied
Soooo...

Erster Erfahrungsbericht:

Nach einem Nand-Backup und dem üblichen rumwipen jetzt die beiden zips nacheinander im cwm installiert und neugestartet.

Zur Grafik: Ein wenig glitcht es doch... aber bisher nur während des Wechsels vom horizontalen zum vertikalen Screen und umgekehrt.
Ansonsten bisher nichts negativ aufgefallen.

Wiederherstellen der Apps mit Titanium lief ohne Probleme, Superuser läuft und auch in den Deepsleep geht er brav.

Schaut (vorsichtig) gut aus für uns P1er :)


(P.S. vielleicht mag ein Mod die links in den ersten Beitrag integrieren :) )

Der ursprüngliche Beitrag von 21:24 Uhr wurde um 22:43 Uhr ergänzt:

Stelle gerade fest, dass die Standortbestimmung nicht klappt. Zumindest nicht bei Google maps.
Ich Versuchs aber weiter.

Gesendet von meinem U9200 mit der Android-Hilfe.de App
 
Zuletzt bearbeitet:
W

woltri

Fortgeschrittenes Mitglied
Entwarnung zur Standorterkennung. Im Gegensatz zu gestern abend weiß das p1 heute morgen recht genau wo es ist. :)

Gesendet von meinem U9200 mit der Android-Hilfe.de App
 
A

Apf

Ambitioniertes Mitglied
Ich habe diese ROM nun auch installiert. Vieles gefällt mir sehr gut, z.B. die gefühlte Performancesteigerung und ein paar sinnvolle Neuerungen aus 4.4 ...

Leider kann ich aber nicht den externen Speicher als Standard setzen. Gibt es dafür einen Patch?

Für mein Backup hatte ich mybackup root benutzt. Das Programm kann unter dieser ROM aber nicht auf den externen Speicher zugreifen. Wenn ich den Speicherort manuell ändere, findet er zwar das Backup aber bei der Wiederherstellung kommt sofort: "Eingabe-Ausgabefehler." etc.

Jemand eine Idee zu den Problemen?
 
P1Fan

P1Fan

Fortgeschrittenes Mitglied
Hast Du CM mit CWM geflasht oder TWRP????

Daran kann es liegen, dass dein externer Speicher nicht erkannt wird bzw. Du nicht darauf zugreifen kannst. Ich hatte das selbe Problem (mit CWM geflasht), habe danach einfach mit TWRP drüber geflasht und siehe da...der externe Speicher wird erkannt.
 
B

burn2004

Neues Mitglied
Ich habe dieses Problem auch, habe die ROM mit TWRP 2.6.0.0 geflasht und habe ART genutzt.
Nur bin ich jetzt erstmal auf B707 umgestiegen, um abzuwarten wann das Problem gelöst ist.(wobei ich dort auch einige Problemchen habe)
Danke schonmal für jegliche Hilfe.

MFG
 
P1Fan

P1Fan

Fortgeschrittenes Mitglied
Hab die Lösung! Da ich auch das Problem mit dem Backup hatte, hab ich es jetzt so gelöst:
Hab auch My Backup Root genommen und ein Backup erstellt. Dieses Backup findet man dann auf der externen SD-Karte. Wie Apf schon gesagt hat kann man es aber nicht wiederherstellen. Deshalb hab ich das Backup von der extrenen auf die interne verschoben und den Pfad geändert, nun funktionierts :D also:

1. Backup machen mit My Backup Root
2. Prüfen ob es auf der externen eine ordner rerware findet
3. Diesen Ordner auf den internen Speicher verschieben
4. Sicherung zurückspielen

Gruß
 
B

burn2004

Neues Mitglied
Danke für den Tip das löst zumindest das Backup-Problem, aber leider ist die SD-Karte bei mir nicht richtig nutzbar. Oder ich mache irgendwo einen Fehler.

MFG
 
P1Fan

P1Fan

Fortgeschrittenes Mitglied
Was meinst du den mit "nicht richtig nutzbar"?
Ich würde gerne den Standardspeicherort auf externe SD-Karte, finde aber diese Einstellung auch nicht.
Wollte versuchen die Apps mit Hilfe einer App zu verschieben. (Bild)
 

Anhänge

B

burn2004

Neues Mitglied
Ich habe die ROM momentan leider nicht mehr drauf, da der Fehler mit der SD Karte doch zu schwerwiegend war.

  • ich hatte das Problem das die Speicherkarte nicht der Standardspeicher ist und daher kaum Platz auf dem Handy bleibt
  • außerdem wurden die Dateien der SD Karte nicht vom Handy gelesen(also Galerie, Videos, Musik), nur über einen Dateimanager.
MFG
 
A

Apf

Ambitioniertes Mitglied
Danke für die vielen Rückmeldungen! Fassen wir zusammen: Die ROM hat Riesenpotenzial ist aber aufgrund des SD-Kartenfehlers derzeit einfach (noch) nicht auf Dauer nutzbar. Dafür ist der interne Speicher einfach zu gering.

Vielleicht könnte ja mal einer von euch, der sehr gut englisch kann, die Probleme mit der SD-Karte direkt im xda-Thread posten?

Übrigens gibt es die Grafik-Glitches auch noch in der "zuletzt verwendeten App"-Vorschau ^^
 
B

burn2004

Neues Mitglied
Ich habe das Thema im XDA-Forum auch schon angesprochen, es gab aber soweit noch keine Äußerungen dazu. Wenn es was gibt melde ich mich.

MFG
 
thor_41

thor_41

Erfahrenes Mitglied
Hallo,

hab die aktuelle von spanorg jetzt seit ein paar Tagen drauf und muss sagen es läuft klasse.

Jetzt tut sich ja was bei BT. Die 4.3 steht kurz vor dem Durchbruch, dann wird spanorg das ganze in die 4.4 portieren und ich denke dann kommt die SD Geschichte und die Grafikfehler dran.

Klasse Arbeit von spanorg.

Gesendet von meinem U9200 mit der Android-Hilfe.de App