TWRP Recovery mit Android 6.0.1 (23.5.A.1.291)

  • 24 Antworten
  • Neuester Beitrag
Diskutiere TWRP Recovery mit Android 6.0.1 (23.5.A.1.291) im Custom-ROMs für Sony Xperia Z2 im Bereich Root / Custom-ROMs / Modding für Sony Xperia Z2.
A

aschix

Neues Mitglied
Gibt es ein TWRP Recovery image das mit Android 6.0.1 (23.5.A.1.291) funktioniert?
Ich habe schon ein paar Versionen ausprobiert (via fastboot) aber ohne Erfolg.
Oder muss ich zuerst wieder auf ein älteres Stock ROM umsteigen?
Danke für Tipps!
 
A

aschix

Neues Mitglied
Ok, vielleicht war das Problem nur, dass vorher das entsprechende boot.img geflasht werden sollte.
Die Beschreibung für die Installation von Resurrection Remix N for Xperia Z2 hat bei mir jedenfalls funktioniert?
 
Aaskereija

Aaskereija

Inventar
nja, du hast wahrscheinlich einfach nur einen anderen Kernel in dem TWRP integriert ist.
 
A

aschix

Neues Mitglied
Offensichtlich lässt sich twrp nur per script installieren und nicht mit fastboot flashen. Info bzw. ein script dazu gibt es in dem XDA Thread.
 
C

COOGOR

Fortgeschrittenes Mitglied
@aschix - warst Du mit der Anleitung aus dem XDA-Thread erfolgreich?
An dem Punkt, dass das TWRP sich nicht mit fastboot installieren lässt bin ich auch gerade. Das Z2 lässt sich nur noch vom PC per ADB ansprechen...
 
A

Android Nutzer 76

Stammgast
im Fastboot Mod werden einfach diese Befehle eingegeben

Fastboot flash Recovery twrp-x.x.x.x-z2.img

sollte funktionieren wenn der botloader offen ist

oder testen mit
Fastboot devices
ob das Handy richtig erkannt wird.
 
C

COOGOR

Fortgeschrittenes Mitglied
Android Nutzer 76 schrieb:
im Fastboot Mod werden einfach diese Befehle eingegeben

Fastboot flash Recovery twrp-x.x.x.x-z2.img

sollte funktionieren wenn der botloader offen ist
Yo, dachte ich auch....hat aber nicht geklappt. Die TWRP Recovery die im Resurrection Remix angeboten wird (Post #2 oben) gibt es als
TWRP-3.1.img
TWRP-Sirius.img
Beide ausprobiert, klappt mit keiner.
 
A

Android Nutzer 76

Stammgast
also bei mir gab's nur Probleme unter Windows 10... wegen der nervigen Treiber Installation. mit Windows 7 hat es dann aber geklappt...
alle Treiber mit den Flashtool installiert und anschließend noch
minimal ADB fastboot 1.4 installiert und damit ging es dann

Minimal ADB and Fastboot
 
A

Android Nutzer 76

Stammgast
ansonsten würde ich das Phone mit der Sony Software EMMA schön zurücksetzen und komplett von vorne anfangen.... der Bootloader bleibt dabei geschlossen.
 
A

Android Nutzer 76

Stammgast
ich meinte natürlich das der Bootloader geöffnet bleibt
 
C

COOGOR

Fortgeschrittenes Mitglied
Android Nutzer 76 schrieb:
ansonsten würde ich das Phone mit der Sony Software EMMA schön zurücksetzen und komplett von vorne anfangen.... der Bootloader bleibt dabei geschlossen.
Minimal ADB....hab noch die komplette ADB installiert gehabt.
Guter Hinweis mit Sony EMMA, ist nur leider Windows -> nutze/hab ich nicht
 
A

Android Nutzer 76

Stammgast
ist nur leider Windows.... richtig.... jedenfalls mit Windows 7 kann man den Flashvorgang viel effektiver nachvollziehen... da hier zu wenig Leute mit Linux so tief in die Materie eintauchen.
bei Windows würde ich auf ein Treiber Problem tippen... aber bei Linux? warscheinlich oder auch nicht??? Windows 7 hab ich z.b. auch in einer VM laufen.... so etwas geht auch unter Linux.... den für manche Sachen ist Windows einfach um einiges besser (bequemer) besonders wenn man fertig werden will.
 
C

COOGOR

Fortgeschrittenes Mitglied
Nun, ich kenne Windows seit den Anfängen (Anfang der 1990er Jahre), und muss es heute noch beim Kunden nutzen. Insofern weiss ich was ich lieber nutze wenn ich fertig werden will :) da ist Windows leider wenig ergonomisch, transparent oder offen. Insofern kann ich die Aussage, dass das 'man den Flashvorgang viel effektiver nachvollziehen' kann - eben nicht nachvollziehen.
Anyhow, hab jetzt wieder ne Stock-Version drauf und starte nochmal neu....
 
A

Android Nutzer 76

Stammgast
naja, eben weil die wenigsten nachvollziehen können. z.b. hier im Forum besser beurteilen kann was schief läuft wenn man Windows 7 als Platform nutzt. sobald hier einer schreibt das er Linux nutzt weiß keiner mehr zu helfen, weil eben niemand hier so richtig weiß wie es mit Linux funzt...
zumal wenn man sich mit Linux 1a auskennt sollte es ja genauso leicht sein wie mit Windows 7... nur wer weiß schon so genau was auf Linux schief gelaufen ist außer sie selbst, oder eben andere Linux Profis...
Mein Kumpel z.b. kennst sich 1a mit linux aus, aber bei sony flashen da kommte er dann zu mir damit ich es für ihn mache da ich letztlich schneller so weit bin... fragt mich dann noch ob er meine windows 7 VM mirnehmen kann damit er es demnächst dann selbst machen kann. fakt ist, egal auf welchen system, wenn ich mich bei beiden erst einlesen muss.... selbst dann bin ich mit windows 7 schneller.
nichts gegen linux.... bestimmte Sachen klappen dort hervorragend.....
e
 
Zuletzt bearbeitet:
C

COOGOR

Fortgeschrittenes Mitglied
Na meist/vielfach liegt das Problem ja auf der Smartphone-Seite, und weniger bei dem System, welches adb oder fastboot aufruft.
Inzwischen konnte ich TWRP über ein Stock-ROM (Siehe Link in der Signatur von Aaskereija) flashen. Der Resurrection Remix (siehe Post #2) ging dann aber trotzdem nicht, weil er eine 'inkompatible Basisversion' bemängelt hat....schaun wir mal was es dazu noch zu finden gibt
 
D

deathrot

Neues Mitglied
Ich steig hier ein, da der Thread-Titel mit einem Fragezeichen auch von mir sein könnte: ich bin seit drei Tagen Besitzer des Xperia Z2, gutes Gerät trotz des Alters, gebraucht bekommen, könnte auch mein Haupthandy werden.
Da ich wegen Bloatware-Entfernung, Speichererweiterung via Link2SD und "Custom-Roms" gerne TWRP und Root installiere und das bei meinen bisherigen Mediatek-Geräten immer problemlos möglich war, wollte ich auch das Z2 rooten und TWRP flashen. Bootloader wurde von mir geöffnet, leider wehrt sich das Gerät standhaft, bis jetzt hatte ich 4 Bricks, immer nochmal zum Laufen bekommen, aber leider noch kein Root :-/

Versucht habe ich bis jetzt folgendes: 1. Temporär Root über Kingroot und mit TWRP-Manager TWRP installiert, Fehlermeldung: keine Recovery-Partition vorhanden.
2. mehrmals über Fastboot verschiedene TWRP-Versionen installiert, vermutlich auch welche für die falsche Firmware erwischt, daher die Bricks, im besten Fall passierte überhaupt nichts

Mit dem Flashtool habe ich bis jetzt das Handy immer nochmal wiederbelebt, desweiteren habe ich darüber auch schon Downgrades auf 5.1 versucht, teilweise scheitert es weil die Datei dann ein .zip ist und keine .ftf, wenn ich eine .ftf bekomme wird sie im Flashtool nicht angezeigt :confused2:.

Maaf, Gerätetreiber, Flashtool, soweit alles vorhanden, vllt kann mir jemand auf die Sprünge helfen und mir die passenden Dateien bereitstellen, bin aktuell etwas ratlos :cursing::confused2:

Edit: unten steht zwar der Screenshot, trotzdem zur Zusammenfassung hier nochmal die Daten: Z2 D6503, Android 6.0.1, Build-Number 23.5.A.0.570, weitere Infos stelle ich gerne bereit

Edit2: grade noch einen Versuch gestartet, Downgrade auf Lollipop schien zu klappen, aber "Prozess com.android.phone wurde beendet" ... mein Latein endet genau hier :confused:
 

Anhänge

Zuletzt bearbeitet:
D

deathrot

Neues Mitglied
Vielen Dank für die Info, ich hab gerade mal das Prerooted-Image geladen, keine Ahnung warum ich den Thread vorher nicht gefunden habe? Das Image wird auf jeden Fall vom Flashtool erkannt und würde sich flashen lassen. Da ich jetzt grad auf die Frühschicht muß, kann ich es erst heut abend wirklich flashen und würde dann einfach mal den Weg des von Dir verlinkten Thread weiterverfolgen. Wenn ich die Dateien ja selbst online irgendwo herkriege, mußt Du Dir nicht die Mühe machen und mir das Zeug schicken, aber schönen Dank für das Angebot.

Falls es im weiteren Verlauf noch Probleme geben sollte, würde ich mich einfach hier nochmal melden.
 
C

COOGOR

Fortgeschrittenes Mitglied
Mach das. Was Du zusätzlich machen solltest: Den Cache wipen, bevor (!) das neue Image aufgespielt wird, Dann kannst Du dir evtl den Umweg über das Prerooted image sparen
 
D

deathrot

Neues Mitglied
Also: ich hatte jetzt mit dem pre-rooted Image angefangen, gleiche Fehlermeldung wie oben, "Prozess com.android.phone wurde beendet". Nächster Schritt war trotzdem die Installation der boot.img aus der RR-Rom und der Sirius-Twrp über Fastboot. Was soll ich sagen, ich komme tatsächlich ins TWRP! Dann die RR-Rom direkt geflasht nach FullWipe, bei den Gapps hatte ich zuerst eine falsche Version, mit der richtigen lief das dann auch. Jetzt läuft wirklich Oreo auf dem Gerät, suche grad noch eine SU.zip, dann sollte root auch klappen, also alles erledigt was ich mir vorgenommen hatte! Big Thumbs up!:thumbsup: Vielen Dank für die Hilfe Coogor, manchmal braucht man einfach nur den richtigen Hint an der richtigen Stelle, dafür warst Du diesmal zuständig