TWRP erkennt SD nicht, System (AICP13.1) erkennt die SD

  • 17 Antworten
  • Neuester Beitrag
Diskutiere TWRP erkennt SD nicht, System (AICP13.1) erkennt die SD im Custom-ROMs für ZTE Axon 7 im Bereich Root / Custom-ROMs / Modding für ZTE Axon 7.
borisku

borisku

Lexikon
Für mich schwer verständlich: Nach längerem Nichtgebrauch taucht obiges Problem auf: Das System erkenn und liest die SD, TWRP (TWRP_3.2.3-0L_v1.3-Axon7-Labs_Mod.img) zeigt nichts an und behauptet, das Dateisystem sei vfat (extfat ist es) hat jemand ne Idee?
 
Carl52

Carl52

Erfahrenes Mitglied
@borisku da ich das selbe Problem hatte, glaube ich das es an der Vendor liegt. Denn als ich LineageOS drauf hatte wurde die SD angezeigt und nach Rückkehr auf Stock auch. Andererseits funktioniert die SD auf dem anderen A7 mit Liquid Remix.
Bleibt nur noch eine Erklärung: die A7 wernden in Heimarbeit per Hand gefertigt und dann kann so was schon mal passieren.;) Ich hatte übrigens die selbe TWRP drauf, also mal eine andere probieren?
 
BaamAlex

BaamAlex

Ehrenmitglied
Dafür hättest du aber keinen extra Thread für aufmachen brauchen :1f606:

Zumal du damit sowieso diesen etwas falsch "positioniert" hast um es mal so auszudrücken. Ich bin aber darüber hinaus immer damit gut gefahren wenn ich die SD Karte in der TWRP mit ext4 formatiert habe. Das sollte keine Probleme in TWRP verursachen und im OS ebenfalls nicht. Probiere das doch mal ;)
 
Piste

Piste

Fortgeschrittenes Mitglied
Ich habe auch immer gute Erfahrungen gemacht, wenn ich die Karte in dem für die Nutzung vorgesehenen Gerät formatiert habe.
Die Daten kannst du ja vorher auf dem PC sichern und dann per Datenkabel auf die SD-Karte im Gerät zurückspielen.
Das hat bei mir bislang immer sehr gut geklappt.
 
Carl52

Carl52

Erfahrenes Mitglied
seltsam ist es trotzdem. Dieselbe SD-Karte in anderen A7 hat problemlos funktioniert.
 
borisku

borisku

Lexikon
Hmm, falsch psitioniert? Ich war davon ausgegangen, dass das möglicherweise mit AICP13 zusammenhängt, von mir aus verschiebs gerne. Ich weiß jetzt, dass offenbar der Schreibschutzeffekt von defekten Sandisks diesen Effekt verursacht. Selbst eine Löschung der Partition bzw. eine Formatierung mit dem SD Formatter übersteht die SD unbeschadet... beim Auslesen werden ca 15 defekte Sektoren gefunden... Bin mal gespannt, ob der Ersatz wieder prblemlos klappt... Bei mir wird die Karte in beiden A7 nicht erkannt, gleicher Effekt... @BaamAlex: Danke für den Tipp, Aber: Wie soll ich die Karte im TWRP mit ext4 formatieren, wenn Sie nicht erkannt wird? "Kann nicht gelöscht werden", Fehler beim Ändern des Dateisystems hör ich vom TWRP...
 
Zuletzt bearbeitet:
BaamAlex

BaamAlex

Ehrenmitglied
Den Beitrag verschiebe ich später. Formatiere sie mal am PC mit einem anderen Dateisystem was die TWRP vielleicht erkennt. Dann wieder ins Telefon und ext4 draufhauen. NTFS sollte nicht schaden. Wie groß ist die Karte überhaupt? FAT32 sollte auch gehen.
 
Piste

Piste

Fortgeschrittenes Mitglied
FAT32 muss das Axon 7 erkennen. Formatiere mal komplett am PC, nicht Schnellormat.
Ich hatte auch schon einiges Theater mit angeblich schreibgeschützten SD-Karten.
Umtauschen musste ich zum Glück noch keine. Ich drücke dir die Daumen.

Wie alt ist die Karte eigentlich? Nicht, dass die doch das Zeitliche gesegnet hat..
 
Carl52

Carl52

Erfahrenes Mitglied
Mit TestDisk kannst du die Partitionstabelle entfernen. Anschließend solltest du wieder eine Partition erstellen können.
HPUSBFW hat mir auch schon weiter geholfen. Habe eine 256 und eine 64 GB Karte. Beide mit FAT32 formatiert und beide funktionieren poblemlos.
 
borisku

borisku

Lexikon
Das sind 400GB, bislang lief die mit exfat problemlos.... SD Formatter ist ein PC Prog und auch die Partition hab ich mit dem AOMEI Partition Assistant Standard Edition 6.3 zu entfernen versucht, erfolglos... Besonders alt dürfte die Karte noch nicht sein, 2 oder 3 Jahre maximal... Ich habe 3 Stück davon, deshalb wird es mit Alterzuordnungen schwierig
@edit: Mit keinem Toll ist es gelungen, die Partition zu löschen oder zu formatieren... Es gibt zwar immer Erfolgsmeldungen, aber wenn ich dann auf die Karte gucke: Alles wieder da... Manchmal wünscht man sich das ja, aber im Moment grad nicht... Werde die Karte an sandisk zurücksenden... Dank für eure Hilfe!
 
Zuletzt bearbeitet:
Carl52

Carl52

Erfahrenes Mitglied
Um den Fehler einzugrenzen solltest Du (falls Du das noch nicht gemacht hast) 2Wege verfolgen:
a- funktioniert im A7 eine andere SD-Karte?
b- funktioniert die SD-Karte in einem andern Smartphone?
Auf die Windowsformatier-Tools solltest Du Dich nicht verlassen, die erfüllen gerade die Grundbedingungen.
Ich habe gerade heute herausgefunden, daß ein Smartphone eine SD-Karte auf die ich mit anderen Tools nicht zugreifen konnte, hervorragend formatiert hat. Also die Karte des Anstoßes mal in einem anderen Handy formatieren. Wenn das nicht klappt, ist sie höchstwahrscheinlich defekt.
 
borisku

borisku

Lexikon
Also, eine andere Karte funzt im A7, und in einem anderen A7 macht die sandisk 400 die gleichen Probs... Das Formatieren in einem anderen Handy werde ich noch mal testen, aber ich gehe auch auf Grund der Überprüfung mit gemeldeten defekten Sektoren (Größe stimmt nicht) von einer defekten Karte aus, habe schon Kontakt zu Sandisk aufgenommen!
 
Carl52

Carl52

Erfahrenes Mitglied
@borisku mit anderen Worten: Dein A7 ist in Ordnung :thumbsup:. Wenn die Karte in einem anderen Handy sich nicht formatieren läßt nimmst Du halt eine andere. Die Ausage mit der defekten Sektorgröße hatte ich auch, aber ein anderes Handy konnte die Karte trotzdem formatieren. Noch etwas: die max. Größe beim A7 soll 256GB sein. Vielleicht ist das der Grund.
 
Zuletzt bearbeitet:
borisku

borisku

Lexikon
Das kann nicht sein, weil bisher alle 3 400er Karten in übrigens allen meinen Android Handys anstandlos funktioniert haben... Fremdformatierung werde ich testen! thx
 
Carl52

Carl52

Erfahrenes Mitglied
... und wieder was dazugelernt
 
borisku

borisku

Lexikon
Karte defekt: Amazon hat die problemlos getauscht (habe sie zerschnitten zurückgeschickt, weil da wesentliche persönliche Daten Passwortsammlungen drauf waren, die weder durch Löschen noch durch Formatieren/Partitionieren zu löschen waren)
 
BaamAlex

BaamAlex

Ehrenmitglied
@borisku wie geht das denn?
 
borisku

borisku

Lexikon
Ich habe die Karte erst bei Amazon mit Hinweis auf das "Nicht zu löschen"-Problemreklamiert und daraufhin sofort eine neue Karte zugeschickt bekommen, die alte habe ich mit Tesaband umhüllt, mit einer kräftigen Schere mitten durchgeschnitten und dann so zurückgeschickt, ganz einfach ...
 
Ähnliche Themen - TWRP erkennt SD nicht, System (AICP13.1) erkennt die SD Antworten Datum
3
39
21