K9-Mail - Einige Fragen

  • 151 Antworten
  • Neuester Beitrag
Diskutiere K9-Mail - Einige Fragen im K9 / K-@ Mail / Kaiten Mail im Bereich E-Mail.
Status
Für weitere Antworten geschlossen.
C

cyorps

Stammgast
Doch, das gibt es in den allgemeinen Einstellungen -> Benachrichtigung -> Ruhezeit. Spam markiert man über das Kontextmenü -> Spam.
 
D

droit

Erfahrenes Mitglied
Moin in die Runde, ich häng mich mal mit rein.

Habe Probleme mit k-9. Betreibe ihn als POP3 Client. Das sollte auch so bleiben.

Probleme:

1.) Holt die Mails manchmal nicht im eingestellten (15min) Zeitraum ab, manchmal erst nach ner Stunde oder so ...

2.) Hängt sich immer wieder beim PollService auf, Dauer zuletzt über 2 Std.

Ausführliche Infos:
https://www.android-hilfe.de/forum/samsung-galaxy-s2-i9100g.545/k-9-mail-empfangsproblem.262166.html

Hoffe, dass jemand eine Idee hat

Danke
Droit
 
C

cyorps

Stammgast
Die Benutzung des POP3-Protokolls mit der Option, dass eine Kopie der Nachricht auf dem POP3-Server gespeichert wird, funktioniert so: Nach der Benutzerauthentifizierung sendet der Emailclient den Befehl "STAT" um die Headerinformationen aller im Postfach befindlichen Emails zu erhalten. Jetzt sendet der Client einen UIDlist-Befehl an den POP3-Server und die zurückgegebenen Informationen gleicht der Client mit den UID's seiner internen Datenbank ab. Wird diese ID einer Nachricht auf dem Server nicht gefunden, so wird sie abgerufen. Wenn sie gefunden wird, wird sie dort belassen. Da UIDL kein m:n-Kommando ist, macht der Client dies mit jeder einzelnen Email, bei jeden Abruf. Jetzt könnte gerade bei mobilen Geräten noch eine Netztrennung a la "3G - 2G - Kein Netz" hinzukommen. In diesem Fall holt der Client den fehlgeschlagenen Abruf sofort mit Verbindungsaufnahme nach (egal welche Intervalle definiert hast) und beginnt wieder von vorne.

Ohne die Anzahl deiner Emails und die Geschwindigkeit deiner mobilen Leitung zu kennen, empfinde ich das von dir beschriebene Verhalten als normal. Zumal du in einem Nebensatz der genannten Diskussion etwas von
(Samsung-Standard-Mail-App + K-9 funzt nicht
schreibst. Es scheint also nicht nur an K9 zu liegen. Ich würde an deiner Stelle alle (kostenlosen) Apps ausprobieren und schauen, welche App mit dieser Funktion am Besten umgehen kann.
 
D

droit

Erfahrenes Mitglied
Hallo cyorps,

danke für die schnelle Anwort.

Die Probleme mit der Samsung Standard Mail App hatte ich mit O2, aber auch im Wlan

So ganz habe ich (leider immer noch nicht) nicht verstanden, warum der PollService manchmal 2 Std. gedauert hat, sich also aufgehängt hat, oder aber auch Mails nicht abgeholt werden, obwohl eine Abfrage gemacht wird.

Jetzt habe ich Simyo (E+) und die Geschwindigkeiten sind meist H, E manchmal 3G.

Ich würde an deiner Stelle alle (kostenlosen) Apps ausprobieren und schauen, welche App mit dieser Funktion am Besten umgehen kann.
Hätte bei pop3 keine Probleme erwartet.

Werde es nochmal mit der Standard Mail App testen, danach
- MailDroid
- Aqua Mail

Besseren Vorschlag oder Tipp bzgl. Reihenfolge?

Reicht es aus vor neuer App, "auf Werkseinstellungen zurücksetzen" um alte störende Mailprogrammreste / Fehlfunktionen zu eliminieren?

Kann es vielleicht auch ein Hardwareprob des Phone sein?

Dank an alle die helfen.

Droit
 
Zuletzt bearbeitet:
D

droit

Erfahrenes Mitglied
Problem besteht auch bei neuer Version 4.011:mad:

Mail App's (kostenlose Versionen) ausprobiert:
- Maildroid -> permanente Werbeeinblendung im Postfach
- Aquamail -> Werbelink in versendeten Mails
aus diesen Gründen direkt wieder deinstalliert

Gruß
droit alias Rudi Ratlos
 
O

officiallyme

Stammgast
funktioniert bei euch das abrufen per push noch?

ich habe ein gmx konto als imap eingerichtet und dazu push.
hatte bis vor kurzem noch top funktioniert aber seit 2-3 tagen funktioniert es nicht mehr richtig.
 
W

__W__

Guru
droit schrieb:
... Probleme mit der Samsung Standard Mail App hatte ich mit O2, aber auch im Wlan ...
Ist das Problem-POP3-Konto, dein O2-Mail-Konto?
Wenn ja, würde das vieles erklären. Der Zugang bei O2 via POP3 ist manchmal derart langsam, das jeder Client in 'nen timeout läuft. Manchmal bekommt man auch gar keine Verbindung :cursing: . Eher selten, schnell und stabil.

Gruß __W__
 
D

droit

Erfahrenes Mitglied
__W__ schrieb:
Ist das Problem-POP3-Konto, dein O2-Mail-Konto?
Nein, das Problem-POP3-Konto liegt auf dem Server des Hosters meiner eigenen de Domain. O2 benutze ich nicht mehr, habe zu E-Plus gewechselt.

Kann denn der Mobilfunkanbieter für die Problematik bei einer POP3 Abfrage mitverantwortlich sein, sofern es keine Netzstörung ist?
 
W

__W__

Guru
droit schrieb:
Kann denn der Mobilfunkanbieter für die Problematik bei einer POP3 Abfrage mitverantwortlich sein...
Der Mobilfunkanbieter kann natürlich mitverantwortlich sein, er stellt ja die "Datenleitung" her und wenn auf dieser Leitung Störungen wie Packetverluste, aus welchen Gründen (Überlastung, Störeinstahlungen, ...) auch immer, auftreten (das ist noch keine Netzstörung), kann es auch zu deinen Fehlern/Problemen kommen.
Bei O2 liegt es wohl am Mailserver selber, denn der Abruf via POP3/IMAP ist mit 'ner "Festleitung" genauso grottig.
Du kannst ja mal deinen Mailserver mit einer Software wie Ping & DNS anpingen (20x am Stück), dann siehst du, ob's Packetverluste gibt.
Ansonsten das POP3-Konto vom Rechner aus abfragen (natürlich mit den gleichen Einstellungen wie auf dem Handy :cool2: ) und in die Protokolle deines EMail-Clients schauen, ob der Mailserver vielleicht irgend welchen Unsinn treibt. Beliebte Problemstellen sind immer die Authentifizierung, die Ports und die Verschlüsselung.

Gruß __W__
 
D

droit

Erfahrenes Mitglied
@ __W__

Danke für die schnelle Info. Das Tool lade ich mir runter und teste dann mal.

Gibt es auch ein Tool, mit dem ich den benutzten Sendemast prüfen kann?
 
W

__W__

Guru
OT

droit schrieb:
... ein Tool, mit dem ich den benutzten Sendemast prüfen kann?
Es gibt diverse Tools ( z. B. Network Info II oder Network Signal Info , mit der du den momentan genutzten Sendemast und die Nachbarzellen auslesen kannst. Prüfen kannst du da aber nichts :crying: .

/OT

Gruß __W__
 
M

Maydonoz

Neues Mitglied
Hallo zusammen,

ich habe folgendes Problem bzw. eine Kleinigkeit die mich stört, bei der K9 Ordneranzeige für mein Gmail-Konto!

In den "Kontoeinstellungen" habe ich unter dem Menüpunkt "Ordner" den Speicherort für die Ordner Entwürfe, gesendete Objekte, Spam und gelöschte Objekte angegeben. Nun stehen hinter den genannten Ordnern jeweils in Klammern die selbe Bezeichung als Beispiel:

[GoogleMail]/Papierkorb (Papierkorb)

Da ich diese Ansicht etwas unsinnig finde, möchte ich gerne die Bezeichnungen in den Klammern weg haben! Nur wie funktioniert das genau? :sad:
 
C

cyorps

Stammgast
Dafür gibt es keine Lösung.
 
M

Maydonoz

Neues Mitglied
Hmm das ist natürlich etwas blöd. Bei meiner ersten Einrichtung des Kontos brauchte ich auch keine Ordner zuzuweisen. Nur nach dem ersten Versand etc. hat er von alleine einen Ordner umgestellt und damit alle Ordner zugewiesen sind, habe ich alle entsprechend eingerichtet.
 
C

cyorps

Stammgast
Ich kann deine Enttäuschung nachvollziehen. Dieses Feature existiert deshalb, da andere, anscheinend viele Benutzer, unterschiedliche Systemordner zwischen Ihren Geräten verwenden. Die nutzen beispielsweise, einen zusätzlichen IMAP-Ordner als Papierkorb um eine Unterscheidung zu haben, was sie auf dem Mobilgerät und was sie auf dem Laptop gelöscht haben. Um zu sehen, welchen Ordner K9 nun wirklich als Papierkorb verwendet, existieren diese Informationsanzeigen wie z.B. (Papierkorb).

Wenn du Lust, Zeit und Nerven hast könntest du bei den Entwicklern nachfragen, ob man diese Informationsanzeige z.B. per Option ausblenden lassen könnte. Denn aus der Erinnerung heraus ist soetwas bei den K9-Entwicklern schon lange nicht mehr nachgefragt worden.
 
holliwood

holliwood

Stammgast
Hi Leute, ich klink mich ma hier ein mit folgender Beobachtung:

Habe immer mal wieder, dass K9 für einen hohen Akkuverbrauch verantwortlich ist. Habe jetzt mit BetterBatteryStats ausgelesen, dass nach 3 Std Handynutzung der K9 Count bei den Partial Wakelocks bei knapp 2000 liegt und als Zeitangabe über 12min insg. steht.

Ich nutze meinen gmail Account via IMAP, pushe den Posteingang und synchronisier Mails der letzten 2 Tage und das nur im Posteingang. Hat jemand ne Idee wie dieser rel. hohe Wert zu Stande kommt? Hängt sich da viell. irgendwas auf bzw. gibt es Einstellungen, die ich nochmal überprüfen sollte?

Danke vorab und nen schönen Abend
 
C

cyorps

Stammgast
Probleme dieser Art tauchen in der Fehlerliste von K9 immer mal wieder auf. Doch entweder verlaufen sie im Sande oder es war dann doch ein anderes Problem. In letzter Zeit wurde übrigens kein ähliches Problem bei den K9-Entwicklern gemeldet, ich es als wahrscheinlich erachte, dass dieser Fehler nicht direkt an K9 liegt. Und wenn es an Google liegen würde, wären die Androidforen voll von ähnlichen Diskussionen.

Daher:
Welche K9-Version nutzt du? Hast du einmal die neuste Version von K9 (direkt von der Entwicklerseite ->Download&Nutzung selbstverständlich auf eigene Gefahr) ausprobiert? Hat sich seit dem Auftreten dieses Problems etwas am Betriebssystem oder an System-Apps geändert (Custom-ROM, partiell Systemapp serneutert etc)? Wenn die Beantwortung dieser Fragen nicht zielführend sein sollten, könntest du auch einen Problembericht bei K9 erstellen. Oftmals sehen die Entwickler mit einem Blick in das Debug-Protokoll, was schief läuft.
 
holliwood

holliwood

Stammgast
Danke schonma für die Antwort... werde mal die neue Version testen.... würd generell mal wissen ob die Zahlen, die BetterBatteryStats mir gibt "normal" sind für meine Einstellungen bei K9.

Nicht unwichtig zu erwähnen ist vielleicht, dass es v.a. auftritt wenn ich mit 2G (manchma 3G) unterwegs bin bzw. schwaches Netz habe... wird bspw. im Zug immer wieder neu synchronisiert wenn das mobile Netz mal kurz aussetzt?
Im WLAN sind nämlich Probleme dieser Art nicht zu beobachten.
 
C

cyorps

Stammgast
Diese Zahlen von BattStatts sind schwer bis gar nicht vergleichbar, da diese Werte von vielen Faktoren wie Gesamtbetriebszeit, Anzahl der Konten, wieviele Ordner davon Push, Sync etc. abhängt. Ich verwalte in K9 sieben IMAP-Emailkonten Push/Sync gemischt (mehrheitlich Sync), das Mobile arbeitete sowohl im WLAN als auch im Funknetz (letzeres mehrheitlich). Auf aktuell 38 Stunden und 41 Minuten Betriebszeit seit dem letzen Ladezyklus, komme ich bei K9 auf 566 Partial Wakelocks mit einer Aktivitätszeit von einer Stunde und 24 Minuten.
 
Kusie

Kusie

Experte
Hallo zusammen,

kann es sein, dass sich bei K-9 mail nicht mehr so arg viel tut in leztzter Zeit? Es ist zwar komplett kostenlos und auch sicher eines der besten Mailprogramme für Android, aber es gibt doch noch recht viele Schwächen und vor allem ist die Usability und die Optik IMHO absolut schlecht.

Nervig z.B.: Ich sende mir einen etwas längeren Link als Reminder selbst zu, und es ist einfach nicht möglich diesen Link (testweise in das Subject und auch nochmal in den Body kopiert) einfach mit dem Finger anzuklicken um ihn im Webbrowser zu öffen - das geht gar nicht. Wenn ich versuche den Link wenigstens als Text in die Zwischenablage zu kopieren geht das auch kaum, da sich der Gestenzoom und das Textauswählen in die Quere kommen ...

Zum Thema Usability: wer ein Emailprg mit mehr als 2 Konten betreibt der merkt nach 2 Minuten, das auf dem Bildschirm mit der Kontenübersicht ein großer Button "alle Konten auf neue Mails prüfen" hingehört, derzeit muss man zwei weitere klicks machen (menütaste -> nachrichten Abrufen) um das zu bewerkstelligen... Schnelle Unterordnerauswahl bzw. Darstellung der Unterordner als Baustruktur, zweispaltige Ansicht uws usf. ... es gäbe soviel zu optimieren.

Ich ertappe mich immer öfter dabei nach was anderem zu schauen, auch wenns Geld kostet. Schade eigentlich.

Gruß,
Kusie
 
Status
Für weitere Antworten geschlossen.