K9-Mail verbrät ungebremst Akku und Volumen

  • 3 Antworten
  • Neuester Beitrag
Diskutiere K9-Mail verbrät ungebremst Akku und Volumen im K9 / K-@ Mail / Kaiten Mail im Bereich E-Mail.
C

Chefi

Neues Mitglied
Hallo alle zusammen,
obwohl ich im eigentlich ein digital-native bin hab ich jetzt mein erstes "Smartphone" ein Z3 Compact mit Android 5.0.2.
Wie gewohnt bei einem neuen Spielzeug erstmal alles eingerichtet,
wollte dann schließlich auch endlich meine Mail-Accounts synchronisieren.
Schnell war klar, K9 Mail ist die App der Wahl, IMAP bei fortgeschrittenen Usern sowieso Pflicht.
Also alle meine Sechs Konten bei IMAP eingerichtet, so doof das klingen mang ich brauche alle: Googlemail, AOL, Hotmail, WEB.de, GMX.net und meine Uni-Adresse.
Die gewünschte Konfiguration sollte dann sein das K9 bei allen Accounts für alle Ordner eine Push Verbindung hält, und wenn ich daheim im sicheren WLAN und bei meiner Steckdose bin möchte ich manuell alle Ordner mit ALLEN Nachrichten synchronisieren, daher Auto-Abfrage auf nie aber wenn dann manuell und alles und Push-Ordner auf alle Ordner aber maximal zehn.

Schnell kam bei Hotmail die Ernüchterung: Die IMAP-IDLE-Push Geschichte unterstütz MS nicht und gibt für K9 auch nicht ihren Exchange Kram frei.
Also muss ich das Konto halt von Zeit zu Zeit manuell synchronisieren oder ich stelle ich Push aus und eine Auto-Abfrage an.
Die Hintergrund-Synchronisation habe ich in den allgemeinen Einstellungen ans Auto-Sync von Android gekoppelt.
Das deaktivieren dieser löst zwar das gleich folgende Problem, aber auch jegliche Push-Aktivität.

Und es funktioniert auch prächitg, die anderen 5 Konten bimmeln praktisch "instant", bei der Registrierung hier über WEB.de blinkte die LED am Handy noch bevor Outlook 2013 überhaupt wusste was gebacken war.

Jetzt hat sich aber nach mehreren Tagen K9 Mail als mit der größte Stromfresser hinter dem Display rausgestellt, obwohl z.B. heute nur 5 Mails gekommen sind. Liegt mit 10 Prozent und etlichen Huntertausend verschickten Paketen direkt hinterm Display, obwohl ich 1,5 Stunden RealRacing gezockt habe was in der Zeit nur 4 Prozent gezogen hat.
Weitere Symptome:
Startet man das Handy neu, verhält sich auch K9 ruhig, gibt Meldung wenn man Emails erhält und pusht ohne in der Statistik auffällig zu werden.
Öffnet man es allerdings einmal, dann drehts durch.
Scheinbar ist es im Hintergrund dann immer am Funken.
Überrascht man es dann sieht man ab und zu wie es immer oben in der Status Leiste hier und da einen Ordner synchronisiert, was je nach Ordner eben ab und zu mal auch X-tausend E-Mails sein können. Syncht er die einmal am Tag bei mir im 50.000er WLAN wärs mir egal, aber aus irgendeinem Grund manövert K9 da die ganze Zeit ungefragt rum und sich einen Wolf.
So verbrät es dann am Tag 10-20MB ohne irgendwas zu tun. Obwohl es ja nur 6-Push Verbindungen halten soll.

Meine Internet-Verbindung sieht so aus als das ich ständing zwischen verschiedenen WLAN Quellen hin und her renne und zwischen durch auch mal 3G nutze, beides ist durchgängig aktiviert.
Mit der Vermutung das es am ständigen Neuaufbau der Push-Verbindung da überhaupt ständiger Verbindungsneuaufbau liegt habe ich die Funktion "Abruf beim Start der Push-Verbindung" unter den erweiterten Einstellungen zu Nachrichten abrufen jetzt mal deaktiviert in der Hoffnung das es daran lag. Werde das Verhalten dann über diese Nacht und morgen über Tag mal beobachten.
Wenn gewünscht lade ich gleich noch Bilder von meiner allgemeinen Ernergiestatistik und der Statistik von K9-Mail hoch.

Hat denn sonst noch einer Ideen und Vorschläge warum K9 so ressourcenunschonend bei mir arbeitet und welche Einstellung ich da verbockt haben könnte, falls das morgen immer noch nicht so arbeitet wie gewünscht?
 
neodrei

neodrei

Stammgast
Ich habe ähnliche Einstellungen wie du und quasi die gleichen Probleme.
K9 hatte gestern bei mir 28% (!!!!!) Anteil am Akku"verbrauch"... das hatte ich mit ähnlichen Einstellungen bei anderen Anwendungen nie...

Wäre mal interessant zu wissen, woran das liegen könnte!
 
Miss Montage

Miss Montage

Ehrenmitglied
Hmm. Wenn k9 bei mir überhaupt in der Verbrauchsliste auftaucht, dann mit höchstens 2%. Mein E-Mail-Verkehr ist aber auch ziemlich geringfügig. Ich glaube aber nicht, dass k9 18-20 MB "verbrät, ohne irgend etwas zu tun". Die hat die App herunter geladen bzw. versendet, weil @Chefi irgendwo eingestellt hat, dass es so erwünscht ist. Ich vermute, dass k9 nach Kräften rückwärts synchronisiert
Ich würde mal in Ruhe die Konten- und Ordner-Einstellungen durchsehen. "Abzufragende Ordner" auf "nur Hauptordner" festlegen, Push-Ordner ebenso. "Nachrichten automatisch laden bis" steht bei mir auf 32KB (wie niedlich!). "Nachrichten synchronisieren" ist bei mir nicht eingeschränkt, bei 6 Ordnern und regerem Traffic ist es vielleicht sinnvoll, z.B. "der letzten 3 Monate" auszuwählen.
 
E

ernie34

Fortgeschrittenes Mitglied
Die Android-Version wäre jeweils interessant. Habe das Moto G 4G (1st gen) und seit dem Update auf 5.1 ziehen sämtliche Push-Dienste enorm am Akku. Habe alle gängigen Mail Apps ausprobiert und überall tritt derselbe Bug auf. Liegt also nicht an K9, sondern an einem bekannten Lollipop-Bug. Die Mobilfunk-Schnittstelle wird hierbei permanent aktiv gehalten, was natürlich am Akku zährt. Bei bestehender WLan-Verbindung tritt das Problem nicht auf.