[Laberthread] LineageOS für Aquaris X / X Pro?

  • 1.096 Antworten
  • Neuester Beitrag
Diskutiere [Laberthread] LineageOS für Aquaris X / X Pro? im LineageOS Forum im Bereich Root / Custom-ROMs / Modding für bq Aquaris X / X Pro.
B

bqNoob

Neues Mitglied
Kann mal bitte jemand die 1822 tan+ App auf seinem nicht gerooteten X Pro mit unlocked bootloader starten und gucken ob es eine Warnung gibt? Das müsste auch gehen wenn man kein Kunde bei der Bank ist. Es wäre traumhaft wenn es dann noch jemand mit root testen könnte. =)

Ich steige an einem Wochenende um auf LOS. Falls was schief gehen sollte habe ich dann genug zu tun:D
 
Zuletzt bearbeitet:
K

Kai B

Ambitioniertes Mitglied
Hallo,
mein Aquaris X ist mit magisk gerootet. Die 1822 tan+ läuft problemlos. Aber erst nach Einschalten der Hide-Funktionen...
 
B

bqNoob

Neues Mitglied
Tausend Dank!!
 
T

Tooo

Ambitioniertes Mitglied
Quallenauge schrieb:
Hi. Ok, dann hier offiziell: Ich habe das Gerät aus der LOS16 Liste entfernt. Aktuell gibt es also "nur" LOS17.1.

Ich habe leider auch nur beschränkt Zeit und mein Development Telefon dauernd auf eine ältere Version zu flashen ist sehr aufwendig...
Hallo Quallenauge,

vielen Dank erst mal für die viele Arbeit, die du in LOS fürs X Pro gesteckt hast und noch steckst.
Es lief immer alles super bei mir. Ich nutze LOS + MicroG (LineageOS for microG) und würde dies auch sehr gern weiter nutzen. Leider geht das aktuell aber nur mit LOS 16.
Welche Arbeit würde denn anfallen, um weiter LOS 16 Updates bereit zu stellen? Ich würde dir die Arbeit ja gerne abnehmen aber weiß nicht in wie weit ich dazu in der Lage wäre. Ich bin leider kein Software Enwickler, könnte mich aber vielleicht ums Testen kümmern? (hab immerhin 2 X Pro, von denen eines als Testgerät genutzt werden kann)
Und vielleicht würden sich ja noch andere Leute finden, die helfen würden...
 
T

Tooo

Ambitioniertes Mitglied
@Ralle666

Danke für den Tipp. Das schöne an LineageOS mit MicroG ist aber eben, dass man nicht erst irgendwie den signature spoofing patch reinfrickeln muss.
Bei deiner Variante geht das zudem ja nur über dieses komisch Windows Tool. Zum einen nutze ich eigentlich nur Linux und zum anderen ist das Tool auch nicht OpenSource, es weiß also keiner was es sonst noch so tut.

btw: Wie ist das denn eigentlich mit dem Signature Spoofing? Muss man das bei jeden Update wieder erneut patchen oder ist das eine einmalige Sache?
 
R

Ralle666

Neues Mitglied
Nutze wenn es irgendwie geht, auch nur Linux.
Da es ein magisk Modul ist, wird automatisch gepatcht. Klappt aber leider nicht immer, wahrscheinlich wenn sich das framework ändert. Dann muss wieder über PC das Modul neu gebaut werden.
Hoffe auch, dass das microg update bald kommt und es wieder los4microg gibt...
 
T

Tooo

Ambitioniertes Mitglied
Ok, danke dir.
Dann werde ich noch mal ein bisschen abwarten, ob nicht vielleicht doch demnächst los4microg in der aktuellen Version kommt.
Irgendwie konnte ich auch nichts dazu finden, woran das aktuell scheitert. Hat jemand Infos dazu?
 
T

Tooo

Ambitioniertes Mitglied
Danke für die Links, den Threads zu folge scheint ja zumindest noch jemand dran zu sein.
Allerdings bin ich überrascht das es sowohl für MicroG also auch für LOS4MicroG scheinbar aktuell jeweils nur einen (mehr oder weniger) aktiven Developer gibt. Insbesondere das MicroG Projekt hätte ich deutlich größer eingeschätzt...
 
Zuletzt bearbeitet:
onlyfor.foren

onlyfor.foren

Stammgast
Update vom 18.07.2020 gestern eingespielt.
Läuft hier problemlos.
Stand der Sicherheitsupdates 5.7.2020,
 
Z

zut

Neues Mitglied
Update von 11.08.2020 läuft bisher ohne erkennbare Probleme.
 
Q

Quoti

Neues Mitglied
Halli Hallo in die Runde,
Ich habe seit Monaten das Problem, dass der Vibrationsalarm quasi unnütz ist. In TWRP vibriert er schön stark, so dass ich einen Anruf auch mitbekommen würde(wenn er diese Intensität auch in Android hätte).
Deswegen nun meine Frage:
Gibt es irgendeine möglichkeit die intensität des Vbirationsmotors in Android zu ändern?
Irgendwie muss es ja gehen wie TWRP zeigt.
Ich weiß das wurde hier und da schonmal besprochen, aber ich finde einfach keine Lösung, und so verpasse ich einfach jeden Anruf, da ich quasi nur den Vibrationsalarm benutze.

Bin auf LOS17.1 (von Ende Juli) inkl Root und Magisk,

Danke schonmal
 
moidept

moidept

Experte
@Quoti , mich stört es mit der praktisch nicht vorhandenen Vibration auch sehr, hier X / X Pro Vibration
wurde das bei der Stock-ROM auch angesprochen, damals hatte ich einen der behauptet hatte, dass lösen zu können leider wurde nix daraus.
 
der_tiroler

der_tiroler

Erfahrenes Mitglied
onlyfor.foren schrieb:
Hat einer einer von euch eine Erklärung, wann das nächste Update "gebacken" wird?
Laut LOS-Reddit ist einer der Admins, genauer gesagt derjenige der die Infrastruktur betreut, seit einiger Zeit am umziehen.
Da er den Singnaturserver privat zuhause betreibt (aus Sicherheitsgründen will man bei LOS die Zertifikate mit denen die Zip´s signiert werden nicht in einem externen Rechenzentrum hosten) kann das noch einige Tage dauern bis es neue Builds gibt.
 
onlyfor.foren

onlyfor.foren

Stammgast
Besten Dank für die Info. 👍
 
der_tiroler

der_tiroler

Erfahrenes Mitglied
Falls es wer nicht bemerkt hat, die Server laufen wieder.
Gestern kam ein OTA fürs X.
Das Pro wäre gemäß dem Weekly-Rhythmus dann am Samstag dran.
 
Zuletzt bearbeitet:
onlyfor.foren

onlyfor.foren

Stammgast
@der_tiroler
hattest Recht.
Heute kam das Update vom 29.8. per OTA raus.
Stand der Sicherheitsupdates 5.8.2020
Installation verlief problemlos durch.
 
Zuletzt bearbeitet:
onlyfor.foren

onlyfor.foren

Stammgast
Kleiner Nachtrag.
Ich habe heute festgestellt, dass ich weder anrufen kann, noch angerufen werden kann.
Auch die Freisprecheinrichtung wollte nicht mehr.
Nach einem heutigen Neustart war wieder alle in Butter.
 
Ähnliche Themen - [Laberthread] LineageOS für Aquaris X / X Pro? Antworten Datum
2
0
7