1. Hast Du Lust, bei uns mitzuarbeiten und das AH-Team zu verstärken? Alle Details zu dieser aktuellen Herausforderung findest Du hier.
  1. badticket, 02.10.2017 #1
    badticket

    badticket Threadstarter Android-Experte

    Hallo,

    aktuelle Firmware meines Shield TV ist vom 28.09.2017

    ich betreibe meine Shield an einem Ligawo Switch der das Bild nimmt und den Ton über Toslink an meinen Verstärker (der kein HDMI hat) weitergibt.

    XBMC habe ich so eingestellt das via Audio Passthrough der Ton (DolbyDigital) an den Verstärker übertragen wird. D.h. die Audio Verkabelung zum Receiver funktioniert mit 5.1 DD (aus XBMC).

    Netflix, Amazon reagieren mit der Einstellung "Surround Sound immer" mit Bildrucklern und fehlendem Ton. Wenn ich in Netflix 5.1 Ton abwähle hört das Bild ruckeln auf und man kann den Film in Stereo sehen. "Google Film" ruckelt nicht mit selbiger Einstellung fehlt aber auch der Ton.

    Wenn ich den Surround Sound dann auf "automatisch" stelle läuft soweit alles "normal" nur 5.1 gibt es dann nicht mehr. Die Option 5.1 wählen/abwählen gibt es dann bei Netflix nicht mehr.

    Also ist der Schalter in den Einstellungen
    "Surround Sound Immer" = 5.1 Dolby Digital
    "Surround Sound Automatisch" = 5.1 wenn verfügbar / sonst Stereo
    "Sourround Sound Nie" = Stereo.

    Ich bin mir jetzt nicht mehr ganz sicher ob dieses Verhalten VOR dem 6'er Android Update auch schon war. Ich meine ich konnte Google Film & Netflix auch in 5.1 schauen. Bei der Amazon App hat das auf meiner Shield noch NIE mit 5.1'er Sound geklappt.

    Hat ggf. jemand einen Tipp für mich wie ich die Shield dazu bewegen kann 5.1 auszugeben (bitte keine Kommentare wie ... kauf Dir einen HDMI Receiver etc.) ?

    greetz

    Badticket
     
  2. Nathaniel9, 02.10.2017 #2
    Nathaniel9

    Nathaniel9 Android-Lexikon

    Habe es mal ausprobiert. Und tatsächlich wird mit der Einstellung "Immer" bei Surround-Sound kein Ton über Toslink ausgegeben.

    Die Einstellung "Automatisch" zusammen mit dem deaktivieren der festen Lautstärke, bringt 5.1 Sound über Toslink an den Verstärker.

    Dann habe ich mit der Einstellung "Immer" den Ton über HDMI ausgeben lassen. Das hat funktioniert. Auch in 5.1.

    Als ich allerdings das HDMI-Kabel wieder in den TV gesteckt habe, um den Ton über den optischen Digitalausgang des TVs zu kriegen, sprang der Ton auf einmal auch dort an und war in 5.1.

    Leider nur bis zum nächsten Neustart der Shield. Dann war über Toslink mit der Einstellung "Immer" wieder kein Ton zu hören.

    Da aber mit den obigen Einstellungen der Ton über Toslink auch in 5.1 ausgegeben wurde, habe ich die Einstellung auf Automatisch belassen.

    Getestet mit der Serie The Walking Dead.
     
  3. badticket, 03.10.2017 #3
    badticket

    badticket Threadstarter Android-Experte

    Hallo,

    vielen Dank für Deine Antwort.

    Habe ich gleich mal ausprobiert. Leider war bei mir bereits die feste Lautstärke deaktiviert. Auf "automatisch" wird mir kein 5.1 Ton zu Auswahl angeboten (bei Netflix Audio Optionen). Der Ton ist Stereo und es ruckelt nicht mehr. Ruckelt das Bild bei Dir auch mit der "immer" Einstellung & Toslink ?

    Da ich über XBMC mit Shield 5.1 bekomme ist das ein Bug in der Shield Firmware....

    Ich glaube das Zauberwort ist "Audio Passtrough" habe ich im Kontext zur Fehlersuche schon mal öfter gelesen. XBMC kann das... die Firmware der Shield scheinbar nicht in allen Fällen. Ich finde auch das Einstellungsmenü extrem irre führend. Hat zwar nur 2-3 Schalter... aber eine feste Lautstärke an eine 5.1 Ausgabe zu koppeln (was bei mir ja nicht klappt) ist meiner Meinung nach ein Bug in der Firmware oder ?

    Tja... bei mir verliert die Shield beinahe komplett ihre Daseins Berechtigung... Die Fire TV kann zum Glück den Ton in 5.1 ... da dann auch bei Netflix.... Google Film müsste ich via Sideload mal ausprobieren.

    An wen müsste ich den so einen "Bug" bei Nvidia Shield adressieren um ggf. mit einem zukünftigen Firmwareupdate diesen zu beheben ?

    Greetz

    Badticket
     
  4. mindscout, 03.10.2017 #4
    mindscout

    mindscout Moderator Mitarbeiter

    Klingt schon nach einem Software-Bug. Vielleicht mit der Komprimierung von 5.1, die Box versucht das bei "immer" vielleicht unkomprimiert zu senden, Toslink kann aber kein unkomprimiertes 5.1, sondern nur Stereo.
    Mittels HDMI ist dann wohl immer eine DD/DTS-Komprimierung aktiv und wird beibehalten, wenn man nur die Kabel umsteckt.

    NAja die Daseinsberechtigung vielleicht nicht gleich, wenn es "nur" Toslink betrifft. Die neueren Geräte unterstützen ja alle HDMI.
    Allerdings ist NVIDIA bei sowas recht engagiert, weshalb ich dir empfehlen würde das mal dort dem Support zu melden.
     
  5. badticket, 03.10.2017 #4
    badticket

    badticket Threadstarter Android-Experte

    Hi,
    bei mir wird ja zusätzlich noch über den Ligawo Switch das Bild ans TV geliefert und der Ton wird auf Toslink gesplittet (den gleichen Weg geht die Fire TV & Xbox One mit 5.1 --> meine Playstation wollte auf dem Weg auch kein 5.1 ausgeben... aber leider sind meine digitalen Toneingänge des Pio.Rec. auf 5 begrenzt (3xToslink, 2xCoax).

    XBMC pustet da aus der Shield das korrekte Signal raus. Shield nativ leider nicht. ABER das war vor Android 6 nicht so... bin ich mir fast sicher, da ich sonst nicht Netflix auf der Shield geschaut hätte....

    Wenn dem so wäre... könnte ich irgendwie auf Android 5 zurück ? Die Shield ist bisher "untouched" also alles originale Firmware drauf.

    Greetz

    Badticket
     
  6. Nathaniel9, 03.10.2017 #5
    Nathaniel9

    Nathaniel9 Android-Lexikon

    Ich habe es nur mit der Amazon App getestet, da ich kein Netflix Account habe. Aber aus Deinem Text war es für mich ersichtlich, dass es auch bei Amazon so ist. Und so war es ja auch.

    Ich hatte vorher die Bildwiederholrate der Shield auf 23,976 Hz umgestellt. Daher hat auch nichts geruckelt. Jedenfalls nicht, solange die Serie lief. Hinterher in der Menünavigation der Amazon App und der Shield-Oberfläche schon. Aber das ist ja normal, weil die GUIs nicht für solche niedrigen Bildwiederholraten ausgelegt sind.
     
  7. andi-hh, 02.12.2017 #6
    andi-hh

    andi-hh Neuer Benutzer

    Hallo alle zusammen.
    Auch ich habe das gleiche Problem mit der Ausgabe von DTS/Dolby Digital.
    Meine Verbindung:
    Per HDMI in den TV und dann per Toslink Kabel in mein Teufel Concept E 450 Digital.
    Es kommt bei Amazon Video und Netflix leider nur Stereo.
    Bei Kodi erhalte ich zum Glück Dolby Digital aber komischerweise keine DTS Ausgabe.
    Hat da vielleicht auch jemand das Problem oder eine Lösung?
     
Die Seite wird geladen...
Ähnliche Themen Forum Datum
SHIELD Experience Upgrade 6.2 veröffentlicht Nvidia Shield Android TV Forum 22.11.2017
Entspricht die Nvidia Shield meinen Anforderungen? Nvidia Shield Android TV Forum 17.11.2017
NVIDIA Shield Android TV: Cursor bewegt sich von selbst Nvidia Shield Android TV Forum 11.11.2017
Nvidia Shield startet nach Experience-Update 6.0 nicht mehr Nvidia Shield Android TV Forum 08.11.2017
TV ein/aus nun über IR der SHIELD Fernbedienung möglich („Home“ + „Zurück“ drücken) Nvidia Shield Android TV Forum 02.11.2017
SHIELD Experience Upgrade 6.1 Nvidia Shield Android TV Forum 30.10.2017
Nvidia Shield Kodi Filme stoppen... Nvidia Shield Android TV Forum 04.10.2017
SHIELD Experience Upgrade 6.0 [28.09.17] Nvidia Shield Android TV Forum 28.09.2017
Nvidia Shield Festplattenerkennung PC Nvidia Shield Android TV Forum 15.09.2017
Rückruf EU Apdater Shield Netzteil Nvidia Shield Android TV Forum 09.08.2017
Du betrachtest das Thema "Shield TV (2015) 5.1 Sound / Audio Einstellung Surround Sound "immer"" im Forum "Nvidia Shield Android TV Forum",