Spezifischer Kernel für das Q Overclocked 1104MHz

  • 41 Antworten
  • Neuester Beitrag
Diskutiere Spezifischer Kernel für das Q Overclocked 1104MHz im Odys Q Forum im Bereich Odys Forum.
S

skybox30

Neues Mitglied
irgendwie scheint das nicht so einfach zu sein, habe jetzt das 1.2.1a Image geflasht. Bis jetzt geht eigentlich alles ---außer der Touchscreen--- :confused:

Benutze das Tab erstmal per Maus das geht irgendwie
 
J

JochenKauz

Gesperrt

skybox30 schrieb:
Bis jetzt geht eigentlich alles ---außer der Touchscreen--- :confused:
Du hast ein kompletten Flash von Oma gemacht, also inkl. EraseIDB etc?
 
S

skybox30

Neues Mitglied
ja habe ich gemacht :crying:

.... was mich wundert ist, das das CWM immer noch die Fehlermeldungen anzeigt
 
J

JochenKauz

Gesperrt

@skybox30,
jetzt wird es seltsam.
Du hast Oma's 1.2.1 inkl. seinem NAND_Format und auch der Sensorlib aufgespielt und es kommt immer noch die Fehlermeldung?
Normalerweise kenne ich es nur so, daß die Meldung einmal vor dem NAND_FOrmat von Oma erscheint und danach weg ist.

Was Du mal machen kannst ist das ODYS_Q_Update_20120814.zip einzuspielen und dann wieder auf Oma wechseln, diese Vorgehensweise hat bei meinem X8 immer geholfen, egal was ich angestellt habe.
 
S

skybox30

Neues Mitglied
was ist denn eigentlich die sensorlib??
 
J

JochenKauz

Gesperrt

skybox30 schrieb:
was ist denn eigentlich die sensorlib??
Sorry... hätte ich genauer sagen müssen.
Damit ist das hier gemeint: Oma_JB_v1.2_Modell_fix_Q.zip
In den Fixen von Oma stecken die sogenannten Sensorlibs. Das sind Module die benötigt werden damit die Sensoren (in diesem Fall der Rotationssensor) des Tablets angesprochen werden können.
 
S

skybox30

Neues Mitglied
ok danke, dann weiß ich Bescheid. Werde dann mal deine Idee mit
dem Org. Rom versuchen
 
S

skybox30

Neues Mitglied
habe es dann mal versucht, einmal mit dem orginal Rom, und einmal mit Oma´s JB Rom 1.2.2a

leider immer noch keine Änderung bzgl. des Screens :(
 
J

JochenKauz

Gesperrt

skybox30 schrieb:
leider immer noch keine Änderung bzgl. des Screens :(
Das ist mehr als merkwürdig.
Hast Du die Möglichkeit ein dmesg anzufertigen?
 
S

skybox30

Neues Mitglied
wenn du mir sagst wie das geht gerne
 
J

JochenKauz

Gesperrt

Du installierst Dir die app Terminal Emulator
Startest die
dann gibst Du ein:
su

danach dann
dmesg >/mnt/external_sd/dmesg.log

Die Datei hängst Du dann hier an.
Das ist das Boot log des Kernels, da kann ich etwas genauer sehen was er so alles macht, insbesondere der Touchsensor.
 
S

skybox30

Neues Mitglied
....so hier ist das log file
 

Anhänge

  • dmesg.log.txt
    34,7 KB Aufrufe: 806
J

JochenKauz

Gesperrt

Hallo skybox,
also auf den ersten Blick sieht das dmesg vollkommen normal aus. Der Touch gibt von sich, das er da und bereit ist.

Da ich aber bei dem StockRom nicht genau geschrieben habe was ich immer mache, möchte ich die Schritte noch mal abklopfen.
1. ODYS_Q_Update_20120814.zip heruntergeladen und in einem Verzeichnis entpackt.
2. Dann das RKAndroidTool aus der entpackten FW als Administrator gestartet.
3. Haken bei Loader machen
4. EraseIDB machen
5. RUN

Schritt 1, 2 und 5 dürftest Du ohne Frage durchgeführt haben, wie sieht es mit 3 und 4 aus?
 
S

skybox30

Neues Mitglied
habe dann mal das ganze so nochmal ausgeführt
wie du beschrieben hast, leider wieder das selbe Problem....

so langsam glaube ich das da was im Argen ist :(

Gruß skybox30
 
J

JochenKauz

Gesperrt

Also jetzt hab ich echt langsam keine Idee mehr. Da scheint sich tatsächlich der Sensor verabschiedet zu haben. Nur hab ich keine Ahnung wie das durch einen Kernel gehen soll.
Ich fürchte Du must mal bei Odys nach nem Austausch nachfragen
 
S

skybox30

Neues Mitglied
Also so wie es aussieht scheint der screen doch nicht defekt zu sein.
Es scheint so als ob er nur verschoben wäre. Zum besseren verstehen habe ich mal drei Fotos gemacht, vielleicht weiß ja doch noch wer ne Lösung für mein Problem......

gruß skybox
 

Anhänge

ronson3

ronson3

Erfahrenes Mitglied
jochen, kannst du vllt. mal bitte kurz zusammenfassen, welchen kernel du als basis genommen hast (source oder schon fertig kompiliert) und wie/ womit du die takt-anpassungen vorgenommen hast
(hab ein vision, das sollte aber bis auf den kleineren screen die gleiche hardware inne haben)
 
J

JochenKauz

Gesperrt

skybox30 schrieb:
Es scheint so als ob er nur verschoben wäre.
Also den Effekt kenne ich und hatte ich auch ab und an bei meinen Tests damals auf dem X8. Dieser Fehler konnte bei mir aber immer durch ein vollständiges Rücksetzen auf den Auslieferungszustand, sprich kompletten StockRom Flash, behoben werden.
Da das ja bei Dir nicht hilft, bin ich etwas ratlos.
Es sieht so aus als wenn der Touch spiegelverkehrt arbeiten würde.

ronson3 schrieb:
jochen, kannst du vllt. mal bitte kurz zusammenfassen, welchen kernel du als basis genommen hast (source oder schon fertig kompiliert) und wie/ womit du die takt-anpassungen vorgenommen hast
Kein Problem.
Basis waren die Sourcen von yatto/xteam bei github. Diese habe ich im Bereich GSensor angepasst (Problem mit der Autorotation beim X8/X7). Zudem habe ich die cpufreq.c angepasst, da über diese Datei festgelegt wird wie die verschiedenen Taktungen der CPU gesteuert werden. Dann habe ich weitere Anpassungen im Bereich des HDMI Chips ANX7150 vorgenommen und die Kamera gefixed.

Da der Q ein paar andere Komponenten als X8/X7 benutzt hatte ich für diesen Kernel hier versucht die richtigen zu finden und zu aktivieren. Als Vergleichsgrundlage dienten hier die Sourcen von Arnova's AN9BG3.
 
ronson3

ronson3

Erfahrenes Mitglied
vielen dank:cool2:
 
S

skybox30

Neues Mitglied
gibt es noch irgend etwas was wir noch probieren können um Tochscreen wieder zum richtigen arbeiten zu überreden??

Mfg skybox30