[Download] TWRP für das Aquaris X / X Pro

  • 42 Antworten
  • Neuester Beitrag
Diskutiere [Download] TWRP für das Aquaris X / X Pro im Root / Custom-ROMs / Modding für bq Aquaris X / X Pro im Bereich bq Aquaris X / X Pro Forum.
loopi

loopi

Ehrenmitglied
Meine Links in dem Post über dir gehen doch noch ;)
 
S

spyro2008

Erfahrenes Mitglied
Hallo nach dem Update von 8.1 scheint das trwp nicht mehr richtig zu gehen.Es kann data /media nicht anhängen.Dadurch ist es nicht mehr möglich ein Backup was zuvor unter /.1 gemacht wurde ,einzuspielen.Wäre toll wenn das trwp angepasst wird.Hatte auf der trwp seite unter support mal geschrieben ,aber es kam keine antwort.Das updat 8.1 ist von bardog und das trwp auch .Hoffe auf ein update des twrp.Danke
 
D

dromaius

Fortgeschrittenes Mitglied
Ja, das TWRP auf diesem Thread ist auch nicht mehr das aktuellste. Probier mal dieses hier.

Gruß Dromaius
 
S

spyro2008

Erfahrenes Mitglied
Lol das habe ich doch schon drauf.Es kann data/media nicht anhängen ,scheinbar ist unter 8.1 die ordnerstrucktur anders.
 
just-Nob

just-Nob

Fortgeschrittenes Mitglied
spyro2008 schrieb:
Das updat 8.1 ist von bardog und das trwp auch.
Wenn Du das "bardock" meinst, das ist nicht der Autor der Software, sondern der Codename für das Aquaris X / X Pro. ;)
dromaius schrieb:
Ja, das TWRP auf diesem Thread ist auch nicht mehr das aktuellste. Probier mal dieses hier.
Wie in beispielsweise in https://www.android-hilfe.de/forum/root-custom-roms-modding-fuer-bq-aquaris-x-x-pro.3058/aquaris-x-x-pro-firmwareupdate-mit-root.834283-page-7.html#post-11025344 zu lesen ist, funktioniert das derzeit aktuellste TWRP V. 3.2.1.0 mit dem neuen Oreo 8.1wie auch bereits von @spyro2008 beschrieben nicht - es ist wohl nicht möglich, die (bei Oreo automatisch) verschlüsselten Partitionen richtig zu entschlüsseln.
 
P

picard47

Stammgast
Konnte es noch nicht ausführlich testen aber bei meinem X 64 Gb funktioniert unter 8.1 die TWRP auch nicht mehr korrekt. Der interne Speicher wird gar nicht angezeigt (bzw. als 0GB). Dementsprechend kann ich auch nix flashen.

Die TWRP merkt sich auch keine Einstellungen.
 
phu76

phu76

Ambitioniertes Mitglied
Ich schließe mich an, Gerade per fastboot das 8.1 Update eingespielt, und nun geht nichts mehr mit twrp =(
 
H

homofaber

Fortgeschrittenes Mitglied
Das Problem ist nicht die Verschlüsselung, sondern eine Änderung im Kernel bezüglich ext4, so dass nach dem Entschlüsseln /data nicht gemountet werden kann (zu sehen im Kernel-Log).
Abhilfe: das TWRP-Image entpacken und mit dem Kernel aus dem aktuellen Original-Recovery-Image neu packen. Damit klappt es dann wieder.
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Update: hier der Link zu der meiner gefixten Version. (Einzige Änderung zum Original ist der Tausch des Kernels gegen den Oreo-Kernel von BQ aus der recovery.img.)

twrp-3.2.1-bardock_pro-fixed_ext4.img

sha256: 16e10085db40916d82db5f0c8e6d2f928d9a54edc3e6ae9421130dd313b80b25
 
S

spyro2008

Erfahrenes Mitglied
Danke dir es geht:thumbsup:.Super
 
bierpatriot1

bierpatriot1

Erfahrenes Mitglied
@homofaber Danke hat geklappt da kommt Freude auf:)
 
moidept

moidept

Experte
Danke @homofaber den gleichen Gedanken hatte ich auch, zum Glück hast du diesen zu ende gedacht, nun klappt das mit dem TWRP unter 8.1 Oreo, so wie es soll..
 
Zuletzt bearbeitet:
moidept

moidept

Experte
picard47 schrieb:
@homofaber Könntest du das für die TWRP des Aquaris X auch erstellen?
Das TWRP welches homofaber hier Bereitgestellt hat, Funktioniert auf dem BQ Aquaris X ohne Probleme.
 
just-Nob

just-Nob

Fortgeschrittenes Mitglied
homofaber schrieb:
Abhilfe: das TWRP-Image entpacken und mit dem Kernel aus dem aktuellen Original-Recovery-Image neu packen. Damit klappt es dann wieder.
Zuerst nochmal Danke für die Lösung und das zur Verfügung gestellte TWRP-Mod-Image.
Nur mal neugierdehalber: In welcher Datei ist der Kernel compilert? boot.img?
 
P

picard47

Stammgast
@moidept hatte ich schon vermutet, aber hab vorher die Prüfsumme der beiden originalen TWRPs verglichen und da diese differieren, wollte ich nicht unnötig was schrotten.
Aber gut zu wissen.
 
H

homofaber

Fortgeschrittenes Mitglied
@just-Nob
Sowohl boot.img als auch recovery.img enthalten ein Kernel-Image.
 
just-Nob

just-Nob

Fortgeschrittenes Mitglied
Stellen beide zusammen den Kernel dar, oder handelt es sich um Redundanz?
Ich nehme einmal an, dass Du beide Dateien ausgetauscht hast?
 
H

homofaber

Fortgeschrittenes Mitglied
@just-Nob
recovery.img wird gebootet, wenn du in den Recovery-Modus gehst.
boot.img wird beim normalen System-Start gebootet.

Von daher brauchen beide Images einen Kernel (es handelt ich i.d.R. um den selben Kernel).
 
Ähnliche Themen - [Download] TWRP für das Aquaris X / X Pro Antworten Datum
4
9
0