Relocked zu unlocked wieder

  • 8 Antworten
  • Neuester Beitrag
Diskutiere Relocked zu unlocked wieder im Root / Custom-ROMs / Modding für HTC One M9 im Bereich HTC One M9 Forum.
Holli33

Holli33

Erfahrenes Mitglied
Hallo Gemeinde,

Nach einem langen Arbeitstag sollte man nicht nach Problemlösungen suchen....
Nachdem am letzten WE noch meine Kopfhörer (über Klinke) funktionierten hatten, habe ich die Firmware auf 2.7.401.1 und die Viper 3.0.0 geflasht. Heute ist mir aufgefallen das die Kopfhörer nicht mehr funktionieren. Kein Symbol oben und auch kein Ton kommt mehr daraus (mehrere Kopfhörer probiert). Die normalen Lautsprecher im Gehäuse trällern vor sich hin.
Nun habe ich andere Firmware probiert und probiert. Dabei scheine ich mal den falschen Befehl in CMD eingegeben (copy paste) zu haben. Ich glaube mal dass es „fastboot oem lock“ war. Blöder Hund….

Nun steht bei mir im „Download-Modus“ RELOCKED…

Wie kann ich es wieder auf UNLOCKED bringen?

Mit „fastboot oem get_identifier_token“ geht es nicht. Da kommt was mit
…disable unlock [KillSwitch] oem unlock Turn Off!.....

Hat jemand einen Tipp/Rat..

Wenn ich nicht gleich antworte nicht böse sein, war ein langer Tag. Ich wollte nur meine Kopfhörer zum Laufen zu bringen

Achso… ich habe S-Off …


EDIT: Mein M9 bootet immer wieder neu nach 2-3 Sekunden auf Homescreen. Ich hoffe es liegt an RELOCKED und man kann mir hier helfen...

Schönen Abend
 
Zuletzt bearbeitet:
R

rolkeg

Ehrenmitglied
Dir wird wohl nichts anderes übrig bleiben, als den Bootloader wieder über HTCdev zu entsperren. Ich zumindest kenne da sonst nichts anderes.
 
Holli33

Holli33

Erfahrenes Mitglied
rolkeg schrieb:
Dir wird wohl nichts anderes übrig bleiben, als den Bootloader wieder über HTCdev zu entsperren. Ich zumindest kenne da sonst nichts anderes.
Danke, wenn es mal so einfach wäre...

Wie ich oben geschrieben hatte " Mit „fastboot oem get_identifier_token“ geht es nicht. Da kommt was mit
…disable unlock [KillSwitch] oem unlock Turn Off!....."

adb>fastboot oem get_identifier_token
...
(bootloader) [KillSwitch] : /dev/block/bootdevice/by-name/frp

(bootloader) [KillSwitch] Last Byte is 0X00, disable unlock

(bootloader) [KillSwitch] oem unlock Turn Off!

OKAY [ 0.014s]
finished. total time: 0.015s

Also kann ich es nicht so einfach:cursing:
 
ferchi

ferchi

Ehrenmitglied
Hast du denn überhaupt schon probiert den Bootloader normal zu öffnen? Also per "echo -ne "HTCU" | dd of=/dev/block/mmcblk0p2 bs=1 seek=33796"

Genaueres kann ich später schreiben wenn benötigt.

Gruß ferchi
 
Holli33

Holli33

Erfahrenes Mitglied
Danke ferchi,
ja hatte ich. Dazu braucht man aber eine Adroid Oberfläche. Bei meiner ROM bootet er nach ca. 3-5 Sekunden neu, komme nicht dazu dieses einzugeben.
Echt blöde ....
Kann man auch was über Recovery was machen? Ich habe da noch TWPR drauf. Im Android schmiert er nach paar Sekunden ab. Schaffe nicht alles einzugeben.
 
Zuletzt bearbeitet:
ferchi

ferchi

Ehrenmitglied
Ja dieser Befehl sollte auch im Recovery funktionieren
 
Holli33

Holli33

Erfahrenes Mitglied
ferchi schrieb:
Ja dieser Befehl sollte auch im Recovery funktionieren
Danke,
werde ich zu Hause (leider morgen erst) probieren.
Ich habe folgendes gefunden...

to UNLOCK your bootloader,enter the following:
adb devices
adb shell
su (if needed to get a # prompt)
echo -ne "HTCU" | dd of=/dev/block/mmcblk0p2 bs=1 seek=33796
(i would very strongly recomend you copy/paste this)
exit
(exit a second time if you need to to get back to a normal > prompt)
adb reboot bootloader

Müsste so richtig sein...

Auf der Arbeit findet er kein Devices. Liegt bestimmt an die fehlenden Treibern. Kann sie leider hier nicht intallieren.
Ich hoffe nur es funktioniert ...
 
Holli33

Holli33

Erfahrenes Mitglied
Hallo und einen schönen heissen Sommertag,

leider habe ich immernoch mein Problem
...geht irgendwie nicht :o( grrrrrrrr.

ich habe eine ROM neu geflasht, somit bleibt er länder ohne reboot.
Nun habe ich folgendes eingegeben:
1.
j:\Handy\adb>adb devices
List of devices attached
HT5.......0 device
OKAY
2.
j:\Handy\adb>adb shell
ViperOne@:/ $
OKAY
3.
j:\Handy\adb>adb shell
ViperOne@:/ $ su
su
1|ViperOne@:/ $

da passiert nichts, und die nächste eingabe von
echo -ne '\x00\x00\x00\x00' | dd of=/dev/block/mmcblk0p2 bs=1 seek=33796
auch nichts
was macht su?

ich habe mal im Bootloader folgendes eingegeben und folgendes erhalten

fastboot getvar all

(bootloader) version: 0.5
(bootloader) max-download-size: 0x20000000
(bootloader) partition-type:cache: ext4
(bootloader) partition-size:cache: 0x14000000
(bootloader) partition-type:userdata: ext4
(bootloader) partition-size:userdata: 0x5e0000000
(bootloader) partition-type:system: ext4
(bootloader) partition-size:system: 0x118000000
(bootloader) serialno: HT5........0
all:
finished. total time: 0

fastboot getvar version-main
version-main:
finished. total time: 0.018s

fastboot getvar mainver
mainver:
finished. total time: 0.006s

Keine aussagen über meine Firmware.

Hilft es vielleicht eine RUU zu flashen?
 
Zuletzt bearbeitet:
Holli33

Holli33

Erfahrenes Mitglied
So, habe es geschafft...
Habe erstmal eine RUU.exe geladen und ausgeführt. Hat wunderbar geklappt. Danach ging auch HTCdev usw... alles nun funktioniert alles wieder...
Schönen Sonntag allen...