Hilfe beim Instalieren von Custom Rom

  • 37 Antworten
  • Neuester Beitrag
Diskutiere Hilfe beim Instalieren von Custom Rom im Root / Custom-ROMs / Modding für Huawei Ascend G510 im Bereich Huawei Ascend G510 (U8951) Forum.
Simon G.

Simon G.

Guru
Dload super na und wieder ein Beweis das dload auch mit Customrecovrry geht
Na twrp draufmachen wie gewohnt und gut.

Solange fastboot geht ist nix verloren wenn das nicht mehr geht brauchst garnicht mehr weitermachen und kannst es als Türstopper nehmen
 
E

elmo-77

Neues Mitglied
Gibt es ne App für das Huawei G510-100 mit der ich es rooten kann?
Nach dem Firmware-Update ist es natürlich wieder zu.
Und die TWRP-App funzt ohne Root-Zugriff auch nicht.
Müsste sonst schon wieder bis heut abend warten.
 
Zuletzt bearbeitet:
Simon G.

Simon G.

Guru
Wenn du CWM flasht brauchst du kein Root und kannst damit die Rom flashen
 
E

elmo-77

Neues Mitglied
Hab mir gerade die SuperSU App von Chainfire geladen.
Beim öffnen gibt die folgende Meldung ab:
"Es ist keine SU-Binary installiert und SuperSU kann sie nicht installieren. Das ist ein Problem!"
Was auch immer das heißt.

Der ursprüngliche Beitrag von 10:09 Uhr wurde um 10:30 Uhr ergänzt:

Glaub ich muss echt erst mit Kingo daran und das Ding rooten.
Oder noch ne andere Idee?
 
Simon G.

Simon G.

Guru
Nur durch suoeruser app instalieren hast du kein Root wenn das so einfach waere. Mensch zieh dir einfach cwm drauf wo ist dein Problem und dann flasht du damit eine Rom. Warum willst du dich vorher mit dem Rooten quälen . Wenn du die Slinkat drauf hast kannst du immernoch twrp drauf machen.

Der ursprüngliche Beitrag von 10:42 Uhr wurde um 10:44 Uhr ergänzt:

Davon mal ab wieso muss gerootet sein damit Twrp funktioniert das höre ich zum ersten mal??? Ich hatte twrp drauf gemacht ohne zu rooten und dann ne Rom geflasht
 
E

elmo-77

Neues Mitglied
Der ursprüngliche Beitrag von 10:55 Uhr wurde um 11:04 Uhr ergänzt:

Ok, dann hier der Ablauf mit CWM:

1. App geladen und gestartet
2. Aktuelle Recovery ist CWM 5.X.X.X
3. Menüpunkt "ROM von SD-Karte installieren" geklickt
4. Slimkat-ZIP ausgewählt ; ROM sichern : Nein ; Daten Löschen : Ja
5. Neustart und Installation
6. Nächstes Fenster mit OK betsätigt
7. FEHLERMELDUNG: "Bei der Ausführung von privilegierten Kommandos ist ein Fehler aufgetreten."
8. Installation abgebrochen und wieder auf dem Startbildschirm.

So, jetzt kommt ihr.
 
Simon G.

Simon G.

Guru
Also irgendwie ist beindir irgendwas merkwürdig. Da weiss ich auch nicht weiter.

Normal reicht offener Bootloader Cwm Twrp druf Rom flashen gapps Bums und fertig
 
E

elmo-77

Neues Mitglied
:laugh: normalerweise !!
Ich hab immer irgendwie son Sch*** anne Hacken.
Wird das Gerät nachher nochmal rooten und dann weitertesten.
Vielleicht liegt es ja wirklich nur daran.
Werde dem gewahr werden und dann wieder berichten.
Bis dahin danke für die Hilfe !!!!!
 
Simon G.

Simon G.

Guru
Ich mein du hast ja dload gemacht und damit die Firmware neu aufgesetzt.

Somit evtl. Fehler der Rom selbst sind weg. So wenn man dann die Recovery per fastboot oder bat flasht sollte das reichen.

Von daher bin ich absolut überfragt da mir sowas noch nie geschehen ist.

Es sei denn in den neuen Twrps und Cwms ist es so das diese wirklich nur unter Root funktionieren. Denn die Zeiten wo ich mit dem g330 und g510 das gemacht habe ist etwas her.
Kann es mir aber nicht Vorstellen . Was anderes fällt mir dazu auch nicht ein.
Firmware neu
Recovery sauber drauf gelflasht muss gehen .

Vielleicht meldet sich ja noch jemand anders zu dieser vermutung. Ich Frage mal jemand
 
E

elmo-77

Neues Mitglied
Pauschal erstmal Dankeschön.
Nach bissl rumlesen im Netz scheint es wirklich so,
dass die aktuellen Versionen von TWRP und CWM die rootrechte brauchen.
Denke mal das der SuperSU dann das gleiche Problem hat.
Und mittlerweile ne kostenlose App zu finden die das Gerät rootet kann man vergessen.
Muss scheinbar wirklich von nem Pc aus gemacht werden.
 
Simon G.

Simon G.

Guru
Ich habe glaube noch ne zip die du über recovery flasht dann hast root ich gucke mal wo die ist. Nur wenn Twrp cwm root brauchen damit Sie gehen geht das auch nicht ich schaue mal
 
E

elmo-77

Neues Mitglied
Bin gespannt und harre .....
 
Simon G.

Simon G.

Guru
Dachte Sie luegt auf dem Devhost ist sie aber nicht

Der ursprüngliche Beitrag von 12:15 Uhr wurde um 12:17 Uhr ergänzt:

Wenn keine Lösung dann schaue ich heut Nachmittag noch mal
 
E

elmo-77

Neues Mitglied
Schade. Kann man nichts machen.
Wie gesagt, werd nachher mal Kingo anschmeissen.
Danach weiß ich mehr.
Lass ich euch dann aber hier wissen.

Der ursprüngliche Beitrag von 12:18 Uhr wurde um 12:19 Uhr ergänzt:

Schätze mal so gegen 1500 weiß ich schon mehr.

Der ursprüngliche Beitrag von 12:19 Uhr wurde um 12:34 Uhr ergänzt:

Ahso, was mich auch noch stutzig gemacht hat:
CWM hat gar keinen Support für mein Gerät in seiner App.
Da kann ich nur das Ascend 2 und das U8160 auswählen.
Ich nehme dann immer "Device not listed above".
Wird dann nach der gewünschten Version gefragt : CWM 2.x oder CWM 3.x
Wähle dann die 3.x und danach kommt die Anzeige:
"ROM Manager wurde so eingestellt, dass ihre existierende Recovery Installation genutzt wird".

Viel mir gerade noch so ein.
Vll auch relevant.

Der ursprüngliche Beitrag von 12:34 Uhr wurde um 13:28 Uhr ergänzt:

Hab just nochmal versucht ne Slimkat-ROM dirket zu flashen.
Bin auch bis zur Installation gekommen, aber die sieht dann so aus:

Finding update package...
Opening update package...
Verifying update package...
Formatting /Cache...
Installation aborted.

Im Hintergrund sieht man den Androiden wie er bei den ersten 4 Meldungen noch steht und den "Bauch" offen hat wo son Pentagram rausschaut,
und bei der 5. Meldung liegt er auf dem Rücken und hat nen Warndreieck auf dem Bauch. :huh::confused2:

Der ursprüngliche Beitrag von 13:28 Uhr wurde um 15:07 Uhr ergänzt:

Also es wird jeder flash definitiv beim formatieren des Cache abgebrochen.
Keine Ahnung was da los ist, aber da hängt es.
 
Zuletzt bearbeitet:
Simon G.

Simon G.

Guru
Hat nicht noch irgendeiner von den alten 510 Hasen die root zip fuer ihn um zu Testen ob es daran liegt das er kein Root hat. Ich muss an mein Windows Backup ran damit ich die Datei finde hab das System neu aufgesetzt.
 
Andy

Andy

Ehrenmitglied
Hier gibts immer die aktuellste SuperSU: SuperSU Download
Die flasht man übrigens mit nem Custom Recovery XD
PS. Mit ROM Manager spielt man nicht, außer man will unbedingt sein Gerät bricken ...
 
E

elmo-77

Neues Mitglied
Ladys and Gentlemen, :thumbsup::thumbsup::thumbsup:

es hat funktioniert !!!!! Slimkat läuft stabil und vollumfänglich.
Wie ich es gemacht habe ???
Verdammt ich hab keine Ahnung.
Rekonstruktion meiner letzten Schritte:

Also ich habe damit angefangen das Gerät auf Firmware zu flashen.
Dachte mir, wenn dann richtig !!
Danach hab ich - um nicht wieder im Firmware-update zu landen - den Ordner dLoad gelöscht. War einfach so intuitiv da ich kontrollieren wollte ob der Bootloader noch "frei" ist. Also in den Lila Bildschirm gestartet (Vol- & Vol+ & Power), DC-Unlocker gestartet und gewartet.
Bootloader war noch unlock, somit ein Problem weniger.
Danach dann normal gebootet, den ganzen Kram mit "Erstinbetriebnahme" abgebrochen und übergangen. Runtergefahren, im Bootloader gestartet (Vol- & Power), fastboot mit Flash twrp ausgeführt = successfull !! :drool:
Recovery restartet, Slimkat-ZIP angewählt aber Flash wurde abgebrochen.
Andere Slimkat-ZIP probiert, und siehe da

ERFOLG !!!!!

Also läuft jetzt alles einwandfrei.
Resume:
Defekte ZIP auf der Karte gehabt und der DLOAD-Ordner scheint irgendwie in den boot-Bereich zu greifen.
Vll hilft das als Tip. Vll auch nicht.

Soweit die News, Ich bin Glücklich.
Und ein mega DANKESCHÖN an Simon und Katy für eure Hilfe.
 
Zuletzt bearbeitet:
Simon G.

Simon G.

Guru
Na wunderbar freut mich . Dann viel Spass mit der Slimkat