[OS] Offizieller CyanogenMod 9 (4.0.x)

  • 455 Antworten
  • Neuester Beitrag
Diskutiere [OS] Offizieller CyanogenMod 9 (4.0.x) im Root / Custom-ROMs / Modding für LG Optimus L3 im Bereich LG Optimus L3 (E400) Forum.
Ygreck

Ygreck

Dauergast
Endlich die erste Custom Rom für das L3 E400!
Allgemein ist diese Rom nicht 100% Altagstauglich allerdings müsst ihr hier für euch selbst entscheiden!

Download
CyogenMod Nightly

Voraussetzung:
Um diese Rom zu Installieren müsst ihr das ClockworkRecovery installiert haben.
Root erhaltet ihr durch diese Rom automatisch!
Neuere LG L3 e400 haben andere Displays verbaut (e400g oder andere Kennzeichnungen sind an der original Verpackung zu finden sein) und werden von aktuellen Roms falsch unterstützt.
Um dies zu Fixen einfach diesen Kernel Flashen: Hier
ich empfehle diesen Kernel JEDEM da diese auf einer neueren Source basiert und somit viele Fehler behebt.
Wenn ihr nicht sicher seit Installiert einfach die Rom wie in der Anleitung beschrieben.
Sollte das Bild nach dem Neustart falsch dargestellt werden kann der Kernel jederzeit nach geflasht werden!

Vorbereitungen:
Das meiste hier ist optional
  • Erstellt mit TitaniumBackUp sicherungen eurer Apps (bitte entscheidet gut was ihr bracht, einige Apps sorgen nach einer Wiederherstellung zu einem instabilen System da diese für 2.3 vorgesehen sind, cm9 ist Android 4.0)
  • Sichert eure SMS mit einer App aus dem PlayStore (meine Empfehlung)
  • Erstellt im CWM ein BackUp eures Systems

Installation:
  1. Downloadet euch die Rom und packt die Zip (unentpackt!) auf die SD-Karte
  2. Wenn ihr den PlayStore und andere GoogleApps benötigt ihr auch die gapps.
    Packt die Zip auf auf die SD
  3. Startet in das CWM (beim start Menü + VolUp gedrückt halten)
  4. Erstellt ein BackUp (optional aber empfohlen!)
  5. führt "wipe data" und "wipe cache partition" aus (wichtig!)
  6. "install zip from SD" und wählt erst die CM9 Zip aus und danach6. die gapps
  7. "reboot system now"

Der erste Neustart kann bis zu 5 Minuten dauern!
Sollte es länger dauern startet ins CWM neu und wiederholt die Installation (und beachte Punkt 4!)

Es gibt einen Overclocking-Kernel.
Dieser fixed auch den Battery-Boot-Bug, basiert aber auf der alten Source v10c.
Altenativ diesen Kernel, wie oben erwähnt, installieren, ist aber noch nicht OC Fähig.
Einfach über CWM installieren, allerdings garantiere ich nicht für seine volle Funktion.

Für jeden der sich für GoogleNow interessiert möchte ich hier noch folgenden Beitrag ans Herz legen:
Giga//Android




Bekannte Bugs:
  • Diverse Sim-Karten (einige e-plus und vodafon karten) werden nicht korrekt erkannt, manchmal hilft es die Pin-Abfrage ab zu stellen
  • Das Mobile Internet versagt manchmal (bei mir oft in der Bahn) <- nicht von jedem bestätigt
  • Beim Staren bootet das Device manchmal in den ChargeModus (Battery-Bug). einfach neustarten oder vom CWM aus ins System booten.
  • Bei neueren L3 e400 Modelen kann das Bild falsch dargestellt werden. In diesem fahl diesen Kernel Flashen!

Changelog
 
Zuletzt bearbeitet:
Ygreck

Ygreck

Dauergast
Es ist nun Offizial!
CyanogenMod Supportet nun das L3 e400.

Im laufe der letzen Woche gab es die ersten frühen Versionen im Rom Manager und auch in diversen Foren (z.B. auch hier) und nun da es offizial ist bekommt das L3 endlich auch ab heute Nightlys!

Hier zur MoDaCo-News

Link zu CyanogenMod
 
Baron1971

Baron1971

Erfahrenes Mitglied
Gibt es eigentlich schon eine Möglichkeit, die SD Karte zum Standard zu machen, und nicht den internen Speicher?
 
Ygreck

Ygreck

Dauergast
hm, höhstens mit den mountpoints, aber um Gottes willen fass die nicht an!

aber solange wir nicht mal usb-mounten können wird das mit der sd auch nix^^ aber man kann mit cm9 über s2e den internen speicher quasi vergrößern...
 
Baron1971

Baron1971

Erfahrenes Mitglied
Alles klar, danke für die Antwort.
 
A

Ace-Andi

Neues Mitglied
cool danke ... mein Handy kommt heute an ich werde mich dann mal dran machen das in den nächsten tagen zu flashen :) danke danke danke

Andi
 
Ygreck

Ygreck

Dauergast
ja, mein selbsterstellter changlog und bug-list sind nicht ganz aktuell... aber für eine rom die nicht mal 2 wochen alt ist ist diese sehr gut!
 
A

Ace-Andi

Neues Mitglied
ich hatte es installiert aber der shop war nicht da ... ich hab sicher bei schritt 2 etwas falsch gemacht ... oder?

einfach nochmal versuchen ... wird es dann funktionieren?

Andi
 
Ygreck

Ygreck

Dauergast
du hast ganz sicher keine gapps installiert, in cm9 sind keine gapps zu beginn da es einfacher ist gapps zu installieren als sie hinterher zu löschen und genug user lieber ein rom ohne gapps wünschen

einfach über cwm drüberflashen
 
A

Ace-Andi

Neues Mitglied
wieso wünschen sie sich ein OS ohne einen market und google maps?

ich hab jetzt wieder die alte 2er version drauf ... wenn ich nun das lg wieder auf die 4er bringen will muss ich dann erst gapps installieren? weil das ist ja gleich schritt 2 in deiner anleitung oder wird das dann automatisch mit installiert?

in der 4.0.4 version ist er immer hängen geblieben als ich auf clockworkMod Recovery installieren gegangen bin ... warum?

danke andi
 
phone-company

phone-company

Enthusiast
oh die erklärung ist ganz einfach.. Google untersagt es den ROM entwicklern die google-apps einzubauen das ist auch schon die ganze erklärung für die nichtvorhandenen googleapps ;)
 
A

Ace-Andi

Neues Mitglied
achso ok ... bei meinem galaxy ace ... welches ich vor gut einem jahr geflashed hatte war das noch nicht so ... sollte also alles funktionieren wenn ich es jetzt nochmal richtig mache ^^

danke erstmal wenn noch was ist melde ich mich :)

danke für den tollen support!

andi
 
Ygreck

Ygreck

Dauergast
ui, dann habe ich da ja was falsch verstanden... sorry^^

endert aber nix daran das du die gapps.zip installieren musst, ob du das über den rom manager machst oder direkt im recovery ist egal... und auch wann ist egal solange du es nach der rom installation machst

früher habe ich immer erst das system gebootet und wlan eingerichtet und dann erst die gapps installiert
 
Baron1971

Baron1971

Erfahrenes Mitglied
Ygreck schrieb:
Bekannte Bugs:
  • Am PC kein Zugriff auf den Speicher (im Build 2 löst USB-Anschluss sogar Bluescreens aus, in Build 3 fehlt der Treiber)
  • Device wird in ADB als "625697" erkannt
  • Crash Reboot bei Apps mit Root-Zugriff (fixed im Build 2)
  • Musik wird nur von den internen Boxen abgespielt (fixed in Build 3)
  • Videos haben Bildfehler (Vorschau normal, doch das Video ist durchzogen von grünen streifen)(fixed in Build 4)
Und es funktioniert doch! ;) Zumindest unter Windows7. Man muss nur bei USB Debugging den hacken weg machen. Dann wird es mit MTD gemountet, und man hat Zugriff auf die interne, und externe SD Karte.

Dafür habe ich nicht reproduzierbare Systemabstürze. Es hilft nur Akku rein und wieder raus.
 
Zuletzt bearbeitet:
phone-company

phone-company

Enthusiast
ihhh das hört sich alles noch nicht so gut an.... Aber es dauert halt alles etwas... gut Ding will weile haben oder wie sagt man :)
 
Ygreck

Ygreck

Dauergast
Das mit USB debuging lese ich überall, aber bei mir funktioniert das nicht :/ aber dafür keine abstürze

Gesendet von meinem LG-E400 mit der Android-Hilfe.de App
 
Baron1971

Baron1971

Erfahrenes Mitglied
Vielleicht ist es Windows abhängig? Ich hab Win7 Ultimate X64 drauf.
Hast du das Treiber Paket von LG installiert?
 
kirc

kirc

Erfahrenes Mitglied
habs soeben geflashed, nur die simkarte wird danach nicht mehr erkannt.
stecke ich besagte simkarte in ein anderes handy, funzt sie sofort. o0
kurioser weise geht allerdings auch eine andere simkarte im e400...jemand eine idee?

emei wird noch angezeigt, aber es erfolgt auch keine pinabfrage beim reboot
 
Baron1971

Baron1971

Erfahrenes Mitglied
Ist es ein E400 von der Telekom? Ist es schon unlocked?
 
kirc

kirc

Erfahrenes Mitglied
ist ein vertragsfreies handy gewesen, simkarte ist von blau.de (die karte die funktioniert ist von simyo, also auch e-plus netz)
 
Zuletzt bearbeitet: