Surnia (LTE) nach Verschlüsselung kein Zugriff mehr via ADB

  • 9 Antworten
  • Neuester Beitrag
Diskutiere nach Verschlüsselung kein Zugriff mehr via ADB im Root / Custom-ROMs / Modding für Motorola Moto E (2015) im Bereich Motorola Moto E (2015) Forum.
N008

N008

Ambitioniertes Mitglied
ADB ist ein gutes Stichwort. Wie bekomme ich eigentlich via ADB Zugriff auf mein Device, wenn dieses verschlüsselt ist?

Ein unverschlüsseltes Gerät wird mit per adb devices angezeigt. Nach der Verschlüsselung bleibt die Liste leer. Auch der Verbindungsversuch via WLAN nach Eingabe der dezidierten IP-Adresse bleibt erfolglos (siehe Screenshot).

Selbstverständlich habe ich das Gerät entsperrt und Dateiübertragung ausgewählt. Seltsamerweise erscheint am Gerät nach der Verschlüsselung keine Abfrage, ob ich den Zugriff via ADB gestatten möchte. Ich habe auch die vorher gewährten Zugriffe zurückgesetzt.
 

Anhänge

Cua

Cua

Moderator
Teammitglied
Hast du USB-Debugging aktiviert?
 
N008

N008

Ambitioniertes Mitglied
Selbstverständlich. ;)

Auf dem Gerät passiert einfach nichts. Normalerweise müsste ja ein Dialog aufploppen, um den Zugriff zu bestätigen. Aber es passiert nichts. Bei ADB über Netzwerk habe ich jetzt einmal die Firewall komplett deaktiviert (zuvor hatte ich eingehende Verbindungen erfolglos ausprobiert) und Zugriff erhalten. Ich würde aber lieber versuchen, das ADB über USB zu nutzen.
 
O

ooo

Lexikon
Firewall aus (Rechner/Phone) bzw. am Phone shell zulassen
USB-Kabel abziehen
Entwickleroptionen
- USB-Debugging an
- Root Access für Apps und ADB
- USB-Debugging-Autorisierungen aufheben (wenn der Rechner bereits permanent registriert war, wird nicht mehr abgefragt)
- Zugriff über WIFi an
USB-Kabel verbinden
- Abfrage-Dialog zur Sicherheit permanent bestätigen
___
Nur für WiFi:
Noch via USB-Kabel verbunden (Vorbereitung):
user@box:~$ adb tcpip 5555
restarting in TCP mode port: 5555
Dann Kabel abziehen und Eingabe
user@box:~$ adb connect <aktuelle IP des Phones>
connected to <aktuelle IP des Phones>:5555
___
Wieder zu USB wechseln:
user@box:~$ adb usb
restarting in USB mode
Kabel wieder einstecken
 
Zuletzt bearbeitet:
Bearbeitet von Cua - Grund: Thema ausgegliedert /Cua
N008

N008

Ambitioniertes Mitglied
Vielen Dank für Eure Hilfe, aber via USB will es mir einfach nicht gelingen. Ich habe alles, wie beschrieben, eingestellt (siehe Screenshot), wie es auch vor der Verschlüsselung anstandslos funktionierte, aber der Dialog erscheint einfach nicht. Dieses Probleme hatte ich übrigens mit allen drei CM-Versionen, wollte es aber jetzt einmal angehen.

Via Netzwerk funktioniert es aber jetzt anstandslos. Man muss offenbar bei AFWall+ auch nach Änderungen in den Einstellungen auf (Regeln) Anwenden klicken, da diese sonst nicht übernommen werden. Zumindest in diesem Fall nicht. Jedenfalls ploppt der Dialog beim Zugriff via WLAN auf. Das hilft mir künftig sehr, um nach dem nächsten clean install nicht alle Apps, die ich nicht benötige, mit dem Mäuseklavier auf dem Device zu freezen.
 

Anhänge

O

ooo

Lexikon
Andere|r|s USB-Kabel | USB-Port | ADB-Treiber/-Version | Rechner?

(TWRP > Vollback > machen - ext. SD Card, dann TWRP > Wipe > Advanced wipe > boot, system, data, cache(s), dann Clean Install nur Nightly - ohne alles, ADB wieder testen am USB-Port ...)
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
@N008 - Verschlüsselung (data-Partition, Adopted Storage) hat nichts mit ADB zu tun (es ist in dem Zustand ja bereits von dir entschlüsselt worden). - Bei mir geht's ja auch (mit Verschlüsselung) ...
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Alle gefreezten System-Apps unfreezen, dann ADB via USB testen?
 
N008

N008

Ambitioniertes Mitglied
Ich bekomme es wirklich nicht hin. Ich habe vor einer Woche mein Gerät nach einem full wipe wieder auf CM13.0 zurückgeflasht, weil mir bei CM14.1 dann doch einige Funktionen zu viel fehlten bzw. sie noch nicht oder nur mit viel Gefrickel funktionierten. Und wieder dasselbe Ergebnis: Nach der Verschlüsselung ploppt die Anfrage, den Zugriff auf das Gerät via ADB zu gestatten, nur noch beim Zugriff über WLAN auf - per USB bleibt das Gerät stumm.

Das ist allerdings kein Beinbruch, da ich, wenn ich nach einer Neuinstallation erst einmal alles konfiguriert habe, auf diesen Zugang verzichten kann. Auch wenn ich es weiterhin nicht verstehe…
 
O

ooo

Lexikon
Wie gehst du GENAU vor bis zum/beim Verschlüsseln? - Exakte Schrittfolge ab Stock-ROM, original - bis einschließlich Nightly > kein ADB über USB.

Gib mir mal deine konkreten Versionen (am Besten Links auf die Software):
  • Letzte geflashte Stock-ROM
  • ADB/Fastboot
  • TWRP Recovery (geflasht oder nur immer gebootet?)
  • Aktuell installierte CM-Nightly
Ich installiere dann alles und schaue nach, was mein USB-Debugging so erzählt ...

(Das wird alleridngs evtl. nichts nützen, wenn du irgendetwas Blockendes/Auslösendes zusätzlich installiert hast - auf dem Rechner oder dem Phone - von dem ich nichts weiß. - Dann wäre es für mich Zeitverschwendung ...)
 
N008

N008

Ambitioniertes Mitglied
Die Mühe musst Du Dir wirklich nicht machen! Über WLAN funktioniert's ja.

Falls es Dich sportlich herausfordern sollte… ;)
  • Ich habe die Stock-ROM aus *diesem Thread* nach Deiner Anleitung installiert, um auf das aktuellere Modem upzudaten
  • Ich verwende weiterhin Minimal ADB in der Version 1.4 vom 17.10.2016 (bei CHIP heruntergeladen :rolleyes:)
  • TWRP starte ich nur per Fastboot und nutze dabei immer die jeweilige Version, die Du uns hier im Forum empfiehlst; aktuell nutze ich twrp-surnia-3.0.2-r5.img direkt von: Squid TWRP for Styx LTE - xda-developers DevDB
  • Derzeit läuft das Snapshot CM13.0 vom 21.12.2016
  • Auf meinem Device ist ansonsten nur SuperSU und die AFWall+ installiert; vom Freezen einzelner Apps abgesehen, greife ich bzw. keine weitere App ins System ein
PS: Mach Dir wirklich nicht die ganze Mühe, wenn Dich nicht das Interesse gepackt haben sollte, wo der Wurm stecken könnte. ;)
Wenn LineageOS jetzt erscheint, werde ich - wahrscheinlich am Wochenende - auch noch einmal herumprobieren. Vlt. werde ich mich dazu auch an einen anderen Rechner setzen, um die Treiber noch einmal frisch zu installieren und Konflikte mit übriggebliebenen Signaturen o.ä. zu vermeiden.
 
O

ooo

Lexikon
N008 schrieb:
Ich verwende weiterhin Minimal ADB in der Version 1.4 vom 17.10.2016 (bei CHIP heruntergeladen :rolleyes:)
Das ist der einzige Unterschied ggü. meinem Setup (allerdings habe ich GNU/Linux, nicht Windows. - In einer Windows VM - XP, 7, 10 - tut es aber auch.) - Ich benutze immer die originalen Dateien von Google.
N008 schrieb:
Vlt. werde ich mich dazu auch an einen anderen Rechner setzen, um die Treiber noch einmal frisch zu installieren und Konflikte mit übriggebliebenen Signaturen o.ä. zu vermeiden.
Das ist mit Sicherheit eine gute Idee.
___

Ich lass' das nach deiner detaillierten Übersicht dann 'mal bleiben mit dem Nachstellen. - Es war eher als "Pausenfüller" bis zur official LAOS ROM gedacht.

___
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Die Schrittfolge bei der Verschlüsselung fehlt allerdings? ...
-- Dieser Beitrag wurde automatisch mit dem folgenden Beitrag zusammengeführt --
Ich gehe dazu (bei einem unverschlüsselten Phone) zurück auf die Marshmallow Stock-ROM, verschlüssel dort (einmalig) und installiere erst danach eine Custom ROM. - Ab da vermeide ich es unter TWRP > Format Data zu benutzen (was die Verschlüsselung komplett entfernt).