[Anleitung] ClockworkMod installieren

  • 52 Antworten
  • Neuester Beitrag
Diskutiere [Anleitung] ClockworkMod installieren im Root / Custom-ROMs / Modding für Sony Xperia P im Bereich Sony Xperia P Forum.
Nexus S

Nexus S

Experte
Hallo Freunde,

da ich die o.g. Aktion grad durchgeführt habe und ich hier keinen Thread dafür finde, schreibe ich hier eine Kurzanleitung.
Ich schreibe hier alles aus der Sicht MEINES Xperia P, was das OS und so weiter angeht. Wenn ihr unterschiedliche Voraussetzungen habt und euch nicht sicher seid was ihr tut. Lasst es besser.

***DISCLAIMER***
Wer bei diesen Aktionen Fehler macht, oder generell durchführt sollte sich darüber im Klaren sein, dass etwas schief gehen kann. Dann hat man einen 300€ teuren Briefbeschwerer. Das installieren einer CUstom Recovery kann im Zweifelsfall euer Telefon unbrauchbar machen. Ebenso geht die Garantie beim Unlock verloren. ICH ÜBERNEHME KEINERLEI HAFTUNG, ihr seid selbst für euer Smartphone verantwortlich!



Voraussetzungen
-Windows 7 PC
-Sony Xperia P auf Android 4.0.4
-UNLOCK DES BOOTLOADERS eures Xperia P (Anleitungen hier im Forum)
-Dieses ZIP mit Treibern, Fastboot Treibern, und CWM
-Installiertes Android SDK mit allen Paketen ab Android 4.0 + Extras Paket
-Datensicherung eurer Apps, Settings etc.

Vorgehensweise
-Entpackt die ZIP Datei
-Legt den Inhalt des Ordners "Fastboot drivers" in []:\android-sdk\extras\google\usb_driver
-Legt den Inhalt des Ordners "CWM XPeria P" in []:\android-sdk\platform-tools\
-Legt den Inhalt des Ordners "Drivers" auf den Desktop
-Schaltet das Xperia P aus
-Steckt das USB-Kabel zum Rechner ein und drückt IM SELBEN MOMENT die Lautstärke+ Taste und haltet diese. Wenn es geklappt hat, ist das Display des Geräts schwarz, aber es leuchtet eine LILA LED oben.
-Jetzt wird Windows euch sagen, es konnte keinen Treiber finden. Das machen wir flux per Hand. Öffnet den Geräte-Manager, dort wird ein unbekanntes Gerät angezeigt. Klickt mit rechts darauf, und wählt "Treiber aktualisieren". --Gebt nun das Verzeichnis an, welches ihr vorhin auf dem Desktop abgelegt habt. WIndows sucht sich die Treiber. Der Geräte-Manager müsste nun wie folgt aussehen:


-Am PC: öffnet ein Kommandozeilen-Fenster (CMD) über Rechtsclick und "Als Administrator ausführen". Wechselt in das Verzeichnis []:\android-sdk\platform-tools
Dort gebt ihr folgendes ein:
Code:
fastboot devices
Mit diesem Befehl prüft ihr die richtige Verbindung zwischen PC und Telefon. Es muss ein Zahlen-Buchstaben-Wert zurückgegeben werden, in etwa wie hier:



-zum flashen der recovery gebt ihr nun folgenden Befehl ein:
Code:
fastboot flash boot kernel.sin
Et voila, das wars. Nun erklär ich euch noch, wie ihr in eure neue Recovery kommt. Schaltet das Phone aus. Haltet die [Lautstärke+]-Taste gedrückt, drückt dazu die [Power]-Taste, bis das Phone kurz vibriert, lasst alle Tasten los und drückt solange ganz schnell hintereinander die [Lautstärke+]-Taste, bis ihr in der Recovery seid.



Viel Spass beim Backuppen, flashen, etc ;)



Quelle
 
Zuletzt bearbeitet:
Rapfl

Rapfl

Experte
Danke für den Tipp, wie man in's Recovery kommt - kann ich nur bestätigen! Anders hat's bei mir bisher noch nicht funktioniert :)
 
Nexus S

Nexus S

Experte
Ich habe ewig gebraucht. Witziger weise geht ja nicht mal ein adb reboot recovery o0
 
solaris63

solaris63

Experte
Nexus S schrieb:
Ich habe ewig gebraucht. Witziger weise geht ja nicht mal ein adb reboot recovery o0
Ich hab auch ewig gebraucht - aber bei mir ist es die Kamerataste :scared:
 
Nexus S

Nexus S

Experte
solaris63

solaris63

Experte
Manchmal ging bei mir auch garnix, dann hab ich bei Titanium Backup auf "In Recovery booten" geklickt :biggrin:
 
Nexus S

Nexus S

Experte
Geht beides bei mir nicht
 
Rapfl

Rapfl

Experte
solaris63 schrieb:
Manchmal ging bei mir auch garnix, dann hab ich bei Titanium Backup auf "In Recovery booten" geklickt :biggrin:
Genau das gleiche mach ich mit ROM Toolbox :rolleyes2:
 
Nexus S

Nexus S

Experte
Interessant. Bei mir geht nur die Methode wie ich sie beschrieben habe

Gesendet von meinem LT22i mit Tapatalk 2
 
Nexus S

Nexus S

Experte
thread updated, zip-archiv wieder online
 
P

panecondoin

Neues Mitglied
Hallo zusammen,

leider habe ich es bis heute einfach nicht erfolgreich geschafft, CWM zum Laufen zu bringen, ohne dass nach flashen gem. dieser Anleitung (sowie diverser relevanten Anleitungen des xda-Forums) der normale Systemmodus wieder normal ausgeführt wird.

Flashe ich CWM komme ich über die besagte Tastenkombi ins CWM-Menü. Leider wird nach Neustart das Display fast dunkel, reagiert so gut wie garnicht mehr und ich muss wieder (mittels hartem Reset) den 6.1.1.B.1.54 - Kernel flashen.
Ich hab das alles mehrfach mit und ohne Flashtool ausprobiert und scheitere immer.
Aber selbstverständlich würde ich gerne auch so ROMS flashen können, bzw die backup

Das Gerät ist durch flashen des auto-root-kernels (der eigentlich auch cwm beinhaltet) gerootet worden. Hat aber dieselben Probleme wie oben beschrieben gehabt, blieb aber nach flashen der Stockware gerootet (Superuser, Titanium-Backup, Rootchecker funktionieren alle)... Nandroid und der ROMmanager fragen eben nach der CWM, die ich einfach nicht installiert bekomme.
Bootloader ist unlocked...

Wie lange soll ich dem Gerät nach flashen des kernels geben? Fängt sich das evtl. irgendwann?

Ich hab das Gefühl, irgendwas übersehen zu haben, irgendeinen Anfängerfehler zu machen und wäre für jeden Hinweis sehr dankbar!
 
solaris63

solaris63

Experte
panecondoin schrieb:
Hallo zusammen,

leider habe ich es bis heute einfach nicht erfolgreich geschafft, CWM zum Laufen zu bringen, ohne dass nach flashen gem. dieser Anleitung (sowie diverser relevanten Anleitungen des xda-Forums) der normale Systemmodus wieder normal ausgeführt wird.

Flashe ich CWM komme ich über die besagte Tastenkombi ins CWM-Menü. Leider wird nach Neustart das Display fast dunkel, reagiert so gut wie garnicht mehr und ich muss wieder (mittels hartem Reset) den 6.1.1.B.1.54 - Kernel flashen.
Ich hab das alles mehrfach mit und ohne Flashtool ausprobiert und scheitere immer.
Aber selbstverständlich würde ich gerne auch so ROMS flashen können, bzw die backup

Das Gerät ist durch flashen des auto-root-kernels (der eigentlich auch cwm beinhaltet) gerootet worden. Hat aber dieselben Probleme wie oben beschrieben gehabt, blieb aber nach flashen der Stockware gerootet (Superuser, Titanium-Backup, Rootchecker funktionieren alle)... Nandroid und der ROMmanager fragen eben nach der CWM, die ich einfach nicht installiert bekomme.
Bootloader ist unlocked...

Wie lange soll ich dem Gerät nach flashen des kernels geben? Fängt sich das evtl. irgendwann?

Ich hab das Gefühl, irgendwas übersehen zu haben, irgendeinen Anfängerfehler zu machen und wäre für jeden Hinweis sehr dankbar!
Stimmt, das hatte ich auch, mit dem Kernel vom FXP148.
Es war einfach dunkel, ohne garnichts. Kein Boot kein nichts.
Ich habe einfach mit dem Flashtool neu geflasht.
Kannst du uns sagen, welchen Kernel du flashst? Oder habe ich das übersehen?
Kannst mal schauen, ob du vielleicht einen CM-Kernel auf deine Stock-FW flashst oder einen 6.1.B auf deine 6.1.1.B-FW flashst.

Sonst weiß ich da auch nicht weiter :(
 
Nexus S

Nexus S

Experte
Was ich auch nicht gelesen habe: hast du den Bootloader entsperrt?
 
P

panecondoin

Neues Mitglied

Anhänge

Zuletzt bearbeitet:
Nexus S

Nexus S

Experte
panecondoin schrieb:
Ich flashe diesen Kernel:
[ROOT][Including .54 update] Rooting Xperia P via Flashtool 0.9.6.0/only for ICS - xda-developers
und der bootloader ist entsperrt (siehe screenshots)

Hat die Antivierenapp was damit zu tun? Nur so ein Gedanke, hab wegen der Antivirenapp weder hier noch auf xda was gelesen und bin gerade nicht zuhause und kann das selbst ausprobieren...
Mit dem Kernel hab ich keine Erfahrung. Nochmal die Frage aber, Bootloader entsperrt oder nicht?
 
P

panecondoin

Neues Mitglied
ähhh, ja. auf jeden fall. einzusehen im ersten Beitrag und im screenshot ...
 
Nexus S

Nexus S

Experte
panecondoin schrieb:
ähhh, ja. auf jeden fall. einzusehen im ersten Beitrag und im screenshot ...
Tritt der fehler auch bei anderen kernel auf? Mal den sliding kernel geflashed?
 
Rapfl

Rapfl

Experte
panecondoin schrieb:
ähhh, ja. auf jeden fall. einzusehen im ersten Beitrag und im screenshot ...
Ich hab bisher noch keinen Kernel gesehen, der durch einfaches flashen den Bootloader entsperrt!? Erstaunlich...

Gesendet von meinem Xperia P
 
P

panecondoin

Neues Mitglied
panecondoin schrieb:
Hallo zusammen,

leider habe ich es bis heute einfach nicht erfolgreich geschafft, CWM zum Laufen zu bringen, ohne dass nach flashen gem. dieser Anleitung (sowie diverser relevanten Anleitungen des xda-Forums) der normale Systemmodus wieder normal ausgeführt wird.

Flashe ich CWM komme ich über die besagte Tastenkombi ins CWM-Menü. Leider wird nach Neustart das Display fast dunkel, reagiert so gut wie garnicht mehr und ich muss wieder (mittels hartem Reset) den 6.1.1.B.1.54 - Kernel flashen.
Ich hab das alles mehrfach mit und ohne Flashtool ausprobiert und scheitere immer.
Aber selbstverständlich würde ich gerne auch so ROMS flashen können, bzw die backup

Das Gerät ist durch flashen des auto-root-kernels (der eigentlich auch cwm beinhaltet) gerootet worden. Hat aber dieselben Probleme wie oben beschrieben gehabt, blieb aber nach flashen der Stockware gerootet (Superuser, Titanium-Backup, Rootchecker funktionieren alle)... Nandroid und der ROMmanager fragen eben nach der CWM, die ich einfach nicht installiert bekomme.
Bootloader ist unlocked...

Wie lange soll ich dem Gerät nach flashen des kernels geben? Fängt sich das evtl. irgendwann?

Ich hab das Gefühl, irgendwas übersehen zu haben, irgendeinen Anfängerfehler zu machen und wäre für jeden Hinweis sehr dankbar!
Den bootloader habe ich mit der offiziellen Methode (Sonycode -> Andoid-sdk, usw.) vor allen Modifizierungen entsperrt.

Komisch ist einfach nur, dass ich keine custom-Kernel langfristig anwenden kann, bein zurückflashen auf stock-firmware das rooten dennoch funktioniert hat.
Sprich: ich kann keinen Kernel, der auch CWM beinhaltet, verwenden. Und ich weiß nicht, wieso das der Fall ist...
 
P

panecondoin

Neues Mitglied
Nexus S schrieb:
Tritt der fehler auch bei anderen kernel auf? Mal den sliding kernel geflashed?
Hab den sliding kernel auch gerade mal ausprobiert.

Selbes Problem. Ich kann zwar in den Recoverymodus booten und auch *.zip-Dateien flashen (hab gerade den Camera-Fix erfolgreich ausprobiert), das Gerät startet aber nicht normal ins System.

Der Bildschirm ist kaum aktiv, ich habe aber gerade gesehen, dass die Meldung "Leider ist Xperia-Home beendet worden."
Flashe ich wieder den funktionierenden Kernel, geht der normale Bootvorgang wieder wie gehabt, ich komme allerdings natürlich nicht mehr in irgendeine CW-Recovery rein...:crying:

Irgendwelche Tipps oder Erfahrungen mit der beschriebenen Problematik?